Jump to content

Recommended Posts

I don't have this issue so there must be a solution. First suggestion would be to try running JoyToKey as administrator.

 

Edit: AFAIR the default keys for the zooms are ALT+Arrows, but using ALT through Joytokey was messing up the game always removing focus from the game window. I had to change the keys to CTRL+Arrows in the mod's config file. It's called d3dx.ini or something like that. You can try this too.

Edited by -[HRAF]Black_Sab

Share this post


Link to post
Share on other sites
On 4/10/2018 at 9:48 PM, Lobstrosity said:

When I try this the mod does not respond to any constant or variable changes. The zoom commands and color fix commands work but none of the changes I make to 'w', 'y6', or 'y7' are reflected in the game after pressing F10. Any idea why this would be? I've installed the mod with JSGME and have already tried deleting the mod folder, taking the snapshot again and extracting version 8.2 back into the mod folder.

Just an update for anyone that runs into the same issue. I had to deactivate the mod in JGSME, run the uninstall batch file afterwards and delete the MOD folder to get rid of everything. Then run JGSME and create the MOD folder and extract the mod (I'm using 8.3) to the MOD folder. BEFORE you activate the mod in JGSME, make any edits to the d3dx.ini and then activate.

 

For some reason I am unable to apply changes I make in d3dx.ini (F10 doesn't work for me) after the mod has been activated without uninstalling it first. It probably has something to do with permissions or admin mode.

 

Now everything is running well! Thanks for this awesome mod!

Share this post


Link to post
Share on other sites

Strange. Maybe you installed the game into program files ? Or you'll have to modify d3dx.ini in the game dir once the mod is installed...

 

 

Share this post


Link to post
Share on other sites

Been gone for a month and it seems none of the zoom settings work. Well they work but they are either plagued by massive black bars, pure black, one eye only or a mix of all the above. I back tracked the thread and tried everyone's posted settings, none are usable. Rift, with the smallest IPD (iirc its 59).

Edited by [CPT]CptJackSparrow

Share this post


Link to post
Share on other sites
2 hours ago, a_radek said:

well, they broke it again. Any tricks to get current migoto version to work?

 

Yeah, the hotfix has messed it up a bit. Now I'm getting a transparent zoomed landscape over the normal, non zoomed landscape. Objects seem fine, just a landscape issue.

  • Upvote 1

Share this post


Link to post
Share on other sites

They updated the way rendering on far forest works, hence the mod needs adaption ^^

 

I believe lefuneste will be on it once he has time ;)

Share this post


Link to post
Share on other sites

This is fixed in the 8.4 version I made this evening.

I had to change the shift used for zoom, maybe it is only to do for Pimax.

I found a small glitch at the base of the yak 1 stick when using IPD modifier, I didn't see that before. Maybe this problem will also occure at another place, so I want to try to fix it before distributing the new version.

You'll have to wait one or two days...

 

Share this post


Link to post
Share on other sites

Could you maybe tell us a hotfix ?

 

The IPD modifier I don't use, I'm using the Rift, it works best without it anyway

Share this post


Link to post
Share on other sites
3 hours ago, lefuneste said:

This is fixed in the 8.4 version I made this evening.

I had to change the shift used for zoom, maybe it is only to do for Pimax.

I found a small glitch at the base of the yak 1 stick when using IPD modifier, I didn't see that before. Maybe this problem will also occure at another place, so I want to try to fix it before distributing the new version.

You'll have to wait one or two days...

 

Is v8.4 available yet, I didn't see it in the usual location (the first post).  Looking forward to the fix, thanks lenfuneste

Share this post


Link to post
Share on other sites
13 hours ago, [CPT]CptJackSparrow said:

Been flying BMS over the Balkans and Israel until I can see again in il2.

BMS implemented VR?

Share this post


Link to post
Share on other sites

Well, I was not aware that the last 3.002 version reset all graphic settings: HDR was on, that was the cause of the glitch. The mod do not  support HDR, so the first post is now updated with the last 8.4 version.

This version includes also the ability to temporary replace map by your own custom images, see the fisrt post for the key to use and how to modify them.

Warning:  I had to change the shift for zoom for my PIMAX, I leave the same settings than before for Rift and Vive, and do not know if they will work again. As they modify things for Vive, it is unlikely that value for Vive in d3dx.ini will work.

Please post here yours if you'll have to modify them.

 

 

Share this post


Link to post
Share on other sites

Working excellent in my rift, seems a bit better than before actually.  Color mod not functional as of yet, some moving tree shadows, but only looking directly below, minor issue.  Every thing else working.  Be doing some sorties tonight, thanks!

Share this post


Link to post
Share on other sites
3 hours ago, [CPT]CptJackSparrow said:

No. How I wish!

Too bad- I agree. 

Share this post


Link to post
Share on other sites
6 hours ago, lefuneste said:

Well, I was not aware that the last 3.002 version reset all graphic settings: HDR was on, that was the cause of the glitch.

 

 

Not for me, my settings stayed the same. HDR has always been unchecked for me. Anyways, it’s working well for me. 

 

Thanks again for your work 

Edited by 1_Robert_

Share this post


Link to post
Share on other sites

I just tried 8.4 version on vive - zoom does not work for me :( (when zooming I see zoomed trees and objects only when I tilt head down about 30-45 degrees, terrain stays unzoomed). Thinking about reinstalling game completely, and installing mod on cleanly installed game.

 

Edit: reinstalling game and mode did not help. I read that there were two game patches lately - 3.002 and 3.002b, maybe second patch came out after 8.4 mod was published?

Edited by Balapan

Share this post


Link to post
Share on other sites

Here is what I have set for version 8.4 on the Vive. I still need to tweak the vertical shift, but this should get you in the area. Also I am not using the black masking.

 

[Key1]
;set high zoom on
Key = ALT no_shift no_ctrl VK_UP
type = hold
; modify here the first value you want to use for zoom increase
w = 10.0

x6 = 0.45
y6 = 0.0
x7 = 0.00
y7 = -0.15

 

[Key3]
;set med zoom on
Key = ALT no_shift no_ctrl VK_RIGHT
type = hold
; modify here the first value you want to use for zoom increase
w = 5.0

x6 = 0.20
y6 = 0.0
x7 = 0.00
y7 = -0.15

Edited by Lobstrosity
Clarification

Share this post


Link to post
Share on other sites
8 hours ago, [CPT]Crunch said:

  Color mod not functional as of yet

 

It works on my config. What graphic setting do you use ? Try disabling HDR, sharpness and so pn...

Share this post


Link to post
Share on other sites

Rift User here, with 3.001 b does not work for me :( Still getting Zoomed Trees whereas the ground stays unzoomed...

 

[CPT] Crunch,  do you mind if you post your functional settings here?

Edited by JimmySolarium
my fingers don´t type without coffee...

Share this post


Link to post
Share on other sites

Didn't customize any settings, they're stock.  Do always run the uninstaller before dropping in the latest version though, there's an uninstaller right in the folder.  If you haven't, try putting the previous version back in, if you still have it, uninstall, than put in the new one. 

 

This is the best version ever for me, spotting has never been so good, this combined with peregrin7's latest settings.  But than I'm running a Vega card, so my mileage often varies from the standard.  The HDR on with bloom locked off makes unzoomed aspect judgements so much better within knife fighting ranges.  Can see reflections, coloring, and light off the major parts of the aircraft, much more lifelike and trackable.  I'm actually picking up contacts beneath against the terrain quite easily, that wasn't very likely before.   From my observations so far, I'm not losing them against the clouds either.  Nothings crystal clear, but nothings invisible either, nor does it disappear at the most inconvenient times any more.

 

Still haven't tried the color fix, but don't think it's needed as of now for me, quite happy.  Don't have that blind as a VR bat feeling so much lately.  And the spotting zoom is working great for me, positive ID, can definitely tell a P-40 from a 109 instantly at nearly all aspects and distance.  Only a few tree shadows magnified and moving when looking directly down, but pretty much have to flip over to see that, not a factor.

Share this post


Link to post
Share on other sites
7 hours ago, JimmySolarium said:

Rift User here, with 3.001 b does not work for me :( Still getting Zoomed Trees whereas the ground stays unzoomed...

 

[CPT] Crunch,  do you mind if you post your functional settings here?

Unfortunately having the same issue with my Rift also, the 3D trees gets zoomed while the flat background is unzoomed.  Both HDR and sharpen are turned off.

Share this post


Link to post
Share on other sites
1 hour ago, 71st_AH_statuskuo said:

Unfortunately having the same issue with my Rift also, the 3D trees gets zoomed while the flat background is unzoomed.  Both HDR and sharpen are turned off.

 

Weird, seems it's the other way round for me. All works well apart from this static anomaly.

Capture.thumb.JPG.c89247a8fcd3b47f19077a7b88475813.JPG

  • Upvote 1

Share this post


Link to post
Share on other sites
3 hours ago, [CPT]Crunch said:

  Only a few tree shadows magnified and moving when looking directly down, but pretty much have to flip over to see that, not a factor.

 

can you post a track showing this problem ?

48 minutes ago, a_radek said:

 

Weird, seems it's the other way round for me. All works well apart from this static anomaly.

Capture.thumb.JPG.c89247a8fcd3b47f19077a7b88475813.JPG

can you post a track showing this problem ? It looks like I did not trap some specific shaders.

Share this post


Link to post
Share on other sites
8 hours ago, a_radek said:

 

Weird, seems it's the other way round for me. All works well apart from this static anomaly.

Capture.thumb.JPG.c89247a8fcd3b47f19077a7b88475813.JPG

 

Yes, that’s exactly what I have. Thanks for posting. 

Share this post


Link to post
Share on other sites

I am getting the exact same issue as above, HDR is turned off, only been hapenning since latest IL2 update

Share this post


Link to post
Share on other sites

I briefly tested in QM in Stalingrad summer and seems to be working fine on Rift.

Share this post


Link to post
Share on other sites

I have the same issues as the others, it's not working on the Rift. The devs changed the way roads and forests are rendered in 3.001, it's written in the patch notes btw. These changes unlocked the forests trees and roads as well as parts if shadows of aircraft from their places to be, when zooming. 

 

Black Sab, every Rift is affected, I believe you'll want to use the mod zoom to also see it. 

Share this post


Link to post
Share on other sites

I checked and found the problem only on moscow maps (I did not chek them :(, only stalingrad and kuban). They used a different shader for ground for moscow, I do not know why,..

The 8.5 version (in first post) should fix that.

  • Thanks 5

Share this post


Link to post
Share on other sites

Yet again my endless thanks to your for your generosity and your help in providing this game with the necessary features for a proper VR experience. 

 

Your service to the community should earn you some honorable badge. 

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

Great! It works well in my Rift. Thanks again. lefuneste. Now I can continue my career in Moscow. :salute:

Share this post


Link to post
Share on other sites

Just popping in to say my sincerest thanks to You, lefu... This mod basically saved the sim for me. With couple of hours tweaking this and that and sipping whisky, I think I can resume playing :D  Once again, Thank You!

Share this post


Link to post
Share on other sites

Confirm it works now with the Rift.   Being Moscow only explains why some of us were seeing the issue and some not (I always test with a QMB in Moscow).

Thanks again for making such a quick fix lenfueste

  • Upvote 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...