Jump to content
lefuneste

3DMigoto mod for VR

Recommended Posts

В 31.05.2018 в 04:33, SCG_Fenris_Wolf сказал:

Settings for the Odyssey:

 

Cool thank you man! This settings work perfectly on Samsung.

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi all! Tried this mod for zooming in the Tanks gunsight in VR

 

it works great but on the highest  zoom level it gets extremely shaky 

 

is there a solution for this? Pausing the VR tracking or something?

Share this post


Link to post
Share on other sites
5 hours ago, Intrud3r said:

Hi all! Tried this mod for zooming in the Tanks gunsight in VR

 

it works great but on the highest  zoom level it gets extremely shaky 

 

is there a solution for this? Pausing the VR tracking or something?

 

yeah, lean and rest your head against a tank visor.. :)

 

it's the same thing when flying. All of your neck micro-vibrations get exponentially increased with x10 zoom. Or try it with real-life binoculars.. :)

Share this post


Link to post
Share on other sites

Using the mod when firing a round in the Tiger results in double vision for about 1-2 secs after the shot. Anyone else seeing this? Makes it really hard to see where the shot landed.

Share this post


Link to post
Share on other sites
5 hours ago, =EXPEND=Tripwire said:

Using the mod when firing a round in the Tiger results in double vision for about 1-2 secs after the shot. Anyone else seeing this? Makes it really hard to see where the shot landed.

 

tongue in cheek.. but wouldn't it feel exactly the same way from inside the real Tiger? 😄

Share this post


Link to post
Share on other sites
8 hours ago, LizLemon said:

Are the shaders in the shader fixes folder just dumps from the game?

 

You can read about how it works on the wiki  - but I'm still learning myself

Share this post


Link to post
Share on other sites
On 7/26/2018 at 5:34 AM, LizLemon said:

Are the shaders in the shader fixes folder just dumps from the game?

In "hunting" mode and when the according dump shader key is pressed yes.

Share this post


Link to post
Share on other sites
On 7/25/2018 at 9:49 AM, Intrud3r said:

Hi all! Tried this mod for zooming in the Tanks gunsight in VR

 

it works great but on the highest  zoom level it gets extremely shaky 

 

is there a solution for this? Pausing the VR tracking or something?

It's a shot in the dark, but I assume you might have the game's VRzoom coupled together with lefuneste's zoom.

 

If I am right, I will suggest you to try ignoring the game's own zoom completely and to not use it at all. Best of luck ! 👍

Edited by SCG_Fenris_Wolf

Share this post


Link to post
Share on other sites
On 7/26/2018 at 5:43 AM, moosya said:

 

tongue in cheek.. but wouldn't it feel exactly the same way from inside the real Tiger? 😄

 

Maybe?, but flat screen players don't have this problem as well unfortunately. The cannon blast and smoke gets messed up with the migoto zoom.

 

 

Share this post


Link to post
Share on other sites
8 hours ago, SCG_Fenris_Wolf said:

It's a shot in the dark, but I assume you might have the game's VRzoom coupled together with lefuneste's zoom.

 

If I am right, I will suggest you to try ignoring the game's own zoom completely and to not use it at all. Best of luck ! 👍

Hi 

thanks for your answer, but Inhaber tried both , pure VRzoom , 3dmigoto Zoom , and a combination of both 

 

of you are moving fast it’s ok , but if you try to get a steady view search for movements in the woods it makes you feel sick 

Share this post


Link to post
Share on other sites
15 hours ago, =EXPEND=Tripwire said:

 

Maybe?, but flat screen players don't have this problem as well unfortunately. The cannon blast and smoke gets messed up with the migoto zoom.

 

 

It's likely if there are new shaders to render them. New shaders not in mod are not modified to take into account zoom.

Share this post


Link to post
Share on other sites

@ lefuneste There certainly is one shader issue, with when you zoom at the sky 5x or 10x, parts of the skies merge into eachother and create artifacts (as if portions of the sky collide/merge like two tectonic plates, creating a line inbetween).

 

 

 

@ Intrud3r , as it refers to any combination, there may be an issue with your tracking. I can hold steadily without much shaking in the Odyssey. I remember I could do so in the Rift as well (using 3 sensors). Now I do not know which VR system you use. But I know how to test it, by taking the zoom out of the equation:

 

You can fly a Quick Mission into air combat, hold your head steady, try soft movements only (concentrate on staying steady), and record the whole thing via the ingame function. Then watch the replay on the monitor and take a look at it. Is it way too shaky? A bit shaky is normal, but too much, you'll quickly see as disturbing. In VR your eyes usually counter this, but are overwhelmed when zooming in. Then it is a tracking issue. I have had the issue in the Rift using two frontally mounted sensors in seated position, which was the reason I got wall mounts and triangled 3 sensors positioned at the wall.

Again, a bit shaky is normal - even while flying a glider as co-pilot when using binoculars it was hard to get it steady.

 

Edited by SCG_Fenris_Wolf

Share this post


Link to post
Share on other sites

@ Intrud3r : did you have the same problem with a tank available without the "tank crew" (T34 or Pz III) ? If this is the case, can you post a track and give the time for zooming ?

If this is a specific Tiger shader I will not be able to fix it, as I do not have either bodenplatte or tank crew.

@SGC_Fenris_Wolf : can you post a track of the problem, except if it is on moscow map (I already fix the missing shader for that map) ?

Share this post


Link to post
Share on other sites

Hello!

 

I'm having a bit of an issue with this mod, wherein when I zoom in at either 5x or 10x, the spacing of the image shown to each eye is further than it should be. What I mean by this is that the image going to my left eye is too far to the left, and the image going to my right eye is too far to the right, creating the opposite of a cross-eyed effect. It makes my eyes want to go in two opposite directions, so I have to close a single eye to get any use out of this mod.

 

Here's a picture:

l58hc6z.png

 

I need the circles to move inwards a bit.

I've tried tweaking the x6 and y6 values in the d3dx.ini file, but they don't seem to be doing anything.

 

I'm using the Rift, and my IPD is around 70mm.

 

Any advice?

Edited by Barney99
Added a pic

Share this post


Link to post
Share on other sites
9 hours ago, lefuneste said:

@ Intrud3r : did you have the same problem with a tank available without the "tank crew" (T34 or Pz III) ? If this is the case, can you post a track and give the time for zooming ?

If this is a specific Tiger shader I will not be able to fix it, as I do not have either bodenplatte or tank crew.

@SGC_Fenris_Wolf : can you post a track of the problem, except if it is on moscow map (I already fix the missing shader for that map) ?

 

The „Crosshair“ is in all tanks hard to see , if you mean this.

 

for zooming, it was a little misleading, I have tried all variants (VR zoom, mod zoom, both together) but it makes no difference in high magnification levels .

 

pure VR zoom isn’t shaky because it’s normal for the eye , but at 10x magnification the normal neck muscle movement have big impact on a steady aim. 

 

I don’t think it’s a bug or something, it’s just a byeffect of this high Zoom Levels 

Share this post


Link to post
Share on other sites
On 7/30/2018 at 11:12 PM, Barney99 said:

Hello!

 

I'm having a bit of an issue with this mod, wherein when I zoom in at either 5x or 10x, the spacing of the image shown to each eye is further than it should be. What I mean by this is that the image going to my left eye is too far to the left, and the image going to my right eye is too far to the right, creating the opposite of a cross-eyed effect. It makes my eyes want to go in two opposite directions, so I have to close a single eye to get any use out of this mod.

 

I need the circles to move inwards a bit.

I've tried tweaking the x6 and y6 values in the d3dx.ini file, but they don't seem to be doing anything.

 

I'm using the Rift, and my IPD is around 70mm.

 

Any advice?

 

 

It looks like each player need to setup his own settings for zoom...

At first : w is zoom factor,  y6 is used to shift horizontally each image left or right when zoomed (each image is shifted in an opposite direction),  y7 is used to shift up or down each image when zoomed (each image is shifted the same), x7 is used to shift horizontally the mask (black area around zoomed view)

The [key1] to [Key3] section contains settings for each zoom level.

eg :

[Key1]
;set high zoom on
Key = ALT no_shift no_ctrl VK_UP
type = hold
; modify here the first value you want to use for zoom increase
w = 10.0
; Pimax settings
y6 = -0.6
x7 = 0.0
y7 = 0.0

So for my 10x zoom I shifted only on X direction for -0.6 (60% of screen).

 

Each zoom level settings may be differents. So you'll have to define each settings for each zoom lever.

The easier way for doing that is to

  • modify entries w in the following section at beginning of d3dx.ini (see below) : set w to the zoom value you want to setup (eg. 5.0)
;----------------
; zoom settings 
;----------------
; zoom square radius
; x = 100
x = 0.12
; default zoom factor (not to be modified)
w = 1.0
  • press F10 : game display should be updated with your zoom factor constantly applied
  • modify the values of y6, y7 and x7 in the following section: try to increase or decrease them to fit your need
;----------------
; XShift 
;----------------
; xshift for defaut IPD like modifier (not to be modified)
x6 = 0.0
; Xxshift for zoom (not to be modified)
y6 = 0.0
; Yshift for zoom (not to be modified)
y7 = 0.0
; xshift for mask(not to be modified)
x7 = 0
; ratio horizontal/vertical for zoom mask
z4 = 0.6
  • press F10 => the view should have been shifted by your settings
  • do it again untill you find the good settings
  • Report the settings in the [Key] section corresponding to the zoom factor you used
  • modify again w, y6, y7 and x7 to their original value
  • press F10
  • check that all is OK when you zoom for the zoom factor you just have set
  • Do all the process again for other zoom factors settings

 

If the 'F10" function does not work, try to replace the line "hunting=0" by "hunting=2" launch IL2 again and press numpad0 then F10. Warning : do not forget to set it at the 0 value at the end of your setting process, it has a huge impact on performance.

 

 

Edited by lefuneste

Share this post


Link to post
Share on other sites

Lefuneste I will get a track, but it only shows while zooming in the headset (both Rift and Odyssey). 

Since tracks don't capture zooming by the mod, the track shows nothing. 

It's on Stalingrad and Kuban map, when you fly, look at the horizon level and zoom in 5x or 10x. The horizon / the sky above it bugs out. 

 

Addendum

The track is not showing it. It is only visible in the HMD. What can I do? Maybe I can capture it on the splitscreen on the monitor (if it zooms as well, never checked that).

Edited by SCG_Fenris_Wolf

Share this post


Link to post
Share on other sites

The track will allow me to zoom or engage IPD modifier in the same place/plane/meteo than you, so I can easily check the problem. Track are not video, they are recording of all objects position, events,....

I've also notice problem on horizon, I have to work on it.

 Post also your graphics settings,

Share this post


Link to post
Share on other sites

I have the same issue as Barney66. When I make changes to the config file I don't see any difference in game. Just to make sure I was applying the changes, I would close IL-2, disable the mod with OvGME, then alter the file, save the file, enable the mod and start IL-2. I was getting frustrated and started making wild changes just to see if I could make something happen... Nothing ever did. When I adjusted the settings in the Xshift section, IL-2 started in zoom and was impossible to use, I reverted those changes.

 

Any Advice?

Share this post


Link to post
Share on other sites

imake changes in the d3dx.ini file in the game dir, not in the mod dir. Set hunting=1 option to be sure that you are working on the d3dx.ini file used by the game.

Once you'll find your settings overwrite the mod d3dx.ini file with the one you have modified in the game dir, so it will not be overwritten and lost in the future. Of course you'll have to update the future version with your settings, but that will be only a copy paste operation between the d3dx.ini of your current version and the d3dx,ini of the new one.

Edited by lefuneste

Share this post


Link to post
Share on other sites

I started making my changes there... no matter what I did, I couldn't make the zoom change. I'll look it over again and see if I can find something I didn't do correctly. Also, If I set "hunting=1" my IL-2 won't start.

Share this post


Link to post
Share on other sites

Ok, I've tried everything I can think of... when I modify the file in the game directory I do not see results in the game. I don't usually go into config files and play with things, is there something simple that I need to do to 'enable' modifying?

Let me give you an example of what I'm doing. 

I go here: D:\Steam\steamapps\common\IL-2 Sturmovik Battle of Stalingrad\bin\game

open d3dx.ini
 

change this:

[Key1]
;set high zoom on
Key = ALT no_shift no_ctrl VK_UP
type = hold
; modify here the first value you want to use for zoom increase
w = 10.0
; Pimax settings
; x6 = 1.3
; y6 = 1.1
; x7 = -0.15
; y7 = 0.1 

 

to this:
[Key1]
;set high zoom on
Key = ALT no_shift no_ctrl VK_UP
type = hold
; modify here the first value you want to use for zoom increase
w = 10.0
; Pimax settings
; x6 = 1.8
; y6 = 1.8
; x7 = 0.0
; y7 = -0.85

 

Save and exit the file 

 

and see zero change in my zoom alignment. 

 

Am I missing a simple step here that I don't understand?

 

Ok, I don't do this type of stuff much, but just in case someone else needs to know this... 

My mistake is that a ';' at the beginning of a line means the system doesn't process it...
 

so I can change a line that looks like this to anything I want and it doesn't do anything:

; x6 = 1.8 

 

But a line that looks like this changes things:

x6 = 1.8

 

Edited by Modeus

Share this post


Link to post
Share on other sites
8 hours ago, Modeus said:


My mistake is that a ';' at the beginning of a line means the system doesn't process it...
 

so I can change a line that looks like this to anything I want and it doesn't do anything:

; x6 = 1.8 

 

But a line that looks like this changes things:

x6 = 1.8

 

 

You are correct here -  any vaules with ";" in front of them are not used.

 

So it should look like this - 

[Key1]
;set high zoom on
Key = ALT no_shift no_ctrl VK_UP
type = hold
; modify here the first value you want to use for zoom increase
w = 10.0
; Pimax settings
x6 = 1.8
y6 = 1.8
x7 = 0.0
y7 = -0.85

 

 

Share this post


Link to post
Share on other sites

Dumb question, the install directory Lefuneste is referring to, where is it located, I have gotten this far but I am not sure what to do next:

 

c:/Program files (x86)>Steam>steamapps>common>IL-2 Sturmovik Battle of Stalingrad>data.

 

Where do I copy the files?

 

Your help much appreciated.

Share this post


Link to post
Share on other sites
9 hours ago, Kandiru said:

Dumb question, the install directory Lefuneste is referring to, where is it located, I have gotten this far but I am not sure what to do next:

 

c:/Program files (x86)>Steam>steamapps>common>IL-2 Sturmovik Battle of Stalingrad>data.

 

Where do I copy the files?

 

Your help much appreciated.

IMO just download JSGME and drop that in your main directory, then put the files in the mod folder it creates and you can easily activate it with that program without messing any of your files up.

Share this post


Link to post
Share on other sites
23 hours ago, 15th_JonRedcorn said:

IMO just download JSGME and drop that in your main directory, then put the files in the mod folder it creates and you can easily activate it with that program without messing any of your files up.

 

+1

I use OVGME and I always disable to mod when I know IL-2 has an update to make sure the update is installed on the vanilla version. Then re-activate the mod. 

 

Edit: to answer your question, this is the folder the files go to: .....\IL-2 Sturmovik Battle of Moscow\bin\game

Edited by -[HRAF]Black_Sab

Share this post


Link to post
Share on other sites

Some news : the next version will include color saturation change, icon/label text &color disabling, fix mostly the problem of planes invisible when in front of cloud.

All these features are working on my PC, I still have the horizon problem to fix and ensure that all is working as it should.

Edited by lefuneste
  • Thanks 1
  • Upvote 3

Share this post


Link to post
Share on other sites

Sweet wish I was still using the rift, went to a massive screen for now. Was gunna buy a new gpu but I am absolutely NOT paying 1200 dollars for a mainstream consumer GPU. Nvidia can shove it. Actually I have still been using the mod for spotting with trackir. It works all the same.

Edited by 15th_JonRedcorn

Share this post


Link to post
Share on other sites
18 hours ago, lefuneste said:

Some news : the next version will include color saturation change, icon/label text &color disabling, fix mostly the problem of planes invisible when in front of cloud.

All these features are working on my PC, I still have the horizon problem to fix and ensure that all is working as it should.

 

This is fantastic. 🤩👍

Share this post


Link to post
Share on other sites
20 hours ago, lefuneste said:

Some news : the next version will include color saturation change, icon/label text &color disabling, fix mostly the problem of planes invisible when in front of cloud.

All these features are working on my PC, I still have the horizon problem to fix and ensure that all is working as it should.

 

Great! Thanks a lot as always. I'm very much looking forward to try.

Share this post


Link to post
Share on other sites

I reinstalled the mod today, using jsgme this time. I used to have it installed directly in the game directory without using jsgme. I seem to have an issue using the x5 and x10 zoom, when I look at the ground it is not clear, like there are two layers, the zoomed one on top of the standard picture.Is it possible the mod didn't uninstall cleanly from the game directory when I ran the uninstall?

Share this post


Link to post
Share on other sites
5 hours ago, 6./ZG76_Archie said:

I reinstalled the mod today, using jsgme this time. I used to have it installed directly in the game directory without using jsgme. I seem to have an issue using the x5 and x10 zoom, when I look at the ground it is not clear, like there are two layers, the zoomed one on top of the standard picture.Is it possible the mod didn't uninstall cleanly from the game directory when I ran the uninstall?

 

you need to adjust the mods settings, search the thread for answers as im not versed enough to explain how

Share this post


Link to post
Share on other sites

Re-installed using JSGME and I'm shocked by how crazy accurate those zooms are at identifying targets.

Share this post


Link to post
Share on other sites
11 hours ago, Artunius said:

Re-installed using JSGME and I'm shocked by how crazy accurate those zooms are at identifying targets.

Told you! 😉

Share this post


Link to post
Share on other sites

New 9.0 version of the mod is available for testing here: http://www.mediafire.com/file/b3y7r47atcagcbc/3Dmigoto_VRBOS_9.0.zip/file

Thanks to test it and report the problems it may have, I did not spent too much time in testing...

 

What's new:

  • Default option are regrouped in a common part at the beginning of d3dx.ini with better explanation (I hope).
     
  • Zoom keys are now binded to "ins", "home", "page up" keys by default because they are useless in VR and  cursor keys interfere with tank driving.
     
  • Horizon and some missing shader bugs fixed. There may be still missing shader (that is part of the image "floating" above or below other parts when zooming). In this case please make a track and post it here, so I can easily check and fix. As I do not purchased BoB or Tank crew and do not plan to buy them until some AI improvement will be done, there may be some shader dedicated to new planes or tank that I would not be able to fix in the future...
     
  • New label option  : you can either hide text, waypoint, or made color replaced by grey. All option are independant. you can set what you want in defautl setting or in the [key7] section. The grey strenght can be specified (30% par default)
    ;----------------
    ; Label/icon 
    ;----------------
    ; masking by airframe : 1 = masking on, 0 = masking off
    w7 = 1
    ; icon limitation
    ; waypoint display : 1 = waypoint, 0 = no waypoint
    z7 = 1
    ; color: 1 = color, 0 = no color (gray)
    x2 = 1
    ; gray replacement strenght (0=black, 1=white)
    x4 = 0.3
    ; text : 0= no text, 1 = text
    x3 = 1

    You can switch between normal icon and limited icon (no text, no waypoint and all icon in grey color) by pressing LSHIFT + U
    Default
    icon_standard.thumb.jpg.6f904469d3525c3a4868f6891dddfd79.jpg
    SHIFT+U:

    icon_reduced.thumb.jpg.c2e1c67f3143765c6b81f3ba6d9f22d8.jpg
     
  • New "staturation" change available with x1 variable (using peregrine7 algorithm given here ) :

    ;----------------
    ; Color Fix
    ;----------------
    ; step 1 new color = saturation change for standard output (x1)
    ; step 2 : new color = saturated color * w6 + z6
    ;
    ; default value to add to each color component 
    z6 = 0.0
    ; default value to mul to each color component 
    w6 = 1.0
    ; default value for saturation (typically -1 to 1, but can be higher or lower...)
    x1 = 0.0

    x1=-1
    low_saturation.thumb.jpg.230526e67e7b3ab557beb0f95febaae4.jpg
    x1=0

    no_saturation.thumb.jpg.d0bb9823dea5ccbc03b0fd2981069c33.jpg
    x1=1
    high_saturation.thumb.jpg.368fbba858db8f3f6ba875bca6248c8f.jpg

    No color change is provided by default, you can toggle it by pressing LALT+u (see [key9] section for the values used).

  • I  tried to fix the bug of plane hidden by cloud behind them. The option is toggled on by default with the variable "z1" and can be disabled/enabled with the key LCTRL+k

    ;----------------
    ; Cloud fix flags
    ;----------------
    ; on/off flag
    ; 0 : no cloud fix
    ; 1 : cloud fix
    z1 = 1

    By default:
    cloud_bug.thumb.jpg.b45094c7ea3f07d38702d04cbf74f7e8.jpg
    With the mod:

    cloud_fixed.thumb.jpg.74104c9af351cade0f3f25b0d8eb3c8f.jpg
    I made some (light) testing and did not find too much problems...Plane are still masked by cloud behind them when far.
    I hope that planes will not be visible trough cloud, I did not see that in my testing, but if you have the case please post a track. Maybe there is a reason explaining why devs did not fix this problem.

 

Edited by lefuneste
  • Upvote 2

Share this post


Link to post
Share on other sites

I hope this new cloud stuff doesn't get this mod banned from multiplayer. It's literally required in VR.

Edited by 15th_JonRedcorn

Share this post


Link to post
Share on other sites

Zoom works good. a Few issues I saw but nothing major.

 

Color fix doesn't seem to work at all, I tried every combo I could, nada.

 

Rift.

 

😃

[Key9]
;Color Fix
Key = ALT no_shift no_ctrl u
type = cycle
; modify the last value with what you want to use for color increase (should be the same as default)
z6 = 0.0, 0.1
w6 = 1.0, 1.0
x1 = 0.0, 0.5

 

(above I changed x1 to 1.0, 0.5, saved, reloaded shaders, relaunched game, tried both left and right ALT+U, didn't work)

 


; Color Fix
;----------------
; step 1 new color = saturation change for standard output (x1)
; step 2 : new color = saturated color * w6 + z6
;
; default value to add to each color component
; z6 = 0.1
z6 = 0.0
; default value to mul to each color component
; w6 = 0.9
w6 = 1.0
; default value for saturation (typically -1 to 1, but can be higher or lower...)
x1 = 0.0
; x1 = 0.5

 

(Down here I tried setting the uncommented x1 to 1.0, saved, reloaded shaders and game, didn't work)

 

Am I missing something here?

All I am after is to toggle the x1=1 color (like in his image posted above) on a key.

 

My kingdom for some color! =p

Edited by [CPT]CptJackSparrow

Share this post


Link to post
Share on other sites

What settings are you using ? Try to disable "sharpen" if you use it, maybe I loose something in this shader or it has changed, so I did not modify the good one..

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...