Jump to content

Recommended Posts

Starting a new thread for PWCG issues.  At the moment they are scattered all over.  I have three things in the queue right now, so if your problem is one of these then no need to report it again.  Otherwise, if issues can be discussed here instead of in the middle of other threads or in their own thread that would help me.

 

1. Bristol and Halberstadt modifications/payload settings still do not work.

2. In a coop mission one player was not recognized as a player

3. PWCG incorrectly increments player missions flown count

 

I have those three so no need to report them again.  Keep using that report error button..  It helps.

Share this post


Link to post
Share on other sites

The possibility to assign skins to other units, like RoF I, please.

Share this post


Link to post
Share on other sites
30 minutes ago, Almenas said:

The possibility to assign skins to other units, like RoF I, please.

 

Really looking more for bugs that enhancement requests, but ... all of RoFs skin assignment capability is still in PWCG.  Skins management is something that I am looking for community support to get going.  There were several people helping me with skins in RoF, which is why RoF supported hundreds of skins.  

 

PWCG never let you assign skins to other units without editing data files.  Editing data files independent of an organized effort is not recommended, as I do not have the ability to support individual installs.

Share this post


Link to post
Share on other sites
1 hour ago, PatrickAWlson said:

Keep using that report error button..  It helps.

Hmm, this would be my issue. Since 8.7.1, I think, I only have 'Leave Campaign' half on my screen, the 'Report Error' button is not on it anymore.

Share this post


Link to post
Share on other sites
5 minutes ago, Yogiflight said:

Hmm, this would be my issue. Since 8.7.1, I think, I only have 'Leave Campaign' half on my screen, the 'Report Error' button is not on it anymore.

 

What are your screen dimensions?

Share this post


Link to post
Share on other sites

Thanks for the thread:

 

Not sure if an issue or feature request:

 

No artillery units are generated.

I have never seen static artillery like ml20, lefh18 in PWCG generated missions.

 

Using PWCG 8.7.2-  ground: high - air: med

Am only I experiencing this?

 

Thanks again for your work!

Best regards

Rieper

Share this post


Link to post
Share on other sites
7 minutes ago, PatrickAWlson said:

 

What are your screen dimensions?

1920x1080, screen set to 100% and PWCG running in full screen. By default PWCG is running in windowed mode, then the 'Leave Campaign' button is not on the screen, either.

Share this post


Link to post
Share on other sites

As I wrote earlier, it would be nice to know the total length of the mission in kilometers, as well as being able to load fuel for the squadron not from 60% of the full
tank volume (as it is now), and with 40%.
Many aircraft do not need a full tank of fuel.
For example, a P-40 E-1 with a full tank becomes so clumsy that it cannot conduct a maneuverable air battle. But he has enough of a full tank load for almost 1000 
km flight. While the game has many missions with a total path length of 100-200 km. Even if you take a doubled fuel supply based on such a path, then it is quite 
possible to do with loading the tank by 30-50%.

Share this post


Link to post
Share on other sites

@rieper_420 The artillery is there during battles and it fires.  The cannons are some of my favorite targets because I am so bad at taking out tanks.

Share this post


Link to post
Share on other sites

I have also had this issue - but only in an imported campaign.  I think there may be some mix-up with previously deceased AI pilots.  I thought it might have just been that my old campaign file was corrupted during an import to a newer PWCG version since I had not seen it happen in either of the new campaigns I created since the logs update (and maybe even since the SP multi-pilot update).  

 

However, since it isn't just me, and I still have one of the old campaigns, I will fly that campaign this weekend to get you another report on this issue.

Share this post


Link to post
Share on other sites
1 hour ago, PatrickAWlson said:

 

Really looking more for bugs that enhancement requests, but ... all of RoFs skin assignment capability is still in PWCG.  Skins management is something that I am looking for community support to get going.  There were several people helping me with skins in RoF, which is why RoF supported hundreds of skins.  

 

PWCG never let you assign skins to other units without editing data files.  Editing data files independent of an organized effort is not recommended, as I do not have the ability to support individual installs.

 

I don't want to bother with it, but I found it a very nice feature in RoF. I tried assigning skins to it, but they don't appear. This is an example I tried, but I will check it again. Thanks anyway.

bf109f2.txt

Share this post


Link to post
Share on other sites
Posted (edited)

The cannons are my favorites too in this case, that's what I mostly use.

______________________________________________________

Edited by sneazzy95

Share this post


Link to post
Share on other sites

thanks for your answers.

That is really weird that only I am encountering the issue. The rest of PCWG works perfectly fine...

I have never seen a bm13 or sdkfz251 firing rockets or a ml20 or lefh18 in any mission - even using Ctrl+F5

Please note that I am talking about long range artillery, not AT guns.

 

Thanks for the clarification.

Share this post


Link to post
Share on other sites
Posted (edited)

I have a p40 career currently at 02/10/41 (october) stationed at Gorstovo and the map is autumn but the flight and I are given winter skins.

 

Thanks for the work in this career generator.

 

Edit: The map might actually be summer, not autumn; it's definately not snowy!

Edited by John_Yossarian

Share this post


Link to post
Share on other sites

Front lines missing in my He111 Bomber campaign after mission on 13th Nov (game time), Moscow map. Campaign and missions (working created with 8.6.0 and non-working created with 8.7.0) are in the "other" thread.

Share this post


Link to post
Share on other sites

Me I would like to be able to start as US volunteer in FC with the Esc 124 Lafayette and transfer to the 94th. Other than that I have no real issuesw... you have done a great service to the community with your program...S!

Share this post


Link to post
Share on other sites
Posted (edited)

I am having issues with 94th Aero generating missions after the first one or two, I rewrote a .json for 103rd Aero using 56 Sqd as a base and it will not work either. Issue with USAS.
The 'mission write' flashes and the generator fails to write the mission bin file.

Edited by NDak

Share this post


Link to post
Share on other sites
Posted (edited)

Do NOT forget this bug for PWCG-FC

 

Edited by Dutch2
forget the NOT

Share this post


Link to post
Share on other sites

Russian campaign on Stalingrad map is broken. Your home field is behind enemy lines. I've created multiple Russian campaigns. On the Moscow and Kuban maps, you take off from Russian territory then fly west towards the front lines (as you should). When I start a Russian campaign on the Stalingrad map, we take off from German territory then fly east towards the front lines. I've tried different start dates, different planes/squadrons, and we always start in German territory and fly east. The German campaign on the Stalingrad map has you taking off from German territory and flying east towards the front lines (as you should). It probably started in version 8.5 or 8.6. This is what I was running into when I started my "Going the wrong way" thread.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/2/2020 at 12:04 AM, BB-Madman said:

Russian campaign on Stalingrad map is broken. Your home field is behind enemy lines. I've created multiple Russian campaigns. On the Moscow and Kuban maps, you take off from Russian territory then fly west towards the front lines (as you should). When I start a Russian campaign on the Stalingrad map, we take off from German territory then fly east towards the front lines. I've tried different start dates, different planes/squadrons, and we always start in German territory and fly east. The German campaign on the Stalingrad map has you taking off from German territory and flying east towards the front lines (as you should). It probably started in version 8.5 or 8.6. This is what I was running into when I started my "Going the wrong way" thread.

 

Yep. I just got the game and I guess the new java version completely  PWCG [edited].

Edited by SYN_Haashashin
language

Share this post


Link to post
Share on other sites
Posted (edited)

@BB-Madman I have tried multiple times to recreate that and have not been able to do so. 

Can you press "Report Error" and post the zip file?

 

9 hours ago, NDak said:

I am having issues with 94th Aero generating missions after the first one or two, I rewrote a .json for 103rd Aero using 56 Sqd as a base and it will not work either. Issue with USAS.
The 'mission write' flashes and the generator fails to write the mission bin file.

 

 Can you press "Report Error" and post the zip file?

 

 

9 hours ago, Nadelbaum said:

Front lines missing in my He111 Bomber campaign after mission on 13th Nov (game time), Moscow map. Campaign and missions (working created with 8.6.0 and non-working created with 8.7.0) are in the "other" thread.

 Can you press "Report Error" and post the zip file?

 
Edited by PatrickAWlson

Share this post


Link to post
Share on other sites
12 hours ago, Varibraun said:

I have also had this issue - but only in an imported campaign.  I think there may be some mix-up with previously deceased AI pilots.  I thought it might have just been that my old campaign file was corrupted during an import to a newer PWCG version since I had not seen it happen in either of the new campaigns I created since the logs update (and maybe even since the SP multi-pilot update).  

 

However, since it isn't just me, and I still have one of the old campaigns, I will fly that campaign this weekend to get you another report on this issue.

 

Looked into that and I saw only 1 human player assigned in the last mission.  Also, the zip did not include the coop directory so it is a bit difficult for me to see how many human pilots are in the campaign and who they are.  Last but not least the campaign is a single player campaign and not a coop campaign.  Wrong campaign zipped?

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, PatrickAWlson said:

@BB-Madman I have tried multiple times to recreate that and have not been able to do so. 

Can you press "Report Error" and post the zip file?

 

Every Russian campaign on the Stalingrad map is like that for me. Here's the file.

Test202005020005330.zip

 

A little mission info - 3 planes in our flight.

1 shot down half way to target; pilot listed in AAR as "Captured".

1 damaged and made a forced landing trying to reach an alternate field; pilot listed in AAR as "Captured".

I was the only one to return to our home field, landed successfully, couldn't find any bullet holes in my plane; pilot listed in AAR as "Seriously Wounded".

Edited by BB-Madman

Share this post


Link to post
Share on other sites
2 hours ago, PatrickAWlson said:

 

 

 Can you press "Report Error" and post the zip file?

 

 

Campaign:

 

HeinkelBomber202004271704372.zip

 

Frontline still showing in in-game map (mission was created with 8.6.0):

 

HeinkelBomber 1941-11-13.zip

 

Frontline not anymore showing in in-game map (mission was created with 8.7.0):

 

HeinkelBomber 1941-11-22.zip

 

Original report:

 

 

I also do get the missing objects complaint every now and then...

 

Share this post


Link to post
Share on other sites
10 hours ago, PatrickAWlson said:

 

Looked into that and I saw only 1 human player assigned in the last mission.  Also, the zip did not include the coop directory so it is a bit difficult for me to see how many human pilots are in the campaign and who they are.  Last but not least the campaign is a single player campaign and not a coop campaign.  Wrong campaign zipped?

I'm sorry that my report wasn't clear - I only fly single player. "3 of us" means me and my 2 AI buddies. But the AAR shows one fewer AI pilot than was actually on the mission in both cases.

Share this post


Link to post
Share on other sites
Posted (edited)
12 hours ago, PatrickAWlson said:

@BB-Madman I have tried multiple times to recreate that and have not been able to do so. 

Can you press "Report Error" and post the zip file?

 

 

 Can you press "Report Error" and post the zip file?

 

 

 Can you press "Report Error" and post the zip file?

 

 

103rd Aero 1918-05-01.zip

Edited by NDak
Added Error and Mission files.

Share this post


Link to post
Share on other sites
3 hours ago, grcurmudgeon said:

I'm sorry that my report wasn't clear - I only fly single player. "3 of us" means me and my 2 AI buddies. But the AAR shows one fewer AI pilot than was actually on the mission in both cases.

 

Thanks for the clarification.  

 

To all who posted zips - thanks.  I will try to get as many fixed as possible today and tomorrow.  

  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, NDak said:

 

The mission is still being generated, just not the binary file.  I have improved the message to be more clear.  The real problem is probably that MissionResaver.exe is not on your system or PWCG does not have permission to run it.  Look for <FC Install Dir>\bin\resaver on your machine.  MissionResaver.exeis a 1C executable (not part of PWCG) that makes the binary file.

 

As stated above, the mission is still being created and you can fly it.  It will just take a few minutes to load.  

Share this post


Link to post
Share on other sites

Did notice that we are putting WWII static trucks on airfields in WWI.  Was hoping that was the unidentified object.  Eliminated them and still get the problem.

 

I pull available objects from the WWI map file.  It is unusual for an object to be deleted or changed, but maybe that happened.  Still looking.  It's one of these:

 

parseval
flak77cml27
hotchkissmle14-aa
leyland3tonraf
mg08-aa
qf13pdr6cwt
thorny13pdr-aa
fakefield
abbayesaintvaast
af_barracksround1
af_barracksround2
af_barrackssmall
af_camptents1
af_camptents2
af_guardgate
af_hangardoubleside
af_hangartent1
af_hangartent2
af_smalltents
arrascitadelle
ballgate
barrackround
barracksmall
beauxartsdelille
beffroidelamairiedelille
bench2
bf_barbed_4
bf_barbed_5
bf_barbed_50
bf_gunpos_1
bf_gunpos_2
cart
church_eu_big
church_eu_mid1
church_eu_mid2
church_eu_mid3
citadelledelille
coverstructure
hangardoubleside
hangartent1
hangartent2
hoteldeville
industrial_block_eu_fabric200x200
industrial_block_eu_fabric250x100
industrial_block_eu_fabric300x200
industrial_block_eu_fabric300x200_2
millitarytower1
operadelille
portedeparis
prefecturedelille
rw
rwplatform_eu
rwstation01
rwstation02
rwstation03
rwstation04
rwstation05
tentcart
town_eu_arras_01
town_eu_arras_02
town_eu_arras_03
town_eu_arras_04
town_eu_arras_05
town_eu_lille_01
town_eu_lille_02
town_eu_lille_03
town_eu_lille_04
town_eu_lille_05
town_eu_lille_06
town_eu_lrg_block_01_01
town_eu_lrg_block_01_02
town_eu_lrg_block_01_03
town_eu_lrg_block_01_04
town_eu_lrg_block_01_05
town_eu_lrg_block_01_06
town_eu_lrg_block_01_07
town_eu_lrg_block_01_08
town_eu_lrg_block_01_09
town_eu_lrg_block_01_10
town_eu_lrg_block_02_01
town_eu_lrg_block_02_02
town_eu_lrg_block_02_03
town_eu_lrg_block_02_04
town_eu_lrg_block_03_02
town_eu_lrg_block_03_04
town_eu_lrg_block_04_01
town_eu_lrg_block_04_02
town_eu_lrg_block_04_03
town_eu_lrg_block_04_04
town_eu_lrg_block_05_01
town_eu_lrg_block_05_02
town_eu_lrg_block_05_03
town_eu_lrg_block_06_01
town_eu_lrg_block_06_02
town_eu_lrg_block_06_03
town_eu_lrg_block_07_01
town_eu_lrg_block_07_02
town_eu_lrg_block_08_01
town_eu_lrg_block_08_02
town_eu_lrg_block_08_03
town_eu_lrg_block_08_04
town_eu_lrg_block_08_05
town_eu_lrg_block_08_06
town_eu_lrg_block_08_07
town_eu_lrg_block_08_08
town_eu_lrg_block_08_09
town_eu_lrg_block_08_10
town_eu_lrg_block_08_11
town_eu_lrg_block_arras
town_eu_lrg_det_01_01
town_eu_lrg_det_01_02
town_eu_lrg_det_01_03
town_eu_lrg_det_01_04
town_eu_lrg_det_01_05
town_eu_lrg_det_01_06
town_eu_lrg_det_01_07
town_eu_lrg_object_01
town_eu_lrg_object_03
town_eu_lrg_object_04
town_eu_lrg_object_05
town_eu_lrg_object_06
town_eu_lrg_object_07
town_eu_lrg_object_08
town_eu_lrg_object_09
town_eu_lrg_object_10
town_eu_lrg_object_12
town_eu_lrg_object_13
town_eu_lrg_object_14
town_eu_med_block_01_01
town_eu_med_block_01_02
town_eu_med_block_01_03
town_eu_med_block_01_04
town_eu_med_block_01_05
town_eu_med_block_01_06
town_eu_med_block_01_07
town_eu_med_block_02_01
town_eu_med_block_02_02
town_eu_med_block_02_03
town_eu_med_block_02_04
town_eu_med_block_02_05
town_eu_med_block_02_06
town_eu_med_block_03_01
town_eu_med_block_03_03
town_eu_med_block_03_04
town_eu_med_block_03_06
town_eu_med_block_03_07
town_eu_med_block_03_08
town_eu_med_det_01_01
town_eu_med_det_01_03
town_eu_med_det_01_04
town_eu_med_det_01_05
town_eu_med_det_01_06
town_eu_med_det_01_07
town_eu_med_det_02_01
town_eu_med_det_02_02
town_eu_med_det_02_03
town_eu_med_det_02_04
town_eu_med_det_02_05
town_eu_med_det_02_06
town_eu_med_det_03_01
town_eu_med_det_03_03
town_eu_med_det_03_04
town_eu_med_object_01
town_eu_med_object_02
town_eu_med_object_03
town_eu_med_object_04
town_eu_med_object_05
town_eu_med_object_06
town_eu_med_object_07
town_eu_med_object_08
town_eu_med_object_09
town_eu_med_object_10
town_eu_med_object_11
town_eu_med_object_12
townhall_eu_1
bridge_hw110
bridge_hw190
bridge_hw70
bridge_hw90
bridge_rr110
bridge_rr70
bridge_rr90
windsock
albatrosd5
bristolf2bf2
halberstadtcl2
pfalzd3a
sopcamel
spad13
 

Share this post


Link to post
Share on other sites
Posted (edited)
5 minutes ago, PatrickAWlson said:

Did notice that we are putting WWII static trucks on airfields in WWI.  Was hoping that was the unidentified object.  Eliminated them and still get the problem.

 

I pull available objects from the WWI map file.  It is unusual for an object to be deleted or changed, but maybe that happened.  Still looking.  It's one of these:
 

Pat, FWIW I have seen the unknown object in my WW2 campaign (the one you now have as zipped). If I understood your post correctly you are narrowing it down to just WW1 objects?

Edited by Nadelbaum

Share this post


Link to post
Share on other sites

Bug report:

When putting ground density to "high", no artillery (howitzers) are spawned in attack/defend missions

 

Thanks

Best regards

Rieper

Share this post


Link to post
Share on other sites

I'm pretty much out of ideas on the missing objects.  Every ground object in the mission file exists in the Arras file.  Every vehicle and gun exists.  The planes are correct and the balloon is fine.  

 

I don't think the game particularly cares about WWI vs WWII.  If it's there then the game will present it.  It does care about the map.  Objects are tied to a map and I suspect that if they are used across maps where they are not specified then there might be a problem.

 

@Nadelbaum If that is also happening in WWII then that is a data point.  

 

Going to ask in mission making forum, see if anybody has any tips.  

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, PatrickAWlson said:

 

The mission is still being generated, just not the binary file.  I have improved the message to be more clear.  The real problem is probably that MissionResaver.exe is not on your system or PWCG does not have permission to run it.  Look for <FC Install Dir>\bin\resaver on your machine.  MissionResaver.exeis a 1C executable (not part of PWCG) that makes the binary file.

 

As stated above, the mission is still being created and you can fly it.  It will just take a few minutes to load.  

When I try to fly the mission in game it just flashes and goes back to the mission screen... just generated and tried this mission file, click start and it goes straight back to the mission screen.

I can get 43 and 56 Sqd campaigns to generate missions.  The USAS jsons do not seem to be working.

103rd Aero 1918-05-01_3.zip

103rd Aero.zip

Edited by NDak
Added 103rd Aero json

Share this post


Link to post
Share on other sites
16 hours ago, PatrickAWlson said:

Last but not least the campaign is a single player campaign and not a coop campaign.  Wrong campaign zipped?

 

6 hours ago, grcurmudgeon said:

But the AAR shows one fewer AI pilot than was actually on the mission in both cases.

 

This may be related - I have been getting a similar type issue with AI "ghost" pilots BUT, at least so far, only in an imported campaign.  So it might just be a glitch in the conversion.

 

I was able to recreate today and the ghost pilot is "2nd Lt Will Redney."  Turns out he was captured while flying P-38s in my active squadron, but he now continues to show up in our AAR and post mission screens when not in our squadron (plus he also shows up with other squadrons and a/c).  I think this has happened with other dead/captured pilots previously in that imported campaign.  File and screenshots follow if that helps:

 

Pilot Flight Log showing capture date of 5/11/44 (this shows up in his "new" squadron when clicking on him):

Spoiler

image.thumb.png.ac9282c790d5b9008ca684e34af43cbf.png

 

Sequential mission screens from 29/11/44 where Redney suddenly shows up in the post mission screens & AAR even though not in the flight (and flying a P-51 not the P-38):

Spoiler

image.png.7de08f9cd6193c04e35849a568b774a7.png

image.thumb.png.9eeafa681d2bb3470a613ca3fe705e23.png

 

image.png.d4c02e52d1afd17ceed8beac5b5de26a.png

 

image.png.33b9d7344b609c50c93f4bcf7ec9efb4.png

 

and then he disappears again...

image.png.86bc96e43c82597cb219ea50c50bcd09.png

 

 

 

Here you can see him showing up in other squadrons (at the same date) - but with 0 missions and with the captured status in his log (I transferred a pilot over to check him out in one of his "new" squadrons):

Spoiler

image.png.7f268fcbdfa8d9598944a62a9ee32c56.png

 

image.png.6077f76f1d5f388b1c42287e0f686a70.png

 

image.thumb.png.993e858d97d1db18f12f1c6f915f2ae2.png

 

Mark - WF - Allies202005021505374.zip

Share this post


Link to post
Share on other sites

@Varibraun Thanks for looking at this.  One common theme is that the ghost pilot is always a pilot lost during a mission.  

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Question: When flying bomber or attack missions, could you consider changing the mission parameters so that the fighter escort stays with my flight all the way to the home airfield approach point?  Currently I hear the escort leader give the RTB order after my flight reaches the egress point, usually just after crossing over into friendly controlled territory.  But on some missions (312th ShAP out of Ivanovskoye on the Kuban map), the bandits chase us until we've almost reached the base.  In regular SP career mode the escort stays with you until you reach your base and then departs.

 

Thanks for all you've done to improve PWCG.  It really makes for a better SP experience!  Swoose

Share this post


Link to post
Share on other sites
8 hours ago, No105_Swoose said:

Question: When flying bomber or attack missions, could you consider changing the mission parameters so that the fighter escort stays with my flight all the way to the home airfield approach point?  Currently I hear the escort leader give the RTB order after my flight reaches the egress point, usually just after crossing over into friendly controlled territory.  But on some missions (312th ShAP out of Ivanovskoye on the Kuban map), the bandits chase us until we've almost reached the base.  In regular SP career mode the escort stays with you until you reach your base and then departs.

 

Thanks for all you've done to improve PWCG.  It really makes for a better SP experience!  Swoose

I usually draw the egress waypoint in the briefing close enough to my base, to not get in trouble after the fighters left.

  • Thanks 1

Share this post


Link to post
Share on other sites

For the Fw-19A3

 

When payload is changed to MG FF Wing Guns in Pilot Selection screen, then only the 2 x 20mm MG FF/M (120 rounds) is applied, there is also the 2 x 20mm MG FF/M (180 rounds) but no option to select it in Payload in PWCG.

 

Just a small thing but an extra 60 rounds is good... 🙂

Share this post


Link to post
Share on other sites

Hi Pat....For FC I was able to create the Esc 124 Lafayette and the 103rd Aero and got them to work.... I did a manual transfer to the 103rd on a date around 180604 and generated a mission and was able to run the mission and got the AAR. So this will work for me to be able to fly as an american volunteer for the french and then transfer to a US squad later. Also had a current French campaign  for esc 3 and was on date 180707 and was also able transfer to the 103rd and am able to continue my campaign.  Will have to continue my campaign over time to see if it continues to work, but looks good so far.  Will update if something goes wrong.  ....Found out that selecting Aces Hunter or Baer seems to break it....had to take a few days leave and it seems ok again....Well maybe not....I am starting to think that it has something to do with the start dates with the US squad....after 19180801 I do not seem to have any problems with missions not generating or the AAR not working..Just what I am seeing...Hope this may help...Sorry for being so long winded....
Attached the .josn files if anyone is interested.

work.zip

Share this post


Link to post
Share on other sites

I tried later dates for 103rd, October and November and had the same issue I had before - json and campaign would not generate a mission file. As I stated above, the other RFC units work fine. I even went so far as to copy all the image files into another folder that were showing in the error log.
I will go back and edit another json to see if I can isolate the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...