Jump to content
=LD=Penshoon

You also think BOS is Beautiful? How about making it ABSOLUTLY GORGEOUS! *Instructions inside*

Recommended Posts

If your GPU is only running at 50% then it's probably bottlenecked by your processor. Basically your GPU is waiting for your CPU all the time as it can't finish his work as quick as the GPU finishes his.

Only way to get higher frames would be to overclock the CPU or buy a faster one. 

 

You could stabilize the fps by giving the GPU some more work though!

Try adding higher AA setting while checking the GPU load in your monitoring program. Try to get it as close to 90-99% load without maxing it out, as long as you stay below 100% load all the time you shouldn't get any worse performance at all, just a better looking game with less fps fluctuations.

Got this fixed as best possible by going to Control Panel--> Hardware -->Power Options-->Change Plan Settings-->Change Advanced Power Settings.  I set the minimum processor state to 80% (was 5%!).    Frame rates stay higher in SLI (60fps on Ultra) overall and the stuttering is gone during flight except for the first time you look around the cockpit. Got the graphics smoother also by turning AA all off also, except for FXAA = ON setting through NVIDIA Control Panel with ingame setting of 2x at 2560x1440.  All terrain set at 4096,8 and looks great!

  • Upvote 1

Share this post


Link to post
Share on other sites

Got this fixed as best possible by going to Control Panel--> Hardware -->Power Options-->Change Plan Settings-->Change Advanced Power Settings.  I set the minimum processor state to 80% (was 5%!).    Frame rates stay higher in SLI (60fps on Ultra) overall and the stuttering is gone during flight except for the first time you look around the cockpit. Got the graphics smoother also by turning AA all off also, except for FXAA = ON setting through NVIDIA Control Panel with ingame setting of 2x at 2560x1440.  All terrain set at 4096,8 and looks great!

Thanks for this tip!

:salute:

  • Upvote 1

Share this post


Link to post
Share on other sites

But how to remove the blur (filter) in the cockpit?

Edited by =RV=GUIGNOL
  • Upvote 1

Share this post


Link to post
Share on other sites

I believe you may go to Turn off Cinematic setting that is located in the Camera options menu. You can do so during flight also.

Share this post


Link to post
Share on other sites

This tip is rad.

 

 

You can much more easily see the frozen rivers and lakes. This is the best navigation tip in the forum.

 

Zero noticeable performance drop.

 

4770K

GTX770

Maximus Hero VII mobo

16gig ram

 

All Ultra settings etc.

Share this post


Link to post
Share on other sites

well it sure needed redoing for me! :)

or more like :( ?

i check regularly that all values are 4096; 8 :-D *rock*

Share this post


Link to post
Share on other sites

Just checked (already!) and mine had stayed as I wanted it through recent updates.

Share this post


Link to post
Share on other sites

I have this setting and still blurry textures.

 

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

 

what does 8, 16, 32, 64 do.

Edited by 71st_Mastiff

Share this post


Link to post
Share on other sites

I have this setting and still blurry textures.

 

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

 

what does 8, 16, 32, 64 do.

 

S!

 

Guess they are the colour depth of the lLODs. 8 bit should be more than enough.

 

Zettman

Share this post


Link to post
Share on other sites

Guess they are the colour depth of the lLODs. 8 bit should be more than enough.

 

Don't think that's a color depth, see Matt's explanation.

Share this post


Link to post
Share on other sites

Hm.. any ideas, men, wether terrain.ini used in 1.009 patch or not???

 

Cant see any difference..

Edited by [I.B.]Zulu

Share this post


Link to post
Share on other sites

Did cross my mind... (Probably just my eyes, but...)

Edited by No601_Swallow

Share this post


Link to post
Share on other sites

 

Hm.. any ideas, men, wether terrain.ini used in 1.009 patch or not???

Think so. Although I don't know the base values that came with 1.009, maybe someone can post them. (I would have to do a clean install to get these all over again).

Share this post


Link to post
Share on other sites

Like FlatSpinMan, the last two patches have not touched my settings for this. So I guess the default values are the same the ones before 1.009.

Share this post


Link to post
Share on other sites

This is true for me only, so others may see different results, but after setting terrain file to

 

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

 

Just changed the "5" to "10" to account for number of lines at top Above these. The "50" at the very top of the file remains the same.

 

I see my system has easier time to keep up framerate than with only 5 lines. Especially close to ground. Nearly had a heart attack when I saw 58 fps (My presetmax) sitting on the tarmac.

Edited by roaming_gnome

Share this post


Link to post
Share on other sites

I did a test of three settings of Terrain.ini.  The setting is above each picture.  All comparisons are using SweetFX however I have included a non-SweetFX of the Original Terrain.ini as a control.  All are in Balanced Preset except the last to show the difference to the Ultra setting.  Resolution is 1920x1200.

 

Original Terrain.ini

texlod=4096,8
texlod=2048,8
texlod=2048,8
texlod=2048,8
texlod=1024,16

.

No SweetFX

16517883238_bb23e33062_h.jpg

.

With SweetFX

16704199732_77d9b42a4f_h.jpg

.

.

2nd Setting - Been using this for quite a while (Improved detail on horizon over original terrain.ini)

texlod=8192,32
texlod=4096,16
texlod=4096,16
texlod=4096,16
texlod=2048,8

.

16517868360_818fe72160_h.jpg

.

.

3rd Setting - roaming_gnome's post  (improved detail throughout over 2nd setting)

texlod=4096,8 X 10 Lines

.

16517866280_33a0f8214a_h.jpg

.

.

3rd Setting in Ultra - (improved detail over 3rd setting in Balanced preset in city and forest directly under plane)

.

16703964801_4f0a8897c7_h.jpg
.

.

.

I have not done extensive testing of the 3rd setting, however in Balanced preset in QMB I seemed to have little to no hesitations where previously there were some.  Keeping my fingers crossed for mp.

  • Upvote 3

Share this post


Link to post
Share on other sites

!CAUTION!

 

More than 5 lines crashes Mission editor.

So use 10 for game but revert to 5 if you want to use FMB.

  • Upvote 2

Share this post


Link to post
Share on other sites

!CAUTION!

 

More than 5 lines crashes Mission editor.

So use 10 for game but revert to 5 if you want to use FMB.

 

Thanks for finding that.  I placed terrain.ini in the JSGME MODS folder making it very easy to activated/deactivate.

Share this post


Link to post
Share on other sites

!CAUTION!

 

More than 5 lines crashes Mission editor.

So use 10 for game but revert to 5 if you want to use FMB.

Many Thanks for this info!

Share this post


Link to post
Share on other sites

The last patch appears to have reset this  to default for me...same for others?

 

Not for me.

Share this post


Link to post
Share on other sites
with the new version, and seting in balance

 

Resolution 1920 x1080

 

PixelSize=50 //meters

 

LodCount=10

 

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

 

 

 

No SweetFx

Il-2%202015-03-17%2023-42-26-56_zpsyebgs

 

With Sweet :

Il-2%202015-03-17%2023-42-28-49_zpsbauxb

 

 

 

 

 

 

 

 

No Sweet :

 

Il-2%202015-03-17%2023-42-40-88_zpsqsfs2

 

 

 

with Swwet FX

 

Il-2%202015-03-17%2023-42-39-54_zpsomrat

 

 

 

:dance:

Share this post


Link to post
Share on other sites

hmm I had forgotten about this.  Going to hae to check to see if all of the updates have reset this.

Share this post


Link to post
Share on other sites

with the new version, and seting in balance

 

Resolution 1920 x1080

 

PixelSize=50 //meters

 

LodCount=10

 

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

texlod=4096,8

 

 

 

No SweetFx

Il-2%202015-03-17%2023-42-26-56_zpsyebgs

 

With Sweet :

Il-2%202015-03-17%2023-42-28-49_zpsbauxb

 

 

 

 

 

 

 

 

No Sweet :

 

Il-2%202015-03-17%2023-42-40-88_zpsqsfs2

 

 

 

with Swwet FX

 

Il-2%202015-03-17%2023-42-39-54_zpsomrat

 

 

 

:dance:

Dude, that's amazing. Post your sweet fx settings!

Share this post


Link to post
Share on other sites

here's my settings

 

 

 

statup confg graphics section

 

[KEY = graphics]

 

adapter = 0

 

desktop_center = 1

 

fps_limit = 120

 

full_height = 1440

 

full_width = 2560

 

fullscreen = 1

 

gamma = 0.55000

 

mgpu_compatible = 0

 

multisampling = 2

 

or_enable = 0

 

or_ipd = 1.00000

 

or_lens_offs = 1.00000

 

preset = 3

 

vsync = 1

 

win_height = 1440

 

win_width = 2560

[END]

 

Graphics folder ini file

 

PixelSize=50  //meters

 

 

LodCount=10

 

 

texlod=8192,8

 

texlod=4096,8

 

texlod=4096,8

 

texlod=4096,8

 

texlod=8192,8

 

my NVidia settings

 

                      

 

In game settings

 

 

 

 

 

Edited by 71st_Mastiff

Share this post


Link to post
Share on other sites

Having 8192 in more than one line will crash my program if I remember correctly, think also that you may have to have lodcount=5 instead of the lodcount=10 since you only list 5 lines of lodcount in the file according to you post.

Share this post


Link to post
Share on other sites

Having 8192 in more than one line will crash my program if I remember correctly, think also that you may have to have lodcount=5 instead of the lodcount=10 since you only list 5 lines of lodcount in the file according to you post.

thanks was not crashing before but now is for some reason,

Share this post


Link to post
Share on other sites

Does changing stuff in the NVidia control thing actually work now?

Last time I tried (sometime in December, mind) it didn't do anything and there were posts here saying it was currently broken.

Share this post


Link to post
Share on other sites

Works fine for me, either NCP or Nvidia inspector

 

Turn on anti aliasing to 16 X and transparency to 8 X supersampling, enhance or override and check to see big fps drop if working

 

Cheers Dakpilot

Share this post


Link to post
Share on other sites

Previously I could not get nVidia CP to do anything with AA over what the game provided. There was a recent post that said nVidia CP will work with Full screen on.  I tried a new test of nVidia CP.  Below are the results of AA testing using full screen setting to ON in game.  The following screenshots were done with no SweetFX.  I do use SweetFX 2.0 Alpha and that works as well even if the game AA is on.

First is the full screen view with following settings:

In Game = Fullscreen OFF, AA 4X, vsync OFF    nVidia = AA mode - Application controlled, AA setting - Application controlled,  AA Trans - OFF
16946073351_7964f2e2fc_h.jpg

Here is the same screen zoomed in.
16945720752_afb90ccada_h.jpg


This shot is zoomed in exactly as the one above except the AA settings have been changed to the following:
In Game = Fullscreen ON, AA 4X, vsync ON    nVidia = AA mode - Override application, AA setting - 32xCSAA,  AA Trans - 2x
16947042855_b6f2655537_h.jpg


There is a difference on the zoomed shots.  I will not run AA on 32x but I wanted to see if there was any difference at all.
 

Share this post


Link to post
Share on other sites

A surprisingly minor difference that validates my personal experience that the in game AA works best on my system.

What was the fps hit?

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello there fellow pilots, 

 

I have done some more research to find out what settings give the best result. Most of all, I wanted to find out whether the settings provided by =LD=Hethwill_Kahn where indeed the best settings.

I have been playing around with various settings to find the best result.

Before we go into the test results, here are the hardware and IL-2 BoS Settings that I used. (only the important stuff.)

 

Hardware:

CPU Intel i7 2600

GPU Nvidia GTX660

I run the game at about 50-60 FPS between 0 and 2000m and over 60 FPS above 3000m

 

Settings in-game:

Balanced

Antialiasing: 2

Gamma correction: 0.8

 

And now the settings in the "terrain.ini" file:

Setting 1: 

(settings used by =LD=Hethwill_Kahn)

 

LodCount=5
texlod=8192,16
texlod=4096,32
texlod=4096,16
texlod=2048,16
texlod=2048,8

 

Setting 2:

 

LodCount=5
texlod=8192,8
texlod=4096,8
texlod=4096,8
texlod=4096,8
texlod=4096,8
 
The colours match the colours in the pictures!
The Zoom Level is indicated in orange.
 
I have made some comparison Pictures to show you guys the difference. A description/explanation can be found under the picture. 
The pictures where taken at expectantly the same point and from the same angle. The pictures where taken in a replay file (when the game automatically pauses the replay). Therefore, the ground textures overlapped perfectly!
The pictures where taken on the "novosokolniki" Map. This map has a lot of forest making it a bit easier to see the differences. 
 
Altitude: 1100 meter!
Ysp04tH.jpg
 
Trees close: There was a small difference. When using setting 1, some of the tree trunks and bushes would be rendered that were not rendered when using setting 2. Unnoticeable when flying.
Trees Texture Far: The tree textures are quite a bit sharper when using setting 2. In my opinion this looked a bit better and more realistic.
Ground Texture Close: Both settings look the same. In both the ground texture is incredibly sharp. 
Ground Texture Medium and Far: In Setting 1 it looks like someone blurred the textures. A very sharp line is visible where the textures transition. In settings 2 the ground textures look a lot sharper. There is a line detectable where the textures transition but it can only be found in a picture and is undetectable when flying. (See the red outlined part on the left.)
 
When performing the test while flying at 2200m, the differences where the same. 
 
When performing the test at 2200m, 4400m and 6600m a new fact became apparent!
 
Altitude: 4400 meter!
uFd4Yip.jpg
 
Trees Texture Far: Just like when flying at 1100m it is more clear when using setting 2. I have also tried navigating with the 2 settings. Using setting 2 made it a lot easier. The colour differences between the
rivers, snowfields and forests become more visible. Being able to see the rivers more clearly helped a lot when navigating. 
 
I have also done some tests with the Following settings:
 
LodCount=5
texlod=8192,4
texlod=4096,4
texlod=4096,4
texlod=4096,4
texlod=4096,4
 
and
 
LodCount=5
texlod=8192,16
texlod=4096,16
texlod=4096,16
texlod=4096,16
texlod=4096,16
 
The result was a not really surprising. By increasing the last number the quality went down. When using the number 4 the quality was amazing but for the first time my FPS went down. 

 

I have also done some simple FPS test to see what the FPS changes are.

When using almost all settings with the last number being 8 or higher, I experienced a FPS increase. About 3-8 FPS where gained when flying at low altitude (I did not test the high altitude FPS gain. This is higher by default and should therefore not be a problem). I have compared the FPS gain with some of the settings used by other players. I did not find any difference in the FPS gain. 

When using "4" as the last number a FPS decrease was noticed. About 5-15 FPS was lost and the game would stutter a bit. 

 

Final Conclusion: To improve quality the following steps need to be taken: increase the first number and decrease the last number. However, when the last number is lowered to a "4", problems start to occur!

 

My advise and opinion:

Use settings 2 these settings provide great textures without any sharp edges and blurs. (Test first to see if you PC can handle the changes.)

 

BlackHellHound1

 

:salute:

  • Upvote 5

Share this post


Link to post
Share on other sites

Unfortunately I can't test them, but if your settings do work that's a very nice find. :salute:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...