Jump to content
BlackSix

Controls, GUI, texts

Recommended Posts

Sorry if it has been posted somewhere else.

 

Brief description: Chat colors dont display correctly
Detailed description, conditions: When on a MP game, the chat color will sitch from blue to red and back within the same conversation and without me switching to the other team. I can see my own colors changing randomly. It becomes very hard to know who is in your side once this happens.

Additional assets (videos, screenshots, logs):
Your PC config data (OS, drivers, specific software):
See Signature

 

Also, I got confirmation from other players online who were experiencing the same issue, so it looks like it's not just happening to me.

Edited by CBZ323

Share this post


Link to post
Share on other sites

Brief description:  Sometimes when I start the game, my Microsoft Sidewinder 2 Force Feedback joystick will produce a strong "kicking" force sensation.

 

Detailed description:    This incident is seemingly random but sometimes when I start the game up and begin flying, my FFB joystick will produce a strong kicking sensation that pulses every second or so.  It doesn't seem to correspond to any simulated forces from the game.  In order to get rid of this, I have to go into devices and disable and then re-enable force feedback.  Apart from this random kicking sensation, the force feedback in the game feels very muted and weak compared to other titles.  

 

I have this problem also in my MS FFB2.

Generaly a force feedbck starts to work correctly when you go to desktop and came back to BOS.

Usualy this proces has to replay a few times before FFB work correctly.

Share this post


Link to post
Share on other sites

Brief description:   Lack of pre stall buffeting in force fedback stick

 

Detailed description, conditions:

 

There is lack of pre stall shake force feedback buffeting. There is any effect of it.  Only i got stick buffeting at high speed dives.

 

 

Your PC config data (OS, drivers, specific software): Windows 7 64 bit,  Saitek Evo Force joystick ( force fedback), staitek drivers and soft.  I got 100% force fedback effects in game menu, force feedback enabled.

 

It looks BOS got problem with some force fedback sticks cause other guys with different stick got no problems.

Edited by 303_Kwiatek

Share this post


Link to post
Share on other sites

Brief description: GUI messed up, happens since 1.009 update

 

 

 

Detailed description, conditions: Often, you pres fly to start mission, but the Map stays fullscreen and you can't see the cockpit.

Or you make it to get into the cockpit, but some time in the mission, parts of the map stay visible, or chat messages or system messages don't disappear but stay visible, and so does the ESC Menu....see screenshot, it was impossible to get those charts and messages away. All while still flying....

 

 

jUpRJy.jpg

 

 

 

 

Your PC config data (OS, drivers, specific software): Windows 7 64 bit, GTX 680, nvidia driver 332.21

Share this post


Link to post
Share on other sites

Brief description: GUI buttons may show incorrect text after mission starts
Detailed description, conditions: Just after mission begins, "My Plane" button of map reads "@MAPPINTOLOCALPLAYER" instead. Closing and re-opening the map after a moment shows correct text.
Additional assets (videos, screenshots, logs):

KbOLg8q.png


Your PC config data (OS, drivers, specific software):

Win7 x64, i7-4790K (4.00GHz), 16 GB RAM, NVIDIA GTX 780 3GB, driver 347.52.

Share this post


Link to post
Share on other sites

As reported multiple times before, the trim commands do not work in the He 111 when using a MSFFB2 joystick. 

Edited by [DBS]El_Marta

Share this post


Link to post
Share on other sites

...little grammar/text correction:

 

In the german ingame messages it should read ..."xy" hat "z" zerstört, instead of,  "xy" hat "z" zerstören....

 

Prescense/Past etc., blablabla ;)

 

yours

v.Greiff :salute:

Share this post


Link to post
Share on other sites

Brief description:   Esc Key Bug has re-appeared after latest update.

 

Detailed description, conditions: 

Ran about 6 or 7 QMB missions today testing for hit sounds, and in more than 50% of those missions I could not end the mission with the Esc key.  When it didn't work, had to Alt-Tab out and shut down BoS from Windows.  I checked and the command is properly assigned, and sometimes it would work, sometimes not.  This was happening fairly regularly a few updates ago, but had been acting properly more recently.

 

Additional assets (videos, screenshots, logs):  None

 

Your PC config data (OS, drivers, specific software):  same as before - see below

Intel Core i7-4770K @3.5 GHz; ASUS ROG Maximus VI MB; 16GB RAM
EVGA GTX 980, 4 GB; Realtek ROG SupremeFX audio
Windows 8.1 Pro 64-bit

Share this post


Link to post
Share on other sites

Brief description:   Bombsight instruments wrong


 


Detailed description, conditions:The instrumetns read incorrect data from what the aircraft is actually doing.  It happens in Both the HE and the PE.


 


Additional assets (videos, screenshots, logs):  None


 


Your PC config data (OS, drivers, specific software):  


Share this post


Link to post
Share on other sites

Brief description: Windows game controller ID

Detailed description, conditions: Game controller ID in windows 8/8.1 and W10 will get random place in the joystick list and on occasion move when connectiong a new controller. This is because of OS handling of USB devices and it's not possible to do anything about it. I strongly suggest that you
change the way BOS/BOM handles device ID to a similar fasion of DCS. DCS doesn't bother with windows game ID list at all and you can connect disconnect
any controls you want and it still works. It's a real problem having to reassign controls because of this.

 

Share this post


Link to post
Share on other sites

 

Brief description:   Bombsight instruments wrong

 

Detailed description, conditions:The instrumetns read incorrect data from what the aircraft is actually doing.  It happens in Both the HE and the PE.

 

Additional assets (videos, screenshots, logs):  None

 

Your PC config data (OS, drivers, specific software):  

 

So I have NEVER experienced this with ANY OTHER PRODUCT but, I re-installed the game and it fixed this issue.  No idea what file was corrupt but the resintall did it!   Disregard bug 

Edited by [TWB]Hooves_McG

Share this post


Link to post
Share on other sites

Hi gutterrat13,

I have the same joystick and have also reported this problem.  I also know others with the same joystick who also have the same problem.  However, the response from the BoS dev team is always that they are "not able to replicate the problem". 

From my perspective it appears that the BoS dev team do not want to recognise that there is a problem.  I get the impression that they don't care if Saitek Cyborg Evo Force feed-back users have a stick that is not compatible with BoS with ffb turned on.

I have stopped flying BoS at the moment and do not have it on my PC because of this.  Instead, I have just started with DCS World WWII aircraft and am looking forward to the DCS WWII project with 'Edge' and the new Normandy map.

The Saitek Cyborg Evo Force feed-back joystick works perfectly well with CloD and DCS, so the evidence clearly suggests that there is a problem with BoS, not the joystick.  I refuse to fly BoS with ffb turned off, so I don't fly BoS anymore.

I also think that there is enough evidence with this issue and others reported on the forum to suggest that there is a problem with pitch control in BoS.

To say that I am disappointed with this is an understatement, as I dearly wanted to fly BoS and have supported it from the start.  Perhaps as BoS gets polished they will finally overcome what I see as pitch control issues.

 

Happy landings,

 

Talisman

 

Brief description: Calibration wrong with saitek cyborg evo Force

 

Detailed description, conditions: I recently purchased this simulator (March 3), but up to now have not been able to play,

 

I spent the whole time trying to calibrate my joystick (saitek cyborg evo Force). It will not be the best but not the worst, and so far it has always worked well.

 

In fact I read that they are not alone in having problems with this model.

 

in short, the problem is with the calibration of the pitch control that is already out of calibration at the start of the simulator (as if it were the lever slightly forward)

 

and when you pull the lever joystick to the maximum in reality simulator does not feels the greatest intensity, lack of value not calibrated forward, and makes it unplayable.

using the adjustment sensitivity helps but does not solve, especially when pull at maximum.

I am very disappointed and hope I have not wasted my money.

 

P.S.: in windows device and in other game (Rise Of Flight) joystick works well.

 

Additional assets (videos, screenshots, logs):

 

joystick in central position, no feedback:

 

2015_4_4_10_9_52r.jpg

 

 

joystick pull the lever joystick to the maximum, no feedback:

 

2015_4_4_10_14_15.jpg

 

 

joystick in central position, sensitivity and feedback on:

 

2015_4_4_10_15_29.jpg

 

 

joystick pull the lever joystick to the maximum, feedback on:

 

2015_4_4_10_15_32.jpg

 

 

 

Your PC config data (OS, drivers, specific software):

windows 7 64

latest driver of Cyborg evo force

 

Share this post


Link to post
Share on other sites

Brief description: Camera settings (Snap Camera mode / Pan Camera Mode speed / inertia in the in-game or main menu / camera menu) are not saved


Detailed description, conditions: When adjusting the speed and inertia of camera rotation and zoom any changes made to the settings do not affect anything (the cinematic mode & head shake settings do work and are saved properly). They appear to save until you reload the game and notice that they didn't in fact save at all; the options screen shows the earlier values. Even the reset to defaults doesn't work (except for cinematic mode and head shake), it seems to do something at first, but no effect and the changes aren't actually saved. I'm actually not certain about the default view mode, it may or may not stick.


Additional assets (videos, screenshots, logs): -


Your PC config data (OS, drivers, specific software): See sig


Share this post


Link to post
Share on other sites

 

Brief description: Camera settings (Snap Camera mode / Pan Camera Mode speed / inertia in the in-game or main menu / camera menu) are not saved

Detailed description, conditions: When adjusting the speed and inertia of camera rotation and zoom any changes made to the settings do not affect anything (the cinematic mode & head shake settings do work and are saved properly). They appear to save until you reload the game and notice that they didn't in fact save at all; the options screen shows the earlier values. Even the reset to defaults doesn't work (except for cinematic mode and head shake), it seems to do something at first, but no effect and the changes aren't actually saved. I'm actually not certain about the default view mode, it may or may not stick.

Additional assets (videos, screenshots, logs): -

Your PC config data (OS, drivers, specific software): See sig

 

Nevermind, this seems to be working just fine again, must've been some sort of a glitch on my end.

Share this post


Link to post
Share on other sites

Brief description:

 

Trying to invert axes for Mouse input for view controls results in loss of mouse control for that view axis entirely

Detailed description, conditions:

 

In an effort to inverse the X axis for external view controls when using a mouse, I went to Camera Controls in the Key Mapping section and clicked on the Inverse button for "Mouse X" input on "Rotate camera left/right." Then when in-flight, if I use any external views, the X axis of view control completely stops responding to the mouse, the mouse can only move the camera in the Y axis. I then tested to see what happens if also inverted the Y axis control for "Rotate Camera up/down" and the same thing occured; the mouse simply no longer affected the camera in external view.

 

I also tested the same thing for controls of "Bow pilot's head vertically" and "Bow pilot's head horizontally" and the same thing occured; inverting the mouse control axis resulted in the mouse control not working at all.

 

The one setting I found that did in fact work was if I went to Input Devices and checked the box for "Invert Y axis" on the mouse, which functioned correctly. But I could not find a way to make the Inverse settings in the controls work correctly.

 

Share this post


Link to post
Share on other sites

Brief description:

Bombsight altitude controls are binded to arrow keys and cannot be changed.
 

Detailed description, conditions:

I have binded auto-pilot to down arrow key and auto-pilot turning keys to left and right arrow keys. When I'm airborne and change position to bomb sight, my altitude setting is adjusted up/down with the left/right arrow keys. So when I correct my heading with arrow-keys, the bomb sight altitude setting is changed in process.

 

I can't find binds for the bombsight altitude settings in control setup.

 

Happens with HE-111 and PE-2

Share this post


Link to post
Share on other sites
Brief description:

Mouse Wheel after remapping from 'Pilot Head Controls -> Pilot Head: Zoom' to 'Engine Controls -> Engine Throttle Control' is with each game restart remapped back.

 

Detailed description, conditions:

I did remap Mouse Wheel to act like Engine Throttle instead of Pilot Head Zoom. After accepting I can play with the new mapping. But each time I start the game again the Mouse Wheel is back on Zoom. I tried also remove all other Mouse Wheel mappings and leave it just for throttle but problem still remains.

 

PC config data:

BOS Standard Edition

Win7 64bit

 

Note:

I know at least about one other user facing the same issue.

Share this post


Link to post
Share on other sites

Controller Settings - Warthog stick, Saitek throttle and rudder pedals.

 

Post 1.10.1 - each time I enter the game I have to reset the key bindings for the controllers.  The joystick "number" changes, ie joy0_axis_Y will have to be updated to joy2_axis_Y.   This is for all functions assigned to controllers.

 

BOS/BOM premium

Win7/64

Share this post


Link to post
Share on other sites

 

Brief description:   Bombsight instruments wrong

 

Detailed description, conditions:The instrumetns read incorrect data from what the aircraft is actually doing.  It happens in Both the HE and the PE.

 

Additional assets (videos, screenshots, logs):  None

 

Your PC config data (OS, drivers, specific software):  

 

 

 

So I have NEVER experienced this with ANY OTHER PRODUCT but, I re-installed the game and it fixed this issue.  No idea what file was corrupt but the resintall did it!   Disregard bug 

 

Reinstallation is not necessary. Bug seems to be related to entries in startup.cfg. Getting a new one solves.

Share this post


Link to post
Share on other sites

Brief description: He-111 dead angle for rear gunner

Detailed description, conditions:

 

When being in the rear gunner in the He-111 there is an importand angle where you cant aim.

 

Aim towards the rudder and as far down you can then slightly move up. You will see that at some degree you cant move up anymore. It just holds. Then you continue to move up and the aim will "pop" up a bit. It is a vital thing because many AI aircrafts tend to be in that spot and you just cant fire back.

  • Upvote 1

Share this post


Link to post
Share on other sites

Brief description:  
Problem with Turret: nestle to the gunsight (LShift+T) key command when AI-autopilot for level flight (LShift+A) is used

Detailed description, conditions:
When AI-autopilot for level flight is enabled and LShift+Z/X (left turn/right turn) is used while in the gunner position, LShift+T (nestle to the gunsight) will sometimes no longer work correctly and it's not possible to look through the gun sight because the view doesn't center in the correct position. So far I've noticed this problem when flying the He-111, Pe-2 and Il-2, but not in the Ju-87.

 

Here's the view I get with LShift+T after using LShift+Z/X (left turn/right turn) in the Pe-2 gunner position:

 

post-348-0-86283200-1440686912_thumb.jpg

Edited by Juri_JS
  • Upvote 1

Share this post


Link to post
Share on other sites

Brief description: P-40E-1 needs a bit of force feedback on machine guns.

Detailed description, conditions: The P-40 has no feedback on joystick when firing.
Additional assets (videos, screenshots, logs):
Your PC config data (OS, drivers, specific software):
MS Sidewinder 2 Force Feedback.

Share this post


Link to post
Share on other sites

Brief description: P-40 Prop pitch control issue when selecting "cold start" or parked

Detailed description, conditions: Prop pitch does not respond any commands when cold start is selected from the option OR starting point is parked. Levers move like they should but engine won´t take commands. Even when select AUTO/MANUAL. And after 5 minutes flying game crashes. (occured and tested once with cold start and parked) When choose option to start from the runway, everything works fine even when "cold start" is selected. 
 

Share this post


Link to post
Share on other sites

 

Brief description: P-40 Prop pitch control issue when selecting "cold start" or parked

Detailed description, conditions: Prop pitch does not respond any commands when cold start is selected from the option OR starting point is parked. Levers move like they should but engine won´t take commands. Even when select AUTO/MANUAL. And after 5 minutes flying game crashes. (occured and tested once with cold start and parked) When choose option to start from the runway, everything works fine even when "cold start" is selected. 

 

 

Edit: When i choose warmed up engine and parked Prop control works. Issue occurs only when parked and cold engine

Share this post


Link to post
Share on other sites

Brief description:  Game crashes when trying to play back tracks with P-40

Detailed description, conditions: Flying online with P-40 with rockets&bombs and recording track. When going to view tracks afterwards I get the following pop up box which crashes the game.

 

post-10861-0-55758400-1443739881_thumb.jpg

post-10861-0-85353000-1443739869_thumb.jpg

Share this post


Link to post
Share on other sites

Brief description: Detailed description, conditions: 

 

The mouse ingame doesn`t work properly. The pointer is bigger than usual and very hard to move and point. To change the ingame mouse sensivity option doesn`t change anything.

That problem exist only ingame Il-2 Battle of Stalingrad. My mouse works fine in any other game and in windows.

 

Your PC config data (OS, drivers, specific software):

 

Intel i3 Dual Processor

4 GB RAM

Windows 7

Share this post


Link to post
Share on other sites

Possible bug 

 

When starting the game the windows sound mixer is always reset to the same as default level. I normally have in game turned up to max and then turn down the game volume using the windows mixer but when you restart the game it is back to the default level again.

 

Only happened since the patch.

Share this post


Link to post
Share on other sites

Not sure if a bug or just an oversight with the new mouse aim but it hinders fly-ability a lot.

When using more than one monitor, the mouse moves outside the game and when pressing any mouse button the game deselects. When full screen the game minimizes and in windowed it deselects. This also happens in all menus etc.

Only way to fix this (so far) is to switch the screen setup to single screen but that kind of defeats the point for several screens, doesn't it?

Share this post


Link to post
Share on other sites

Brief description:

Can't rotate pilot's head with mouse while holding down Shift button.

 

Detailed description, conditions:

I use the mouse to rotate my pilot's head.  I mapped the Shift button + another key to several actions that require a keyboard button to be held down continuously: Shift + F to raise flaps, Shift + W to open water radiator for example.  When those keys are engaged, the mouse does not respond and I cannot rotate my pilot's head.  This problem doesn't exist for Ctrl or Alt buttons, so I can rotate the pilot's head while dropping flaps for example (Crtl+F), but not while raising them.  I use Joy-to-Key to map joystick buttons to keyboard shortucts, but the problem still persists even if use the keyboard directly.

The simple workaround was to use Ctrl and Alt keys only and not Shift, but I thought I'd report the bug anyway.

Your PC config data (OS, drivers, specific software):

Windows 7, BoS version 1.105

Share this post


Link to post
Share on other sites

Thanks, frends !

I want to apologize that I have so overheated responding.

The problem with the joy0_pov0 ... (Force Feedback 2  / MSFFB2 SideWinder )

has been done. simply rename in joy2_pov0 ... if necessary.

all to be found in:

 

C: \ Program Files (x86) \ Steam \ steamapps \ common \ IL-2 Sturmovik Battle of Stalingrad \ data \ input \ current.actions

 

:)

Edited by Tomi_099

Share this post


Link to post
Share on other sites

 

Brief description: Fw190's 20mm cannons are now linked with the machine guns - but should not be.

Detailed description, conditions: When you press the machine gun button in the Fw190, the cannons fire. But only the Machine guns should. When you press the cannons button, the cannons don't fire, but they should!

Additional assets (videos, screenshots, logs):

Your PC config data (OS, drivers, specific software): N/A

Share this post


Link to post
Share on other sites

Brief description: Both Bf109s and Fw190's TrackIR Headroom when "leaning forward" is restricted too much now when you move forward you hit an invisible wall.

Detailed description, conditions: When you lean forward to the max, instead of giving more headroom to the Fw190, the headroom of Bf109 is now just as limited as the Fw190 was. Instead of making the Fw190 headroom better, the invisible wall was added to the Bf109 as well. I want to kiss my revi if I want to. But I can't. But for sure if you adjust seat and the belts how you like it, it should be possible. Pilots who didn't tighten their belts to the max and did a crash landing, often hit the revi, so there is no way the head can't reach it....pls give more headroom and dont place an invisible wall in the cockpit in front of our nose...

Additional assets (videos, screenshots, logs):

Your PC config data (OS, drivers, specific software): N/A

Share this post


Link to post
Share on other sites

Brief description: In game, the steering of the pitch elavator is responding in the opposite manner

 

Detailed description, conditions: Under Settings -> Key Mappins -> Main Controls -> Plane Control: Pitch = oridinary settings of the Y-Axis. This means: pushing the flightstick menas "nose down" and pulling the stick means "pulling up". The settings are confirmed with the control and test panel -> "Input responses: planbe control: pitch". Nevertheless, in game, the response to the flight stick input on the Y-axis is the opposite.

 

Additional assets (videos, screenshots, logs): not available

 

Your PC config data (OS, drivers, specific software): input device for flying the simulator is the "THRUSTMASTER Hotas Warthog"

Share this post


Link to post
Share on other sites

Brief description: 

Memory read error when trying to enter aircraft.

Detailed description, conditions:

I'm posting this here because in the last update it said that if you experience this type of crash to report it.

Additional assets (videos, screenshots, logs):

post-14731-0-75440100-1454296940_thumb.png

_gui.log.err.rtf

Your PC config data (OS, drivers, specific software):

  1.  Microsoft Windows 7 Pro x64
  2. Track IR5
  3. MSI Afterburner
  4. Thrustmaster TARGET software
  5. Teamspeak 3

Share this post


Link to post
Share on other sites

Brief description: Typo on Pilot Card
 

Detailed description, conditions: There's a grammatical error (English) with two of the achievements on the Pilot Card which I've highlighted in the screen shots below. It should read 62nd rather than 62th.
 

Additional assets (videos, screenshots, logs):

 

Pilot%20Card%20typo%201_zpsycvmnopn.jpg

 

Pilot%20Card%20typo%202_zps2n5b9f3b.jpg

Share this post


Link to post
Share on other sites

Brief description: The "Open Bomb Bay" lever in the gunsight screen did not work as before for me and another guy on my flight when using He111. 
Detailed description, conditions: We were flying He111 in MP and when using the open bomb bay lever from the bombisght screen we encountered weird behavior. Sometimes the bombays opened but the lever stayed in the "closed" position, or the bays wouldnt open.
Your PC config data (OS, drivers, specific software): See signature

Edited by Jade_Monkey

Share this post


Link to post
Share on other sites

Brief description: Train anti-aircraft platforms have no icons/labels


 


Detailed description: It seems only the locomotive item has icons/labels and wagons do not. If you place a single anti-aircraft platform (without locomotive) - there will be no icon (see screenshot).


 


Additional assets (videos, screenshots, logs):


 


post-412-0-38395900-1457504929_thumb.jpg


Edited by Sim

Share this post


Link to post
Share on other sites

Brief description: mouse go on the second monitor while controlling the plane
Detailed description, conditions: NA
Additional assets (videos, screenshots, logs):
Your PC config data (OS, drivers, specific software): Windows 7 GPU: R9 280x

Share this post


Link to post
Share on other sites

Brief description: Bombsight Auto view angle / distance setting  is lost when switching to manual

Detailed description: iirc before the patch you could set your view angle in auto and switch to manual and back whithout the auto view angle being changed. Thus you could use auto for lining up with the target and manual for the release. This does not work anymore and makes bomb runs more difficult.

 

I found out that the view angle setting is saved if you  go via "view"  from "manual" to "auto" and back. Problem solved.

Edited by [DBS]El_Marta

Share this post


Link to post
Share on other sites

Brief description:
Same as gutterrat13 posted on November 2014. Trim only works when FFB disabled. Otherwise, uncorrectable pitch up.

Detailed description, conditions:
With force feedback enabled, elevator trim feels stuck fully tail heavy; trimming has no effect in bringing the nose down. The only way to do so it to slow until the a/c stalls. FFB bias seems wrong (having no neutral setting). Flying straight requires constant forward pressure on stick. Turns and shooting are nearly impossible. With force feedback disabled, everything works as it should (except no "spring" tension to assist); aircraft can be trimmed for level flight at any speed, or trimmed to assist climb/decent/turn. This behavior predates (but includes) the current game build.

Your PC config data (OS, drivers, specific software):
Windows 7 Ultimate 64bit SP1
MS FF2 (no manager loaded)
i7-3820 (no overclock) on MSI X-Power II Big Bang
32G RAM
VCard EVGA GTX 780, 353.82 drivers
Display Samsung S27D390H (1920x1080)

 

Solved by suggestion to avoid USB 3.0 ports. Forces and trim now very good when MS FF2 uses legacy USB port.

Edited by buster_dee
  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...