Jump to content
BlackSix

Controls, GUI, texts

Recommended Posts

The purpose of this topic is to provide us, the devs, with readable and structured information about the issues of corresponding types

How should a message be formated:
1) Make sure that the issue is actually a game bug, and it has not been reported yet
2) Copy the template text (as shown below this list)
3) Fill in the blanks
4) If you are not reporting a new error but want to add to somebody's message, please, just quote it and use the same template for your addition.
 
Recommended form:

Brief description:
Detailed description, conditions:
Additional assets (videos, screenshots, logs):
Your PC config data (OS, drivers, specific software):

 
The topic is under strict moderation rules. Any message that does not follow the guidelines will be deleted without warning. This topic is for bug reports.

Share this post


Link to post
Share on other sites

Brief description:

 

Mixture Settings of russian Fighters works partial only. Tested with YAK1; LAGG3; LA5.

Detailed description, conditions:

On high altitude f.e. 6000 m, you can fly these planes in "full rich" Mixture-Settings without a problem. No engine stutters or black exhaust.
Normaly you have set the MXs. to lean in this altitude.

In all other cases:

Mixture Settings to lean or to rich doesnt increase or decrease the engines temperatur in any sort.

Your PC config data (OS, drivers, specific software):
Intel Core i5 3570K
Geforce GTX 770 / 4GB Driver: NV 3.44.48
Installed phys.RAM 16GB
Mainboard MSI Z 77A-GD6
Windows 7

Share this post


Link to post
Share on other sites

Brief description:  

 

Stuka water radiator indicator gauge in cockpit does not work when manually opening/closing radiator.

 

Detailed description, conditions 

 

With auto-radiator setting turned off, using the controls mapped to open and close the water radiator appear to work (according to the tech chat displayed on the screen), but the indicator in the cockpit does not move.  During auto-start process, the water radiator indicator needle does move, but not when the radiator is operated manually.

 

Additional assets (videos, screenshots, logs):

 

Track files available here:  http://www.mediafire.com/download/8y68xazici34n35/Panther's_Stuka_Water_Radiator_Gauge_track.zip

 

 

Your PC config data (OS, drivers, specific software):

 

Intel Core i7-4770K @3.5 GHz

ASUS ROG Maximus VI MB
16GB RAM
EVGA GTX 980, 4 GB
Realtek ROG SupremeFX audio
Windows 8.1 Pro 64-bit

Share this post


Link to post
Share on other sites

Brief description: Steam version Gama default is .80000 Change it and it reverts back to .80000

 

Detailed description, conditions: I change the gamma settings in notepad++ to .50000 and for some reason when I restart the game the gamma is back to .80000

 

Additional assets (videos, screenshots, logs): NA

 

Your PC config data (OS, drivers, specific software):in sig

Share this post


Link to post
Share on other sites

Not sure why I can't edit my post above about the Stuka water radiator cockpit gauge indicator, but after further testing today I've realized this is probably not a bug after all.  I think all that's happening is that there's no power to the cockpit gauges until some point during the automated startup process, and thus the needle on the gauge will not move when you open or close the radiator before starting the engine.  After the engine is running, the needle does move when I manually open or close the radiator, so I guess it's probably working as intended  (might be a good idea to mention this in the manual when one is created, so other folks won't think it's a bug like I did).

Edited by TG-55Panthercules
  • Upvote 1

Share this post


Link to post
Share on other sites

Brief description:  Sometimes when I start the game, my Microsoft Sidewinder 2 Force Feedback joystick will produce a strong "kicking" force sensation.

 

Detailed description:    This incident is seemingly random but sometimes when I start the game up and begin flying, my FFB joystick will produce a strong kicking sensation that pulses every second or so.  It doesn't seem to correspond to any simulated forces from the game.  In order to get rid of this, I have to go into devices and disable and then re-enable force feedback.  Apart from this random kicking sensation, the force feedback in the game feels very muted and weak compared to other titles.  

Share this post


Link to post
Share on other sites

Brief description:  As reported a couple of updates ago, pilot view controls when mapped to the hat switch of the third controller in a multi-controller setup do not react to view settings as specified in the control settings, it seems to use the default speed and inertia settings.

 

Detailed description:   When mapped to any other controller (joy_0 or joy_1 respectively), it is working fine, however that is not an option for me because I want to fly with my MSFFB 2 Sidewinder, which gets always recognized as 3rd controller no matter how I plug them in. This problem is persistent since a couple of updates ago, it is hard to pinpoint when it first started, since I didn't play for a couple of months towards the end of the early access stage. But I know for certain that it did work before. Quick camera panning is crucial for me since I don't use TrackIR. MP is not an option right now because of this.

Share this post


Link to post
Share on other sites
Brief description:  Year wrong in description of Kalach award, and results numbers on profile screen are wrong..

 

Detailed description, conditions:  The pop-up for the award given "For bravery in the battle near Kalach” describes the battle as occurring in 1943 – should be 1942.  Also, the numbers displayed for sorties, successful missions and hours flown are all incorrect (and different (lower) than they were the last time I looked, despite several additional successful missions having been flown between views of this screen).

 

Additional assets (videos, screenshots, logs):  

 

See Screenshot below:

BoS-campaignresultsscreenissues-1.jpg

 

 

Your PC config data (OS, drivers, specific software):

 

Intel Core i7-4770K @3.5 GHz

ASUS ROG Maximus VI MB

16GB RAM

EVGA GTX 980, 4 GB

Realtek ROG SupremeFX audio

Windows 8.1 Pro 64-bit

 

Share this post


Link to post
Share on other sites

Brief Description: Game no longer launches

 

Detailed description: After changing some key bindings and joystick axis settings my game no longer launches.

 

Additional info: attached is a sceenshot showing BOS icon in task bar

post-893-0-33330800-1415152682_thumb.jpg

Edited by 450Devil

Share this post


Link to post
Share on other sites

Brief description: Some keys do not react while in-game. 

 

Detailed Description: In game and after I start the chat line (with "Enter"), the "Enter" and "Esc" keys stops working and do not react anymore. That meant I can still wrote but I cant send the message neither I can cancel the chat (this makes whole keyboard unusable)

It sometimes occure in singleplayer as well, without even starts the chat (can finish mission or even escape and so have to use alt+esc to end IL-2: BoS from Windows). 

 

*It seems to me that this happen when I use Windows key or otherwise minimalize the game at any moment since the game has started.

 

My PC: Graphic Card:Nvidia GTX 770, Windforce 2G

             Motherboard: Gigabite H87-HD3

             RAM              : 8G DDR3

             Processor    : i5-4750, 3.2 Ghz

             OS                : Windows 8.1

  • Upvote 1

Share this post


Link to post
Share on other sites

Texts around the achievements could use some tweaking (for the English versions):  See below:

 

BoS-awardsscreen-1.jpg

 

The red part, which is related specifically to this particular achievement, probably doesn't need to be there at all. However, if it is retained, the words "Description Medal" should read "Awarded during".

 

Also, the purple part (which appears on these achievements generally and should be fixed everywhere) should be changed from "has been" to "awarded" or perhaps "obtained".

Share this post


Link to post
Share on other sites

Brief Description: inlet cowl shutters control

Detailed Description: axis animation does not move for the inlet cowl shutters control command on the configuration screen. In-game, it does work properly. It's just the control setup screen that needs fixing.

Hardware: CH Throttle Quadrant

 

Note: the outlet cowl shutters control command works fine with the CH Throttle Quad

Edited by LukeFF

Share this post


Link to post
Share on other sites

Brief description: v1.004.  In replay videos, exhaust flames on IL-2 planes still only appear on one side of the engine.


Brief description: v1.004.   Grammar mistake.  After successfully taking off from an airfield, the yellow text displays the message "You have successfully took off."  This is incorrect.  It should read either "You have successfully taken off."   or "You  took off successfully."

Share this post


Link to post
Share on other sites

In version 1.004 nothing has changed concerning the problem I mentioned. I can't imagine this being such a big and time-consuming issue to fix, but it is VITAL for someone flying without TrackIR or mouse view, one cannot maintain sight on an enemy aircraft during ACMs if the view pans so slowly as it does in the default speed.

 

Brief description: I did some more test runs today, the problem also occurs if only two controllers are plugged in: camera settings (rotation, movement, FOV change speed) do not apply when mapped to the hat switch of a second controller (joy_1) and instead use the default values. Additionally it seems that only vertical or horizontal hat switch movements are recognized at a given time, i.e. diagonal movement does not work when panning around. Single controller works fine.

 

Detailed description:   I used this time only two joysticks for testing purposes: MSFFB2 Sidewinder and T16k from Thrustmaster. As long as only one is plugged in (thus being joy_0 in settings), either is working fine. As soon as both are plugged in, the Sidewinder automatically is recognised as Joy_1 by the game, and when mapping controls for pilot head movement to the hat switch of this controller, there is only one (default) speed setting, no matter what parameters I change in the camera settings (rotation speed, inertia etc.). These settings however are still having an effect on the first controller (Joy_0 [being always the Thrustmaster stick]).

Share this post


Link to post
Share on other sites

Brief Description:La5 Inlet cowl shutters closing not included in automatic startup procedure leading to failure of firing up the engine (procedure stops when outer flaps are closed)

Share this post


Link to post
Share on other sites

Briefing text obscuring "O" map.

 

Since 1.005 the briefing text on the full briefing map will not stay closed. When the map is called up in flight using the "O" key, the briefing text opens up. The text can be shut manually, but if the map is opened again the text will reappear. If the map is closed and opened again the text will shut, then open again the next time the map is used.

 

This makes the map hard to use on any mission where the briefing text obscures the flight plan.

Share this post


Link to post
Share on other sites

Brief description: 1.005 drop bombs mode for HE111 does not work from pilot seat

 

Detailed description, conditions: can not drop bombs from pilot seat, manual, you have to go into V bomb sight and press the drop bombs button.

 

Additional assets (videos, screenshots, logs): n/a

 

Your PC config data (OS, drivers, specific software): 1.005

Share this post


Link to post
Share on other sites

The "close engine outlet" key binding also closes the oil radiator in the La5.  

 

When I press the key for this binding I can see the oil radiator lever on the left side of the cockpit move and the wheel for the engine cowl outlet on the right side move.  

Checked the external view and both are closing. 

Share this post


Link to post
Share on other sites

Brief description: throttle controller X52 wheel button no longer works in game

 

Detailed description, conditions: the button press works in windows and other

games, the button also had worked before for the game now no longer works after last update, 1.005

 

Additional assets (videos, screenshots, logs):

 

Your PC config data (OS, drivers, specific software):

 

ok today its working, I think your online stuff is making a lot of this UI not to work because its looking for server,

Edited by 71st_Mastiff

Share this post


Link to post
Share on other sites

Brief description: 1.005 text overlapping

 

Detailed description: In the arming screen, text overlaps drawing.

 

Additional assets (videos, screenshots, logs):

 

post-2149-0-51220900-1416353046_thumb.jpg

 

Share this post


Link to post
Share on other sites

Brief description: Logitech Extreme 3D Pro joystick settings ignored.
Detailed description, conditions: This would seem to be under all conditions, planes etc. although I haven't tested them all. In-game settings for controls take precedence over settings made in the Logitech Profiler software. Making, in particular, the setting of a button as a "shift" button not possible.
Additional assets (videos, screenshots, logs): N/A
Your PC config data (OS, drivers, specific software): Win 8.1 64 bit, AMD A10-6700 APU 3.70 GHz, 16 GB RAM, Geforce 635 2 GB VRAM, Logitech Extreme 3D Pro joystick (brand new) - Logitech Profiler software version: 5.10.127

  • Upvote 1

Share this post


Link to post
Share on other sites

Track IR setup wiped/f**ked

 

Brief description: Default view setting shows view looking at left wing
Detailed description, conditions:

 

I had Track IR centre + pilot snap view forward mapped to same button- has worked in IL2 original for 7 years. For past 3 days view is left wing. Nothing I change makes any difference. Only way to fly is to move head to top Right hand corner of screen & get a sore neck. Unbelievably frustrating!

 

Why is it not possible to simply choose Track IR as tool/device, wipe all the nonsensical keyboard view mapping & explain all the settings simply?

Additional assets (videos, screenshots, logs):

 

Your PC config data (OS, drivers, specific software)

Win 7, i7 Quad Core Processor i7-3770 (3.4GHz) 8MB Cache, 8GB KINGSTON HYPER-X GENESIS DUAL-DDR3 1600MHz, 2GB NVIDIA GEFORCE GTX 650Ti, 120GB KINGSTON V300 SSD. MS FFB2- works perfectly in IL2 etc.

Share this post


Link to post
Share on other sites

Brief description: Flight Interface screen: Color option: It is not possible to swap colors for friend and foe icons.
Detailed description, conditions: I tried ot swap so that blue is enemy and red is friendly but it seems to always default back to blue friendly and red enemy
Additional assets (videos, screenshots, logs): 

post-12436-0-33103400-1416903208_thumb.jpg
Your PC config data (OS, drivers, specific software): Windows 7 x64

Edited by =69.GIAP=MYATA

Share this post


Link to post
Share on other sites

Brief description: Logitech Extreme 3D Pro joystick settings ignored.

Detailed description, conditions: This would seem to be under all conditions, planes etc. although I haven't tested them all. In-game settings for controls take precedence over settings made in the Logitech Profiler software. Making, in particular, the setting of a button as a "shift" button not possible.

Additional assets (videos, screenshots, logs): N/A

Your PC config data (OS, drivers, specific software): Win 8.1 64 bit, AMD A10-6700 APU 3.70 GHz, 16 GB RAM, Geforce 635 2 GB VRAM, Logitech Extreme 3D Pro joystick (brand new) - Logitech Profiler software version: 5.10.127

NOTE: I have deleted the profile from the Logitech profiler software and it (IL2 BOS) at least works reliably now. Without of course, the extra features available - most notably the addition of a "shift' buton ...

Share this post


Link to post
Share on other sites

Brief description: 

Trimming of aircraft not possible with force feedback enabled

Detailed description, conditions:

I have noticed that with force feedback enabled, trim settings have no effect on how the aircraft flies.  I end up having to push the nose down which makes flying a bit of a chore.  With force feedback disabled everything works as it should and I can trim the aircraft for level flight.

Your PC config data (OS, drivers, specific software):

Windows 7 64bit

Saitek Cyborg Evo Force Joystick

  • Upvote 1

Share this post


Link to post
Share on other sites

Brief description: 

Trimming of aircraft not possible with force feedback enabled

Detailed description, conditions:

I have noticed that with force feedback enabled, trim settings have no effect on how the aircraft flies.  I end up having to push the nose down which makes flying a bit of a chore.  With force feedback disabled everything works as it should and I can trim the aircraft for level flight.

 

Your PC config data (OS, drivers, specific software):

Windows 7 64bit

Saitek Cyborg Evo Force Joystick

Hi gutterrat13,

I have the same joystick and have also reported this problem.  I also know others with the same joystick who also have the same problem.  However, the response from the BoS dev team is always that they are "not able to replicate the problem". 

From my perspective it appears that the BoS dev team do not want to recognise that there is a problem.  I get the impression that they don't care if Saitek Cyborg Evo Force feed-back users have a stick that is not compatible with BoS with ffb turned on.

I have stopped flying BoS at the moment and do not have it on my PC because of this.  Instead, I have just started with DCS World WWII aircraft and am looking forward to the DCS WWII project with 'Edge' and the new Normandy map.

The Saitek Cyborg Evo Force feed-back joystick works perfectly well with CloD and DCS, so the evidence clearly suggests that there is a problem with BoS, not the joystick.  I refuse to fly BoS with ffb turned off, so I don't fly BoS anymore.

I also think that there is enough evidence with this issue and others reported on the forum to suggest that there is a problem with pitch control in BoS.

To say that I am disappointed with this is an understatement, as I dearly wanted to fly BoS and have supported it from the start.  Perhaps as BoS gets polished they will finally overcome what I see as pitch control issues.

 

Happy landings,

 

Talisman

Share this post


Link to post
Share on other sites

Brief Description: return to base command

Detailed Description: the Return to Base command is not working from the on-screen command menu. Pressing the F7 key currently does nothing.

Edited by LukeFF
  • Upvote 1

Share this post


Link to post
Share on other sites

Problem with non-applied settings of camera fov and movement speed for pilot head control when mapped to a second controller remains still unsolved since before release. For the love of it, I know you have only one programmer, but how long can it take to review the camera settings code and see if there's a missing or not working link for extra controllers that results in not taking the settings...30 minutes? It HAD worked before, so it's not like inventing the wheel anew.

Share this post


Link to post
Share on other sites

Brief description: Blue screen when in setting while in game MP

 

Detailed description: I was having no Input response while in syndicate server MP, I open setting/ controls/ and tried to assign my X52 throttle mouse push button wheel, to "wheel break" no response.

after about 10 multiple press's; I got a blue screen no log but the event. the blue screen event stated (failed to attach _to device )

Additional assets (videos, screenshots, logs): n/a

 

Fault bucket , type 0

 

Event Name: BlueScreen

 

Response: Not available

 

Cab Id: 0

 

 

Problem signature:

 

P1:

 

P2:

 

P3:

 

P4:

 

P5:

 

P6:

 

P7:

 

P8:

 

P9:

 

P10:

 

 

Attached files:

 

C:\Windows\Minidump\120614-24320-01.dmp

 

L:\TEMP\WER-34335-0.sysdata.xml

 

L:\TEMP\WER92FB.tmp.WERInternalMetadata.xml

 

 

These files may be available here:

 

C:\Users\Mastiff\AppData\Local\Microsoft\Windows\WER\ReportQueue\Kernel_0_0_cab_05aca755

 

Analysis symbol:

 

Rechecking for solution: 0

 

Report Id: 120614-24320-01

 

Report Status: 0

Share this post


Link to post
Share on other sites

Brief description: 

Trimming of aircraft not possible with force feedback enabled

Detailed description, conditions:

I have noticed that with force feedback enabled, trim settings have no effect on how the aircraft flies.  I end up having to push the nose down which makes flying a bit of a chore.  With force feedback disabled everything works as it should and I can trim the aircraft for level flight.

 

Your PC config data (OS, drivers, specific software):

Windows 7 64bit

Saitek Cyborg Evo Force Joystick

 

I get the same problem with my Microsoft FFB2, but only in the He 111. The trim wheel moves, but the forces do not act accordingly. All other planes do work.

Share this post


Link to post
Share on other sites

Have mentioned this before...the direction that the directional indicator instrument on the aircraft instrument panels (at least the ME109 and Stuka) seems to indicate wind direction as it mirrors the wind direction HUD cheat in the left corner bottom. It would be so much better if it at least indicated that it was homing in on the home base beacon...that way you do have some navigational abilities.

F7 - return to base command does not work anymore.

I have both the Steam version and the version originally sold by 1C/777. I usually use the 1C/777 version because it seems more stable and I do not get a bunch of Steam messages when starting up. I wonder how or if Steam screws up the games...but last night, I went into the Steam version after playing on the 1C/777 version and saw that a few of my saved mission records/videos did not appear on the Steam version...while they did on the 1C/777 version. No big deal...I will play the 1C/777 version as said before...but I thought your programmers may see some clue to issues if I mentioned this.

All in all...still enjoying the game. With the exception of not hearing when my aircraft is hit, your graphics really make it great. Now...before people argue about hearing sounds of being hit...read Gunther Rall's book, "My Logbook"...he could certainly hear his aircraft being hit...

Share this post


Link to post
Share on other sites

Brief description: Unable to rotate external camera in track playback
Detailed description, conditions: I cannot use my mouse to rotate the camera in external view when I watch a recorded track. What am I doing wrong? a Bug? And: buttons of choosing a certain camera (F1, F2, F4 ect.) don't work all the time, sometimes they do, somtimes they dont work...


Brief description: TrackIR rear-view swapped to wrong direction
Detailed description, conditions: When I pan/shift my head from side to side when looking forward, all is fine. When I look back to check my six and lean to either side, it is the opposite, exactly counter-intuitive. (e.g. I have to lean LEFT to move my head to the RIGHT to look over my left sholder to see my 7 o'clock.) This needs to be changed!

Share this post


Link to post
Share on other sites

 

  

Brief description: Unable to rotate external camera in track playback

What am I doing wrong? 

   

 

You are forgetting to press "H" - to hide track player interface and access these camera functions.

Share this post


Link to post
Share on other sites
Brief description: Stabilizer trim wheel keeps turning after letting go of button.

Detailed description, conditions: In the Bf 109 F-4 and G-2, the stabilizer trim wheel will keep turning for a while even if you let go of the input button. Basically like it's trailing behind. It should stop turning, as soon as you let go of the control button.

 

(If this is a feature, please move my post to the "suggestions" topic)

 

Share this post


Link to post
Share on other sites

Brief description: New key assignment for in-game chat does not work.

Detailed description, conditions: As it quite often happens to me to press Enter instead of Ctrl+Enter when sending a chat message which is supposed to be for my allies only, I changed the key settings in the menu as seen in the screenshot below. However, this new assignment seems not to be recognised by the game. I still have to use the old commands, Enter for "send msg to all" and Ctrl+enter for allies only. Please see the screenshot of the chat menu in flight, still showing "Ctrl+Enter".

Additional assets (videos, screenshots, logs):

Your PC config data (OS, drivers, specific software): N/A

post-555-0-13135200-1420098180_thumb.jpg

  • Upvote 1

Share this post


Link to post
Share on other sites

Brief description: Recorded tracks-view cannot be controlled with mouse.

 

Detailed description, conditions: 'Camera: head-unlinked cockpit' does not allow view to be controlled by the mouse. This feature is beneficial when creating movies or analyzing telemetry during replay. This feature was available IL2-FB and is currently available in Rise of Flight and IL2-Cliffs of Dover. 'Camera: head-unlinked cockpit' does free the view with TrackIR but using the mouse during replay is much easier and more functional. This feature does work when flying in SP.

 

Additional assets (videos, screenshots, logs): None needed. Just review one of your saved tracks.

 

Your PC config data (OS, drivers, specific software): Windows Home Premium x64-SP1, i7-3770K@3.50 Ghz OC'd @4.50 Ghz, GTX690 with 347.09 Drivers, 16g memory, Warthog HOTAS, CH Throttle Quadrant, Crosswind Pedals.

Share this post


Link to post
Share on other sites

Brief description: Replay Modes "edit" and "load"
Detailed description, conditions:

mode "load": User can go fastforward and rewind the video, but not move camera position.

mode "edit": User can't go fastforward OR rewind the video, but can move camera position.

 

Shouldn't be both changing time and camera position be possible in one of the modes, just for sake of viewing enjoyment and convenience?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×