Jump to content
Sign in to follow this  
Arfsix

After Windows update, Launcher will not function

Recommended Posts

Posted (edited)

     After the latest Windows update (Update for Microsoft Windows KB4495620 and KB4503293), Launcher.exe will not stay open and gives the following error message:

 

Capture.PNG.80c113bc5fe3d2dd9c51ca4701a168c5.PNG

 

     Any ideas and/or help, Please.

          Thank you

Edited by Arfsix
Typing

Share this post


Link to post
Share on other sites

This might be worth a try.  Go to your Il-2 BOS folder and open it, go to be BIN folder then to the game folder open the game folder then go to the Launcher,  double click and see if that will launch the game.  If the game launches then maybe the game exe launcher became corrupted.

Share this post


Link to post
Share on other sites
3 hours ago, Taxman said:

This might be worth a try.  Go to your Il-2 BOS folder and open it, go to be BIN folder then to the game folder open the game folder then go to the Launcher,  double click and see if that will launch the game.  If the game launches then maybe the game exe launcher became corrupted.

     Thanks. Game will launch using IL-2.exe but launcher.exe does not function. Did complete reinstall but launcher.exe opens launch page but then same error message appears. When you acknowledge or close error message, launch page closes and program quits.

     Anyone know what is producing the error message?

Share this post


Link to post
Share on other sites

I woke up to more or less the same issue today. Launcher opens fine enough, but at the moment I press "PLAY" I am presented with this message:

 

614067406_Errormessage.thumb.jpg.45e0b4e0705b1c6e6156ac74c8603af6.jpg

 

The launcher then closes down and the game does not launch.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

      Launcher appears to be corrupted and complete reinstall does not correct. Evidently uninstall and reinstall does not remove or change registry entries from previous installations.

     Submitted "Ticket" to support.

Edited by Arfsix

Share this post


Link to post
Share on other sites

The latest game update has been giving so many people trouble. Only thing I can suggest is to create a shortcut of the iL-2 exe and place it on your desktop. I use steam and often at times if I launch from steam my hardware controls will not register to the game. But using a direct shortcut to the game exe seems to always work without issue.

Share this post


Link to post
Share on other sites

The problem appears to have been solved by applying the following as suggested by Support; particularly removing read only property and running game and launcher as administrator. Thank you to Olga Yemelyanova of 1CGS Support Team <support@1cgs.net>.

 

From FAQ about launcher and updating https://forum.il2sturmovik.com/topic/5321-faq-about-launcher-and-updating/
1) Before you start
Remember that the game uses certain ports 
Setup or turn off your security software (antivirus, brandmauer, UAC, SmartScreen, etc.)
Make sure that you're logged into Windows as Administrator
Open context menu by a right click on game's icon, go to Compatibility settings and choose to Run as Administrator

 

From Game setup and settings FAQ https://forum.il2sturmovik.com/topic/2074-game-setup-and-settings-faq/#faq8
6) The game doesn't start, the application shuts down and a warning error message appears. What can be done here?
You need to launch the game as Administrator. Click with the RMB on IL-2.exe (...\IL-2 Sturmovik Battle of Stalingrad\bin\game\Il-2.exe), enter the menu and choose to run it as Admin.
13) Game crashes to desktop all the time, what's wrong?
Find the catalog where the game is installed, enter the folder properties and remove the tick from Read Only field.

 

Notice

Before doing a complete uninstall and reinstall, try removing read only property from game folder (IL-2 Sturmovik Great Battles) and run launcher.exe and IL-2. exe as administrator.

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

Arfsix, 

 

Glad that Support supplied the fix for you.  Happy flying:salute:

Share this post


Link to post
Share on other sites

Having looked into it, it seems to me, that my IL-2.exe is completely missing??!!  It's simply not in the "game" folder.

 

Any way to restore it without having to do a complete reinstall?

 

 

 

Share this post


Link to post
Share on other sites
5 hours ago, Finkeren said:

 

Waddaya know! It worked!

 

Thanks a lot 😍

Hey, where did you get that new zip folder?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...