Jump to content

Recommended Posts

Hi I'm looking for a setting of SweetFX 2.0 in the last one 1.4/1.5 Iused the config of 5tuka. I don't use mediator. Someone have a good setting ?

Share this post


Link to post
Share on other sites

Hmmm...Just installed a gtx980, have the latest update, and mediator starts but crashes the game before loading.

Share this post


Link to post
Share on other sites

Also got a 980 no crash on my end. Point mediator to il2.exe.

On my end Nvidia Inspector settings are ignored while using reshade. Thus I switched to ingame AA settings. Does anyone else experience the same with inspector?

Edited by [DBS]El_Marta

Share this post


Link to post
Share on other sites

On my Nvidia Inspector settings are ignored while using reshade. Thus I switched to ingame AA settings. Does anyone else experience the same with inspector?

I've heared this can happen if you induce AA via SweetFX. In this case it would overrite the Nvidia AA settings.

 

That's at least what I've been told. Either way, after testing I don't recommend using SweetFX SMAA or FXAA. Both lead to worse spotting because slim parts like aircraft wings will turn transparent quicker than with only ingame AA.

Share this post


Link to post
Share on other sites

I disabled the SMAA and Lumasharpen in my profile, but this did not help. Ingame AA looks decent enough, so no need for Inspector. Will check wether spotting improves without SMAA.

Share this post


Link to post
Share on other sites

I was able to successfully install SFX 2.0 and Mediator.  Looked at a few You Tube tutorials on using Mediator but can't get it to work right and have a few questions


 


Is the updated version of IL2 Direct X 9 or 10/11?


 


After loading the IL2 exe in the add window I can not get IL2 in the upper box to the right, only the lower one


 


When I try to change a setting in the FX area and hit apply, I am not able to see until I close and restart the game


 


FX split screen is not working but Scroll Lock is


 


Any help would be appreciated.


Share this post


Link to post
Share on other sites

It shows "Direct X 9c" in mediatorand I think it still is.

Did you press "update" after adding the exe?

Edited by [DBS]El_Marta

Share this post


Link to post
Share on other sites

I was able to successfully install SFX 2.0 and Mediator.  Looked at a few You Tube tutorials on using Mediator but can't get it to work right and have a few questions

 

Is the updated version of IL2 Direct X 9 or 10/11?

 

After loading the IL2 exe in the add window I can not get IL2 in the upper box to the right, only the lower one

 

When I try to change a setting in the FX area and hit apply, I am not able to see until I close and restart the game

 

FX split screen is not working but Scroll Lock is

 

Any help would be appreciated.

 

It must looks like this:

 

Nowy-3JPG_sspqeqw.jpg

 

Update > Apply > Permanent Push....

 

I use only this settings:

 

Nowy-3JPG_sshanws.jpg

 

btw. If You have before 1.201b Redshade+Mediator : deactivate profile for IL-2 BoS/BoM (Delete button, see the arrow on the picture before) and activate it again. Will be ok I think.

 

If someone wants, I put here the version with Mediator (1.1.0): https://m.sendspace.com/file/rchu13 .

 

IL2BoS87j_sshanwq.jpg

 

IL2BoS2jp_sshansr.jpg

 

IL2BoS86j_sshansp.jpg

 

My preset: https://www.sendspace.com/file/yvao4h .

Edited by YoYo

Share this post


Link to post
Share on other sites

Thanks YoYo.  My setup screen looks like your except the window over present folder location is blank and when I select the drop down there is nothing to select.

Share this post


Link to post
Share on other sites

Thanks YoYo.  My setup screen looks like your except the window over present folder location is blank and when I select the drop down there is nothing to select.

Something like this? I checked with the new program - after the "Confirm" button I can create the new set of settings. Maybe You have wrong files inside of Redshade+Mediator?

Nowy-3JPG_ssrhesr.jpg

 

You can check the path also in: ReShade Framework 1.1.0\ReShade\PersonalFiles\Profiles\Il-2 Sturmovik\Profile.cfg and my preset is here: \ReShade Framework 1.1.0\ReShade\PersonalFiles\Presets\Il-2 Sturmovik .

Share this post


Link to post
Share on other sites

Can I use my old presets from sweet FX 1.5 in 2.0 and I if so what is the thread for the folder location. Do I need to rename anything?

Share this post


Link to post
Share on other sites

Hey YoYo thanks a million man!

I had an old backup of reshade+mediator that for some reason wouldnt work with the game. The download you linked to with a fresh new install worked for me.

Thanks again!

 

Well never mind-tried out DSR and it crashes the game, even when going back to non DSR settings.

Well, I guess its just not going to work for me.

Edited by II./JG53_Uwe

Share this post


Link to post
Share on other sites

Something like this? I checked with the new program - after the "Confirm" button I can create the new set of settings. Maybe You have wrong files inside of Redshade+Mediator?

Nowy-3JPG_ssrhesr.jpg

 

You can check the path also in: ReShade Framework 1.1.0\ReShade\PersonalFiles\Profiles\Il-2 Sturmovik\Profile.cfg and my preset is here: \ReShade Framework 1.1.0\ReShade\PersonalFiles\Presets\Il-2 Sturmovik .

YoYo… Used your version of Mediator and it worked like a charm. Thanks for your help could not have done it without you! Once you select settings and pipeline can you save them? Also can you use presets from older versions of sweet FX? With new presets what folder do you place them in? Thanks!!!

Share this post


Link to post
Share on other sites

Once you select settings and pipeline can you save them? Also can you use presets from older versions of sweet FX? With new presets what folder do you place them in? Thanks!!!

Just do "ticks" after this click "Update" (of profile) and "Apply" (and in the final effect "Permanent Push..."). Im affraid that old settings doesn't work with this version BUT mediator is very easy and simply tool, You can check it in the game immediately > in the game Alt+Tab, next do changes in Mediator, next Update, Apply, Permanent and back to the sim.

Hope it helps.

Share this post


Link to post
Share on other sites

YoYo, back with a question.  But first, thanks again for your help and settings...they look great!

 

Here's my question, the game looks great but once I did the permanent push I selected Sweet FX, selected some of the individual settings like Technicolor, moved the Techniamount slider, clicked apply and no differecne.  I watched a Mediator tutorial on You Tube and when he moves a slider and ticks apply, there is a noticeable change.  What am I doing wrong???

 

Thanks!

Share this post


Link to post
Share on other sites

 

Bingo. It starts but this version looks strange for me. Maybe for IL-2 BoS we must do something more, not only install it? The picture is very dark, poor antialiasing and I didnt see any changes If I did some of correction plus pushed apply and update.

 

Back to Sweet FX 1.5. No problems here like this.

 

Screenshot31076_zpsbb2iktuy.jpg

 

Screenshot29842_zpst6jum71g.jpg

 

Screenshot12135_zpsawktrhms.jpg

 

Screenshot90643_zpsy4wtuq8w.jpg

 

That looks PERFECT! Could you share it??

  • Upvote 1

Share this post


Link to post
Share on other sites

First stage of tweaking with the Mediator toll is done. I'm not 100% satisfied with the results yet although I'm glad I could manage to greatly enhence ground detail and visibility wih this (sth that bugged me most with the new summer map). I don't think the screenshots can do justice but the improvement should be visibel.

ILosE2n.jpg

 

8CBsQle.jpg

 

FTaQPhc.jpg

 

Note: This will only work with Reshade Framework 1.1.0 + Mediator configurator, do not use this for SweetFX standalone versions.

Note2: I will translate my settings into a SweetFX settings file once done with the work. Mediator is not much of an improvement because the other provided shaders don't work/look well with BoS.

 

Download: http://www.mediafire.com/download/rxv27ixl24bxo1b/Mediator_SweetFX_settings_by_5tuka.rar

 

Installation: Open Mediator and create a new profile for BoS. After that close Mediator and navigate to ReShade ReShade Framework 1.1.0\ReShade\PersonalFiles\Presets\YourProfileName . Replace the "SweetFX.cfg" with the one in the Download. After that launch Mediator again and reload the Profile.

 

Hope you enjoy it! Feedback is welcome. :salute:

 

Hey Stuka, do you have an earlier preset for mediator with more color?? It looks great but I miss your more colorful SweetFX 2.0 winter preset :(

Share this post


Link to post
Share on other sites

Well This has about made me bin the whole game.

No matter what I do from a clean install of the game, clean install of mediator, different profiles etc it always crashes the game at compiling effects.

Really confused about this one.

Furthermore-I tried using the old Sweet FX 2.0 from Stuka5 and it simply doesn't engage the game at all. The files are unseen by the game.

Edited by II./JG53_Uwe

Share this post


Link to post
Share on other sites

Well This has about made me bin the whole game.

No matter what I do from a clean install of the game, clean install of mediator, different profiles etc it always crashes the game at compiling effects.

Really confused about this one.

Furthermore-I tried using the old Sweet FX 2.0 from Stuka5 and it simply doesn't engage the game at all. The files are unseen by the game.

 

Kameraden,

 

Check and see if the Reshade64.dll is in your game folder, for some odd reason mine did not get copied over. I moved it manually and everything started working. Also, watch out for any Overlay as it can make things a bit unstable.

 

S!

Share this post


Link to post
Share on other sites

Oh glad I saw this-update lol

The Teamspeak overlay was interfering with it. I didn't even realize it was on but after disabling it all is well, reshade and mediator working 100%.

Share this post


Link to post
Share on other sites

YoYo, back with a question.  But first, thanks again for your help and settings...they look great!

 

Here's my question, the game looks great but once I did the permanent push I selected Sweet FX, selected some of the individual settings like Technicolor, moved the Techniamount slider, clicked apply and no differecne.  I watched a Mediator tutorial on You Tube and when he moves a slider and ticks apply, there is a noticeable change.  What am I doing wrong???

 

Thanks!

If You did changes in Mediator next push (on the main SETUP page) button "Update" > "Permamnet push..." and back to the game. It works.

 

That looks PERFECT! Could you share it??

Its here in the end (but for Redshade and Mediator):

http://forum.il2sturmovik.com/topic/17096-reshade-sweetfx/?p=345901

 

IL2BoS96j_ssxerqa.jpg

 

IL2BoS75j_ssxexph.jpg

Edited by YoYo

Share this post


Link to post
Share on other sites

Guys,

 

I used to run SweetFX no problem. But now I can't get this to work. I've downloaded YoYo's framework and I'm following the directions, but it's not being applied to the game. I get the Re-Shade messages in the left hand corner and the framerate counter, but it doesn't apply in the game itself. I'm also not running an overlay. Am I missing something?

 

Jason

  • Upvote 2

Share this post


Link to post
Share on other sites

Guys,......

Hello Jason,

nice to hear You that You are user of Sweet/Redshade in BoS too (I discovered old 1.0 SweetFX thanks to You on the RoF Forum years ago :)  ).

If You see this it means everythink is ok and program was loaded properly.

 

Nowy-1JPG_ssxenns.jpg

 

Maybe You haven't active profile? If You change something on this screeen:

 

Nowy-3JPG_swhnrse.jpg

 

... and next in the menu of Sweet FX (for example):

 

Nowy-3JPG_ssxenww.jpg

 

Hit on this screen UPDATE > Apply > Permanent Push To Applications (btw You can do it "on live" when the sim is running also to see the new effect).

 

Nowy-34jp_ssxenwq.jpg

 

You can also check the path of installation, example: C:\Program Files\ReShade Framework 1.1.0\ReShade\PersonalFiles\Profiles\Il-2 Sturmovik\Profile.cfg . It must looks near like this:

 

ProfileName:Il-2 Sturmovik

ProfileModule:d3d9.dll <- very imortant and d3d9.dll must be in \IL-2 Sturmovik Battle of Stalingrad\bin\game

ProfilePath:P:\IL-2 Sturmovik Battle of Stalingrad\bin\game\Il-2.exe (but if You see this http://s5.ifotos.pl/img/Nowy-1JPG_ssxenns.jpg the path is ok I think)

ProfileDll:ReShade64.dll

ProfilePreset:Il-2 Sturmovik

 

Btw. after the patch 1.201 of BoS (the new sctructure for 64bits) all old profiles must be removed and created it again.

 

Video tutorial:

. Edited by YoYo

Share this post


Link to post
Share on other sites

Man I just spent 2 hours with this Mediator. I just can't get the game to hook it and apply anything. So weird. What in the world am I missing?

 

Jason


Yes I am following those directions.

 

Do I need to put the Mediator app files in a certain place? That's the only thing I have different than you.

 

And what about this PresetFolderLocation settings I see. Should I point that somewhere?

 

Jason

Share this post


Link to post
Share on other sites

Do I need to put the Mediator app files in a certain place? That's the only thing I have different than you.

 

And what about this PresetFolderLocation settings I see. Should I point that somewhere?

 

Jason

1/ No, You can have it on Your desktop for example. The path will be created automatically.

2/ Its default setting, I didn't touch it.

 

btw. Maybe You have old dll's for Sweet FX from old installation?

As I remember for SweetFX 1.5 or 2.0 only the folders and dll's was in two folders, directions in BoS.

Edited by YoYo

Share this post


Link to post
Share on other sites

I don't know what the deal is. I used SweetFX for years and am an expert on all it's settings and never had a problem. But I hadn't a chance yet to try it with 64 bit or with this Mediator. I am trying a clean install and see if that fixes it.

 

Jason

  • Upvote 1

Share this post


Link to post
Share on other sites

Ok guys I solved it. Thanks for the help. 

 

I did a complete re-install of the game, but that didn't do it. So I re-installed the latest nVidia drivers and that did it. I'm just running some Lumasharpen and a little Vibrance to get the screen image I like.

 

I also run 2x Grid Supersampling in Inspector.

 

Then 2x AA in the game on Ultra. SSAO on, but HDR off.

 

Nothing crazy and running well.

 

Jason

Share this post


Link to post
Share on other sites

Good to hear You! My settings are similar:

 

NVidiaIns_ssxeqhw.jpg ustawieni_ssrssnn.jpg

 

(v-sync off only = monitor is with g-sync).

 

IL2BoS57n_ssxeqnw.jpg

 

Regards!

Edited by YoYo

Share this post


Link to post
Share on other sites

Thinking I might try this again.  Have used SweetFX on and off over time.  Glad to see you sorted it out Jason, you were making me nervous.

Share this post


Link to post
Share on other sites

Good to hear You! My settings are similar:

 

NVidiaIns_ssxeqhw.jpg ustawieni_ssrssnn.jpg

 

(v-sync off only = monitor is with g-sync).

 

IL2BoS57n_ssxeqnw.jpg

 

Regards!

 

Kameraden,

 

I was of the impression the 2xSGSS setting should match the 2xAA setting in the game Graphics options. I also have the AA - Mode set to Enhance Application in Nvidia Inspector, but I'm not sure where I read that originally.

 

S!

Edited by II./JG1_Lipfert

Share this post


Link to post
Share on other sites

Hey Guys

Can someone please make a tutorial for this. I have the old sweet FX but want to update to the latest version, but really don't no where to start and how to delete the old files. Any help on this would be appreciated. I've read the whole thread but everyone's input into the thread is kinda confusing because not everyone settings are the same. I know we have a lot guys here that are very educated in this matter and hoping that they may be able to guide the rest of us..Thanks in advance for any help....

 

 

Update Thanks to UWE and JG1 Lipfert I got this all taken care of....Thanks Guys!

Edited by II./JG53_Badger

Share this post


Link to post
Share on other sites

I think I am in a separate reality.  I went to Reshade.me and downloaded Version 2.0.3f1 (vs what I see above).  I unzipped the files and there is no Mediator file.  Instead the instructions say to use the ReShade Assistant tool.

 

Here is the main page, not the Mediator shown above.  Frankly this one is quite confusing.

26439700526_582578ab4c_z.jpg

 

So I went to Profiles and set the path to the IL-2 Sturmovik exe.

26373304472_29e74fe36e_z.jpg

 

Then I established a Preset for my settings.

26465619095_2847ed8bd6_z.jpg

 

When I go to the Shaders however there are none marked for SweetFX.  Do I have to load these into the Reshade folder manually?

26465619185_fd912ccc28_z.jpg

 

When I start IL-2 BOS,the Reshade load message does come up and say that it loaded successfully.  Having a hard time to get any effects to show however. 

 

EDIT:  the shaders I do see are in fact working.  I just don't understand how to tweak them with sliders. 

 

2nd EDIT:  OK. I was able to see the sub tab to edit specific shader settings.  They are not easy to get to, very hit and miss.  Did I say the GUI is confusing?  

 

3rd EDIT:  To get to the Shader sub tab, right click on the Shader you want and the sub tab becomes available.

 

4th EDIT:  OK, I'm slow.  All of the SweetFX Shaders are already contained within this version of Reshade.  They are listed with the suffix name of CeeJay.  Same descriptions and settings.  So, nothing else to download, copy or import, except maybe a Profile. 

 

5th EDIT:  It appears that if you edit the Shader settings while the game is up, the CeeJay ones can be edited/saved and updated within the game without a crash.  Changes to Shaders not by him while the game is open seem to result in a game crash.  These Shaders may still work, you just can't edit on the fly.

Edited by 12.OIAE_Stick-95

Share this post


Link to post
Share on other sites

A question: with SweetFx and Mediator (Yo-Yo's preset) I sometimes get weird green glow/reflections on custom skins. The glow only appears on the custom pieces of the skin such as personalized markings etc. What parameter should be tweaked to get rid of this? Or do I have to live with it.

Share this post


Link to post
Share on other sites

A question: with SweetFx and Mediator (Yo-Yo's preset) I sometimes get weird green glow/reflections on custom skins. The glow only appears on the custom pieces of the skin such as personalized markings etc. What parameter should be tweaked to get rid of this? Or do I have to live with it.

 

I think it's a HDR effect (or SSAO) something like BLOOM effect, maybe with Sweet FX it's more visible but it is always if You have HDR "on". If You dont like it turn off HDR/SSAO.

 

Example:

 

Il-2-2016_sseaase.jpg

 

Il-2-2016_sseaaar.jpg

Edited by YoYo
  • Upvote 1

Share this post


Link to post
Share on other sites

Is it possible  to avoid applying anti aliasing to all those particles effects (dust,smoke,exhaust,clouds etc) in sparse grid supersampling?

Share this post


Link to post
Share on other sites

I think it's a HDR effect (or SSAO) something like BLOOM effect, maybe with Sweet FX it's more visible but it is always if You have HDR "on". If You dont like it turn off HDR/SSAO.

 

 

 

 

 Thanx. I'll try that.

Share this post


Link to post
Share on other sites

Hello I followed the instructions and it works , I just this yellow written when loading the game , what it means ?

 

aywwhc.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...