Jump to content

Recommended Posts

I have a mission in which I have a few moving convoys. They do everything I want them to. They follow their route, they go the speed I want, and they stay in formation however, there seems to be an issue because on a couple of them they are exploding or not following the lead vehicle! I made sure they are all set to ground, and linked up, but I'm wondering if there's a specific thing I am missing. Perhaps they are placed too close together?

Share this post


Link to post
Share on other sites

Do you spawn them or activate them? If you spawn them, they don't act as a formation. I've also found out that the AI is not very good at avoiding collisions, so it might be just that.

Share this post


Link to post
Share on other sites

I'm fighting a similar issue with a Tank Column.

Took a working german Type III tank column as template, did the very same thing with a russian T-34 column and only the leader starts moving, even though the formation command has clearly been given and the formation is using an activate trigger and not a spawn one (this was something I've stumbled upon before and replied to that thread, it's a different topic and IMHO a serious bug).

Once the german tanks arrive at the russian's location, the remaining (non-leader) tanks start moving, but... they all crash into each other, toppling each other over or bursting their comrades in flames.

This formation is in no way special.

The formation order has been double-checked, the type is "road column" and the distance is "safe".

I don't see why any of this should happen, but it does.

 

Cheers!

Mike

Share this post


Link to post
Share on other sites

Maybe can be you need to add some formation trigger in the start with "on road column" and  "safe" , second one in the end with the waypoint and you need to have in this formation trigger "stop "and "dense". That work fine to me in multiplayer.

Haaaa dont forget to click out enable.

Share this post


Link to post
Share on other sites

Why should I click out enable? I do have a formation change just after the first waypoint is triggered. For the record I am using an activate command.

Share this post


Link to post
Share on other sites

I hade that issue, and  for me.work fine, I have a truck convoy, and tank convoy activate with check zone and friendly fly, when I hade the enable mark donsent work, but if I unmark enable work.

Share this post


Link to post
Share on other sites

Hey shade.  Where is it they are blowing up?  I found a couple of places in cities that the water wells are not placed correctly and they sit in the middle of the road within some towns.  I would check all the roads along the route.  Also as someone else pointed out, set the density to safe.

Share this post


Link to post
Share on other sites

Just for the record, the tank column issue I've reported has been solved by putting the initial spawn positions of the russian T-34 tanks excessively far from each other, easily two times the spacing required for a german type III tank column.

 

Cheers!

Mike

Share this post


Link to post
Share on other sites

When you guys target link the vehicles to the leader make sure it is done 1  by 1 IN ORDER. To check, double click on any vehicle and observe the number in formation (actually starts at 0, then 1,2,3 ect)

 

I remember just selecting a bunch of vehicles, hitting shift T and target linking them to the "leader" ... the formation order was random, thus collisions happened inevitably.

 

If doing it one by one seems like the opposite of good workflow... select them all and save/export as a group file to be used whenever. I spent a few days making groups after making sirens of death... helped workflow insanely on everything ever since.

 

But yeah, trees or other objects can cause damage. Remember if they are hauling ass it takes a bit of distance for them to come to a full stop. Also consider super long convoys cause issues. In the past going over 15 seems to be sketchy... maybe this has changed in the new update, I am not sure. 

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×