Jump to content

Failed to update 100 times


Cooperman1205
 Share

Recommended Posts

Cooperman1205

I still have not been able to play new battles i have bought because it keeps failing to update i have tried all the advice on here i had a huge rant and rave on here a month ago still nothing changed, read all the moans about aircraft or missions or damage, or how long some people have been waiting to have things fixed, all the rants about finishing the battles before doing something else i can live with all that because the sim is good, but i need to be able to download and install it first, it does download but stops at 96% when updating and just says failed to update. there is no point in buying anymore till this is fixed it has been going on for many many months JUST FIX THE DAM THING before you do anything else i have addons that i have never seen or played

Link to comment
Share on other sites

Have you been told to 'right click' the BOS game's icon, then left click the properties, then click the security tab and make sure you have full permission as Administrator?

Also, you may want to consider getting the Steam version of BOS as it's less then $10.00 right now.  Running the Steam version will link your other purchases to work through it, just follow the instructions as prompted.  This may be the quickest way to solve your issues 'today'.

Link to comment
Share on other sites

2 hours ago, Cooperman1205 said:

I still have not been able to play new battles i have bought because it keeps failing to update i have tried all the advice on here i had a huge rant and rave on here a month ago still nothing changed, read all the moans about aircraft or missions or damage, or how long some people have been waiting to have things fixed, all the rants about finishing the battles before doing something else i can live with all that because the sim is good, but i need to be able to download and install it first, it does download but stops at 96% when updating and just says failed to update. there is no point in buying anymore till this is fixed it has been going on for many many months JUST FIX THE DAM THING before you do anything else i have addons that i have never seen or played

 

Hi,

 

I'm sorry to hear this. Here are some advice you may consider:

 

1. Make sure to NOT install the game in the default installation folder - Win OS does some strange things regarding files rights management.

    Instead: Install the game in a own folder - something like C:\games or D:\games, if you have more than one disk/partition.

2. Make sure your antivirus program does not block files etc.

 

Buying BOS as a Steam version, I think, will not help very much in your case, because you already own BOS - and this might be an issue, when

trying to link both accounts (your actual account and the new Steam account). You better leave this out, if you ask me.

 

Good luck and Merry Christmas to you

 

Cheerio

Link to comment
Share on other sites

Cooperman1205

Thankyou both for replying i do not have it installed to a the default folder, and all was fine until it updated the downloader, i only have 1946 and cod blitz installed in steam, but i have bought Moscow, Stalingrad, Kuban and 2 campaigns (ten days of autumn & blazing steppes) Moscow and Stalingrad use to be ok up until they updated the updater, i have not since been able to install Kuban or the campaigns, wanted to buy some more while they are on sale but what's the point????? will be asking for all my money back as software not fit for purpose if they dont fix it quick, i might even take them the the small claims court! 

Edited by Cooperman1205
bad spelling
Link to comment
Share on other sites


Small claims court? You’d lose. Hyperbole won’t get you any further but it will generate contempt for you and your issue. 
 

Others have had some issue updating but they resolve their difficulties without resorting to a rant, despite how unutterably frustrating such a first world problem can be. 
 

When you consider how many of us auto-update without problems it appears that your problem is specific to you. If you can’t solve it via the normal methods just save the inputs and skins folders, delete the entire game and download/install it again. 
 

von Tom

Link to comment
Share on other sites

Salutations,

 

https://forum.il2sturmovik.com/topic/68314-10005-please-update-your-gamenew-version-available/

 

Open the Steam client. Go to the Steam menu, choose Settings. Go to Downloads and click the Clear Download Cache. Once cleared, relaunch Steam and it will install a new Steam client update. Reboot. Start Il-2 and it will install the latest patch. Reboot  (optional), and then you should be able to start Il-2 normally updated to the latest version.

 

steamupdage.jpg

Edited by Thad
Link to comment
Share on other sites

Cooperman1205

Many thanks to Thad but I don't have it installed in steam it is a standalone purchase and used to run fine..... as for you von Tom I have tried all the answers going back on this forum about 5 years and it IS a common problem, I know a lot of you have solved the problem, however I cant, I'm not stupid!! and I try every thing I can if one day software is working great then an update comes along and it does not work anymore that's not down to me or my hardware (ROF works fine DCS works fine Ms flight sim 2020 works fine + many others) so it has to be a bug.

 

I'm 62 years old have have been building, upgrading, repairing and in some cases writing software (very basic) since the commodore Vic 20 back in 1980ish so please don't lecture me about my attitude, if it upsets then get it fixed hey presto!!!!!! no attitude no rants easy isn't it!!!!  and you should know from being a founder with 1000 post that this is an ongoing problem.

 

I have as I think I said deleted the whole lot even going into the reg and deleting the pointers then reinstall from scratch 4 or 5 times still cant get past 98% done or installing, please don't take offense I have paid good money for this (like everyone else) out of my pension and I don't have a lot, it takes me saving up for a while to buy these and like you I love flying them which I cant do

Link to comment
Share on other sites


The attitude and the problem are distinguishable from each other. Rant about how you’ve tried a gazillion times really doesn’t help. It truly doesn’t. For example you said ‘I had a huge rant and rave on here a month ago still nothing changed.’

 

Saying - this is the problem, this is my setup and this is what I’ve tried to do to fix it, will help. That way people can provide targeted help i.e. update Windows, don’t update wirelessly,  create/delete the updater folder and so on.

 

Try listing what you’ve done and others who are more knowledgeable will provide constructive help.
 

von Tom

Link to comment
Share on other sites

Cooperman1205
Posted (edited)

Thank you for your understanding, this may help others, I was thinking about how most people were saying about the drive that it is installed to (it is not on "C" drive) so I deleted everything and started again this time i put it on a mechanical drive, (it was on an NVME SSD Drive connected via pcie slot) and that seemed to work.

 

lesson to be learned try all drives, it might work on a 2.5 sata ssd but my nvme looked like it was causing the problem, still cant work out why it was working before????

 

Ian 

Edited by Cooperman1205
bad spelling
Link to comment
Share on other sites

6./ZG26_Custard

It maybe a corrupted registry error causing the issues you are having. If you have a persistent problem I would recommend that you try (at your own risk) to download CClearner and install the free version and clean your registry entries.

 

Here is the link https://www.ccleaner.com/ccleaner

 

 

Link to comment
Share on other sites

Cooperman1205

Thank you Custard, i seem to have sorted it now thank you for trying to help

Ian

Link to comment
Share on other sites

cardboard_killer
8 minutes ago, Cooperman1205 said:

Thank you Custard, i seem to have sorted it now thank you for trying to help

Ian

 

Wow. What did the problem turn out to be?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...