Jump to content
Sign in to follow this  
wowzer

Unable to play IL-2 Sturmovik: Battle of Stalingrad

Recommended Posts

On running IL-2 Sturmovik: Battle of Stalingrad I receive two options to select: 'I just brought the game' and 'I have played the game before and I have an IL2 account' which ever option I select I receive a wheel that spins then IL-2 Sturmovik: Battle of Stalingrad  goes back to desktop and does not run.Please note with the option: 'I have played the game before and I have an IL2 account' I have tried to 'link accounts and login' and 'steam login only' andIL-2 Sturmovik: Battle of Stalingrad  does not load and reverts to desktop.
I have around 250 hours played in the game(but I haven't played in around two years-the game worked fine previously)I purchased the game with a steam key.I have been in touch with customer support, who's only suggestion has been to send them dxdiag/msinfo logs and to re-install my graphics drivers.
If anyone is able to help with this problem I would greatly appreciate it. 
 

Share this post


Link to post
Share on other sites

If you have it on Steam, I'd recommend uninstalling it via the Steam 'delete game files' menu option, and then reinstalling it, if you've not yet done that.

 

If that doesn't work, I think we'll need more information: hardware? OS?

Share this post


Link to post
Share on other sites

Andy thanks for the reply. There is no option to  'delete game files' on steam.There is a uninstall option. Which I have tried and then re-installing on steam.

Sys specs

i72600k

16gb ddr3 ram

gtx 1070

win 10

 I have been able to play IL-2 Sturmovik: Battle of Stalingrad previously, so I'm unsure of why this problem has developed.

Share this post


Link to post
Share on other sites

Did you ensure that any files were not held over when you 'uninstalled' the game?

 

Make sure there is NOTHING remaining of BOS then re-install. :salute:

Share this post


Link to post
Share on other sites

Thad I'm trying this now, thanks for the reply.

25 minutes ago, wowzer said:

Thad I'm trying this now, thanks for the reply.

Same problem, BOS reverts to desktop.

Share this post


Link to post
Share on other sites

Is there anyone in the community that can help me solve this problem? The customer support team have now stopped answering my emails.

Share this post


Link to post
Share on other sites

if possible, get a refund from Steam, then buy and install the game directly from the il2 website?

 

Other than that, I can't think of anything else than what already has been said. A complete uninstall from Steam, then find whatever folders are left over in file explorer and delete everything before reinstalling. Also, check if you can log in on il2 website with your old credentials. Maybe there is a login issue?

Share this post


Link to post
Share on other sites

Is your game in C\Program files folder? Move it away to a different place on your disc and try, using the il2.exe from the ...\bin\game folder to start the game.

Edited by FlyingH
misspelling

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...