Jump to content
Alonzo

Repaired AAA not firing - what have I done wrong?

Recommended Posts

Hey folks. I'm trying to repair a AAA unit after it is destroyed by enemy fire. I have a test mission with two AAA guns and two AI attacking aircraft. The AAA is wired up using the standard checkzone activation group. After the Flak38 gun is killed, I wait 30 seconds then activate and repair the gun. The two AI aircraft are still circling and see the gun, but it doesn't fire at them. It just sits there waiting for them to kill it.

 

I've tried using force complete "high" and then attack area to convince the repaired AAA unit to target the bad guys, but no joy. Unsure if I'm doing something wrong or this kind of scenario is just not supported. Or maybe those aircraft need to go away and come back for the gun to see them again? Seems weird.

 

Mission attached. Can anyone see what I've done wrong?

 

 

Respawning-AA-Test.zip

Share this post


Link to post
Share on other sites

I tested AA deactivate-repair-activate long ago and could not get the guns to fire. You could try AA delete-spawn and see if it works.

  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites
57 minutes ago, JimTM said:

I tested AA deactivate-repair-activate long ago and could not get the guns to fire. You could try AA delete-spawn and see if it works.

 

Aha! That seems to work. Delete, respawn, onspawned -> forcecomplete -> attackarea is a recipe that seems to work. Thanks!

Share this post


Link to post
Share on other sites

A repaired gun that does not work anymore, has not been repaired. So repair is bugged.

I wonder if the devs keep a list of all ME bugs sofar.

Share this post


Link to post
Share on other sites

Repair is a feature that is known to be non-functional. It’s not bugged, it just isn’t there despite what the settings might indicate. 

Share this post


Link to post
Share on other sites

I opened your mission, and there is something which is wrong for me. You use several Attack area for the same AA. For me, you can have only one attack area.

 

Gambit, he uses the repair from the command Damage which worked (i didn't test it since a long time), not the features from airfield.  

 

I'll run some test if i have time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...