Jump to content
Sign in to follow this  
SShrike

Throttle/Stick/Rudder Pedals etc. Not Responding - Fix Without Re-mapping or Re-installing

Recommended Posts

Hi there.

I found a way to solve this without having to re-install anything or re-map any keys.

I noticed a few people had this problem. It occurred after I had reinstalled windows 10.

I had my game on a second hard drive so I did not have to re-install it. However when I went to play the game, all my controllers were not recognized by the game.

I went into:

 

D:\IL-2 Sturmovik Great Battles\data\input

 

Inside the input folder is a file called "devices"

 

I opened that and saw that all my input devices were doubled, like this:

 

configId,guid,model|
0,%221a238430-e3ae-11e8-0000545345440680%22,Joystick%20-%20HOTAS%20Warthog|
1,%221a25f530-e3ae-11e8-0000545345440f80%22,Throttle%20-%20HOTAS%20Warthog|
2,%221a25f530-e3ae-11e8-0000545345441080%22,Logitech%20Extreme%203D|
3,%221a25f530-e3ae-11e8-0000545345441180%22,Mad%20Catz%20Pro%20Flight%20Combat%20Rudder%20Pedals|
4,%223ed907b0-f27b-11e8-0000545345440680%22,Joystick%20-%20HOTAS%20Warthog|
5,%223ed907b0-f27b-11e8-0000545345440f80%22,Throttle%20-%20HOTAS%20Warthog|
6,%223ed907b0-f27b-11e8-0000545345441080%22,Logitech%20Extreme%203D%20Pro%20USB|
7,%223ed907b0-f27b-11e8-0000545345441180%22,Mad%20Catz%20Pro%20Flight%20Combat%20Rudder%20Pedals
 
I remembered from when I was setting key bindings that my stick was device 0 and throttle was 1, so I deleted all the lines below my devices that were repeated, to get this:
 
configId,guid,model|
0,%221a238430-e3ae-11e8-0000545345440680%22,Joystick%20-%20HOTAS%20Warthog|
1,%221a25f530-e3ae-11e8-0000545345440f80%22,Throttle%20-%20HOTAS%20Warthog|
2,%221a25f530-e3ae-11e8-0000545345441080%22,Logitech%20Extreme%203D|
3,%221a25f530-e3ae-11e8-0000545345441180%22,Mad%20Catz%20Pro%20Flight%20Combat%20Rudder%20Pedals|
 
When I restarted the game I got a message I had never seen before. said something like, "New input devices detected, to use key bindings from an old device to use with the new device, select and proceed" I highlighted each one by one and clicked proceed and when the game started, all inputs were recognized and all bindings/mapping was not changed.
 
Hope this can help someone else. No re-mapping keys or re-installing anything.
  • Like 1

Share this post


Link to post
Share on other sites

Found your link to this thread regarding my issue. I checked the file and no double entries.  My controls only stop responding when I try to load the game with the thrustmaster target software running otherwise it works fine.   It worked without issue before the recent update.

my devices file

https://i.imgur.com/xh2a07E.png

 

 

Edited by Geronimo553

Share this post


Link to post
Share on other sites

You are trying to use a TARGET profile with the joystick and throttle combined?

 

That should be the only device. Also in joy.cpl that should be the only device (while TARGET profile is active).

Share this post


Link to post
Share on other sites

I have never found the need for target software. So unless you need it, just run game without it. 

  • Upvote 1

Share this post


Link to post
Share on other sites

It's useful if you know how to use it.

 

I use similar software, I can fire a flare and put the gun away again with a single press of a button.

 

 

 😁

Edited by SCG_Fenris_Wolf

Share this post


Link to post
Share on other sites

That could be handy. Multiple actions in one key. This is possible without the software in some instances. You can also fire a flare without having to take out the flare gun or opening the canopy. Best part is there are infinite flares that way!

Share this post


Link to post
Share on other sites
On 1/8/2019 at 3:21 PM, SCG_Fenris_Wolf said:

It's useful if you know how to use it.

 

I use similar software, I can fire a flare and put the gun away again with a single press of a button.

 

 

 😁

You can also do that with “cover me” and “patrol the area” single keybinds. At least I’m doing it and I think it works! 😜

  • Upvote 2

Share this post


Link to post
Share on other sites

I was having the some problems with TARGET software sometimes it would start other times it will just sit there or once I start to run the profile it too just sits there end up restarting. Once in the game I have problems with the ‘P’ button I can tap away but nothing happens have the same problem with the ‘ESC’  which ends in a forced restart. Since I have stopped using Target I have had no problem it’s a good program but creates so many problem for me any way!

 

tacks a while to program key through IL2 but seems better than using Target. 

Share this post


Link to post
Share on other sites

If you have the "Esc", "P" or any other key stop responding with Target you have another swich active. Usually its the flaps control  but it can be any swich that is sending a command blocking the mentioned keys. To find out which tab out of the game when it happens and start notepad or any other program that registers letters to see what command is sent. Then you´ll know which swich you forgot to put to neutral!

Hope this helps.

Share this post


Link to post
Share on other sites
On 1/8/2019 at 7:22 PM, SShrike said:

I have never found the need for target software. So unless you need it, just run game without it. 

 

Hello!

 

SShrike - I can't get my t16000M (no HOTAS yet) to work at all.

 

Not running target, so no "interference" with software etc.
I have remapped 8 times - nothing. Joystick control is enabled, Steam recognises that my joystick is connected, as does the game (BoS). 
Even when key mapping, the twist isn't recognised, so I have no yaw either. Other flight controls are recognised, including throttle and PoV hat, but nothing works in game.
In Thrustmaster control panel (windows recognises T16000M is plugged in and working) it indicates every button push and movement, but nothing happens in game.
I tried resetting to default in game - nothing. Re-mapped the keys (yet again - about 8 times now) and nothing.

 

Config says this - 

configId,guid,model|
0,%22d39b42d0-4f17-11e8-0000545345440180%22,T.16000M

 

Any suggestions?

Thanks

Share this post


Link to post
Share on other sites

Was the stick working okay and then quit, or has it never worked?

 

when you are in game and mapping the keys, under your plane control menu, axis:pitch, roll, yaw, do you see the indicator move  when setting it but no control in game? Or does the indicator not move at all under key mapping?

 

is the stick plugged directly into USB? I have heard of issues if it is plugged into USB hub. 

Share this post


Link to post
Share on other sites

had this problem.

joystick & throttle working fine (Fw190 joyride through Kuban canyons was fantastic!)

set up bindings for all the other stuff and noticed first throttle no longer responsive, then joystick.

all other buttons/switches were doing their thing

 

deleted all bindings - including pitch, roll, yaw, throttle, prop

re-assigned bindings to pitch/roll/yaw, etc. and all started working again.

i guess somewhere I had bindings that were stepping on the flight & engine controls

Share this post


Link to post
Share on other sites

Rename the devices.txt (to back it up) and run Il-2 to create a new one.  It will give you a list of devices with the associated numbers as picked up in the sim.

 

When in the keybindings screen look at the joystick numbers (0, 1, 2 etc) that your different devices are assigned.

 

If your throttle is seen as Joystick 2 in keybindings, make sure it is number 2 in devices.txt.  If your joystick is device 1 then it must also be number 1 in devices.txt (and so on).

 

Example

configId,guid,model|

1,%22126dc660-2f98-11ea-0000545345440b80%22,Logitech%20G940%20Joystick|

2,%22126dc660-2f98-11ea-0000545345440780%22,Throttle%20-%20HOTAS%20Warthog|

3,%22126dc660-2f98-11ea-0000545345440680%22,T-Rudder

 

Don't worry about the order the numbers are in, as long as the numbers match within input.map and devices.txt it is fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...