Jump to content

Stuttering while turning my head in the cockpit (SOLVED to 95%)

Recommended Posts

Well, the first I have to say two things:

1) I have a high-end rig (i7-7700@4,9GHz; 32GB RAM, 1080Ti, 165Hz LCD G-Sync, TrackIR 5), all settings ultra, Target FPS set to 120 Hz.

2) All QMB and Scripted campaigns as well most of the default careers at their start phase are OK, smooth like silk while turning my head in the cockpit, cca 95-120 FPS.


I have been playing Stalingrad Campaign from the start as Bf 109G-2 pilot. Settings: realistic, difficulty moderate, dense... All was OK until the winter map came - since then I started to have stuttering while turning my head. FPS still between 100-120! I have cca 120 missions flown so far...


But I have not encountered stuttering in my other Kuban map career.

So I tried to start the new Stalingrad career from the start (Stalingrad autumn map) and no stuttering at all...

So I tried to start the new Stalingrad career from the 12.12.1942 on winter map and whoa!: stuttering is present


I tried to cut down the air density from Dense to Scattered (as adviced in the other threads about stuttering) but no improvement at all (or maybe only very small).


My conclusion is, that there is something wrong with the winter Stalingrad map.... Sadly I cannot continue with my campaign because of the eye strain due to that ugly micro stuttering.


Note 1: I have the stuttering even without the Stalingrad city with its smokes rendered (i.e. flying far away from the city).

Note 2: the external view is always smooth (but I am not using TrackIR while in the external view but NUM pad keys)

Share this post

Link to post
Share on other sites

Do you have a Force Feedback stick? 


Try the settings below, except instead of Smoothness 50, put Smoothness 100.  That works well enough for me.  Devs really need to fix this issue as it comes up all the time and turns serious simmers off of the game. 


On 8/25/2018 at 1:38 AM, [DBS]TH0R said:

+1 who would like to see this fixed.


For a brief period I used MSFFB2 a while a go, and initially the game was unplayable since I use low smoothness in the camera settings. Since then I've re-done my TiR settings. Increasing smoothness or filtering makes for an easier viewing and also helps with spotting targets I've found.




  • Like 1

Share this post

Link to post
Share on other sites

The first I have to say that I was a little bit optimistic in the first post because I found out that the stuttering was present not only in the Stalingrad career but also in some other careers including scripted campaigns... 


Well I have spent a couple of hours with tweaking and I believe I managed to find cca 90-95% solution 😃


1) The first thing that helped me was deactivating my Asus PG278QR LCD's 165 Hz and set 60 Hz in Nvidia panel for this LCD. Probably LCD is not able to manage higher frequencies well together with TrackIR input (TrackIR works best on 60 or 120 FPS ). In other games without TrackIR 165Hz works well.


2) The next thing that helped was tweaking smoothness Track IR settings:

- basic settings: Smoothness = 1
- advanced settings - Camera: Precision Smoothness settings = 0

I was not able to find out how exactly these two TrackIR smoothness setting cooperate or enhance one another, but lowering the Precision smoothness to 0 was the key (there was probably too many smoothnesses in work)


3) Increase the in-game Smoothness settings from default 50% to 75% (Thanks Davjack for the tip!)

With the TrackIR settings described above, in-game smoothness set to 100% was too much and 50% too little - both values causes unpleasant eye strain. So 75% seems to be the best compromise.


Note 1: I set target FPS in-game to 120 because over 120 I see some tearing. IMHO 120 FPS is quite sufficient and best for TrackIR input synchronization.

Note 2: My FPS is the same before and after tweaking: cca 95 - 120 FPS.

Note 3: I do not have Joystick with FFB (I have VKB Gunfighter KG12)


Now I can play even Stalingrad career without noticeable stuttering on Moderate difficulty and Medium density (If I set Hard difficulty or/and Dense density I notice tiny stuttering but it is still playable).


My conclusion: tweaking the settings can successfully eliminate major stuttering in the game even in the career. On the other hand, it does not mean that there is not something weird in the game because increasing the career settings to maximum lead to the noticeable stuttering while CPU and RAM are not used above 50%.


I add screenshots of all my settings relevant to the stuttering while using TrackIR. Hope that may help some other virtual pilots with similar problems.




Tapi_Asus-PG278QR .jpg











Edited by Tapi

Share this post

Link to post
Share on other sites

One more thing:

I have two LCDs: the older 1920x1080 connected via HDMI and the G-sync 2560 x 1440 LCD connected via DisplayPort.

I used to switch between them with hotkey WIN + P. But even if  I switch this way to G-sync monitor and chose to use it as the only LCD and turn off the other LCD, I have stuttering in the BOX even with the settings described above!!!


I have to boot PC directly with the only G-sync LCD turned ON (and the other LCD turned OFF) and then there is NO STUTTERING in the game.

Edited by Tapi

Share this post

Link to post
Share on other sites

Before current patch I used to use windowed mode and vsync turned off, gsync disabled. After new patch I had some stuttering so I switched to full screen and gsync and now game is  smooth again.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...