Jump to content
Sign in to follow this  
Skylok

Awful Rift performance

Recommended Posts

Hello,

 

I'm almost at the point of giving up, but I thought I'd try here as my last chance. Below is a detailed list of my computer hardware, settings, and things tried:

 

1. Intel  I7 6950X black edition, 10 Core CPU @ 4.1Ghz w/25mb Cache

2. Nvidia 1080ti

3. 32GB Ram

4. 500GB SSD (game/OS installed)

5. Asus STX Essence 2 sound card (saves me precious CPU cycles)

6. Win10 64

7. Oculus Rift

8. Game played via STEAM

9. Power settings are on max performance

10. I even tried Razer cortex...

 

Every driver / Firmware is up to date. Clean system, constantly maintained with an OCD like quality.

 

Elite Dangerous is the only other game I play in VR, and I get a buttery smooth 90FPS, with quality settings, and HMD @ 1.3

 

The problem in IL2:

 

While playing in Non VR, I set my preferred FPS to 100, max out every setting I can, and I get a constant 90-100FPS depending if I'm over a city with ground units. Game looks gorgeous. I just can't stand my limited and restricted view not playing in VR.

 

While playing VR, no matter my in game settings (I've done research on this forum for the fastest/best VR settings), no matter what settings I use in Steam VR, 66% to 200% resolution, my FPS hang between 30-45 depending on situation. The only changes the settings do is either make it look like garbage, or smooth it out, but no change in performance.

 

I've elevated the game to a high processor priority, which does nothing. I tried Razer cortex, which does nothing. I've combed over every setting in detail, nothing changes. 

 

Please help me, I'm at wits end.

 

Thanks

 

 

Share this post


Link to post
Share on other sites

Hey, I have similar system and having same issues. It seemed to be okay until the recent oculus 1.26 software?? (never great performance but not this bad)

 

I used to run from steam with oculus software not running, but after 1.26 you can't not have it in background.. Not sure if it is this or something else, but I would sure like to know if anyone has any suggestions or similar experience.

 

I tried Fenris_Wolf's cut'n paste settings just now, and it was so choppy, looking around it made me start feeling sick just sitting on the runway! Reading between 30 and 45 fps, but it appeared much worse, like 5..  Needing all settings on low, no SS etc to get a 'smooth' 45fps with a 1080ti, something must be wrong..

Share this post


Link to post
Share on other sites
54 minutes ago, Skylok said:

Hello,

 

I'm almost at the point of giving up, but I thought I'd try here as my last chance. Below is a detailed list of my computer hardware, settings, and things tried:

 

1. Intel  I7 6950X black edition, 10 Core CPU @ 4.1Ghz w/25mb Cache

2. Nvidia 1080ti

3. 32GB Ram 

 

- don't compare it to monitor. For VR you need double performance (think about it).

 

1)  cpu 4.1ghz is too slow. You need to figure out a way to OC it to 4.7-4.8ghz  to get decent performance.  You'll get 20-30% performance boost here alone.

2)  1080ti  -  are you running at 1,900-2,000mhz at least? Make sure your OC settings work here as well, although TI is a best as it is so this is more of an optimization exercise more than anything

3) are you running XMP profile? RAM must be at ~3200mhz  as well for best performance. The default 2400mhz will create a bottleneck for texture loads.

 

Once you take care of the above hardware stuff:

-  make sure you enable AWS in Rift.  And don't disable it until you tried every other setting out. AWS is the last thing you want to turn off. With bad framerate it'll still look like crap but at least it won't be choppy.. just a fluid mud though.. lol  :)

-  run SS oversampling in Oculus debug tool or Oculus tray tool. Set steamVR stuff on 100% and disable any filtering it's using, asynchronous, interleaved, etc etc. In all don't mess with SteamVR.

 

 In game:

-  drop the shadows to Low or turn them off completely. You can turn them back on/try them out once you stabilize the performance.

-  Clouds on low  (same as shadows, increase it once you get the baseline going)

-  horizon draw distance ~100km  <-- minimal impact from this setting

-  SSAO off

-  vsync off

-  4k textures On

-  start with Balanced preset, go to High if balanced is ok

-  Anti-aliasing -  start with OFF, however you'll get a lot of shimmering. If framerate improves then turn x2 on, and so forth..

-  Target frame-rate - set it to 0.8.  If the game is fluid, bump it up to 0.9, but no more.

 

Focus on cpu OC though. It's your best bet to improve the performance right away.

 

 

 

Share this post


Link to post
Share on other sites

Try no SSAO, no HDR, no mirrors.

Landscape draw at 40 km.

Balanced Preset

2x AA

No SS.

 

Is your testing on the Kuban Map? If so also try one of the others to compare.

 

Share this post


Link to post
Share on other sites

The problem is your CPU. Intel's HEDT line is ill suited for gaming in general and is particularly bad in predominately single threaded game engines such as the ones BoX and DCS use. This is one of those cases where a piece of crap $130 i3-8350k is actually superior to a $2000 HEDT CPU. The specific reason as to why is mainly clock speed, but latency also plays a role. Those of us getting 90-ish fps in BoX are overclocking i5's and i7's to 4.7 GHz or higher (mostly higher). However, even if you get that speed out of your chip, it will still be lackluster.

 

The reason is Intel's HEDT line uses a mesh style interconnect between CPU cores. This offers greatly superior bandwidth but also dramatically increases latency. VR at 90 fps is roughly equal to 180 fps on a monitor from a  CPU standpoint. Any increase in latency can cripple the CPU's ability to feed the GPU quick enough to maintain that framerate. AMD's Threadripper and Ryzen CPU's (to a lesser extent) also have this problem.

 

As for what you can do to improve performance without messing with hardware, the only thing is reducing the number of objects rendered. While the GPU takes care of all the actual drawing/lighting/texturing of objects, the CPU has to tell it what objects to draw in the first place. Reducing that list by reducing draw distance settings will make a big difference.

Share this post


Link to post
Share on other sites

Unfortunately like everyone here has said, that cpu just isn't made for gaming. It's drastically holding back your framerate. I get great performance with a 1070 and a 8700k at 4.9ghz.

 

Also unfortunate is the fact that without swapping out your mobo there's no quick fix.

Share this post


Link to post
Share on other sites

Thanks for the frank responses.

 

I got it a more acceptable level today by fiddling with the one options I never touched... Vsync.

 

Now it occasionally breaks into the 90s, but consistently stays at 45. (when I move my head up there it seems to constantly say 44-45).

 

I'm disappointed in what I'm hearing about my CPU. It was relatively expensive, and performed very powerfully for me in my 3D Mark tests, and CPU tests (including single core tests).

 

Anyone know which map performs the best? I only own the Stalingrad map.

 

Thanks!

Share this post


Link to post
Share on other sites
8 hours ago, Skylok said:

Thanks for the frank responses.

 

I got it a more acceptable level today by fiddling with the one options I never touched... Vsync.

 

Now it occasionally breaks into the 90s, but consistently stays at 45. (when I move my head up there it seems to constantly say 44-45).

 

I'm disappointed in what I'm hearing about my CPU. It was relatively expensive, and performed very powerfully for me in my 3D Mark tests, and CPU tests (including single core tests).

 

Anyone know which map performs the best? I only own the Stalingrad map.

 

Thanks!

Oh dang dude, yeah definitely don't have vsync on with VR. I dunno if it even works but apparently it does. You could also disable ASW which will limit the framerate to 45 if you drop below 90 frames, I don't use it as I get that awful prop jumping effect on the gunsight with it on. I'd rather not disable the propellers either. Get the oculus tray tool and you can toggle it on and off in game by pressing ctrl+numpad 1, if you like it off just set it to off on the tray tool.

 

You don't need 90 fps to enjoy VR in this game in my opinion. If you could get that cpu overclocked even a little bit it could help as well. Look up some guides on the web. Be careful though it's pretty hard to kill a cpu these days but it's still possible.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×