Jump to content
DaGengster

Stuttering clouds?

Recommended Posts

Ive noticed that when the setting is at anything but ultra, the clouds seem to be stuttering. I found a video someone else made linked below. The issue is very apparent at about 2 -3 seconds into the video where he looks to the side. The cloud "whisps" seem to be moving/stuttering. From what Ive seen of clouds irl, that looks kind of unnatural.

Is there anyway to fix this? Ive tried clouds at medium and high, both have that issue. Couldn't find anything from just googling. I usually run at ultra but the recent patch had a lot of micro stutters and I turned my settings down. (I tried the 4k option thing from the other thread but didnt work :( )

Specs:
4690k, 980 ti 16 gb ram, Rift VR

 

Edited by DaGengster

Share this post


Link to post
Share on other sites

hi, DagGenster i got the same problem,

like i say many times on the forum and sorry for that,  reducing texture to high performance helped me a lot with the stutters.. and also, the clouds stutters are definitively reduced too ,now they are fine sometimes,  if i look trough right or left window clouds are fluid, smooth and when i move my head to 6 o clock or 12 o clock the clouds stutters come back,like to have the plane in sight add pressure on the video card,  but not always , i think my video card miss some power, i m wondering if you try those setting and maybe the textures filtering option on too with your 980 ti you can get it right ?

note: i wish we could have an in game option to have statics clouds ? dont know if it can be done easily

Share this post


Link to post
Share on other sites

Can we get some feedback on this. My clouds, no matter what setting, seem to be rendering at 1 fps. Looks horrible. Everything was fluid smooth before this all great wonder patch. Ever since, I've had to work around settings to get rid of stutter with smooth frames. FPS counter hardly ever dips below 59-60. I have gotten the overall game smooth with the work arounds, but the clouds just ruin it for me atm.

 

I bought Kuban and the two planes while on sell, but I am afraid I am going to have to shelve this game till the devs sort these glaring issues out.

Edited by CastorTroy

Share this post


Link to post
Share on other sites

I have the same issue.  I was experiencing major stuttering issues.  Followed Jason's advice and was able to eliminate the stuttering by coming down from ultra, but now clouds look atrocious, on top of stuttering and pixel-distorting (creating a pixellated outline/emanation) anything that flies through them.

 

This persists at every cloud quality level, on every setting besides ultra.

 

It makes the game look like complete crap on any other setting.  RoF looks ages better in comparison right now.

 

Either fix this, or let us disable clouds altogether please.

Edited by hrafnkolbrandr

Share this post


Link to post
Share on other sites

I experience the following issues as well:

 

- dancing clouds

- Low fps clouds ( clouds stutter from position to position), even with 60+ FPS.

- low definition clouds in the horizon-

- Terrible aliasing of aircraft when flying over, through, or under the clouds.

 

I experience these issues with clouds on "low" and "medium", and overall settings on "low" and "Balanced". Issue persists with 4k skins enabled and vsync activated.

Edited by Pupo

Share this post


Link to post
Share on other sites

I tried using 'Low' clouds as suggested by Jason and it was horrendous! See photo.  I went back to 'High' which is not perfect but nowhere near as bad

 

 

CloudsLow.jpg

Share this post


Link to post
Share on other sites

I don't have any problems with clouds per se (I'm on Ultra with detailed clouds), but when close-by planes fly into clouds I see the same jagged contours as on the screenshot by Roblex. Quite annoying when my target visually disintegrates as I get closer to it.

Share this post


Link to post
Share on other sites
7 hours ago, sniperton said:

I don't have any problems with clouds per se (I'm on Ultra with detailed clouds), but when close-by planes fly into clouds I see the same jagged contours as on the screenshot by Roblex. Quite annoying when my target visually disintegrates as I get closer to it.

 

Yeah the problem seems to go away on ultra. This only happens when on lower settings.

I would think making static clouds would take less system resources than low fps clouds and they would look better IMO.

 

But apparently using 4k textures instead of the standard fixes stuttering issues for some people this patch so idk whats going on here imao.

Edited by DaGengster

Share this post


Link to post
Share on other sites
11 hours ago, 56RAF_Roblex said:

I tried using 'Low' clouds as suggested by Jason and it was horrendous! See photo.  I went back to 'High' which is not perfect but nowhere near as bad

 

 

CloudsLow.jpg

 

Same issue for me Roblex. It's like against any cloud, other planes' resolution drops dramatically. Running ultra with 4k textures on. 

Share this post


Link to post
Share on other sites
5 hours ago, DaGengster said:

 

Yeah the problem seems to go away on ultra. This only happens when on lower settings.

My point is that the problem is still there, even if it's not directly perceived on clouds. Planes flying in or into the clouds appear miserable even in Ultra. I switched off DRS, believing it was the culprit, but planes disintegrate into a pixelized cloud with jagged contours even when DRS is off.

  • Upvote 1

Share this post


Link to post
Share on other sites

Here is the issue I was talking about. The very same moment captured from different viewpoints. Note the much reduced rendering quality when planes appear in front of clouds. Preset is Ultra, cloud quality "high", AAx4.

2018_3_23__9_54_37jpg.jpg

2018_3_23__9_54_49jpg.jpg

Share this post


Link to post
Share on other sites

Try enabling "Antialiasing - Transperency Multisampling" in nvidia inspector or the nvidia control panel when you have an nvidia card. I wouldnt say it completely fixed the low quality when above clouds but it reduces it so it isnt really noticable anymore for me. I also use 4xAA ingame and MFAA On in control panel. Maybe it helps.

  • Upvote 3

Share this post


Link to post
Share on other sites

I have the same problem in VR and seems nothing helps, i hope hotfix will solve it cos it is terrible.

While i managed to reduce stuttering on Kuban map, in the case of clouds nothing helps, it's like 1fps slideshow.

My friend who fly in VR have same problem.

Maybe if they don't find solution they can give us VR users pre patch clouds option.

Share this post


Link to post
Share on other sites
On 3/23/2018 at 12:13 PM, Ishtaru said:

Try enabling "Antialiasing - Transperency Multisampling" in nvidia inspector or the nvidia control panel when you have an nvidia card. I wouldnt say it completely fixed the low quality when above clouds but it reduces it so it isnt really noticable anymore for me. I also use 4xAA ingame and MFAA On in control panel. Maybe it helps.

Thanks for information. This helped a bit and I've noticed also better fps for clouds.

Share this post


Link to post
Share on other sites
26 minutes ago, klobuk said:

Thanks for information. This helped a bit and I've noticed also better fps for clouds.

pictures and other option suggestion with MFAA on, for clouds AA and performance help

 

Share this post


Link to post
Share on other sites

The clouds need to be looked at, they cause jaggies on aircraft that are close in front of them, also they seem to reduce frame rate somewhat.

I have beefy hardware, so I can run on high cloud setting, however its not a pretty sight, the clouds worked great on previous game version.

 

Cheers

Walt

 

  • Upvote 4

Share this post


Link to post
Share on other sites

i know the subject is about close distance clouds stuttering , but even before the update, the very long distance ones have always been pretty much with jaggies for me, even everything to max and ultra, and all kind of aa transparency added from nvidia inspector, textures settings, anisotropic , dsr etc... tried everything setting i could think , i m just able to reduce it a bit.. do i miss something in the settings, any recommendation that could help ?

thanks

Share this post


Link to post
Share on other sites

Could be of interest to some. Requires modes=1 in startup.cfg (or "enable mods" in game settings).

It doesn't solve the problem with jaggies around plane outlines, but should solve the "simmering" effect of clouds, which some might also calling stuttering.

Mostly for offline play, as there are no servers with mods on enabled at the moment.

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Could this issue be in anyway related to the campaign?

 

Tried out "Low" settings with clouds on High, and reduced my visibility to 100km. Tried a quick mission with overcast, and was really happy to see that the issue was fixed. But then I jumped to the next mission in the career, and there they were, the stuttering clothes were back.

 

Another option could be the fact that I set the quick mission to have 0 m/s wind, and the campaign has "some" wind. Could it be that the issue is not the clouds by themselves, but rather rendering moving clouds?

 

Will investigate more tomorrow.

 

 

Share this post


Link to post
Share on other sites

Ok. I tested, and the problem only exists (for me) if the mission has wind. 

 

If you go to quick mission, and start a mission without wind and clouds to heavy, you should not experience stutters. Add a bit of wind, and clouds will start stuttering.

 

Confirming this is important, because some people may be claiming to not experience this issue since they are playing in wind-less multiplayer servers, or quick missions set with no wind.

 

 

Share this post


Link to post
Share on other sites

@Ishtaru, thanks a lot for the hint, but unfortunately it didn't work for me, and also had an FPS hit. BTW at a closer look I see scattered pixels around the plane, some kind of graphic noise. Something is wrong with the clouds as a background when image is blended onto them, I don't get this issue in front of other backgrounds, including smoke.

 

@Pupo, would you check please whether you have the jagged contours when the stuttering seems to be gone?

Share this post


Link to post
Share on other sites
8 minutes ago, sniperton said:

@Pupo, would you check please whether you have the jagged contours when the stuttering seems to be gone?

 

Nope, jagged contours remain. 

Share this post


Link to post
Share on other sites

Thanks a lot, so it seems we have a major graphic glitch related to the new clouds, and no workaround has been discovered so far. I hope the issue will be addressed in the next patch, hopefully very soon. I don't say the game is unplayable now, but it's certainly not up to the high playability standard we are used to. My very personal suggestion to the devs would be that if they feel they can't sort out the issue of clouds within a few days, it would be better to temporarily disable the new clouds and to restore the old ones.

  • Upvote 5

Share this post


Link to post
Share on other sites

I can really hope this bug(s) are on the top priority list! This ruins the fun and become  a real gamebreaking bug for me.

 

It´s a shame for a full price title in 2018

 

 

2018_3_21__20_48_9.png

2018_3_22__22_32_27.png

2018_3_22__22_49_22.png

2018_3_22__23_38_25.png

  • Like 2

Share this post


Link to post
Share on other sites

Same here.  Windows 10 64-bit, Intel Core i7 CPU 930 @ 2.80Hz, 8.0GB RAM, NVIDIA GeForce GTX 750 Ti.

2018_5_2__1_29_22.jpg

Edited by claycrosby
Added CPU information

Share this post


Link to post
Share on other sites

It´s not a bug..it´s a feature ;)

2018_4_24__17_1_23.jpg

2018_4_24__21_7_55.jpg

2018_4_18__23_3_22.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...