Jump to content
Sign in to follow this  
neofightr2

Turn ASW off for Rift to remove artifacts

Recommended Posts

This applies to Rift users and possibly only useful for high-end gpu/cpu users.

 

I have been doing a lot of performance testing ever since I OCd my 6700k to 4.8ghz.

 

I decided for comparison to turn off Asynch timewarp via the rift debug tool.

 

I was surprised to see a much better experience. Here is why:

 

With ASW on, the Rift will make sure the game downsteps the FPS once it dips below 90fps (after a certain period of time) to a steady 45fps to allow the ASW rendering to function correctly. This ASW process causes undesirable effects primarily in squiggly renderings of the prop and other items in view as well as a double vision of enemy aircraft at a distance.

In addition the almost digital back and fourth fps jump between 90 and 45fps is distracting during gameplay to say the least.

 

When you turn off ASW, this dramatically changes the process since now you see a smooth analog degradation from 90fps down to 60fps (for my high-end system this is as low as it gets) then smoothly back up to 90 as the rendering workload changes.

 

This allows the rendering to remain crisp with no weird artifacts like squigly lines or double vision of far off planes etc.

 

The downside of course is judder while moving your head mostly in cockpit for me. The good news is this judder is barely noticeable and only becomes obvious during intense rendering periods.

 

To me this is a no brainer since dipping down to 60fps is not going to make me sick, I never feel nauseous in VR anyways.

 

I suspect those with mid-level and low level systems for VR should not try this because I am sure the FPS stays low enough and long enough to guarantee you a headache without ASW on.

 

Vive does things different with their form of ASW so you don't see artifacts to begin with so it isn't much of a factor (I own both headsets but prefer the Rift).

 

Share this post


Link to post
Share on other sites

I have had ASW turned off for quite some time ( via OTT) and have always preferred it that way. Better experience for me.

Share this post


Link to post
Share on other sites

I have had ASW turned off for quite some time ( via OTT) and have always preferred it that way. Better experience for me.

I am amazed at the difference in performance when you turn off ASW.

It's like ASW cripples the overall performance of a high-end system.

 

For example I use to get a consistent 45fps (asw has clearly turned on) when at the airfield after landing.

Now I get 90fps when I have asw forced off at the exact same spot with with the exact same settings.

 

This is huge!

 

BTW none of the original posters of this links talk about exactly what is going on with the ASW process for this game. I feel my post is still relevant and stands out because it makes a clear case of a major boost in performance (at least with high-end systems).

Edited by neostar

Share this post


Link to post
Share on other sites

I am amazed at the difference in performance when you turn off ASW.

It's like ASW cripples the overall performance of a high-end system.

 

For example I use to get a consistent 45fps (asw has clearly turned on) when at the airfield after landing.

Now I get 90fps when I have asw forced off at the exact same spot with with the exact same settings.

 

This is huge!

 

 

:good: 

 

Exactly.

That is what I found as well , and in heavy combat when frames do drop into the mid 60's or 70's I am still having a very fluid and smooth experience.

Share this post


Link to post
Share on other sites

:good:

 

Exactly.

That is what I found as well , and in heavy combat when frames do drop into the mid 60's or 70's I am still having a very fluid and smooth experience.

yes indeed it makes dogfighting a very smooth and consistent experience.

Share this post


Link to post
Share on other sites

ASW off might be producing the slight flickering I get which is not continuous? It`s the thing I haven`t managed to stop, near clouds, heavy action and it comes in barely noticeable but it`s there. I`m on a 3570k at 4.2, 16gb of DDR3 at 1866 and a 1080, I`ve set the graphics on high and edited a few bit`s and bobs to get a decent enough image. SS is 1.7 , Gamma and HDR 0.9 , Sharpen is on. What would people suggest as a decent settings baseline to work from given the components I have. I would like rid of the prop tbh as well, shame that isn`t an option in the graphics set up screen. Any help greatly appreciated as I`m a VR noob, I know where most of the settings are but what they do is a complete mystery to me!!!

Share this post


Link to post
Share on other sites

A warped single flicker now and then Smurfy?

 

 

To test where it comes from:

 

Are you playing on WoL or TAW? Lag induced then, most likely.

 

Is it in SP as well, at lowest possible preset graphics settings?

 

Then it may be related to a faulty sensor setup, redo sensors.

 

Do you use a Rift without an internal dedicated USB controller? That might be an issue as well (inateck USB card is recommended by Oculus).

Share this post


Link to post
Share on other sites

A warped single flicker now and then Smurfy?

 

 

To test where it comes from:

 

Are you playing on WoL or TAW? Lag induced then, most likely.

 

Is it in SP as well, at lowest possible preset graphics settings?

 

Then it may be related to a faulty sensor setup, redo sensors.

 

Do you use a Rift without an internal dedicated USB controller? That might be an issue as well (inateck USB card is recommended by Oculus).

 

Apologies for the late answer.

 

The flickering is virtually non-existent now I`ve disabled ASW and disabled the prop.

 

I`m only playing SP at the minute and I play the same mission repeatedly to try and find the best solutions.

 

I am using an Inateck card for one of the 2 sensors, the other and the headset are on the boards USB 3.0 ports.

 

I`ve reset the sensors which has cured the dodgy tracking I was getting.

 

Settings are on HIGH I tried LOW and balanced and tbh it was like going back 10 years , you had to be virtually on top of the target to see what it was, even at say 1000 yds it was just a few pixels which were easily lost against the background. May be realistic I guess but it ain`t fun.

 

Even now the definition of the other aircraft isn`t that good, the image quality is way better but spotting, following and not losing them is a real task in itself. I`ll post all the settings if that will help. It may well be that the CPU & Ram just aren`t good enough to play the game at a clarity my 50 year old eyes can handle with any great enjoyment. I love being in the pit, I like the sensation of being `up there' but man is it hard work in a fight. A Ryzen 1700/1800 might be on the cards now the price has dropped and I`ve read that RAM speed is actually a bigger influence on FPS in games than increasing CPU speed? so maybe 16gb of 3200 will do the trick. Or live with it and go big when the next generation VR headsets drop.

Edited by BFsSmurfy

Share this post


Link to post
Share on other sites

Even with ASW disabled. I still get double imaging artifacts when I enter a large enough fur-ball in Wings of Liberty. 

Share this post


Link to post
Share on other sites

Ok here you go:

 

In Oculus Tray Tool:

 

SS = 1.7

ASW = off 

High Performance

USB selective suspend is disabled

 

In game:

 

HDR is on

Sharpen is on

Shadows = low

Mirrors = off

Distant land detail = 3

Land filter = sharp

Grass = normal

Dynamic Res factor = full

AA = 2

Gamma Correction = 1.0 

 

General setting is High.

 

 

Pc wise it`s an i5  3570K at 4.2, 16gb of DDR3 at 1902, Palit 1080 default overclock, I`m on Win10 pro and everything is running off SSD`s

Share this post


Link to post
Share on other sites

You mentioned you want to buy Ryzen to improve performance. It will worsen it. Avoid Ryzen at all costs for when you want to play IL 2 VR please (as well as most other VR apps) .

 

I won't go into detail now, but we have accumulated user data (especially chiliwilli!) and users have reported terribly low fps, hiccups, etc. on Ryzen. On Ryzen, Il2 VR is unplayable (dipping below 45fps) compared to an Intel CPU.

 

Only go Intel, best i7 8700k. Reason is, IL 2 needs single thread performance - just like many other VR apps as well. Ryzen is multicore oriented. Check chiliwilli 's gathered performance data for details if you will.

 

P.S. Not the Ryzen'fault, as it is up to developers how to constitute their engines, but a result is a result.

Edited by SCG_Red_Wolf

Share this post


Link to post
Share on other sites

You mentioned you want to buy Ryzen to improve performance. It will worsen it. Avoid Ryzen at all costs for when you want to play IL 2 VR please (as well as most other VR apps) .

 

I won't go into detail now, but we have accumulated user data (especially chiliwilli!) and users have reported terribly low fps, hiccups, etc. on Ryzen. On Ryzen, Il2 VR is unplayable (dipping below 45fps) compared to an Intel CPU.

 

Only go Intel, best i7 8700k. Reason is, IL 2 needs single thread performance - just like many other VR apps as well. Ryzen is multicore oriented. Check chiliwilli 's gathered performance data for details if you will.

 

P.S. Not the Ryzen'fault, as it is up to developers how to constitute their engines, but a result is a result.

 

Agreed i7 8700k its amazing for Il2 BOS.

Share this post


Link to post
Share on other sites
1 hour ago, rogueblade said:

Is the general advice still to turn of ASW?

 

I used to on my old rig, but after building this one I have gotten to where I just leave it on.

The bulk of the time it does not kick in, but those times that it does I find it is not that bad at all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...