Jump to content
Sign in to follow this  
InProgress

Throttle acting weird

Recommended Posts

When i fly my throttle often goes up to 100% on its own. Happens to all kind of planes i fly. I put it on 50% and few seconds later it goes to 100%. Not all the time, sometimes it stays as i wish but mostly it does not and always goes to max. What to do? :(

Share this post


Link to post
Share on other sites

Make sure you do not have the green engine auto control or throttle limiter boxes ticked in your difficulty boxes.  If they are not on, you need to check throttle calibration with the appropriate software, whatever that may be. 

Share this post


Link to post
Share on other sites

Did you check your throttle axis and did you calibrate it correctly under Windows OS? Does the axis do and depict what you want to do?

Or does the axis have some spiking? In this case, bad news for you - throttle is broken.

 

If your throttle works correctly under Windows OS and perhaps in other games, then try to find out if you don't have flight aids checked

on in the realism panel.

 

Cheers

Share this post


Link to post
Share on other sites

It's not broken, it works in BoX. And in old CloD too. I have full realism on, no helpers etc.

Share this post


Link to post
Share on other sites

This can happen if you have throttle 1. engine  assigned together with just throttle . make sure you have only 1 axis on engine 1 throttle and throttle 

Share this post


Link to post
Share on other sites
Posted (edited)

I cleared all buttons there, all engine things is throttle on my physical throttle, engine 1 - ctrl+1, engine 2 - ctrl+2, all engines - ctrl+~

But it keeps happening anyway.

 

Here more detailed what's going on, when i put something like 70% for example. I can fly like this for a while and then it randomly goes to 100%. Sometimes it plays with me, i put 50% it puts 100%, i change to 50% again and it goes to 100%. Sometimes i can fly on my setting for a longer time and then it changes again. Feels like it's random.

 

All i have in engine control is main throttle on joystick as axis. And that's all there. Other engine options is select engine 1, 2 and all, which is ctrl+1 +2 + ~

 

It happens on 1 engine planes and multi engines as well. Really annoying :(

 

Not 100% sure since i played only 1 mission, but in campaign it did not happen. In multi i dont know yet, will try as soon as i can. Now it only happens in quick mission.

Edited by InProgress

Share this post


Link to post
Share on other sites
Posted (edited)

Make sure you do not have the green engine auto control or throttle limiter boxes ticked in your difficulty boxes.  

 

This looks Bo'X features only.

 

 

 

When i fly my throttle often goes up to 100% on its own.

 

In some CloD QM are a related bug that may make throttle became "automatic", e.g. in Low Level dogfight Spit X Bf 110, but is rare.

 

 

 

 Sometimes it plays with me, i put 50% it puts 100%, i change to 50% again and it goes to 100%.

 

Look if you have a axis or key assigned for "Throttle War Emergency Power", this instantly put the (in game) throttle in 100%, whatever is joystick throttle position and is not "WEP" (available for Bf 109/110...).

If have remove (is another CloD "unfinished" feature, that don't work as should).

Edited by Sokol1

Share this post


Link to post
Share on other sites

 

 

In some CloD QM are a related bug that may make throttle became "automatic", e.g. in Low Level dogfight Spit X Bf 110, but is rare.

Happens all the time in QM so does not seem so rare :P

 

I have Throttle War Emergency Power on "W" i think, but i am not clicking on it tho. But will remove and see what happens.

Share this post


Link to post
Share on other sites

Sokol, could "antropomorphic control" (or wahtever this BS option was called) cause these things? @InProgress, you say you're set for full real, so that option might be on. Turn it off and see what happens.

Share this post


Link to post
Share on other sites

What "Antropomorphic Control" do is limite the axis use to four I think (e.g. aileron, elevator, rudder, throttle), but a spiking axis can interfere and block for example momentarily throttle use, but don't think that will change throttle adjust for 100%. 

 

Anyway leave this OFF, this is a good idea on paper but in CloD implementation don't consider the bad quality of joystick potentiometer's, even a Warthog HOTAS announced as all HALL, use a pot their slider axis.

 

InProgress

 

What you should use of commands for "WEP is

 

"War Emergency Power" - for Bf 109/110...

 

"Boost Cut-Out" for British planes, I think Italian too.

 

"Throttle War Emergency Power" require throttle axis divided in two bands, what CloD dev's provide in control options, but forget to allow that an axis could be use for 2 different commands (Bo'X allow up 3) :

 

"Throttle" and "Throttle war emergency power" - this command can be assigned to a key too, but only make sense for ones flying using only keyboard.

Share this post


Link to post
Share on other sites

I deleted that emergency power and turned off Antropomorphic Control, no changes. Still changing throttle power to max. But it seems like it only happens in QM. I tried campaign and single missions and it seems like it does not happen there.

Share this post


Link to post
Share on other sites

That broken "training" (of patience maybe) module rely on scripts and triggers for AI assume plane control as "instructor" (sometimes for crash the plane on ground).

 

This script's are not in mission folder (e.g. like campaign mission script) but in internal files (SFS).

 

Probable in QM this script's are triggered - by "Gremlins" hidden in the "web net" of game code.  :biggrin:

 

Happens that most people fly QM's with throttle in "110%", so the issue is not noticed, but the bug was already reported and confirmed in QM - Dogfight Even - Low level (Spit x Bf 110).

 

I don't notice this, probable because at long time I use edited QM and put then in Documents\1C..\quick\ folder instead the defaults inside SteamApps\common\il2...\quick\.

 

CloD is this = get used with their "peculiarities".

 

After all ~12 years goes by, two development equips, and their "logic" still not logic.   :wacko:  :lol:

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×