Jump to content
Buzzsaw

Enabling CH Products Joystick Control Manager in Windows 10

Recommended Posts

The popular CH Products Joysticks and Rudders have software designed to allow them full function.  Unfortunately CH has said they will not support the software and provide updates for W10 changes.

 

WIN 10 CH Manager Work Around

 

Problem:  The controllers are grayed out in CH Control manager software and they do not work properly.

Below is the work around for this problem since the latest Windows 10 creators updates.

First, you need to prevent your computer from saving information to boot faster upon shutdown (you need to turn off fast startup in windows) so that it treats the controllers the same whether you cold boot or restart.

1. Click the start button and type "CONTROL PANEL", then choose Hardware and Sound then Power options. On the left side click "Choose what the power Buttons do". Now click "Change settings that are currently unavailable". Lastly UNcheck "Turn on fast startup (recommended)"

2. Now when you boot from cold boot or a restart it will treat the controller the same way.

3. Boot/reboot the computer. When it comes up DO NOT DO anything related to games or control manager loading scripts. You must open Control Center, or Control manager and wait for about 2-3 minutes until you hear the last chirp of the USB being recognized. Once that last chirp happens you can then load scripts or change whatever. If you do not wait for the last chirp (2-3 minutes) and you try to manage your controllers then you must reboot and start over.

4. Instead of manually opening control center upon startup. You can add the CMStart.exe (CH startup program for the 5 sec delay) shortcut to your SHELL :

 

STARTUP folder.
* CMSTART *
To add CMStart to your SHELL : STARTUP Folder

1. in the Address bar of Windows Explorer type or paste C:\Program Files (x86)\CH Products

2. in windows explorer top left choose FILE Open New Window. In the Address bar of that window type or paste SHELL : STARTUP

3. once you have both windows up RIGHT click and drag the CMSTART application to the SHELL : STARTUP folder and let go. When the options come up, select "create shortcuts here".

4. now every time you boot, the controller will begin the process of the 2 min wait

In addition in STEAM:

 

Under STEAM > SETTINGS > CONTROLLER > GENERAL CONTROLLER SETTINGS > Uncheck the "Guide Button Focuses Steam" checkbox to prevent Steam from turning your Controller Gray again when Loading CM scripts.

  • Like 1

Share this post


Link to post
Share on other sites

The workaround above does not work for many, including myself.  I have had intermittent success, sometimes restarting a few times to get it to work.  Tonight, after the 10th restart, I decided to look for an answer some more, or just start mapping my gear in the game and not using the Control Manager Software anymore. 

 

I THINK I FIXED IT!!!  Here is how: 

 

1)  Open Device Manager in Windows 

2)  Find the CH Products list and expand it 

3)  For every device listed: 

      A)  Right click, then click properties in the window for the device.  

      B)  Click the Power Management tab, if there is one.  If not, just close the window and move to the next device 

      C)  UNCHECK the box that says “Allow the computer to turn off this device to save power” 

 

After I finished all the devices in the list, I restarted my PC 

 

After that… it worked flawlessly, like it always used to.  I can switch back and forth between direct and mapped modes over and over, load a new profile, switch between modes some more, load another profile, all is right with the world again.  I even restarted again to be sure.  I didn't wait for anything.  When the desktop came up, I opened Control Manager, and switched from direct to mapped mode, and it worked fine!

 

Hope this helps someone (hopefully everyone with this problem!)!! 

Edited by Eclipse4349
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

I did this the old school way by making the folder.

 

Edited by Proudtiger

Share this post


Link to post
Share on other sites

Apem that you link made joystick for industrial use.

 

Apem division that make domestic joystick is CH-Products.

http://www.chproducts.com/

 

Good products, the downside is that still using the same 8 bits introduced in ~1999, design is too from last century. 😀 

 

If fair they probable are the most durable game joysticks ever made.

 

 

 

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites
On 8/8/2019 at 7:25 AM, Sokol1 said:

Apem that you link made joystick for industrial use.

 

Apem division that make domestic joystick is CH-Products.

http://www.chproducts.com/

 

Good products, the downside is that still using the same 8 bits introduced in ~1999, design is too from last century. 😀 

 

If fair they probable are the most durable game joysticks ever made.

 

 

 

 

 

I have one which I bought in 2000 which is still working perfectly.

Share this post


Link to post
Share on other sites

My CH setup is approaching 20 years of use also.

Share this post


Link to post
Share on other sites

What I have just found that so far has worked for me several times in a row is to........

 

1. Open / launch the Control Manager software using "Run As Administrator"

2. Before loading a profile, ensure the mode is set to OFF (ie. don't have it in DIRECT mode or MAPPED mode)

3. You can now load a profile, edit it and then press the DOWNLOAD button and the buttons won't grey out  (well, at least for me they didn't)

 

You can then play whichever game you want to play and the key assignments will be working as you have programmed them.

 

Please note that for me if I go back to Control Manager program after playing a game and then load and download a different profile the buttons grey out again.  The workaround for that so far for me is to:

1. Close the game I was playing

2. Close the Control Manager program

3. Re-open /launch the Control Manager program (Run as Administrator)

4. Put Control Manager into OFF mode

5. Load the different profile

6. DOWNLOAD the different profile

 

 

I hope this works for everyone

Edited by MurrayCod
extra info added

Share this post


Link to post
Share on other sites

I tried MurrayCod's trick.   (After doing the power management  thing). 

 

As soon as I click 'OFF' the download button and three mode buttons are greyed out.   I load a map... they never come back. 

 

I've been screwing around with this for days.    I'm wondering if it's time to just give up on flight sims.    This is just too much.  

 

Share this post


Link to post
Share on other sites

More test results.... I thought the 'load your map as soon as you start your computer' would work ok.    But after five minutes or so my rudder pedals stopped working.   

 

Getting lots of really random results here.   

Share this post


Link to post
Share on other sites

This issue was really bad around 12 months ago with a number of work arounds posted. The issue it turned out was within Windows 10 itself, as determined by some of the CH gurus. In my case a Win10 update around 10 months fixed it. I have not seen greyed out CH manager buttons since then.

 

So all I can suggest is make sure your Win 10 install is up to date.

Share this post


Link to post
Share on other sites

The current fix for greyed out CH Control panel is to click the start button and type STORE (yes the Microsoft store) then you will hear the chirp.

 

If you are still having problems then stop Gigabyte's RGB fusion 2 (it somehow interferes with CH products getting loaded for the first time) Once you are up and working you will not need this fix until your next reboot/map load. There may be other RBG software causing the problem too. Just exit those wait for the chirp then restart them.

 

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites
On 9/21/2019 at 5:06 PM, Bert_Foster said:

This issue was really bad around 12 months ago with a number of work arounds posted. The issue it turned out was within Windows 10 itself, as determined by some of the CH gurus. In my case a Win10 update around 10 months fixed it. I have not seen greyed out CH manager buttons since then.

 

So all I can suggest is make sure your Win 10 install is up to date.

This was my experience, also. I've been away from flying a while, just getting back to it, but I haven't had any problems. I also have a brand new installation of WIN10, FWIW. 

 

I hope this issue is resolved for everyone else, also! 

Share this post


Link to post
Share on other sites
Posted (edited)

This issue is back with a vengeance. I restarted more last night than I have in a long time. I came across this solution on Reddit a few minutes ago, so I'm spreading the word:

 

Post 1:

When the buttons grey out, sign out of windows and then sign back in. The devices will reinitialize and Control Manager will be in the mode you had tried to switch to.  I have used this solution, and can confirm it works for me and for a friend.

 

Post 2:

Turn off and Disable the Windows Service called SysMain. That fixes all the issues. It gets reenabled by updates though. 

*Edited for better wording.*

The service has something to do with precaching for the windows metro apps. If the buttons grey out again, just open the Windows Store app. Disabling SysMain completely fixes it.

 

Post 3:

Killing the Microsoft Store process in the task manager literally fixed every single problem I've had with Control Manager in Windows 10.

 

 

Edited by Eclipse4349
updated - solution 1 confirmed
  • Upvote 1

Share this post


Link to post
Share on other sites
On 9/23/2019 at 11:14 AM, Comrad64 said:

The current fix for greyed out CH Control panel is to click the start button and type STORE (yes the Microsoft store) then you will hear the chirp.

 

Typing STORE at the start button fixed the grayed-out panel for me as well. Glad there's an easy way out of that. I had been unplugging all my CH devices, restarting, and plugging them all back in again, which usually worked for me. A hassle to do though. Thanks for posting this solution.

  • Upvote 1

Share this post


Link to post
Share on other sites

 

 

 

 

I am only after the ability of the throttle to (upon a button press) supplying a 'ctrl key press'  in the stream (as if from the keyboard IO.)

There has to be a way to program this without ch manager.

 

 

Share this post


Link to post
Share on other sites
2 hours ago, AKA_TG- said:

There has to be a way to program this without ch manager.

 

Joystick Gremlin?

Edited by Sokol1

Share this post


Link to post
Share on other sites

Looks like a good lead Sokol1

Thanks!

 

Share this post


Link to post
Share on other sites
On 9/23/2019 at 11:14 AM, Comrad64 said:

The current fix for greyed out CH Control panel is to click the start button and type STORE (yes the Microsoft store) then you will hear the chirp.

Holy **** where did you find that??  It worked... I didn't even have to log out.  Thanks!

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...