Jump to content
Spirit_Wars

Second Throttle and Rudder pedals not responding

Recommended Posts

Hi there,

 

I have a microsoft ffb2 joystick, Warthog throttle, CH throttle quadrant and CH rudder pedals.

 

In other games, all of these devices work perfectly but as soon as I jump on BOS, neither of my CH products work in game...

 

They work in the CH manager and in the game's key binding, I can set them to bindings, but as soon as I try change the curve graph or play in game, they don't respond.

 

Can anyone help please

Share this post


Link to post
Share on other sites

Hi Spirit. just a suggestion . Don't run CH Manager or exit it if you have enabled on start-up. Go to windows Control Panel and verify they are all working. If so, test them in BOS... It may be a CH Manager or a USB assignment issue !

Hope that helps mate ! ~S~

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Spirit. just a suggestion . Don't run CH Manager or exit it if you have enabled on start-up. Go to windows Control Panel and verify they are all working. If so, test them in BOS... It may be a CH Manager or a USB assignment issue !

Hope that helps mate ! ~S~

 

Thanks mate, i'll try this out and let you know

Share this post


Link to post
Share on other sites

Hi Spirit. just a suggestion . Don't run CH Manager or exit it if you have enabled on start-up. Go to windows Control Panel and verify they are all working. If so, test them in BOS... It may be a CH Manager or a USB assignment issue !

Hope that helps mate ! ~S~

 

 

So I ran BOS without CH manager running and it still didn't work. I went into device manager and it says that both devices are working. I tried running BOS as admin but no change... I tried checking the game integrity but nothing.

 

I'm not sure what to do

Share this post


Link to post
Share on other sites

Hello,

 

Have you checked in settings if the numbers assigned are not changed ?

 

Have fun

Share this post


Link to post
Share on other sites

Hello,

 

Have you checked in settings if the numbers assigned are not changed ?

 

Have fun

 

 

Can you explain more?

 

The problem i'm having is that the game is registering that the controler is there by when I hit a button or use an axis during key binding, but when I check the axis curve graph next to the bind, it doesn't pick up any movement for those two devices. Where as it picks up the input changes in the curve graph with my joystick and Warthog throttle.

 

So somewhere between the game realising that a button or axis from those two CH devices are being used and then not actually working in the game or axis graph... is my problem. I don't think the device number assigned to them is changing. It's joystick 11 for my rudder pedals and joystick 10 for my CH throttle quadrant. Joystick 6 is my Warthog Throttle and Joystick 7 is my ffb2 joystick.

 

why are the joystick numbers so high when I only have 4 devices plugged in?

Share this post


Link to post
Share on other sites

Is there a way to reset the game files so that it reassigns the numbers of the devices?

 

When I try reset to default, it says there is a joystick 0 bound to a few keys, but that isn't any of my current device numbers... when I first set up my keys in BOS I was using a Saitek x55 HOTAS, could it still be registering them and throwing off everything else?

Share this post


Link to post
Share on other sites

Yes you can delete the following file DEVICES.TXT (with the game closed)
Located in folder IL-2 Sturmovik Battle of Moscow\data\input

Move or delete this file and rerun the game it will make a new file with clean and correct assignments,
Then Redo all your keybindings to right sticks and things.
Then leave them plugged into pc when not playing IL2.
If you must remove them replace in same order and same USB ports Before starting IL2 again.



 

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi,

 

I'm not 100% sure, but I once read that under Windows 10 (assuming you are running Win10) sometimes those input device ID numbers get

messed up. My advise would be to backup your input config file in the BOS directory and then delete it. So you can start from new and check

your devices, if they are working or not in BOS. (\IL-2 Sturmovik Battle of Stalingrad\data\input\devices.cfg)

 

There is also an utility to check and display the input device ID numbers under Win10 - but actually don't remember how it's called. Anyway,

with this tool you can check the ID numbers running under Win10. Compare those ID numbers with the ID numbers listed in key mapping

in BOS.

 

Cheers

 

PS: The devices.cfg looks like this when opened in editor (Notepad)

 

configId,guid,model|

0,%223a233d00-a28a-11e1-0000545345440380%22,SideWinder%20Precision%202%20Joystick|

1,%22cd3bc820-7cff-11e5-0000545345440380%22,Thrustmaster%20Virtual%20Game%20Controller%20(root)|

2,%223a22eee0-a28a-11e1-0000545345440180%22,Microsoft%20SideWinder%20Precision%20Pro%20(USB)|

3,%223a2315f0-a28a-11e1-0000545345440280%22,SideWinder%20Force%20Feedback%202%20Joystick|

4,%224509bd60-b9cc-11e3-0000545345440180%22,Saitek%20Pro%20Flight%20Quadrant|

5,%22fdc97740-b9cd-11e3-0000545345440280%22,Saitek%20Pro%20Flight%20Quadrant|

6,%22a00b1390-5ecb-11e4-0000545345440280%22,MFG%20Crosswind%20Rudder%20Pedals

Edited by Therion

Share this post


Link to post
Share on other sites

Yes you can delete the following file DEVICES.TXT (with the game closed)

Located in folder IL-2 Sturmovik Battle of Moscow\data\input

 

Move or delete this file and rerun the game it will make a new file with clean and correct assignments,

Then Redo all your keybindings to right sticks and things.

Then leave them plugged into pc when not playing IL2.

If you must remove them replace in same order and same USB ports Before starting IL2 again.

 

 

 

I managed to find this by my self and delete it. Now it all seems to be working great!

 

Thank you very much to everyone for the help

Share this post


Link to post
Share on other sites
On 11/15/2017 at 4:27 PM, =TBAS=Sshadow14 said:

Yes you can delete the following file DEVICES.TXT (with the game closed)
Located in folder IL-2 Sturmovik Battle of Moscow\data\input

Move or delete this file and rerun the game it will make a new file with clean and correct assignments,
Then Redo all your keybindings to right sticks and things.
Then leave them plugged into pc when not playing IL2.
If you must remove them replace in same order and same USB ports Before starting IL2 again.



 

 

 

Thank you, this solved a problem for me. 

  • Thanks 1

Share this post


Link to post
Share on other sites

ya gotta go Left shift + N & Left shift + M to cancel auto Propeller Pitch & Mixture Controls and then ya havta be flying a plane that utilises Propeller Pitch & Mixture Control to test that they are working.

Share this post


Link to post
Share on other sites

Hi there.

I had this same problem. It occurred after I had reinstalled windows 10.

I had my game on a second hard drive so I did not have to re-install it. However when I went to play the game, all my controllers were not recognized by the game.

I went into:

 

D:\IL-2 Sturmovik Great Battles\data\input

 

Inside the input folder is a file called "devices"

 

I opened that and saw that all my input devices were doubled, like this:

 

configId,guid,model|
0,%221a238430-e3ae-11e8-0000545345440680%22,Joystick%20-%20HOTAS%20Warthog|
1,%221a25f530-e3ae-11e8-0000545345440f80%22,Throttle%20-%20HOTAS%20Warthog|
2,%221a25f530-e3ae-11e8-0000545345441080%22,Logitech%20Extreme%203D|
3,%221a25f530-e3ae-11e8-0000545345441180%22,Mad%20Catz%20Pro%20Flight%20Combat%20Rudder%20Pedals|
4,%223ed907b0-f27b-11e8-0000545345440680%22,Joystick%20-%20HOTAS%20Warthog|
5,%223ed907b0-f27b-11e8-0000545345440f80%22,Throttle%20-%20HOTAS%20Warthog|
6,%223ed907b0-f27b-11e8-0000545345441080%22,Logitech%20Extreme%203D%20Pro%20USB|
7,%223ed907b0-f27b-11e8-0000545345441180%22,Mad%20Catz%20Pro%20Flight%20Combat%20Rudder%20Pedals
 
I remembered from when I was setting key bindings that my stick was device 0 and throttle was 1, so I deleted all the lines below my devices that were repeated, to get this:
 
configId,guid,model|
0,%221a238430-e3ae-11e8-0000545345440680%22,Joystick%20-%20HOTAS%20Warthog|
1,%221a25f530-e3ae-11e8-0000545345440f80%22,Throttle%20-%20HOTAS%20Warthog|
2,%221a25f530-e3ae-11e8-0000545345441080%22,Logitech%20Extreme%203D|
3,%221a25f530-e3ae-11e8-0000545345441180%22,Mad%20Catz%20Pro%20Flight%20Combat%20Rudder%20Pedals|
 
When I restarted the game I got a message I had never seen before. said something like, "New input devices detected, to use key bindings from an old device to use with the new device, select and proceed" I highlighted each one by one and clicked proceed and when the game started, all inputs were recognized and all bindings/mapping was not changed.
 
Hope this can help someone else. No re-mapping keys or re-installing anything.
 
 
 
 

Share this post


Link to post
Share on other sites

My G940 logitech controls don't work properly, On IL2. The elevator and ailerons work fine but the pedals work the throttle????? HELP!!!!

Share this post


Link to post
Share on other sites
On 6/23/2019 at 7:43 PM, blastersurveyorsaint said:

 The elevator and ailerons work fine but the pedals work the throttle????? HELP!!!!

 

Reassign the axes.

Share this post


Link to post
Share on other sites

Delete the file (Devices.txt), open the game, go to Keybinds and assign pedal axes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...