Jump to content
KAFKegetys

OpenVR with Vive not rendering to the full display area

Recommended Posts

Using the OpenVR implementation with the Vive I seem to be having some problem where the game is not rendered to the full area of the headset display. On the right eye the left side of the image is black, and on the left eye the right side of the image is black resulting in rather distracting black bars to be visible in the peripheral vision. This is very visible when using the 6mm foam padding (or removing the padding entirely) for a bit of extra fov although I can just about see it even with the stock vive foam.

 

I can see the problem clearly when I enable the headset mirror from SteamVR:

bos_mirror1.jpg

 

As you can see in that image there is a black rectangle to the left (this is the right eye image) and this is what I see in my pheripheral vision. I tried adjusting some video options, resolution, etc. but its always there both in-game and in the menus.

 

If I open the SteamVR menu on top of the game it is properly rendered on that area so it appears to be something wrong with how the game renders the VR view: screenshot

 

Maybe the game is trying to render the SteamVR hidden area mask (GetHiddenAreaMesh in SteamVR API) but it goes somehow wrong? A screenshot from The Lab shows how that mask is really supposed to look like on the Vive: screenshot

 

Repro steps:

- Run the game in VR mode with the Vive

- From the SteamVR window menu open Headset Mirror window

- Observe black bar to the side (you may need to resize the window to see it properly, alternatively from the menu enable "both eyes" and you can see it in the middle)

- Compare to other SteamVR apps such as SteamVR home, the black bars should not be there

 

This is with IL2BOS version 2.010, SteamVR version 1497390325.

i7 6700K, GeForce GTX 1080, 32GB RAM, Windows 7, HTC Vive.

  • Upvote 2

Share this post


Link to post
Share on other sites

Hello,

 

i bought the game today and i notice that immediately, not happening with any other game i tried, including other simulators. Hope theres a solution for this becasue its hard to me to play like this.

Edited by dblue_one

Share this post


Link to post
Share on other sites

I have the exact same issue as OP and with IL2 only.

 

BOS V2.012d, SteamVR 1512445023, Windows 10 1607, 1080 Ti 388.71. My startup.cfg reads this:

 

    or_enable = 1
    or_height = 3098
    or_hud_rad = 1.50000
    or_hud_size = 0.75000
    or_ipd = 0.06510
    or_width = 2300

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...