Jump to content
dburne

How to prevent Oculus Home from starting with Steam VR games

Recommended Posts

Hey gang,

 

So as we Rift users know, for playing BoS or any Steam VR game , Oculus Home will also launch automatically when putting the headset on and then we launch the game with Steam VR, resulting in having the overhead of both Oculus Home and Steam VR running.

 

There is a way to prevent Oculus Home from running for when we choose to run our Steam VR games. Credit to this thread over on the Oculus Forums, where it has been tried and tested.

https://forums.oculus.com/community/discussion/53317/how-to-prevent-home-from-starting-when-playing-steam-games#latest

 

Basically just set the OculusClient.exe to " Run as Administrator". Right click the OculusClient.exe, choose properties, and put a checkmark in the " run this program as administrator" box and apply.

 

I did a quick check, and now putting on the headset the Oculus Home Client does not start automatically. Launch BoS and Steam VR starts and I am in the game very quickly. Have not had a chance to do any real comparisons on any possible performance difference without having Oculus Home running, but I would have to think with it being a little leaner without it running it certainly can not hurt and reduces some overhead.

 

When Oculus Home is needed, just launch Oculus Home manually  and click yes when getting the prompt to run as administrator.

Now us Rift users can run BoS through the required Steam VR without having the extra layer of Oculus Home running in the background.

Edited by dburne
  • Like 1
  • Upvote 3

Share this post


Link to post
Share on other sites

Thanks for the tip, Don! Even if there is no overhead savings, the savings in annoyance is worth it!

Share this post


Link to post
Share on other sites

Thanks for the tip, Don! Even if there is no overhead savings, the savings in annoyance is worth it!

 

 

Thanks!

 

:good: 

 

Glad to help!

It is working quite well like that for me, I much prefer having it this way. 

Share this post


Link to post
Share on other sites

Edited:

 

Good trick. Then enable SS in SteamVR.

 

 

Btw, I got used to playing with ASW.

 

When before using ASW the PC could not hold 90fps on the GTX1080 on balanced graphics / no AA / landscape 2x / SS 2.2,

 

now it can hold fluent gameplay on Ultra graphics / no AA / landscape 3x / SS 2.2

Edited by 1CAG_Fenris_Wolf

Share this post


Link to post
Share on other sites

Thanks this worked for me with the VIve, I have the Oculus software installed so i can use Revive, it was annoying me that it opened when I launched BOS.

 

Cheers

Share this post


Link to post
Share on other sites

Thanks Don for giving us this useful trick.

 

I have been doing a series of testing with the Balapan track in VR with the Oculus Home ON and OFF, and apparently it doesn´t affect the fps performance in a measurable way. (I say that because running repeteadly the Balapan track in VR without touching anything in the settings or rig produce slightly different averages (+-1fps).

 

In any case, I prefer to have the Oculus Home OFF and switch OFF the ASW with Ctrl+NumPad1.

 

Currently I have supersampling to 1.0, so no need for OTT. I will experiment with SS in the SteamVR

Share this post


Link to post
Share on other sites

Sorry to resurrect this thread, but this no longer seems to work?

 

Can anyone else confirm?

Share this post


Link to post
Share on other sites
1 hour ago, OrLoK said:

Sorry to resurrect this thread, but this no longer seems to work?

 

Can anyone else confirm?

Was playing today and it still works for me. SteamVR  launches on game start but not oculus home.

Share this post


Link to post
Share on other sites

Orlok,

It does work. Dburne wrote "oculusclient.exe" in the instructions. But all it takes is setting your desktop il2 icon (the shortcut itself, not actual exe file) to administrator only and oculus home won't launch unless you want it to.

Edited by a_radek

Share this post


Link to post
Share on other sites

Odd. Won't work for me anymore.

 

I can stop it from launching but can't get any image to my Rift if I don't.

 

Used to use this method just fine...

Share this post


Link to post
Share on other sites

Assuming you have windows 10, do the following to keep it from auto launching:

 

1) Right click desktop icon

2) Click properties

3) click shortcut tab

4) click advanced

5) check "Run as administrator"

6) save/apply changes and exit all those windows

Share this post


Link to post
Share on other sites

Yes.

 

That's what I *used* to do.

 

I can stop it launching but then il2 won't appear in the rift.

 

Once it did for a second and then went blank.

 

 

Share this post


Link to post
Share on other sites

Well, first load up SteamVR and check if that works. Sometimes it needs to get started twice. (turn on turn off turn on)  

 

 

Once that works, go start IL-2. For me that's how I do it. Make sure to check via your OTT beforehand that the OVRserver is running.

Share this post


Link to post
Share on other sites

I have had same issue with nothing displaying in the head set if Oculus is not launched. i use DK2, it was working in random ways up untill today and now its always overlaying in game screen if its open and black headset if its not open :(

very frustrating. Any tips welcome

 

 

Share this post


Link to post
Share on other sites

With the latest version of the software - Rift Core 2.0 ( 1.31), you will not get a display in headset unless the software is running.

It fades out to a gray screen when you launch a game, and the Home environment comes back  in when the game is exited.

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, dburne said:

With the latest version of the software - Rift Core 2.0 ( 1.31), you will not get a display in headset unless the software is running.

It fades out to a gray screen when you launch a game, and the Home environment comes back  in when the game is exited.

 

StreamVR appears when I exit the game despite starting it in Oculus Home. I HATE the new Oculus software. They've made things much worse by allegedly releasing an improved version!

Share this post


Link to post
Share on other sites
2 minutes ago, Lensman said:

 

StreamVR appears when I exit the game despite starting it in Oculus Home. I HATE the new Oculus software. They've made things much worse by allegedly releasing an improved version!

 

Yeah I was talking in general terms ( IL-2 is the only game I have that requires Steam VR).

When I exit IL-2 it has always dropped me to a Steam VR screen. I just close it and am back in Oculus Home.

Share this post


Link to post
Share on other sites
48 minutes ago, dburne said:

 

Yeah I was talking in general terms ( IL-2 is the only game I have that requires Steam VR).

When I exit IL-2 it has always dropped me to a Steam VR screen. I just close it and am back in Oculus Home.

I do the same thing including closing the IL2 icon at the bottom of my screen and have never had a problem.

Next time up, I can either start directly with the IL2 desktop symbol or Oculus home and go to previous history and click on IL2 or DCS or FS2.

Both procedures work very well and absolutely no problems.

 

Share this post


Link to post
Share on other sites

unfortunately for me using the DK2 and no controllers for Oculus, I can not play il2 as the oculus dash board will al;ways render over top of the game and if I cant seem to find a way to prevent it :(

any step by step solutions would be welcome 

cheers

Share this post


Link to post
Share on other sites

Bare with me, macro1 -- I don't have a technical solution, but...

 

Until recently, I'd just double-click the Il-2 icon from the desktop and the whole mess would load (Oculus, SteamVR and then Il-2). A week or so ago, I started getting the same result you report: The Oculus dashboard would render over the Il-2 screen making the game unplayable.

 

To get around this, I started Oculus (separately) with the start menu. Then I'd load IL-2 -- seems to work properly now.

 

Best of luck.

Share this post


Link to post
Share on other sites
On 10/17/2018 at 7:49 AM, Lensman said:

 

StreamVR appears when I exit the game despite starting it in Oculus Home. I HATE the new Oculus software. They've made things much worse by allegedly releasing an improved version!

 

I set the CPU affinity for the home exe proceses to my last 4 cores so that they don't interfere with Steam VR and IL-2. 

Share this post


Link to post
Share on other sites
9 hours ago, BlackMambaMowTin said:

 

I set the CPU affinity for the home exe proceses to my last 4 cores so that they don't interfere with Steam VR and IL-2. 

 

A nice trick if you have more than 4 cores!  🙈

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...