Jump to content
richtervonboyce

PERFORMANCE ISSUES and frame rate issues.

Recommended Posts

Hello! well first off I have come across a issue where the game is GPU intensive while in menu and not in the actual gameplay. This leads to frame rate being just fine to actual freezes as if its taking time to load something. Other issues are the trees in the summer and autumn maps that seem to have constantly change color patterns. Flashing plane skins, flashing ground, smoke that constantly travels over the front windscreen of the fw 190. These are things I've seen mentioned but not talked about in great detail and nothing has come out about it in the new update. Anyone know what's up?           My computer specs are : windows 7 , R9 290x , fx 8core 4.0 ghz , 16 gigs of ram.                                                                                                                                                                                                                                                                                                                                                           

  • Upvote 1

Share this post


Link to post
Share on other sites

Since last update, I also have issues, that I din't have before, I have the impreesion that I have lower fps, but I didn't change anything ! :(

 

So now I'm trying to fix this, but everything was fine before the update

Share this post


Link to post
Share on other sites

Same here, stutterings, very big FPS drop and Track IR lacked fluidity ... flying is painful

 

No problem before update 1.105

(Windows 7 SP1 64 Bits, i7-3770 @ 3.90GHz, 32 Go Ram, GeForce GTX 680)

Share this post


Link to post
Share on other sites

Same here, stutterings, very big FPS drop and Track IR lacked fluidity ... flying is painful

 

No problem before update 1.105

(Windows 7 SP1 64 Bits, i7-3770 @ 3.90GHz, 32 Go Ram, GeForce GTX 680)

+1

 

Win 10, i7 2600, 8RAm, GTX 780 Ti

 

:(

Share this post


Link to post
Share on other sites

Yesterday I started up the game again for the first time since a couple of weeks (I only flew once since the summer map was made available) and noticed a lot of drops in performance too. Never had that before.

 

Specs: win10 i5 2500k, HD7970, 8G, SSD

Share this post


Link to post
Share on other sites

Yes same here.

 

Got frame drops every 2 seconds which leads to stuttering. It drops from 60 to 52-ish all the time when plaing multiplayer with a friend. No such thing when playing single player.

Share this post


Link to post
Share on other sites

I've had two crashes to the blue screen of death.  I dropped the video down to low and that seems to have taken care of it.  Both crashes happened while I was tanking. 

Share this post


Link to post
Share on other sites

After update, getting stuttering all around , especially when turning head with Trir. Same settings latest drivers not a change before and after update.

 

Win7 64 Home, i7 4790k, 8GB Ram, 980 Gtx

Share this post


Link to post
Share on other sites

In the past reinstalling dx9 after an update fixed the performance issues for some people.

  • Upvote 1

Share this post


Link to post
Share on other sites

In the following folder you can find the dxsetup file:

 

IL-2 Sturmovik Battle of Stalingrad\data\updater\3rd_party\dx

 

But I don't know if this folder also exists in the Steam version.

  • Upvote 1

Share this post


Link to post
Share on other sites

I have the same problem, stuttering and falling much larger FPS really, what worst Stuttering, which together with the TrackIR is not fluid, bad overall performance I notice.

 

Before Update 1.105, I do not have these problems now many same parameters and performance issues.

 

PC

 

Windows 7 SP1 x64

16Gb DD3 1600 CL9

Fx 3850 8Cores 4.0Ghz

SSD x2 120Gb

Asus GTX 680 DirCu II TOP 2GB

 

I do not know what I have to do

 

Today reinstall DirectX for Folder 3rd_Party. and Repair VcRedis

Share this post


Link to post
Share on other sites

Same here. Microstuttering every 2-3 seconds, with TrackIR, mostly in MP. Overall FPS is decent but the stutters make the movements look jerky, not fluid.

I tried to record it and make a video, but on the track it's not as pronounced as it was in MP when I recorded.

 

i7-920 at 3.2 GHz, 6 G RAM and GTX470 1.2 GB here. High settings, HDR off, SSAO on.  I did not have this problem before.

 

In game it's a lot worse:

 

https://youtu.be/7Xh3SYyP800

  • Upvote 1

Share this post


Link to post
Share on other sites

High performance loss since the update (in average 10FPS).

 

High settings preset, Landscape Detail 4x, HDR On, SSAO off.

 

On ground: -  on servers with medium detailed airfields and 3+ players on the field FPS range from 18-24 (before: 32-39)

 

In air: - at medium altitudes (1000-2000m) FPS are 42-45 (before 50-60)

         -  at high altitudes (3000-5000m)  FPS range from 50-75 (before 60-80)

 

Tanks are nearly unplayable since after a short time FPS instantly drop from 35-32 to 22-15 within the first 5 min of gameplay.

 

I will try reinstalling Direct x9 as proposed.

 

System: MSI GeForce GTX970, Intel I-5 4570 3,2Ghz, 16Gb Ram 1333Mhz, Gigabyte Z87 mainboard

Share this post


Link to post
Share on other sites

+1

 

Windows 7 SP1 64 Bits,SSD, i7-2600K @ 4.60GHz, 8 Go Ram, GeForce GTX780 Lighting@1,25GHz

Share this post


Link to post
Share on other sites

Well I reinstalled the direct x and there was very little improvement. But hey take what you can get right.  

+1 No improvement for me

High performance loss since the update (in average 10FPS).

 

High settings preset, Landscape Detail 4x, HDR On, SSAO off.

 

On ground: -  on servers with medium detailed airfields and 3+ players on the field FPS range from 18-24 (before: 32-39)

 

In air: - at medium altitudes (1000-2000m) FPS are 42-45 (before 50-60)

         -  at high altitudes (3000-5000m)  FPS range from 50-75 (before 60-80)

 

Tanks are nearly unplayable since after a short time FPS instantly drop from 35-32 to 22-15 within the first 5 min of gameplay.

 

I will try reinstalling Direct x9 as proposed.

 

System: MSI GeForce GTX970, Intel I-5 4570 3,2Ghz, 16Gb Ram 1333Mhz, Gigabyte Z87 mainboard

same range of loss of FPS, Only last update 1.105

Share this post


Link to post
Share on other sites

I'm also noticing issues. I had hi-quality texture settings in NVIDIA inspector in 1.104 (2x sparse supersampling), now I've changed it to no supersampling, and also lowered texture filtering to prioritize performance over quality. No luck. I'm observing low FPS and low GPU usage at the same time, which would indicate I'm bound by CPU.

 

I don't know why, but when there are tanks and other vehicles visible, even if they are so far they are drawn as a few pixels, frame rates drop as low as 30 from 45-to 60 (45 when turning the head and looking at some portion of landscape I was not looking at before, 55 to 60 when looking at "known" landscape).

 

This is not a new problem, it's always been like that for me, all the way back to BOS EA. It got noticeably worse now in 1.105. I don't understand why rendering a tank or a plane as a 10-pixel rectangle requires an extra 25% CPU. When I switched from a core i7 960 to a core i5 4690K the problem became less painful, but it did not disappear.

Edited by coconut

Share this post


Link to post
Share on other sites

 

On ground: -  on servers with medium detailed airfields and 3+ players on the field FPS range from 18-24 (before: 32-39)

 

In air: - at medium altitudes (1000-2000m) FPS are 42-45 (before 50-60)

         -  at high altitudes (3000-5000m)  FPS range from 50-75 (before 60-80)

 

 

 

 

Same pronblem here.

 

I was very happy in the 1.104 when the performance got better....now is worse...i hope that you'll watch to that issue

 

thx dev

Edited by E69_Marq

Share this post


Link to post
Share on other sites

hello all

 

This is my PC :

 I7  4790K -

8GB Ram 

Gigabyte 970 G 1 

 

I have also fallen to me FPS  and especially Ihave noted stuttering 

 

THX

 

 

regards .....

Share this post


Link to post
Share on other sites

some of my 71st brethren have found that running with;

 

my setting in the NVIDIA control panel 3D program Settings make a profile for BOS. exe

 

if you don't have NVIDIA and your on a AMD ATI card try setting the threaded optimization to off.

 

 

 

 

 

if this does not work for you, more than likely you may not meet the minimums for this game.   well I'll strike this out,

 

 it could be a number of issues SSD transfer ratio to ram to to read write speeds, number of thing could cause video stutters, even recently I had issues with micro stutters in CLOD and it was NVIDIA's Drivers only 

 

it took BF4's microstutters to fix this (CLOD) game.

 

its really suxs your GPU 100%.

 

and the guys with blue screens is usually a hardware conflict, and or not enough RAM.

Edited by 71st_Mastiff
  • Upvote 1

Share this post


Link to post
Share on other sites

I'm also noticing issues. I had hi-quality texture settings in NVIDIA inspector in 1.104 (2x sparse supersampling), now I've changed it to no supersampling, and also lowered texture filtering to prioritize performance over quality. No luck. I'm observing low FPS and low GPU usage at the same time, which would indicate I'm bound by CPU.

 

I don't know why, but when there are tanks and other vehicles visible, even if they are so far they are drawn as a few pixels, frame rates drop as low as 30 from 45-to 60 (45 when turning the head and looking at some portion of landscape I was not looking at before, 55 to 60 when looking at "known" landscape).

 

This is not a new problem, it's always been like that for me, all the way back to BOS EA. It got noticeably worse now in 1.105. I don't understand why rendering a tank or a plane as a 10-pixel rectangle requires an extra 25% CPU. When I switched from a core i7 960 to a core i5 4690K the problem became less painful, but it did not disappear.

Yup. The new single player missions play at 25-30fps . Even since the beginning I have silently grumbled every time i look at a he111 on the screen, just looking at it causes my frames to fall by half, from 60 to 30. Not even going to mention what happens trying to shoot it down. Its a real head scratcher. Why would looking at it cause so much damage to my frame rate? I've heard it the AI sitting inside, but it's just nuts and almost not worth it.

Share this post


Link to post
Share on other sites

I don't agree with that, im more then positive, that most us who have valid complaints have riggs that are capable enough to run this sim. If your trying to say that we have get some insane rigg to run this sim then that's just BS. I can run rise of flight at max everything and war thunder at max. These games are demanding but guess what no issues so there something else going on that needs to be addressed. Plus the people with medium to high range riggs are the main customers of the pc game world. Most people cant put 4000 plus into a computer! Most people can do like 1200. What we need is the advanced graphics setting options back just like rise of flight. SYSTEM SPECS windows 7 64 bit, Radeon r9 290x 4gigram, fx 8 core processor 4.0ghz , 16 gigs of ram.

Share this post


Link to post
Share on other sites

There is obviously a change in performance since 1.105 compared to 1.104

 

BUT

 

I didn't have enough time to test tonight on WoL (where I met Mastif ... lol hello there  !!!) but will do extensive test on Nvidia and network settings he provided tomorrow.

 

This could be a good temporary solution in the meantime, waiting for the 1.105 stutterings to be fixed (because they remain anyway for sure). Will test performances on a track between 1.04 & 1.105 tomorrow.

 

By for now

Share this post


Link to post
Share on other sites

also try implementing FPS limiters, in the game it self.

 

 

Hi

 

that you have not done but with this latest update is very wrong, even the TrackIR goes wrong, beaten ,stumbling
  .... before it was all more fluid, ........
You tell me that machine takes to move the game, I am very disappointed with your answers .... so it is going
 
 

 I7  4790K -

asus Z97 A

8GB Ram 

Gigabyte 970 G 1 

Edited by E69_antiguo
  • Upvote 1

Share this post


Link to post
Share on other sites

Antigo, I agree with you.

I also noticed the same problem for the trackIR (see in a previous message)  

 

Same here, stutterings, very big FPS drop and Track IR lacked fluidity ... flying is painful

 

No problem before update 1.105

(Windows 7 SP1 64 Bits, i7-3770 @ 3.90GHz, 32 Go Ram, GeForce GTX 680)

 

But you should not blame mastiff who's the only guy that try to help us. 

 

As a tester, i'm not sure he is authorized to admit here that there is a performance leak since 1.105, so maybe you don't like his answer, but he tries to help by providing lower Nvidia setting to lighten the memory stress caused by the 1.105.  

 

From a personal point of view I'm considering his advises just as a turnaround until the "guilty" 1.105 code will be fixed (in the near future I hope). Of course you don't want to lower our setting just because there is a regression in the code and on this point I'm aligned with you mate. If I had a GTX 970 like you I would like to take advantage of it's huge power, and I would refuse to tune down my setting from Normal to Ugly.

Edited by MadisonV44

Share this post


Link to post
Share on other sites

Antigo, I agree with you.

I also noticed the same problem for the trackIR (see in a previous message)  

 

 

But you should not blame mastiff who's the only guy that try to help us. 

 

As a tester, i'm not sure he is authorized to admit here that there is a performance leak since 1.105, so maybe you don't like his answer, but he tries to help by providing lower Nvidia setting to lighten the memory stress caused by the 1.105.  

 

From a personal point of view I'm considering his advises just as a turnaround until the "guilty" 1.105 code will be fixed (in the near future I hope). Of course you don't want to lower our setting just because there is a regression in the code and on this point I'm aligned with you mate. If I had a GTX 970 like you I would like to take advantage of it's huge power, and I would refuse to tune down my setting from Normal to Ugly.

I also have the stuttering also.  Asus 970.  You will find they never comment on things they don't know how to fix.  ie

 

hit sounds

trim on axis

invisible planes

random game crashes

 

They usually don't even acknowledge these problems.  They count on their mighty forum defenders to say the problem is on our end.   ;)  :biggrin:

 

Sarcasm.  But there is always a little truth in every sarcastic remark.    :P

Share this post


Link to post
Share on other sites

I don't agree with that, im more then positive, that most us who have valid complaints have riggs that are capable enough to run this sim. If your trying to say that we have get some insane rigg to run this sim then that's just BS. I can run rise of flight at max everything and war thunder at max. These games are demanding but guess what no issues so there something else going on that needs to be addressed. Plus the people with medium to high range riggs are the main customers of the pc game world. Most people cant put 4000 plus into a computer! Most people can do like 1200. What we need is the advanced graphics setting options back just like rise of flight. SYSTEM SPECS windows 7 64 bit, Radeon r9 290x 4gigram, fx 8 core processor 4.0ghz , 16 gigs of ram.

I Didn't mean the game is not worth it. Just the He111 in particular. Doesn't matter what rig you get, you will get same issue. Star citizen gives a nice diagram on parallel calculations regarding multi core in one of their recent monthly updates. 8ms delay for single core process is reduced to 2ms on 4 core unit. It looks nice in theory. Best work around is to buy monitor with gsync to aleviate the sputtering of frame rates.

Edited by roaming_gnome

Share this post


Link to post
Share on other sites

I also have the stuttering also.  Asus 970.  You will find they never comment on things they don't know how to fix.  ie

 

hit sounds

trim on axis

invisible planes

random game crashes

 

They usually don't even acknowledge these problems.  They count on their mighty forum defenders to say the problem is on our end.   ;)  :biggrin:

 

Sarcasm.  But there is always a little truth in every sarcastic remark.    :P

 

As for invisible planes, a special log to bug track was made and reports asked for when this problem was encountered,

 

Not a good example of dev's ignoring an issue

 

Cheers Dakpilot

Share this post


Link to post
Share on other sites

Guys, we have perhaps a clue in this thread : 

http://forum.il2sturmovik.com/topic/19556-memory-could-not-be-read/

 

Graphic memory seems to be a very important thing. So when you are experiencing problems please share the graphic memory your graphic card has. Also, if possible try to run GPU-Z when running the game to see how the memory is used.

 

According to my tests, they lack some flush after they do a malloc. After a crash I have 90Mo of vram still used, after a proper exit, I have 278Mo... Same thing with the hangar, when first in the hangar it take 500Mo, after flying over stalingrad hangar takes 1010Mo!

I have a 560 with 1Go RAM, with VRAM so poorly managed those stuttering (miss in the VRAM) and crashes (bad address in the VRAM) are very likely to happen.

 

Cheers!

Share this post


Link to post
Share on other sites

Yup. The new single player missions play at 25-30fps . Even since the beginning I have silently grumbled every time i look at a he111 on the screen, just looking at it causes my frames to fall by half, from 60 to 30. Not even going to mention what happens trying to shoot it down. Its a real head scratcher. Why would looking at it cause so much damage to my frame rate? I've heard it the AI sitting inside, but it's just nuts and almost not worth it.

 

Right. The weird thing is that the slowdowns only happen when you are looking at them. Why on Earth would the AI be more CPU-intensive when you look at it? In MP it makes sense to run physics-based interpolation between position updates sent by the server, especially for planes you are shooting at. Maybe the devs were a bit optimistic in their performance estimations, and they enabled physics-based interpolation for too many vehicles.

 

Maybe SP uses the same client-server code under the hood, and performs unnecessary physics-based interpolation in addition to the full physics simulation it is already doing.

 

Regardless, I think there is a problem with the current development cycle. We are basically on a constant early-access phase because developments for BOM also affect BOS, since they share the same client. That's a nice thing for all the new features that work well, but not so well for regressions, which are impossible to avoid totally. I'm not sure there is an easy solution. The additions we got for BOS were really needed (summer and autumn maps), and I'm overall happy we got them. Probably better than having more stable and smoother winter maps instead.

Share this post


Link to post
Share on other sites

Same here, stutterings, very big FPS drop and Track IR lacked fluidity ... flying is painful

 

No problem before update 1.105

(Windows 7 SP1 64 Bits, i7-3770 @ 3.90GHz, 32 Go Ram, GeForce GTX 680)

 

 

+1

Share this post


Link to post
Share on other sites

if this does not work for you, more than likely you may not meet the minimums for this game.

 

its really suxs your GPU 100%

If a GTX 970 isn't enought you can write the game off right away.

 

Compared to DCS, where I get 140 FPS in the new engine, BoS is terribly underoptimised.

  • Upvote 1

Share this post


Link to post
Share on other sites

Guys, we have perhaps a clue in this thread : 

 

http://forum.il2sturmovik.com/topic/19556-memory-could-not-be-read/

 

Graphic memory seems to be a very important thing. So when you are experiencing problems please share the graphic memory your graphic card has. Also, if possible try to run GPU-Z when running the game to see how the memory is used.

 

According to my tests, they lack some flush after they do a malloc. After a crash I have 90Mo of vram still used, after a proper exit, I have 278Mo... Same thing with the hangar, when first in the hangar it take 500Mo, after flying over stalingrad hangar takes 1010Mo!

 

I have a 560 with 1Go RAM, with VRAM so poorly managed those stuttering (miss in the VRAM) and crashes (bad address in the VRAM) are very likely to happen.

 

Cheers!

It is or is not VRAM,worse if it is that everything works perfect upgrade 1,104, Soft smooth. 1,105 is fatal

Edited by E69_Lothar29

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...