Jump to content
ludo789456123

pertes de framerate au sol et fumées

Recommended Posts

Bonjour, j'ai constaté un probleme en jeu, le jeu tourne très correctement en vol (plus de 50fps) mais lorsque je suis au sol je descend à environ 30 fps. Aucun problème grave apparement mais il se trouve que je jeu subbit des sortes de micro freeze à ce moment là qui rendent le roulage plutôt complexe. Le même problème se produit aussi en vol lorsqu'il y a des fumées au sol (les énormes panaches de fumée) ou alors lorsqu'un avion que je poursuit fume et que je m'en approche trop.

 

Le jeu est en ultra, anticrénelage x4, en 1920*1080 sans V-sync et le problème persiste même si je passe en low sans AA.

 

Ma config :

 

i5 4670K

8Gb de ram

HD7850

Edited by ludo789456123

Share this post


Link to post
Share on other sites

Est ce que tes pilotes de carte graphique sont à jour ?

 

Est ce que tu as fais des modifications dans les pilotes pour BoS ?

Share this post


Link to post
Share on other sites

Oui les pilotes sont à jour et non je n'ai pas fait de moddification pour BoS. C'est assez frustrant d'avoir des super performances en l'air et de pas pouvoir atterrir parce que ça freeze, de plus la plupart des serveur ont quelques nuages/effets de fumée au sol donc difficile de jouer avec des amis ...

Share this post


Link to post
Share on other sites

BoS tourne-t-il bien sur 4 coeurs? J'ai remarqué qu'en forçant BoS sur 2 coeurs via Bill's Process, le framerate s'écroulait.

Share this post


Link to post
Share on other sites

Oui le jeu tourne sur 4 coeurs. J'ai remarqué que j'arrive à améliorer les choses en baissant la résolution (seul parametre que je n'avais pas testé, pensant que ça ne pouvait pas venir de ça) et que il n'y a que en faisant celà que j'arrive à peu près à avoir un framerate correct en toutes circonstances (comprenez sans freeze intempestifs), mais le jeu deviens sacrément moins beau en 1280*720 ... La carte graphique serait-elle trop faible ?

Share this post


Link to post
Share on other sites

BoS tourne-t-il bien sur 4 coeurs? J'ai remarqué qu'en forçant BoS sur 2 coeurs via Bill's Process, le framerate s'écroulait.

Oui, et c'est même indispensable d'avoir un quad coeur.

Share this post


Link to post
Share on other sites

 

 

La carte graphique serait-elle trop faible ?

 

Je ne m'y connais pas trop en cartes graphiques et encore moins en AMD, mais il existe apparemment des HD7850 à 1Go de mémoire. Si c'est le cas, c'est peut-être ta carte en effet.

Share this post


Link to post
Share on other sites

Ca vaut quoi une 7850, car ca fait un moment que j'ai laché l'affaire chez AMD. C'est une vrai carte de jeu, ou une carte juste bonne à faire tourner le démineur de windows, et le vielle IL2 ?

Share this post


Link to post
Share on other sites

C'est bien au dessus de la configuration recommandé : (GPU: 1024 Mb+, GeForce GTX 260+/Radeon HD5850+)

 

 

Processeur graphique AMD Radeon HD 7850

  • Fréquence processeur (Mhz) 860
  • Mémoire vidéo 2 Go
  • Fréquence mémoire vidéo de base (Mhz) 2400
  • Type de mémoire GDDR5
  • Largeur du bus mémoire 256 bits

 

Le reste de la config est au dessus également, le problème doit être ailleurs ?

Edited by H2G-Stoyann

Share this post


Link to post
Share on other sites

Vu la description du problème, c'est lorsque la carte graphique est soumise à de nouvelles infos. A part les pilotes, je ne vois pas. Je viens de regarder, et c'est un vrai carte de jeu. est ce que tous les programmes tiers requis par le jeu sont à jour (même si je ne crois pas à cette piste) ?

Share this post


Link to post
Share on other sites

Tu vas là :

H:\IL-2 Sturmovik Battle of Stalingrad\data\updater\3rd_party

 

Et tu as directX, net frameworks, vcc.

Share this post


Link to post
Share on other sites

J'ai une version steam il m'a donc fait les mises à jour de ces trucs là avant de lancer le jeu la première fois ... Je suis dépité, comment mon PC gallèrerait-il à afficher 2 effets de poussière/fumée/nuage alors qu'il en affiche des milliers à la fois sans aucun probleme dans tous les autres jeux. Le pire c'est que c'est que quand je m'approches desdites fumées, par exemple quand un avion ennemi fume et que je traverse la trainée avec le mien

Share this post


Link to post
Share on other sites

Ce qui est sur, c'est que c'est le cas typique d'un soucis de drivers, qui pédale dans la semoule dès qu'un nouvel effet arrive. Comme j'ai pu le lire, et je ne fais que rapporter, les drivers de l'ATI sont devenus problématique pour la gestion de directX 9. En fait les optimisations ont dégagés, du coup, tu n'as pas de soucis en DX11, mais en DX9, c'est la merde.

Share this post


Link to post
Share on other sites

Oui, trés peu de chance que ça évolue de ce côtés là. Maintenant, il est fort probable que d'un pilote à l'autre ça s'améliore ou se dégrade, mais c'est valable aussi bien pour nvidia que AMD. Il faudrait voir si quelqu'un à une AMD/ATI, et s'il rencontre les même problème, et quel pilote il utilise.

Share this post


Link to post
Share on other sites

J'attends donc que quelqu'un se manifeste ! D'ailleurs j'ai oublié de le mentionner mais même dans le menu j'ai du mal à cliquer sur ce que je veux parce que ça ramme aussi

Share this post


Link to post
Share on other sites

Sur le forum anglophone, certains utilisateurs d'ATI parlent d'activer la vsync. A essayer peut-être...

Share this post


Link to post
Share on other sites

Essaie de faire une exclusion de scan de ton antivirus sur le répertoire de Bos.

Share this post


Link to post
Share on other sites

Je viens de remarquer un truc: avec la mise à jour de ce soir, mon jeu s'est remis en mode fenestré. Au ras du sol, mes fps plafonnaient à 30. Une fois remis en plein écran, j'ai retrouvé mes fps d'origine. C'est peut-être le même problème que tu rencontres...

Share this post


Link to post
Share on other sites

:dash:

 

Boudiou, merci pour cette remarque PA-Sniv!

 Deux semaines (deux semaines!!) que je me demande pourquoi diable mon jeu lagg3e-t-il plus qu'avant... :sleep:  

Share this post


Link to post
Share on other sites

Malheureusement non, ça ne vient pas de là ... Mode fenetré ou pas, je dois jouer dans une résolution dégueulasse pour que ça reste à peu près fluide du coup c'est tout flou et moche. Ca me fait vraiment chier parce que c'est même pas des chutes de framerate, c'est juste des freezes intempestifs qui rendent le truc totalement injouable à l’approche de n'importe quel effet de fumée/poussière/nuage débile et lors d'un passage près du sol. Alors imaginez un décolage où l'on est à la fois près du sol et avec des effets de neige qui vole partout et des nuages au dessus de la tête !

 

Et je refuse de croire que ma carte graphique n'est pas capable de gérer ça, fraps de dit que ça sort du 40 fps dans les conditions cités, c'est donc qu'elle peut le faire alors pourquoi ces freezes à la con qui me pourrissent la vie ... Jouer en 720p sur un 24" c'est vraiment juste horrible, en plus le jeu me met des bandes noires en haut et en bas et étire l'image latéralement (allez savoir pourquoi ...) du coup je dois jouer sur un jeu flou avec une image bizzare et ça ne regle qu'à moitié le problème parce que j'ai certes moins de freezes au sol, mais ça ne veut pas dire qu'il n'y en a plus, de plus si je traverse la fumée d'un avion ennemi endommagé ça ne change rien, les effets sont les mêmes qu'avec une bonne résolution, le problème n'est reglé que pour les nuages en baissant la résolution.

Share this post


Link to post
Share on other sites

bandes noires et image étirée, ça ressemble bien à une résolution qui ne correspond pas avec le ratio de ton écran... Est-ce que la résolution du jeu correspond bien avec la résolution native de ton écran?

Share this post


Link to post
Share on other sites

Ben justement non, si tu lis les messages précédents tu découvriras que plus ma résolution est élevée (= proche de 1920*1080, résolution native), plus j'ai de freezes. je suis donc obligé de jouer avec des résolutions inférieures pour avoir un semblant de fonctionnement correct, sauf que les bandes noires je les ai en 1280*720, un ratio qui est pourtant le même que 1920*1080, or le jeu me met des bandes noires et étire l'image ... Pourquoi ? je ne sais pas ! Car les résolution qui n'ont pas le même ratio sont elles aussi étirées, mais sans bandes noires ... Enfin bref, de toute façon j'imagine que je vais devoir investir dans une Ô combien chère carte graphique vu que rien ne semble vouloir etre amélioré sur ce point. Et je ne cache pas que ça me fait mortellement chier de devoir dépenser 300€ de plus juste pour pouvoir jouer à 1 jeu en particulier ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...