Jump to content
chiliwili69

Items to review if you have low performance in IL-2 VR test

Recommended Posts

If you have run one of this IL2 VR performace tests:

 

 

and you achieve a significanly lower fps than your rig peers, or lower fps than expected (column U), then you should review these checkpoints to try to solve it.
Please, feel free to post any issue you solved or any item that should be included.

 

HARDWARE:
1.- Verify that your single GPU is placed in the best PCIE slot (your Mobo manual should recommend the best slot)
2.- If you use 2x4Gb, 2x8Gb, or 2x16Gb RAM, verify that your two RAM modules are placed in the right slots to use dual channel (tipically slot 1&3 or 2&4, they have same color)
3.- If you have 16Gb RAM, verify that you have 2x8Gb or 4x4Gb RAM modules to benefit from Dual Channel. Same applies for 8 (2x4), 32Gb (2x16, 4x8) etc. Always a pair of RAM sticks.
4.- Run the full Passmark (https://www.passmark.com/products/pt.htm) and UserbenchMark (http://cpu.userbenchmark.com/ ) and compare your percentiles for CPU, RAM, GPU
Verify specially your Passmark CPU Single-Threaded number you achieve.
5.- If your RAM has a slow clock speed your performance will be lower. It should be desirabe to be at or above 2400MHz. (Try to enable your XMP profile in BIOS)
6.- If your CPU is a Ryzen, they are not good for IL-2 VR. They have low performance for single-thread.
7.- If your CPU is i5-4690K, they don´t perform particularly well in IL-2 VR. Based on their PassMark SingleThread, they are below VR expected performance. We don´t know why.
8.- Go into Device Manager and look in the Oculus VR Devices, under it you will see your sensors listed. Set each one to keep from shutting off, by right clicking- click properties-click power management tab. Uncheck "allow the computer to turn off this device to save power", then click apply
9.- Verify in the Windows Task Manager that no other apps or heavy processes are running in the background

 

VR SETTINGs:
1.- Double check that your are using the same settings specified in the VR test and don´t forget to press H to hide the hud.
2.- Verify you only use SuperSampling in one place (for VR test either SteamVR with 1.5 or OculusTrayTool/OculusDebugTool with 1.2)
3.- Verify that you set ASW OFF when running the VR test. See your in-game fps counter pressing Backspace and verify it has values diferent from 45 or 90. Or verify that properller artifacts disappear.
4.- For VR test, be sure to not use any Mod or Reshade code since they affects performance.
5.- Put SS=1 and run the VR test again. If your fps increased considerably, then the fault is in the GPU.
6.- Try to run the test with the monitor. If you have a good fps then the problem is with the Rift/Vive.
7.- Remember to not use "Advanced Supersampling Filtering" settings in SteamVR
8.- Launch the "Oculus Mirror" tool (Located at C:\Program Files\Oculus\Support\oculus-diagnostics) which displays what you actually see in the Rift. You have a number of options (described at https://developer.oculus.com/documentation/pcsdk/latest/concepts/dg-compositor-mirror/ ) but the useful info will tell you the actual horizontal and vertical pixels of the render. Tip: To display this info you have to enable the "Visible HUD: Layer" in the Oculus Debug Tool. This are the numbers that you should have: https://forum.il2sturmovik.com/topic/36160-supersampling-ratios-rift-vs-vivepro-vs-odyssey/

 

GPU SETTINGS:
1.- Update your GPU driver.
2.- In the NVIDIA control panel, set power management for "Maximum performance" for IL-2 application
3.- Monitorize CPU/GPU clock, RAM/VRAM usage, CPU/GPU temps with MSI Afterburner using trendlines and check that they are where they have to be.(not downclocking CPU/GPU)
4.- Be sure your Rift is connected to the GPU HDMI and not the HDMI of the Mobo (Who knows!)
5.- If your GPU is GTX-970 or GTX-1050/1060, they are the limiting factor in the VR test. You will need to decrease SS or use lower graphics settings to play IL-2 VR with good fps.

 

BIOS SETTINGS:
1.- Update your BIOS firmware and Chipset from your Mobo manufacturer.
2.- Remove CPU power limits or CPU amperage limits to avoid CPU throttling.
3.- Try to put AVX offset to 0. Since IL-2 uses AVX instructions this could downclock your CPU a bit.
4.- It depends very much of every Mobo, but just for reference this is my BIOS settings: https://docs.google.com/spreadsheets/d/1zrEWtXGD4d1KMG3v9bGLeyITKJOAzA2Q91ghgCs0NxY

 

Edited by chiliwili69
  • Upvote 2

Share this post


Link to post
Share on other sites

This man cannot be thanked enough for his summaries. Top notch.

 

Absolutely, him, dburne and a couple of others have stopped me selling the bloody thing and starting to really enjoy it.

Share this post


Link to post
Share on other sites
On 2/10/2018 at 5:09 AM, chiliwili69 said:
[...]
2.- Remove CPU power limits or CPU amperage limits to avoid CPU throttling.
[...]

 

I just want to point out that this setting has many different names.  My problem (i5-4670k; GTX 770) came from my MSI motherboard.  A setting called “CPU Phase Control” was the culprit.  It would reduce the power to my cpu when it saw the load lighten from a less intense scene in-game.  This would also cause my gfx cards to reduce output (I don’t know why).  This caused my fps to drop in half or worse.  Then the inverse would happen as the PC sensed the increased demand for power.  

 

Turned off my “CPU Phase Control” and the problem was fixed.  No amount of other settings would cancel out that setting in the BIOS.

 

This seems to be a MSI issue so far as I can tell.

 

sorry for the necro.

Share this post


Link to post
Share on other sites

Don't forget to plug the 1080 Ti into the highest PCI-e slot, some machines have both x4 and x16 slots.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×