Jump to content
Sign in to follow this  
chris455

Request technical guidance- differential braking on German aircraft

Recommended Posts

Hello Gents,

Although I made some cursory searches both here and elswhere, I came up empty-handed. Maybe someone here can solve a puzzle for me.

 

I have a set of Saitek  Pro Combat rudder pedals. I know that some are very passionate about hardware choices, but I can say from experience, the Saiteks were a good investment for me. They have performed flawlessly in ROF, FSX, DCS, IL2 COD, etc. They always hold their zero, and are comfortable to use. I like them.

 

In IL2 BOS, I am encountering my first issue with these pedals. Although rudder (yaw) functioning is perfect, I cannot bind the differential brake AXIS to the toe brake function built into the pedals. IL2 BOS simply won't recognize my toe brakes. While I can assign the comma and period keys to the toe brakes, they still do not function as such because the Saitek programming software doesnot  have a "hold" fetaure that will continuously generate the keypress while the brake is held down. Thus, it seems an analog soultion is the only one that might work, but I cannot invoke analog functioning unless the sim recognizes the axis.

 

Anyone who is looking forward to the release of the He-111 can already see where this is headed. You simply cannot handle such a big bird on the ground without differential braking, and, call me a fanatic, I want to do it using my toebrakes, not my keyboard.

 

Has anyone had and solved this, or a similar problem? Has anyone been able to use diff braking in this sim using the Saitek Combats?

 

Thanks all in advance for any help you may be able to give-

S!

 

Share this post


Link to post
Share on other sites

You just need to push the brake first, and click the bind setting(for example left brake), and release the brake. It will work.

(Yes, I'm using Combat Rudder pedals)

 

Or just spam the brake until it binds into the game.

 

Same thing works on dual staged trigger.

Edited by resmania
  • Upvote 1

Share this post


Link to post
Share on other sites

 I'm also using Saitek Combat Rudder pedals. Here's the deal...

Last time I checked If you bind Russian brake to one toe brake it will make both L and R toe brakes go down on the German planes. It's a bug.

I mapped Russian brake to a whole different button not on my pedal set up. Just be aware of this. 

Edited by LastRights13
  • Upvote 1

Share this post


Link to post
Share on other sites

The left toe brake doesn't work on CH pedals either. It used to work but a BOS update killed it a few months back. I'm still waiting for this to be fixed as the Fw190 is impossible to taxi without it.

Share this post


Link to post
Share on other sites

I mapped Russian brake to a whole different button not on my pedal set up. Just be aware of this. 

Which is what i needed to do to make the toe brakes work on my pedals.

 

If the Russian brake was also bound to the toe brakes, the brakes for the German planes wouldn't work properly.

 

Not sure if they fixed it, but if you're having trouble getting your toe brakes to work, i would make sure to unbind the Russian brake command first and see if it helps.

Share this post


Link to post
Share on other sites

I have the Saitek Combat pro pedals and the toe brake axes were straightforward to bind.  I am not using any Saitek programming software though.

 

Have you tried it without any game controller software running?

 

Hood

Share this post


Link to post
Share on other sites

 I'm also using Saitek Combat Rudder pedals. Here's the deal...

Last time I checked If you bind Russian brake to one toe brake it will make both L and R toe brakes go down on the German planes. It's a bug.

I mapped Russian brake to a whole different button not on my pedal set up. Just be aware of this. 

+1. This is what I had to do to get my Combat Rudder Pedals to work properly.

Share this post


Link to post
Share on other sites

The left toe brake doesn't work on CH pedals either. It used to work but a BOS update killed it a few months back. I'm still waiting for this to be fixed as the Fw190 is impossible to taxi without it.

I got mine working yesterday. The two brakes show as different axes and are definitely working. Others seem to be having difficulties as well.

Share this post


Link to post
Share on other sites

For what it's worth I upgraded to an SSD the other day so I decided to do a fresh OS install. Then installed BOS and still the left toe brake isn't recognised. So it's not a configuration conflict or a bug created by not updating cleanly.

Share this post


Link to post
Share on other sites

I have Saitek Combat Pro Pedals and the toe brakes work fine for German aircraft. I've always assigned the Russian aircraft's brakes to a button on my joystick since, if you notice when activating the brakes for Russian aircraft, the brakes are actually a lever/button on the control column.

Share this post


Link to post
Share on other sites

FuriousMeow has it. The toe brakes [German] work fine, as long as you don't assign them to 'Wheel brakes' also.

 

With 'Wheel brakes' [Russian], assign a button on your joystick, not an axis on your pedals.

Share this post


Link to post
Share on other sites

Believe it or not but I completely stopped playing this game because of this one issue. Every few months I fire the game up to see if this has been fixed. Then I get so annoyed that I give up, that and that all my peripherals need to be remapped as I've plugged them in differently.

Does anyone else know a way around this? The axis works fine in all my other sims and did work in BOS for a while until an update killed it.

 

Also tried playing with the current.actions file and manually putting in joy0_x_axis and it stops the game from loading. I then remove the line and the game still doesn't load. Is this an anti-cheat mechanism?

Edited by xnomad

Share this post


Link to post
Share on other sites

Believe it or not but I completely stopped playing this game because of this one issue. Every few months I fire the game up to see if this has been fixed. Then I get so annoyed that I give up, that and that all my peripherals need to be remapped as I've plugged them in differently.

Does anyone else know a way around this? The axis works fine in all my other sims and did work in BOS for a while until an update killed it.

 

Also tried playing with the current.actions file and manually putting in joy0_x_axis and it stops the game from loading. I then remove the line and the game still doesn't load. Is this an anti-cheat mechanism?

 

You stopped playing because your toe-brakes didn't work?

Share this post


Link to post
Share on other sites

 

 

Also tried playing with the current.actions file and manually putting in joy0_x_axis and it stops the game from loading.
 

The reason for that is, that the line should read "joy0_axis_x" instead.

Share this post


Link to post
Share on other sites

Last time I checked If you bind Russian brake to one toe brake it will make both L and R toe brakes go down on the German planes. It's a bug.

 

 

No, is not a "bug".

 

Is a feature - planed for the "poor" gamer with his cheap "3in1" twist rudder joystick, can brake brake in German planes without buy expensive rudder pedals with - the most important command in games controllers - the "tip-toe brakes".

 

So the (game controls) command "Wheel brakes" need work for all planes of the game, be assign a joy button or keyboard key, and associated with "twist rudder"  (in that cheap "3in1" stick) brake right or left wheel in Russian planes, and as bonus - for easy the life of the above describe guy - in German/American planes too. ;)

 

The "bug" happens when the lucky guy with his fancy pedals with "tip-toe brakes" (the most import... blablabla) resolves "cheater" the games commands and ad foot controlled brakes for planes that never has foot controlled brakes - most of Russian/Italian/British WWII planes.

 

But if he does this only for the proper planes, German/American will work 100%. :)

 

The culprit is your joystick, that don't have this control:

 

http://forum.il2sturmovik.ru/uploads/monthly_09_2016/post-25408-0-33479700-1474713605.jpg

http://forum.il2sturmovik.ru/uploads/monthly_09_2016/post-25408-0-33030900-1474713604.jpg

 

  :lol:

 

I already assign for brakes in this game: CH Pedals tip-toe brakes, VKT-Rudder "Virtual axis brake" (not need, just for test), brakes in homemade pedals, with homemade (MJoy8) USB controller,  joystick X and Y axis (just for test), all work.

 

Axis assignment sometimes is trick, but is just matter to move back and forth several times, or start with axis inverted, eg. brake pressed.

 

Sometimes the "bug" is... behind the keyboard.  :biggrin:

Edited by Sokol1

Share this post


Link to post
Share on other sites

I've tried the repetitive axis assignment 'trick' many times and reversed, nothing registers. 

 

Yes believe me, this annoyance and that my wife and I have young twins, so have very little time to play, is enough for me to give up.

 

I'm not some beginner I played IL2 obsessively since the start but have less time over the years. Every time I want to play there is a massive download, as it's been a few months, then I have to remap all my settings as I've plugged my peripherals in differently, and then I can't control the plane on the runway because of the brakes. By then I've had enough and give up.

 

I want differential braking, not both brakes at the same time.

 

So how do other CH pedal users have theirs working?

Share this post


Link to post
Share on other sites

Xnomad

 

First thing you need do is go in Windows Control Panel > Games controllers (or type joy.cpl in Start box) and check if pedal brake axis are working OK, or use CH software for test.

 

If the above test result OK, there's no reason for the controller don't work in any game that use DImput based controls.

I post above about my experience with several controllers brake assignments - even useless ones - and all work as expected.

 

But, computers - even same model bought in same store - don't work equals due several reasons, most related to user preferences.

So why some became 'problematic" with simple things.

 

For example in this same forum other user say that need a "war" to make their Logitech 3D PRO - a common low cost joystick model - be recognized by game (IL2:Bo') controls, and finally discover that what prevents this are a third part software used for KosmoSimov controls who make their joystick a "virtual joystick" . 

 

A practical thing to try:

 

In the mentioned Games Controllers (joy.cpl) take note of the names Windows set for your pedal brakes axis, as well the position pedal are listed by Windows, if 1st, 2nd...

 

Windows see joysticks starting from 1 but  (most) games see controllers starting from 0, so:

 

1st in Windows Game Controllers = 0 for games

2nd in Windows Game Controllers= 1 for games

etc.

 

Go to this folder:

 

...\IL-2 Battle of Stalingrad\data\

 

Open, with Notepad, this file:

 

current.actions

 

Find this lines:

rpc_wheel_brakes,                             key_space,                                        0| // Wheel brakes
rpc_wheel_brakes_left,                        joy0_axis_rx,                                     0| // Left wheel brakes
rpc_wheel_brakes_right,                       joy0_axis_ry,                                     0| // Right wheel brakes
Names for keys and axis vary, the above is personal prefernce.
 
Change in rpc_wheel_brakes_left (and right) the names "joy0_axis_rx" for the ones that you take note in Games Controllers.
 
If your pedal are the 2nd in list, and their left brake axis is Z will be "joy1_axis_z". Etc.
 
Save the file, open the game and test brakes (for German, P-40 and i-16 only*) - if work but brakes became inverted, try invert in Games Controls ticking the proper box or in the above file change 0|  for 1|.
 
Ok, is laborious, but a definitive test, better than try the same thing in Games Controls again and again, and again...  :biggrin:
 
*This don't apply for other Russian/Italian planes of the game for obvious reason: they never have bakes on pedals (Tip-toe Brakes, Toe Brakes, Joe Brakes). ;)
 
EDIT
 
BTW - For example DCSW latest versions have problem in detect axis, so I just select the axis by name in their drop down list there and work OK. :)
Edited by Sokol1

Share this post


Link to post
Share on other sites

Thanks,

 

I had already tried editing the current.actions file before, however every time I did the game would crash on startup. This time, going on your recommendations I used notepad though, and it let me edit it, all the other times I was using vim.

Also all my axis work in all other games and in ch manager. Plus this all worked back when BOS came out, then an update killed it.

 

However, I have noticed something very odd. If I start the game without my joystick plugged in then my rudder pedals get assigned as joy0.

 

I then quit the game and plug in my joystick. So my joystick is now joy0 and my pedals are joy1

Then start the game and my left toe brake works as roll. That means the game recognizes the toebrake axis as joy0 even though the joystick is now joy0. 

If I edit the current.actions file copy the right toe brake assignment and rename it left and change the axis to x, the game doesn't respond to input on that axis!

 

I'm going to try plug my pedals into other ports on my pc and see if this makes a difference.

Share this post


Link to post
Share on other sites

Your controls seems corrupted.

 

Try: rename current.actions and current.map (in same folder) files. E.g. add a _ inf front of names.

 

When you start the game again will be created new files, with default assignments.

 

Then try assign axis again for joy and pedals.

 

If work OK assign the remains buttons etc, and save a copy of this files.

Share this post


Link to post
Share on other sites

Thanks. I've deleted and recreated those files several times but it doesn't work. However I have found a fix!

 

1. I plug in my MS FFB as joy0.

2. I then plug my CH combat Stick as joy1.

3. I assign the x axis of the CH joystick to left toe brake and the y axis to the right toe brake.

4. Quit the game

5. remove CH stick and insert CH pedals in same USB port.

6. Start game. Now the CH pedals are assigned as joy1 and this works.

 

This fools the game into letting me have toe brakes again. Who knows how long that will last.....

It's definitely a bug in the game.

Share this post


Link to post
Share on other sites

 

Xnomad

 

First thing you need do is go in Windows Control Panel > Games controllers (or type joy.cpl in Start box) and check if pedal brake axis are working OK, or use CH software for test.

 

If the above test result OK, there's no reason for the controller don't work in any game that use DImput based controls.

I post above about my experience with several controllers brake assignments - even useless ones - and all work as expected.

 

But, computers - even same model bought in same store - don't work equals due several reasons, most related to user preferences.

So why some became 'problematic" with simple things.

 

For example in this same forum other user say that need a "war" to make their Logitech 3D PRO - a common low cost joystick model - be recognized by game (IL2:Bo') controls, and finally discover that what prevents this are a third part software used for KosmoSimov controls who make their joystick a "virtual joystick" . 

 

A practical thing to try:

 

In the mentioned Games Controllers (joy.cpl) take note of the names Windows set for your pedal brakes axis, as well the position pedal are listed by Windows, if 1st, 2nd...

 

Windows see joysticks starting from 1 but  (most) games see controllers starting from 0, so:

 

1st in Windows Game Controllers = 0 for games

2nd in Windows Game Controllers= 1 for games

etc.

 

Go to this folder:

 

...\IL-2 Battle of Stalingrad\data\

 

Open, with Notepad, this file:

 

current.actions

 

Find this lines:

rpc_wheel_brakes,                             key_space,                                        0| // Wheel brakes
rpc_wheel_brakes_left,                        joy0_axis_rx,                                     0| // Left wheel brakes
rpc_wheel_brakes_right,                       joy0_axis_ry,                                     0| // Right wheel brakes
Names for keys and axis vary, the above is personal prefernce.
 
Change in rpc_wheel_brakes_left (and right) the names "joy0_axis_rx" for the ones that you take note in Games Controllers.
 
If your pedal are the 2nd in list, and their left brake axis is Z will be "joy1_axis_z". Etc.
 
Save the file, open the game and test brakes (for German, P-40 and i-16 only*) - if work but brakes became inverted, try invert in Games Controls ticking the proper box or in the above file change 0|  for 1|.
 
Ok, is laborious, but a definitive test, better than try the same thing in Games Controls again and again, and again...  :biggrin:
 
*This don't apply for other Russian/Italian planes of the game for obvious reason: they never have bakes on pedals (Tip-toe Brakes, Toe Brakes, Joe Brakes). ;)
 
EDIT
 
BTW - For example DCSW latest versions have problem in detect axis, so I just select the axis by name in their drop down list there and work OK. :)

 

This solve my problem with the saitek pedals. IL2 did not recognize left and right toe brakes of the pedal when I was trying assign keys and axis... but, I had not problems with the yaw assignment in the pedal. My pedals are named as joy2 and the solution was edit the file current.actions but with these two sentences, joy2_axis_x and joy2_axis_y

 

Thanks for your post, I helped me a lot, Sokol1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...