Jump to content
Sign in to follow this  
PostumusAgrippa

Limited Z-axis head movement - please help

Recommended Posts

I'm currently using Freetrack with an active IR system (hat with LEDs).  All head movements except for the Z-axis (forward/backwards) seem to be working fine, but for whatever reason, there seems to be an extremely limited band of movement in this axis.  I tried playing with the in-game controls to move the pilot head forward/back, but I cannot get it to where I can both lean back to view the controls, and move my head all the way to the gunsight.  I have to fiddle with the zoom or head forward controls whenever I want a better view of a target, which is a giant pain.

 

Is there any fix to this problem?

Share this post


Link to post
Share on other sites

I'm currently using Freetrack with an active IR system (hat with LEDs).  All head movements except for the Z-axis (forward/backwards) seem to be working fine, but for whatever reason, there seems to be an extremely limited band of movement in this axis.  I tried playing with the in-game controls to move the pilot head forward/back, but I cannot get it to where I can both lean back to view the controls, and move my head all the way to the gunsight.  I have to fiddle with the zoom or head forward controls whenever I want a better view of a target, which is a giant pain.

 

Is there any fix to this problem?

I have TIR4 with version 5 software and Track-Clip-Pro and have noticed the same thing.  I changed my Z-axis to give me quicker movement but still not up to much in BoS.  You really notice the difference when you fly another flight sim that allows you to move head forward and back better.  Best I can say for now is change your axis for faster response.  TIR just seems to work a little different with BoS.

I have had to adjust most of my TIR settings to make them faster for BoS as TIR is very sluggish compared to CloD, for example.

Share this post


Link to post
Share on other sites

I have opentrack as well as freetrack, and so far I have actually found freetrack to be the better software.  For whatever reason, freetrack has lower latency, and I have none of the issues with other axis', such as restricted pitch, which the poster describes in the other thread.  The only issue I have is restricted Z-axis movement, and the issue persists whether I use opentrack (I just tested it) or freetrack. 

 

Watching the visual representation of the tracker output shows the virtual head moving forward far past the position where I stop seeing forward movement in game.  I realize that the cockpit restricts head movement, but the maximum forward view with the head tracker from a reasonable starting point isn't close to touching the front of the cockpit.  Also, the band of movement in the Z-axis moves with the neutral position - it is always the same amount of forward translation, no matter if it is centered with the pilot head pushed against the headrest, or 3/4 of the way to the instrument panel.  Finally, while it is not possible to move the pilot's head far enough forward using the head tracker, it IS possible to do using the manual pilot head position controls in the game (NUM +/-).

 

So, so far I have one response saying they have the same issue, and one response from which I infer that the poster does not have this issue, or at least isn't bothered by it/aware of it.  Can anyone else who either has or has not experienced this respond?  I just would like to know if this is a bug, or if it is some sort of malfunction in the head tracking interface, or if there is some special change I need to make in the tracker profile for this game.

 

I also just tested this with my freetrack setup in ROF, and had no problems there.  I could move the pilot head all the way up to the windscreen using the head tracker, and the manual pilot head forward/back did not change the amount by which I could move forward, it only made it require more head movement as you would expect.

Share this post


Link to post
Share on other sites

This "better software" is no longer developed and has very annoying bugs. It mey work for You but i didn't had the time to find "special way" to run freetrack. But this far from yours problem. I use opentrack mostly with ROF and I don't have problems with Z axis. I need to check that in BOS and report. 

Share this post


Link to post
Share on other sites

I use freetrack and had the same problem, I got it fixed but in the end it was not very smooth. I then put the pilot head zoom to a hat on my joystick and increased the zoom time. All in all this is working very well and I some what prefer it to actual head movement not just in bos but other titles that don't have this problem

Share this post


Link to post
Share on other sites

I tested today Opentrack  2.2.a2 (PointTracker 1.1 with Accela Filter MK4 (some adjusted) and PS3eye 320x480@180FPS) is smooth and responsive even better (earlier had 2.0 version) and work in full band in Z-axis. I can move head to gunsight  and back to seatback.

Share this post


Link to post
Share on other sites

Hi - I use opentrack and here is my profile which I have spent some time making very responsive.

 

Add this into a settings file.

 

[PointTracker]
CameraId=0
CameraF=@Variant(\0\0\0\x87?\x80\0\0)
CameraResX=640
CameraResY=240
CameraFPS=75
CameraRoll=0
CameraPitch=0
CameraYaw=0
PointExtractThreshold=54
PointExtractThresholdSecondary=177
PointExtractMinSize=3
PointExtractMaxSize=30
PointModelM01x=@Variant(\0\0\0\x87\0\0\0\0)
PointModelM01y=@Variant(\0\0\0\x87\x42 \0\0)
PointModelM01z=@Variant(\0\0\0\x87\xc1\xf0\0\0)
PointModelM02x=@Variant(\0\0\0\x87\0\0\0\0)
PointModelM02y=@Variant(\0\0\0\x87\xc2\x8c\0\0)
PointModelM02z=@Variant(\0\0\0\x87\xc2\xa0\0\0)
tMHx=@Variant(\0\0\0\x87\x42\xe0Op)
tMHy=@Variant(\0\0\0\x87\xc2.P@)
tMHz=@Variant(\0\0\0\x87\x42\xe'\x80)
DynamicPoseResolution=true
VideoWidget=true
SleepTime=2
ResetTime=1000
EnableRoll=false
EnablePitch=true
EnableYaw=true
EnableX=true
EnableY=true
EnableZ=true

[PointTrackerDialog]
ActiveModelPanel=0
CustomM01x=0
CustomM01y=40
CustomM01z=-30
CustomM02x=0
CustomM02y=-70
CustomM02z=-80
ClipTopHeight=40
ClipTopLength=30
ClipBottomHeight=70
ClipBottomLength=80
CapHalfWidth=40
CapHeight=60
CapLength=100

[Tracking]
invertYaw=true
invertPitch=true
invertRoll=false
invertX=false
invertY=false
invertZ=false
tcomp-rz=true
compensate=true
rx_alt=false
ry_alt=false
rz_alt=false
tx_alt=false
ty_alt=false
tz_alt=false
zero_tx=0
zero_ty=0
zero_tz=0
zero_rx=0
zero_ry=0
zero_rz=0

[GameProtocol]
DLL=libopentrack-proto-freetrack.dll

[TrackerSource]
DLL=libopentrack-tracker-pt.dll
2ndDLL=

[Filter]
DLL=libopentrack-filter-accela.dll

[Accela]
rotation-alpha=20.1
translation-alpha=20.1
deadzone=0
exponent=2.85
second-order-alpha=8.1
third-order-alpha=8.1
axis-0=1.5
axis-1=1
axis-2=1
axis-3=0.8
axis-4=0.8
axis-5=1.25

[Curves-rx]
point-count=2
point-0-x=0
point-0-y=0
point-1-x=31.6000003814697
point-1-y=180

[Curves-ry]
point-count=1
point-0-x=25.1000003814697
point-0-y=90

[Curves-rz]
point-count=0

[Curves-tx]
point-count=1
point-0-x=18.1071434020996
point-0-y=22.5

[Curves-ty]
point-count=1
point-0-x=18.25
point-0-y=48

[Curves-tz]
point-count=1
point-0-x=20.7142848968506
point-0-y=60

[Curves-tx_alt]
point-count=0

[Curves-ty_alt]
point-count=1
point-0-x=23.1071434020996
point-0-y=0

[Curves-tz_alt]
point-count=1
point-0-x=21.8571434020996
point-0-y=12

[Curves-rx_alt]
point-count=0

[Curves-ry_alt]
point-count=1
point-0-x=9.80000019073486
point-0-y=68.5

[Curves-rz_alt]
point-count=0

[KB_Shortcuts]
Shift_Center=true
Ctrl_Center=false
Alt_Center=false
Key_index_Center=55
Shift_Toggle=false
Ctrl_Toggle=false
Alt_Toggle=false
Key_index_Toggle=0

[FT]
UsedInterface=0

[FTIR]
useTIRViews=false
useDummyExe=true
 

Share this post


Link to post
Share on other sites

Hi - I use opentrack and here is my profile which I have spent some time making very responsive.

 

Add this into a settings file.

 

 

Gave that profile a shot, but I still have the same problem with limited Z-axis band.

 

I tested today Opentrack  2.2.a2 (PointTracker 1.1 with Accela Filter MK4 (some adjusted) and PS3eye 320x480@180FPS) is smooth and responsive even better (earlier had 2.0 version) and work in full band in Z-axis. I can move head to gunsight  and back to seatback.

 

tomcat, do you have ROF?  Can you test your setup in ROF and tell me if you get the same results?  Also, when you tested your setup in BOS, what was your starting position in the virtual cockpit (how far forward)?  The last question I ask because you would not notice if there was limited Z-axis movement if the forward part of the band intersected with the front of the cockpit.

Share this post


Link to post
Share on other sites

 

 

tomcat, do you have ROF?  Can you test your setup in ROF and tell me if you get the same results?  Also, when you tested your setup in BOS, what was your starting position in the virtual cockpit (how far forward)?  The last question I ask because you would not notice if there was limited Z-axis movement if the forward part of the band intersected with the front of the cockpit.

 

 

 

I spend a lot more time playing ROF than BOS, I did set up custom snap center view in BOS and ROF, hard to describe i could post screenshot in weekend if you like?

Share this post


Link to post
Share on other sites

In opentrack under the Freetrack 2.0 settings make sure you have "EZCA" checked. That fixed the issue for me. Also Eyek's config info is working well for me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...