Jump to content

weird tie dye ring effect applied to clouds/sky and no AA applied to rivers on Kuban map and a weird tree issue


brahguevara
 Share

Recommended Posts

brahguevara

I hadn't changed my graphics settings recently.
Playing Kuban on finish server.
Game looks very bad

https://imgur.com/a/Dw9rgpn

 

how do i get rid of shimmer on the bottom of clouds in the distance
its diagonal in the pics, but if my head/plane is perfectly flat 
its the same ring effect I have seen before
its like theirs two separate worlds/dimensions rendered around me in rings 
I can see the rings if i look straight up
and for clouds far away the overlapping rings cause shimmer? 
i tried a bunch of different settings and it didn't help
turning off sharpen makes it less obvious 
and double sharpen makes it more obvious
as in these pictures
https://imgur.com/a/sjkM7Zb

its clearly a lighting issue from my limited understand 
but its always their
tried bloom on off, different presets, different cloud levels, different render distances

it also happens on other maps/weather

 

 

also third minor issue with trees looking like they are made out of camo net 
as seen in the first picture on the far right tree top

https://imgur.com/a/9LOoRBM

 

also on kuban
the rivers have a white edge up close which is ok
but once they get far enough away the river edge looks like crap because it has no AA applied to it
actually seems to happen the ground in general sometimes



I know if I had nvidia i could run FXAA and MSAA
but having a 5700 xt all i can do is run MSAA and it looks awful 

 

 

tried a million different settings
tried deleting my startup.cfg

 

another weird issue is the shadow on the a20 rendering like crap
although at some point in this process it was rendering quite smooth
so far i think iv seen 3 different shadow renderings 
i also thought at some point in the process i had solved the problem, but either restarting the game broke it again or i was just imagining it working properly

 

Imgur: The magic of the Internet

 

Edited by brahguevara
Link to comment
Share on other sites

LizLemon
4 hours ago, brahguevara said:

I hadn't changed my graphics settings recently.
Playing Kuban on finish server.
Game looks very bad

https://imgur.com/a/Dw9rgpn

 

how do i get rid of shimmer on the bottom of clouds in the distance
its diagonal in the pics, but if my head/plane is perfectly flat 
its the same ring effect I have seen before
its like theirs two separate worlds/dimensions rendered around me in rings 
I can see the rings if i look straight up
and for clouds far away the overlapping rings cause shimmer? 
i tried a bunch of different settings and it didn't help
turning off sharpen makes it less obvious 
and double sharpen makes it more obvious
as in these pictures
https://imgur.com/a/sjkM7Zb

its clearly a lighting issue from my limited understand 
but its always their
tried bloom on off, different presets, different cloud levels, different render distances

it also happens on other maps/weather

 

 

also third minor issue with trees looking like they are made out of camo net 
as seen in the first picture on the far right tree top

https://imgur.com/a/9LOoRBM

 

also on kuban
the rivers have a white edge up close which is ok
but once they get far enough away the river edge looks like crap because it has no AA applied to it
actually seems to happen the ground in general sometimes



I know if I had nvidia i could run FXAA and MSAA
but having a 5700 xt all i can do is run MSAA and it looks awful 

 

 

tried a million different settings
tried deleting my startup.cfg

 

another weird issue is the shadow on the a20 rendering like crap
although at some point in this process it was rendering quite smooth
so far i think iv seen 3 different shadow renderings 
i also thought at some point in the process i had solved the problem, but either restarting the game broke it again or i was just imagining it working properly

 

Imgur: The magic of the Internet

 

 

Are you using mods or not? Because you have a half dozen issues going on and its not obvious if you are running this mod or not.  Its either the mod or you have some severe driver issues.

Edited by LizLemon
Link to comment
Share on other sites

vonGraf
5 hours ago, brahguevara said:

but having a 5700 xt all i can do is run MSAA and it looks awful 

Strange, I have an AMD as well and can use both AA modi.

But MSAA works better for me anyway.

I think the FXAA in game is just a post-processed slight smoothing of the edges, not a real AA. Of course it's more performance friendly.

Link to comment
Share on other sites

brahguevara
Posted (edited)
15 hours ago, LizLemon said:

 

Are you using mods or not? Because you have a half dozen issues going on and its not obvious if you are running this mod or not.  Its either the mod or you have some severe driver issues.

no mods, because i play multiplayer

 

13 hours ago, vonGraf said:

Strange, I have an AMD as well and can use both AA modi.

But MSAA works better for me anyway.

I think the FXAA in game is just a post-processed slight smoothing of the edges, not a real AA. Of course it's more performance friendly.

nvidia users can run both at the same time
its annoying because in world of warships I run both and it makes the game look way better than just having one version

 

 

Reading though the clouds mod thread.
They say they have a solution, but I can't run mods and multiplayer.
Requires LUA script edit or preset edit or both.

 

This is the problem with the ocean.
Imgur: The magic of the Internet

 

Strange cloud banding and stuttering in 2.012 - Technical Issues and Bug Reports - IL-2 Sturmovik Forum from 2017

 

[MOD] Banding fix - Mods - IL-2 Sturmovik Forum apparently a fix?

Talking about it on discord - quite a few people have the issue they just deal with it 

Seem like I'm entirely reliant on the devs incorporating these mods into base game.

 

Edited by brahguevara
Link to comment
Share on other sites

brahguevara
Posted (edited)
30 minutes ago, LizLemon said:

You can run FXAA with AMD in this game. Why don't you turn it on?

Can I run it with MSAA at the same time?

 

Heres more details of my settings after I updated graphics driver
During which I deleted my shader cache 
I also deleted my startup file again

I've already tried changing clouds shadows HDR bloom sharpen

Imgur: The magic of the Internet

Currently the A20 shadow is working ok, still not as good as other shadows though

I also had an issue with freesync which is why its disabled, but very occasionally I still get flickering when my FPS is well above the FPS that flickering should occur at which is 44 fps.

My fps is hitting my top limit in flight, around 100 on the runway, tanks drop it as low as 90.

Edited by brahguevara
Link to comment
Share on other sites

I did see some pictures on my low resolution tablet and what I did see is mostly normal behavior from the BoX game engine and I suppose when running AMD cards these are more prominent to be seen. 

One picture at the first post I do see banding in clouds this could be occurring when enabling Dynamic Resolution factor. The transparent plane at your last post I do not have any explanation. 

The good news finally as it seems 1C did also notice it and maybe they are upgrading the sky dome and clouds, for the mean time you could always go for MS FS2020. 

 

 

 

Edited by Dutch2
Link to comment
Share on other sites

brahguevara
Posted (edited)
18 hours ago, Dutch2 said:

I did see some pictures on my low resolution tablet and what I did see is mostly normal behavior from the BoX game engine. The shimmers, strange borderline between the ground & sky at the horizon, those bad made clouds and skydome, its the game and I suppose when running AMD cards these are more prominent to be seen. 

One picture at the first post I do see banding in clouds this could be occurring when enabling Dynamic Resolution factor. The transparent plane at your last post I do not have any explanation. 

The good news finally as it seems 1C did also notice it and maybe they are upgrading the sky dome and clouds, for the mean time you could always go for MS FS2020. 

 

 

 

The main purpose of the post is the banding in clouds.
All of the pictures have banding in them.
The banding doesn't show up very well with a static picture.
The horizon shimmer is caused by viewing the banding at a high angle, because the rings are really close together.
The same rings when view from above and below have much greater spacing and do not shimmer. i.e PgKJfPD.png (1920×1080) (imgur.com)
It is not normal behavior nor acceptable.
Dynamic Resolution factor is not enabled.
Thanks for the input I guess?
If you go back though my posts you will find clear problems with clear solutions.

Some of my examples didn't load in imgur correctly. 
The plane being transparent isn't the problem at all please reread carefully.
Yes things can be done to reduce how obvious the effect is i.e. sharpen, but the effect is also inconsistent.
The A20 wing shadow was used as an example of inconsistent render errors, as are the rings I believe. 
The solutions are not my ideas, they are things people have actually done that actually fix it.
I'm unaware of any current plans to fix it, but that is great if true.

Edited by brahguevara
Link to comment
Share on other sites

  • 1CGS
-DED-Rapidus

@brahguevara, @Dutch2, unfortunately, the ring cloud effect is the current solution, until it changes, the question is to study the problem more deeply and when will the specialists start working on it? I can't say for sure. Therefore, I ask you to refrain from judging and discussing each other's words.

  • Like 1
Link to comment
Share on other sites

1 hour ago, -DED-Rapidus said:

@brahguevara, @Dutch2, unfortunately, the ring cloud effect is the current solution, until it changes, the question is to study the problem more deeply and when will the specialists start working on it? I can't say for sure. Therefore, I ask you to refrain from judging and discussing each other's words.

 

Thanks, noticed after rereading also that now it looks like the game is barely playable while its only an minor thing in my case, can not do any judgements on AMD cards. I will correct this btw. 

Link to comment
Share on other sites

The GTX1080 (driver from febr 2021),  Samsung Odyssey+ and 2005 TLT 19” square monitor that does run 1240x????

No need for my 27” 2k IPS now I’m running VR 😎

 

I do run no cloud mods, or other graphic enhancements mods, the only thing I have modified are the clouds in GPreset file, so I can run the lowest ingame preset while using the clouds from extreme presets.

SteamVR 140% & reprojecting on auto while important for you Dynamic Resolution Factor 0,9. I do not know the effect what this DRF do in combination to the reprojection mode/140%. Would like to know does this shift down the 140% sampling in SteamVR tot an lower factor or does this reduce the resolution on your VR HS screens. (To me it looks like it does shift down the VR screen resolution). And is the 0.9digit, 90% from the total pixels or a reduction of only the horizontal/vertical pixels. 

Another point at what point  does DRS works is this being activated all below the 90FPS, or is there an specific point like below 73FPS. 

 

As I did wrote down, I noticed it, it’s only absolutely not as being showed by the TS and for me an minor aspect, think the AMD owner, especially for the RNDA2 6000 series needs more attention. While I do hope this summer I can upgrade my GTX1080 to an RTX3070ti or 6800XT if prices are being normal. 

 

Edited by Dutch2
Link to comment
Share on other sites

brahguevara
Posted (edited)


I don't think its an AMD issue at a basic level, most of the problems amd has with this game are weird amd settings that are default turned on.
Prime example of this is turning amd freesync off in amd per game settings, fixes flickering and freesync still works.
And the weird texture filter quality and tessellation mode, which has default settings which make spotting harder because it blurs pixels. 

Tonight I reset all my graphics settings in amd windows etc.

Tried again in il2, exact same map exact same map settings I was having chronic issues with as above
It only happens to clouds that are too thin or something, this time.
I tried to screenshot it but quick mission pictures seem to white out on imgur 
Anyway to describe what I could see all the clouds rendered 99% ok, no horizon shimmer at all either.
But their was like an edge of one cloud that had the ring effect. 
Its not unplayable either Dutch2, like I said, I had been playing for weeks zero issues then it started up again.
Its just super annoying because its inconsistent.

So short term solution might just be reload the map?
Heck it could have even been resetting my shader cache which I manually did before todays tests. (I had presumed a driver update would reset it anyway but who knows)



I don't have the time right now to check how consistent these cures are.

 

But separate to the cloud issues, I did point out weird things related too:
kuban map rivers beyond a certain distance loose the smooth white sand edge, get a black edge and become jaggy
the weird camo net tree rendering effect 
the weird a20 hanger shadow 
and not having the option to enable both msaa and fxaa in game 

Anyway thanks for the feedback Rapidus 

I didn't mean to have a big moan, just wanted to document these frustrating issues I'm having, and get some feed back on them.

edit: check on finish server
 Imgur: The magic of the Internet 
no horizon shimmer anywhere
looking away from sun no ring effect
looking at sun ring effect
so yea no magic cures from me

 

Heres some more pictures with zero shimmering or ring effect:
Imgur: The magic of the Internet

 

Ok further experiments 
Preset controls cloud shimmer, it removes shimmer at high and above setting
And changing AMD control panel freesync mode from optimised to ON fixes freesync


edit: after further tweaking I have largely removed horizon shimmer using below settings
limiting horizon draw in game to 50 and 70
then changing the startup.cfg to this
doesn't effect clouds issue though
[KEY = graphics]
    3dhud = 0
    adapter = 0
    bloom_enable = 0
    canopy_ref = 0
    desktop_center = 1
    detail_rt_res = 4096
    draw_distance = 1.00000
    far_blocks = 1
    fps_counter = 1
    fps_limit = 0
    full_height = 1080
    full_width = 1920
    fullscreen = 1
    gamma = 0.90000
    grass_distance = 100.00000
    hdr_enable = 0
    land_anisotropy = 16
    land_detail = 3
    land_tex_lods = 0
    max_cache_res = 1
    max_clouds_quality = 3
    mgpu_compatible = 0
    mirrors = 1
    msaa = 1
    multisampling = 2
    or_ca = 0.00000
    or_dummy = 0
    or_enable = 0
    post_sharpen = 1
    preset = 3
    prop_blur_max_rpm_for_vr = 155
    rescale_target = 1.00000
    shadows_quality = 4
    ssao_enable = 0
    vsync = 0
    win_height = 1080
    win_width = 1980
[END]

Edited by brahguevara
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...