Jump to content

[Solved] NullPointerException when generating mission for custom squadron


Recommended Posts

I created a custom squadron JSON file for the RCAF 412 Squadron, the Falcons.  The file is mostly a copy of RAF Squadron 193.   I can assign a pilot to the squadron but I get a NullPointerException when I try and generate a mission.

 

I changed the JSON file's airfield locations and dates to reflect the historic record.   I also changed the squadronId, name, and callsign.  Perhaps one of those fields is generating the error?

 

The squadron JSON is attached. Here is the error report.

 

Any help would be appreciated.

412 Squadron.zip

Edited by Garafrax
Link to post
Share on other sites
1 hour ago, Garafrax said:

I solved the problem.  I had to use one of the predefined squadron callsigns.  The campaign is working now.

 

The problem won't be solved until the exception is caught and handled, or better yet - prevented.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...