Jump to content

Kuban Autumn Nth Africa Desert Beta upload - Updated version to 4.0 04-04-2021


Off_Winters
 Share

Recommended Posts

Beebop

WHEW😵

 Looks like all is back to "normal".  👍

1 hour ago, Off_Winters said:

will take you about 15 minutes.

🤣  HAHAHAHAHA!!!  More like an hour.  😁  But I took my time and it appears to have been worth it.  No more default desert planes or desert textures on objects.  And if I find something I overlooked I know how to fix it.

I have learned a valuable lesson.  And although I still couldn't mod a phone booth into an outhouse I do know a lot more about how mods work thanks to you.

 

THANK YOU SO MUCH for you help and patience with an old duffer like me.

 

@457_Stonehous, thanks for the link to Winmerge.  Honestly I couldn't figure it out but I'm keeping it for possible future use.  I appreciate the suggestion.

  • Like 1
Link to comment
Share on other sites

Stonehouse
Posted (edited)

You basically select two folders or objects and then right click on the selected objects and run winmerge and it will identify the differences. Makes comparison of all sorts of files very easy and also folders. Probably worth reading up on the game file snap shot feature of JSGME and perhaps running it as it may have made resolving the issue easier. Anyway glad to hear you are back up and running ok again.

 

LOL I am going to have to contact the 1C tech support guys and get my username changed to get rid of the underscore so it becomes No457Stonehouse and fits on one line 😁. Either that or pretend I belong to a Axis squadron and become Stonehaus

Edited by No457_Stonehouse
Link to comment
Share on other sites

Beebop

I have one niggling issue left.

In the planes setup menu and in the viewer I have the DAW names for the planes instead of the stock names.  i.e. instead of "White" for the winter skin I have "XXX Algeria" for example.  The skins are correct, just the names are wrong.  I have looked through all the folders in the mod and can't seem to find where this info is located.  I was thinking maybe the "swf" folder but found nothing that looked right.

Other than that everything else seems in order.

TIA

Link to comment
Share on other sites

Stonehouse

*Might* be the skins.tab.eng file under \Kuban_Autum-1943_Desert_Beta_4\data\graphics\skins in the mod folder and IL-2 Sturmovik Great Battles\data\graphics\skins in the game folder

  • Thanks 1
Link to comment
Share on other sites

Beebop
Posted (edited)

By Jove I believe you struck the nail on the head! 🧐

I took out that file and now both the setup menu and the viewer display the correct names!:good:

:thank_you:

Edited by Beebop
Link to comment
Share on other sites

Beebop

🤬

Still some lingering issues.

Some planes still show DAW skins as defaults and replacements.  Notably the Hurricane/P-39/SpitVb/SpitIXe.

In the QMB mission setup menu the previews are correct but when I start the mission and go to the planes Setup menu the DAW skins appear.  Like in the QMB mission setup menu the previews are correct but the wrong skin loads.

In my game folder data > graphics > Planes > Textures, all I have is the 'B' normal map and the Custom photo.

The DAW skins show up in game and in the viewer.

Removing the "skins.tab.eng file" got rid of the DAW naming.

Where oh where can I find whatever it is that gives me these DAW skins? :scratch_one-s_head:

Link to comment
Share on other sites

Beebop

So my current solution is to delete all desert skins in my skins folder.  So far that's worked.  However if I can find out what script/file causes the game to load DAW skins I would like to remove that too in the event that when I install and uninstall the mod I don't find myself back with default DAW skins.

 

I figure I'm not going to fly desert skins on the stock maps (although Western Stalingrad and Western Moscow Autumn are pretty "deserty" although deserted is a better description) so I'll just use the desert skins the mod installs.

 

On a side note I always wondered why they gave us "official" desert skins if they didn't have plans for a desert map?  I've never seen an Eastern Front plane in desert camo colors around Stalingrad/Moscow/Kuban nor heard of it.

 

In the meantime this solution works although I won't be surprised to find another 'anomaly'.

Link to comment
Share on other sites

Stonehouse

I think there are quick mission templates somewhere but I wouldn't have thought they would be impacted by the desert mod. Have you tried using Vanders EMG instead for quick missions? Just to see if the problem persists (but also you will get more interesting quick missions).

Link to comment
Share on other sites

Robert_Molders
Posted (edited)

You can also check the files integrity via Steam. This will revert your game to vanilla ( Updated to the last patch ) so don't forget to save/make a backup first of your eventual custom settings like for example the keybindings, video settings, etc

Edited by SKG210_Molders
Link to comment
Share on other sites

Beebop
5 hours ago, SKG210_Molders said:

You can also check the files integrity via Steam. This will revert your game to vanilla ( Updated to the last patch ) so don't forget to save/make a backup first of your eventual custom settings like for example the keybindings, video settings, etc

Non-Steamer.  I don't like the idea of a "middle man" for the game.  I also use mods so their "automatic update" feature I don't like.  When an update comes along I disable all mods and backup my 'input' folder first, as you suggested, so if the game modifies my settings I can get them back easily.  And I can reload my mods one at a time and see if the update breaks any of them so I'm not left wondering why the game won't start/looks wonky/acts like it took drugs. 😉

But I know a lot of people like Steam and more power to them, I'm just not one of them.

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
Robert_Molders
Posted (edited)

@Off_Winters I'm working on the tank skins description but I have a question....

 

In the skins.tab file it seems that to each skin is assigned a unique ID ( The one highlighted in red in the sample quote below ).

 

Any idea to what they are related/needed or which ones must be assigned? ( So far I've given the skins random ones and it seems to work. I'm just curious to know what are they for/their function. )

 

Quote ( Only the part of interest )

 

"graphics\Skins\_PzVI-H1\pzvih1_01.dds" "0B5B800C" "1"

Edited by Robert_Molders
Link to comment
Share on other sites

DD_Friar

Salute

I have just tried this mod for the first time having been following the thread with much interest.

 

I applied the mod via JSGME. I did not include the tress option.

I created a deathmatch map and created a single tank spawn. The spawn point only had M4A2's, it was a linked entity with a nationality of Great Britain.

 

When I start the mission up I see the spawn point as I would expect but when I click on the spawn point nothing happens other the screen going dark (see below). I left it for quite a while. As soon as I click on the mouse the screen goes bright again.

 

Any thoughts?

Africa Mod Issue.JPG

Link to comment
Share on other sites

Off_Winters
Posted (edited)
On 5/25/2021 at 1:55 AM, Robert_Molders said:

@Off_Winters I'm working on the tank skins description but I have a question....

 

Quote ( Only the part of interest )

 

"graphics\Skins\_PzVI-H1\pzvih1_01.dds" "0B5B800C" "1"

G'day Rob,

I believe they tie in somehow to how the game validates content, but like you I have not had any issues with them when assigning new skins.

regards Rob.

On 5/27/2021 at 2:52 AM, DD_Friar said:

Salute

I have just tried this mod for the first time having been following the thread with much interest.

 

I applied the mod via JSGME. I did not include the tress option.

I created a deathmatch map and created a single tank spawn. The spawn point only had M4A2's, it was a linked entity with a nationality of Great Britain.

 

When I start the mission up I see the spawn point as I would expect but when I click on the spawn point nothing happens other the screen going dark (see below). I left it for quite a while. As soon as I click on the mouse the screen goes bright again.

 

Any thoughts?

Africa Mod Issue.JPG

Sorry DD_Friar,

the mission builder and hosting online are not something I'm that familiar with. I play online with a group and we use the desert mod a lot, but its hosted by one of the guys I've never had to set one up.

I'm sure others may be able to point you in the right direction though.

regards Rob. 

Edited by Off_Winters
  • Like 1
Link to comment
Share on other sites

Blitzen

As stated in earlier posts I really like this mod & appreciate all the work involved but because of a recent re-install & in the process of “loading” Mods from JSGME ,I found a weird glitch showing up : Sun lens visual anomalies that appear as glowing geometric shapes where default lens effects used to show up.After much testing I finally pinned it down to this mod,by loading this mod first & viewing the effect in game, then by removing it & finding “clear skies” were back. Normally I would have said this could be caused by an interaction with another mod ( like say “Remove lens effect” one of the first available mod from years ago..) but in testing it all by itself I thave honk I can definitely say its this mod interacting with something in my default install and/or the way my PC deals with it. Others appear not to be having this problem, so clearly it must be a glitch on my end, but the result is that I’ve sadly had to disable it…perhaps you have an idea what I should do next…perhaps install most but not all its folder ( like say at least add its missions to my mission folder?

Link to comment
Share on other sites

Stonehouse
Posted (edited)

Very odd. The only sky/sun related file I can find in the Nth Africa mod is I believe the repaint of the hangar scene outside view. So nothing to do with the sun ie there is no sunglow.dds or similar nor folder data/graphics/sky/textures where such sun related files usually live I believe is present in the Nth Africa mod.

 

Just trying to clarify your comments a bit - you say "by loading this mod first" - using JSGME if there is a file clash then it is the last mod loaded that wins out and generates what you see.  So it would be by loading the Nth Africa mod last that you ensure you see it's files in play rather than another mods.

 

My guess is somehow you have another mod in action causing the issue..........it isn't totally clear from your post but have your tried loading the mod all by itself and nothing else? Have you ever stopped/killed JSGME part way through a load or unload of mods? This can leave files embedded in the game folders. If you have tried the mod all by itself with nothing else and still have the problem I would be thinking somehow you have some leftover files from another mod except you say you have just reinstalled................very confusing.

Edited by No457_Stonehouse
  • Upvote 1
Link to comment
Share on other sites

Beebop
4 hours ago, No457_Stonehouse said:

Have you ever stopped/killed JSGME part way through a load or unload of mods? This can leave files embedded in the game folders.

I can attest to the veracity of that.  I did that once with this mod and it took two days and a lot of help from Off_Winters (thank you very much sir) to clear it up.

Link to comment
Share on other sites

jollyjack

Hi Rob .... jus' a little curious. Any news from down under?

In case of mess ups, i learned the hard way to keep a backup of a freshly downloaded new game version each time.

Start new with the mods fresh. So far less mess ups it seems.

Link to comment
Share on other sites

  • 2 weeks later...
Off_Winters
On 6/4/2021 at 5:02 AM, jollyjack said:

Hi Rob .... jus' a little curious. Any news from down under?

 

Hi Jollyljack,

Have been locked away here at work due to COVID restrictions and working 6 x 12hr days a week for the last 2 months, so not much time for modding, but I have been plugging away at a few things, mostly updating the in game map to have the desert themed names applied (about 60% done now). fixing the skins script and a few other things after the latest update changed some files, and adding in a few more historical squadron schemes. Also experimenting with a few of the new British assets introduced with the last update. Will be home on extended break from work in about 4 weeks, and plan on tidying up things and releasing new content then.

regards Rob.

  • Like 2
  • Thanks 2
  • Upvote 1
Link to comment
Share on other sites

Vishnu

Don't know if asked before, but the mission screen, I click on it, and it shows the 2 missions, and it says loading description, but nothing happens.   As well, is this just a mode for QMB?  

(PS not to be that guy, but it's desert, not dessert :)

Link to comment
Share on other sites

Off_Winters
7 hours ago, Vishnu said:

Don't know if asked before, but the mission screen, I click on it, and it shows the 2 missions, and it says loading description, but nothing happens.   As well, is this just a mode for QMB?  

(PS not to be that guy, but it's desert, not dessert :)

Hi Vishnu,

After each update any 3rd party missions need to be resaved in the mission editor, this will fix the hanging load times. I have fixed them my side and will include with next update very soon. or if your familiar with the mission editor you can use the resave function under tools to do it yourself.

And thanks for being "that guy" :) I'll fix the mission folder name. amazing how we can look at something numerous times and not see a mistake, and a fresh set of eyes picks it up. So thanks again.

regards Rob.


 

Link to comment
Share on other sites

Beebop
9 hours ago, Vishnu said:

PS not to be that guy, but it's desert, not dessert

Except....THIS desert is a dessert!  😉

Link to comment
Share on other sites

Vishnu
7 hours ago, Off_Winters said:

Hi Vishnu,

After each update any 3rd party missions need to be resaved in the mission editor, this will fix the hanging load times. I have fixed them my side and will include with next update very soon. or if your familiar with the mission editor you can use the resave function under tools to do it yourself.

And thanks for being "that guy" :) I'll fix the mission folder name. amazing how we can look at something numerous times and not see a mistake, and a fresh set of eyes picks it up. So thanks again.

regards Rob.


 

Thanks for the response.   I’m  asking because I had to wipe my computer which totally sucked.  I had to redo all mods, skins, and joystick bindings.  

Yours was one of the first to test out.  So I went to missions and they were stuck. So I’m not sure what you mean by missions need to be re-saved.  Perhaps. I’m not understanding.  

 

Thanks in advance. 

Link to comment
Share on other sites

Stonehouse

Pretty sure he means just to open the mission in the editor and then save it without changing anything. 

Link to comment
Share on other sites

Off_Winters
14 hours ago, Vishnu said:

Thanks for the response.   I’m  asking because I had to wipe my computer which totally sucked.  I had to redo all mods, skins, and joystick bindings.  

Yours was one of the first to test out.  So I went to missions and they were stuck. So I’m not sure what you mean by missions need to be re-saved.  Perhaps. I’m not understanding.  

 

Thanks in advance. 

Hi Vishnu,

You dont have to open the mission in the editor.

Open the mission editor and select the tab half way across the top "Tools" then half way down select the option resave all missions in folder.image.png.856ab24522e7d8985803b25c51460d5b.png

 

Then navigate to the folder your missions are located in and hit ok. thats it your done.
image.png.5f3e4ec305e84710e513fbb5890dbe20.png

 

they will now work in game.

I have a folder on my desk top that I copy the files to, resave them and then place them back into my game folder. Its just easier navigating to desktop in the editor then finding the IL2 directory folders.

regards Rob.

 

Link to comment
Share on other sites

Vishnu

Ahhhhh.  Ok.    I had no idea or inkling what the mission editor was.   I figured it out.  Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...