Jump to content
ITAF_Airone1989

Run a multiplayer server: random crash and weird behaviour

Recommended Posts

Hi guys, I have some trouble with the server.

 

Big problem number 1: (solved)

It has a random crash. Sometimes after 30/40 minutes from the first mission, some other after several hours...

If I'm inside the server appear a message with"connection lost due to: time out". Than in the DOS window everything seems to be ok (it also continue to load next missions) but you don't find the server in the multiplayer list.

Now, because it's a server with AI could be this related with that? Like to many AI in the same place.. But it doesn't seems to happen during particular crowd dogfights. 

 

Big problem number 2:

Sometimes AI don't spawn at all. The mission works like this: when you fly over a specific zone a message appear and some AI come. Everything seems to work fine, but then suddenly no message and no AI.

I really have no idea about what is the problem, if I reload the mission everything is back to work normally.

 

Small problem A: it's possible to change the direction of player air spawn? Cause all of them seem to be pointed North and I cannot modify it.

 

Small problem B: randomly when you spawn in the air you have no elevators control. So your airplane just dive, spin and crash. This will happen every time you spawn from the same place, until you change side. Then if you try the previous spawn point everything works ok.

 

Thank you very much!

Edited by ITAF_Airone1989

Share this post


Link to post
Share on other sites

BP1:

To me this sounds like a networking issue. If the Server process is still running fine, and loading the next mission... Could it be a port conflict/issue on the server?

I've never seen a relation between lots of AI's in the server and a timeout issue. And I've overloaded missions with AI plenty of times :)

Maybe try and run the file integrity check via Steam?

 

BP2:

Sorry, can't really help you there, I'm not using any triggers in missions like that.

(Does sound like some scripting/programming error though - a trigger does not fire anymore)

 

SP1:

Don't think there is a way to change that ...

 

SP2: 

Never ever heard of that issue, never experienced it.

But one would then to think a scripting/programming issue - although it could be a game bug. Then again - having never seen it, I doubt it... 

 

General remark on my experiences with the CloD server: the DangerDogz server(s) use the ATAG Watchdog, it makes sure the server is restarted when it stops/crashes, and the CloD server process itself is being stopped and restarted every 4 hours.

This in order to keep it all 'clean', as sometimes some errors that occur can make the server process increase its memory use to very high levels.  (Like crashed AI aircraft that get stuck on the gound and never get removed automatically)

 

Good Luck!

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Solved big problem 1 using WatchDog. 

So thank you very much @DD_FT-

 

Big problem 2 still remains. Could be a wrong script, but I cannot figure out what is wrong.

There are 4 triggers and I did copy/paste from the first one, so I cannot understand why just the second one is not working while the others are fine. 🤔

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...