Jump to content
busdriver

SOLVED: Controller recognition issue (pedals)

Recommended Posts

I'm trying to get Blitz up and running. I'm having a problem getting Steam or Blitz to correctly recognize my rudder pedal inputs. I've scrolled through trying to find a similar issue and solution, but I'm not seeing one.

 

In Steam I see this:

 

362673418_Blitztroubleshoot_01.thumb.jpg.cb617ad2336867ce010413aef6e77ca8.jpg

 

In Blitz this is what I see:

 

2102667661_Blitztroubleshoot_rudderaxis.thumb.jpg.6c85cef08d1e4c3dfad8b261a0107577.jpg

 

Pitch and Roll response is normal. 

 

When highlighting the Rudder control when I push full rudder Left or Right deflection I get these:

 

579012393_Blitztroubleshoot_fullleft.thumb.jpg.47346f80b6104cd22d7e599beb5d319a.jpg

 

 

1751745181_Blitztroubleshoot_fullright.thumb.jpg.ea9e1c5b746f04fc5cbe08d3d0ebac2f.jpg

 

When I press the right toe brake I get this:

 

1527064893_Blitztroubleshoot_righttowbrake.thumb.jpg.155b44556a133377c046a91e875593f7.jpg

 

I'm guessing the issue is with Steam and it "recognizing" my rudder pedals. Any suggestions on fixing this?

 

 

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, 56RAF_Stickz said:

Busdriver - here is  a link to atag for blitz using the crosswind rudders. Seems there is some necessity to set brake pedals first because of their sensitivity else they trigger before the rudder.

I dont have them so hope this may help you

https://theairtacticalassaultgroup.com/forum/archive/index.php/t-31069.html

 

Much obliged...I'll report back. 🤞

 

Bugger...no joy. Assigning toe brakes to an axis results in the tiniest displacement of rudder pedal left/right being the axis assigned, rather than the pedal rotating forward. Scratching my cranium on this. Oh well, probably should have tried to program BLITZ before I bought Tobruk. No worries though...I think the project is worth supporting.

Edited by busdriver

Share this post


Link to post
Share on other sites
Posted (edited)

try putting a large dead spot on brake axis, turning them off or changing sensitivity so it doesnt register as moving, is that possible via its own s/w? It looks like those guys got it working.

It seems to me you need to move the lateral bit with out touching pedals to get rudder operating (I am working blind here).

The idea that springs to mind is trying to set the rudders axis by moving the rudder arm only (not the pedal) to get that recognised, looking at a picture of crosswinds this might be possible (unlike on my saitek cheapies)if small feet or hands available. Bit of a guddle I know, possible involve crawling round floor a bit and even pulling the rear of the pedal with hands. If that works then set the brake pedals with a large deadspot so they dont interfere subsequently. There are probably other, better ways, you just need to reach the right guys. Could post it for help on atag clod forum itself.

I see that llv34_flanker uses Crosswinds - maybe trying email him

Edited by 56RAF_Stickz
desperation

Share this post


Link to post
Share on other sites

Thanks for trying to help me out. :salute: The brakes aren't the show stopper. It's that the rudder axis only recognizes the first X or Y axis movement (but not full range deflection) . I'll reach out to LLv34_Flanker.

 

Share this post


Link to post
Share on other sites
Posted (edited)

In STEAM Controller settings, remove all checks - CloD don't need this. But if STEAM controller are the culprit, your joystick will be not recognized.

 

You don't have MFG Crosswind rudder axis assigned for Rudder control, should be the RZ axes, not Y axis like in pictures. See MFG axes names in this pictures:

 

https://forums.eagle.ru/attachment.php?attachmentid=156319&d=1485975786

http://simhq.com/forum/files/usergals/2014/08/full-35288-84641-mfg_configurator_1.41.jpg

 

For assign double click over Rudder command and in a windows asking for press a key (an "It's CloD!) move the pedal axis, should see Rz axis, after hit APPLY.

 

MFG Y axis is right brake pedal

MFG X axis is left brake pedal.

 

Right Brake should be at 0 (no green bars) when don't depressed, and full bars when pressed. Same for Left Pedal.

You are seeing movement in green bars in Right Brake test?

 

BTW - This L/R brakes will work only for Bf 109, He-111, Ju-88, Stuka,  Marlet and P-40's.

 

For British, Italian... planes set a button for "wheel brakes" in Keys.

 

Or can use your X-56 twist brakes axis  - e.g. twist for left, for "Wheel Brakes" in Axes, but need do a special calibration for this axis, since you will use only half of the axis.

https://forum.il2sturmovik.com/topic/50488-wheel-brakes-in-twist-rudder-or-paddle-axis

 

Or use Joystick Gremlin Split Axis  for make twist movement for left emulate a new axes 0-100% and assign for Wheel Brakes.

https://www.youtube.com/watch?v=zcCyq4aDpM8

 

 

Edited by Sokol1

Share this post


Link to post
Share on other sites

If Flanker already helped, just disregard this and I hope he got you running ok.

I think sokol may have described it better above than I did. I assumed you realised I meant game was seeing the brake axis pressure applied to the pedal rather than the rudder axis movement.  I guess you are pushing with right leg first but game sees the brake pedal pressure before the rudder movement hence the +X in your rudder line. That should be the entry seen in the right brake line lower down when setting them. As a quick check try moving left leg first and see if it shows +Y instead. It needs to show +RZ for rudder axis.

It should not be happening, but I believe it maybe more a question how sensitive crosswind brake pedals are to pressure of the vertical axis (brakes). Or your feet are too heavy :). Hence my attempts to describe methods to move rudder without applying pressure to a pedal.

Here is my control indication as sokol points out, get +RZ axis for rudder. At the bottom can see the two brakes pedals recorded as +X/Y axis.

As an extreme fix, this is my confuser.ini file and could hand edit (backup first so no cockup caused by my engineering). The segment is almost at the end of the file. You can see how mine relates the the  config screen. Just edit your rudder pedals line (second line down here as +AXE_RZ=1rudder). All you may need to alter on yours is AXE_X to AXE_RZ.  However this will not set up rudder sensitivity (its in another location) so is a last resort.

 

[HotKey pilotMove]
Saitek_Pro_Flight_Rudder_Pedals-8A3D3329+AXE_RZ=1rudder
BU0836X_Interface-D90819BD+AXE_RY=-1trimaileron
Saitek_X52_Pro_Flight_Controller-ABC73591+AXE_RY=1trimrudder
Saitek_X52_Pro_Flight_Controller-ABC73591+AXE_RX=1pitch
Saitek_X52_Pro_Flight_Controller-ABC73591+AXE_Z=-1throttle
Saitek_Pro_Flight_Rudder_Pedals-8A3D3329+AXE_Y=1brakesrt
Saitek_X52_Pro_Flight_Controller-ABC73591+AXE_Y=1elevator
Saitek_Pro_Flight_Rudder_Pedals-8A3D3329+AXE_X=1brakeslt
Saitek_X52_Pro_Flight_Controller-ABC73591+AXE_X=1aileron
Saitek_X52_Pro_Flight_Controller-ABC73591+AXE_U=1mix
[ChatWindow]

 

 

BrakeCapture.JPG

Share this post


Link to post
Share on other sites
16 hours ago, Sokol1 said:

You don't have MFG Crosswind rudder axis assigned for Rudder control, should be the RZ axes, not Y axis like in pictures. See MFG axes names in this pictures:

 

LOL ;)...yes I understand that. That's why I posted my problem.

 

5 hours ago, 56RAF_Stickz said:

Or your feet are too heavy :). Hence my attempts to describe methods to move rudder without applying pressure to a pedal.

 

LOL...I even tried just pushing on the cross-member (not the pedals) with my big toe. Yesterday I ran MFG's Configurator to calibrate the pedals and confirmed I had the up to date firmware. Closed Steam and Blitz multiple times. Kept repeating the problem.

 

Today ran the Configurator again...calibrated pedals again. Fired up Blitz and it recognized the proper axis assignment. :yahoo:The only thing that changed as far as I can tell is that I shut down my PC overnight.

 

Many thanks to @56RAF_Stickz, @Sokol1 and @LLv34_Flanker for your assistance!

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

If they are not recognized at all: (I posted this elsewhere): Steam again is to blame, set input mapping to off:

 

CLoD Steam input mapping 2.jpg

Edited by jollyjack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...