Jump to content
Han

VR "fish-eye" trouble with normal zoom

Recommended Posts

I have this problem too:

 

1. Have you "fish-eye" trouble with normal zoom after 4.006d update? YES - exactly this. Example: Gauges appear to slide left a bit when I rotate my head right. New problem started today.

 

2. Which VR device model you have? Pimax Artisan. Tried with PP on and off - same result.

 

3. Have you d3d11.dll file in <game_install_folder>\bin\game\d3d11.dll folder? No it is not there.

 

4. Is PC restarting solving this issue? No, it did not help.

 

NOTE: My windows desktop is set for 4K, but my monitor is only 1080p (for VR recording/cropping reasons). I noticed that IL-2 auto-changed my in-game resolution setting to 640p after the update, and now will not allow 4K to be set any more like it was before. Tried 1080p in-game but still the fisheye problem exists. I would like 4K to be available again too, please.

Share this post


Link to post
Share on other sites
Posted (edited)
13 hours ago, rowdyb00t said:

2020_5_29__2_19_10.thumb.jpg.982e07646b5432862a2cbefffe88d4da.jpg

2020_5_29__2_19_17.thumb.jpg.3b5a99aba1371cfe0bce4e811fe7a91b.jpg

 

Make sure this setting is set to your native monitor setting. Not sure why or how, but its fixed.

 

I tried it. It's not fixed.

 

I've set my monitor to 1900x1200 and it did reduce the Fov a little bit. But it's still not 1:1. 

 

I can tell by turning my head 90 degrees and I can pretty much see fully my 6 o'clock. That's not possible in real life. The FoV is f&%^ up, it's way too much than in reality, hence I get this 'fishbowl' effect.

13 hours ago, rowdyb00t said:

2020_5_29__2_19_10.thumb.jpg.982e07646b5432862a2cbefffe88d4da.jpg

2020_5_29__2_19_17.thumb.jpg.3b5a99aba1371cfe0bce4e811fe7a91b.jpg

 

Make sure this setting is set to your native monitor setting. Not sure why or how, but its fixed.

 

it does help a little bit but it doesn't solve it 100% in vive. The FoV is still way too wide.

Edited by Count_de_Money

Share this post


Link to post
Share on other sites
3 minutes ago, Count_de_Money said:

I've set my monitor to 1900x1200 and it did reduce the Fov a little bit. But it's still not 1:1.


So your native monitor setting is 1900x1200? That you need to make sure. My monitor is 4k at  3840x2160 that’s it’s native. I can set it to any resolution I want but it’s still 3840 pixels by 2160 pixels. 

Share this post


Link to post
Share on other sites
19 minutes ago, rowdyb00t said:


So your native monitor setting is 1900x1200? That you need to make sure. My monitor is 4k at  3840x2160 that’s it’s native. I can set it to any resolution I want but it’s still 3840 pixels by 2160 pixels. 

yup... it's what the game is showing as he maximum allowed resolution (and what my monitor supports).

 

I think there's some discrepancy between the FoV the HMD can render and what the game forces it to render. Like I'm no longer seeing 110degree (VivePro advertised value) but 120 or more degrees... It's similar if you set your monitor to display a wider fov.. but in VR hmd.. it's a weird feeling, especially when you take it off your head.

Share this post


Link to post
Share on other sites
5 minutes ago, Count_de_Money said:

think there's some discrepancy between the FoV the HMD can render and what the game forces it to render. Like I'm no longer seeing 110degree (VivePro advertised value) but 120 or more degrees... It's similar if you set your monitor to display a wider fov.. but in VR hmd.. it's a weird feeling, especially when you take it off your head.


  Odd that didn’t fix your problem. I have the Vive pro as well. Maybe you can try 1920x1080 in your game settings? Or any other for that matter. 

Share this post


Link to post
Share on other sites
23 minutes ago, rowdyb00t said:


  Odd that didn’t fix your problem. I have the Vive pro as well. Maybe you can try 1920x1080 in your game settings? Or any other for that matter. 

 

i tried 1080p and it "seems" like it helped, but I have no idea anymore since I've been playing/testing it for 2 hours and I have pretty long VR legs, so I might've just gotten used to the effect. But as soon as I take off my HMD the real world just starts swimming in front of my eyes, i.e. there's definitely some discrepancy somewhere...

Share this post


Link to post
Share on other sites
6 minutes ago, Count_de_Money said:

But as soon as I take off my HMD the real world just starts swimming in front of my eyes


 I know the feeling. What is type of monitor do you have?

Share this post


Link to post
Share on other sites

1. No

 

2. HP Reverb 90 Hz

 

3. No

 

4. No need

 

However I've notice that the IPD setting in the startup.cfg file don't match IPD setting in WMR.
MWR has IPD 63,5 and startup.cfg file read 0,06315 which I interpret as IPD of 63,15. Am I correct?

Share this post


Link to post
Share on other sites
Posted (edited)

EDIT: I can confirm the problem exists for Normal and Large Fov on Pimax.

 

1. @Han My zoom still does not work at all because I use a Pimax. But, even worse, now the regular view's perspective is off. It is as if the entire FOV has increased. I can tell because the wings are now canted forward too much. Even adjusting the in game IPD does not fix this. Also, I set my in game resolution to my monitor's native resolution. The problem persists.

 

2. Pimax 5K+

 

3. No file.

 

4. Problem still persists after restart.

 

Han, this is a valiant effort, but would it be possible to offer an option for those of us having a major problem with how the game is rendering to use the earlier configuration from the prior update? I can live without zoom for now, if it means I can return to how the game was rendering yesterday. I have to say, I had the game looking and running the most smooth it has ever been. I have been playing through Achtung Spitfire and Career Mode while this zoom issue has been addressed. As of now, with a Pimax 5k+, the game is unplayable at all. Please allow the earlier rendering solution for those of us still having the fishbowl effect (unless this effect can be negated).

 

Thanks!

Edited by SCG_redcloud111
  • Upvote 2

Share this post


Link to post
Share on other sites
Posted (edited)

1. Yes on the Fish-Eye  🤢🤮
2 Pimax 5K+

3. Nope, file is not in this directory.

4. Nope.

 

I would add - I do not get the fish-eye effect in the main menu hangar screen, only when flying. Not a big surprise there, but that's something.

 

Edited by RampantCoyote
  • Upvote 1

Share this post


Link to post
Share on other sites

1. no fish eye but have had to set my fov to small or i am too close to dashboard also i have to use parallel projections or the vr zoom is gives me double vision 
2 pimax 5k+
3. yes 
4 no   

Share this post


Link to post
Share on other sites
Posted (edited)

1.yes, but it seems that the view is already zoomed, and that i am much nearer to the Instruments and revi-making me a Little bit Dizzy (fovnormal 150grad)

2.pimax 5 k plus

3.no

4.no

 

when you turn parallel projections off, Instruments and Cockpit are much smaller but not ok like before and zoom is not usuable strange view

 

 

Edited by II/JG11ATLAN_VR

Share this post


Link to post
Share on other sites
8 hours ago, Han said:

Friends,

 

If you're using VR device, than please note here:

 

1. Have you "fish-eye" trouble with normal zoom after 4.006d update?

 

2. Which VR device model you have?

 

3. Have you d3d11.dll file in <game_install_folder>\bin\game\d3d11.dll folder?

 

4. Is PC restarting solving this issue?

 

1. No fish eye problem at all

 

2. Oculus Quest

 

3. Yes, the d3d11.dll file exists in my ...\bin\game\ folder.

 

4.  I did restart my PC as a matter of best practice after an update

 

Zoom works very nicely now, thank you!  It's a tad too zoomed in for reading gauges, but I mostly use zoom in the cockpit to read the pilot's notes from Storebror's IL-2 Great Battles Pilots Notes for Cockpit Photos v1.02 mod.

Share this post


Link to post
Share on other sites

1. No

2. HP Reverb

3. No

4. No PC Restart needed since no issue

 

Everything is working great, very smooth.

Share this post


Link to post
Share on other sites
Posted (edited)

1. Have you "fish-eye" trouble with normal zoom after 4.006d update? Yes

 

2. Which VR device model you have? Pimax 5K+

 

3. Have you d3d11.dll file in <game_install_folder>\bin\game\d3d11.dll folder? Will have to check in the morning

 

4. Is PC restarting solving this issue? No, tried several times

 

Of note, the fisheye appears to go away when I use the "potato" setting (e.g. extremely narrow FOV) in PiTools. But that defeats the point... as it is since the update, I find the game unplayable in VR. As others have noted, it is only when in the cockpit... when in the main/hanger screen, everything appears normal.

Edited by Reaper02

Share this post


Link to post
Share on other sites
Posted (edited)

 

I added 5th question:

5. How is view in hangar?

 

A) Parallel projections off (as it should be)

1. No fish eye, but wrong convergence; my left and right eye do not see at same spot in infinity

2. Pimax 5k+, max. fov, pp off

3. no

4. no

5. In hangar normal view, nothing wrong

 

B) Parallel projections on (as expected performance ca. 30% lower)

1. yes, Fish eye present, but convergence correct

2. Pimax 5k+, max. fov, pp on

3. no

4. no

5. In hangar normal view, nothing wrong

 

 

EDIT!!!!!!! I was talking about views without zoom, they are wrong, and that is now main problem. Zoomed views are also wrong, of course.

Edited by Brzi_Joe

Share this post


Link to post
Share on other sites

1. yes fish-eye;

2. Odyssey+;

3. no file;

4. no

 

Share this post


Link to post
Share on other sites

1. No

 

2. Valve Index

 

3. No

 

4. Not applicable

 

@Hanit is a very nice improvement, thank you very much.

Share this post


Link to post
Share on other sites
Posted (edited)
51 minutes ago, Reaper02 said:

Of note, the fisheye appears to go away when I use the "potato" setting

 I can confirm this. Also, small FOV seems also to be nearly acceptable. The wings still seem slightly canted forward. The problem is that I don't fly in small, only Normal.

 

For anyone interested, Pimax offers: potato, small, normal, and large as fov options.

Edited by SCG_redcloud111

Share this post


Link to post
Share on other sites
Posted (edited)

1. No

1. HP Reverb

3. No

4. Everything work perfectly. Last win10 update (19041.264), 60hz mode, (my ipd is 64mm-maybe this matters).

Edited by airsheep_VR

Share this post


Link to post
Share on other sites

It's interesting how differently this manifests for everyone. For me it looks as though the FOV is narrower, like there was some zoom even in default view. On top of that, things move in an unnatural way when looking around. It is, as some other users have reported, quite nauseating. I don't normally have issues with nausea.

Setting the resolution in the game settings to monitor default, which for me is 1920 x 1200, has helped some. After that I've forced the resolution to 4K in startup.cfg and it appears this solved the problem. How much it costs in performance I've yet to find out.

 

My HMD is an original Vive.

 

 

 

 

Share this post


Link to post
Share on other sites

1. Have you "fish-eye" trouble with normal zoom after 4.006d update? -YES

 

2. Which VR device model you have? - Vive Pro

 

3. Have you d3d11.dll file in <game_install_folder>\bin\game\d3d11.dll folder? - No

 

4. Is PC restarting solving this issue? - Nope

Share this post


Link to post
Share on other sites
11 hours ago, Han said:

1. Have you "fish-eye" trouble with normal zoom after 4.006d update?

Yes, non zoomed and zoomed - prior, I just had to close an eye when zoomed in.

 

2. Which VR device model you have?

Pimax 8K

 

3. Have you d3d11.dll file in <game_install_folder>\bin\game\d3d11.dll folder?

No but I have DXbackend11.dll instead - does that count??

 

4. Is PC restarting solving this issue?

No.

 

To expand the non zoomed view is now like the zoomed view of previous versions.  This leads to perspective warping on the horizon draw distance and when in cockpit, wings like on the Yak 1/P51 (tested so far in QMB)  look like they are swept back Mig15 style.

 

In game interface and menus are normal.

 

Windowed resolution changes did have some effect on this but my VR rig has a 1440p monitor so I am not sure I can dial in 4K res on it but I tried it in the startup.cfg file and no difference.

 

If this update works for people, great.

I use the 8K Pimax in Large FOV mode.

 

I would also like to comment on the 4.006c zoom/Id issues people were talking of even though I am not an "Engineer" by profession - I work in Large Format Photographic Printing and Medical Educational Digital Printing business and do I Print based Graphic Design as well.

 

SweViver in his demonstrations has shown the Pimax 8K to be one of the weaker headsets in image quality in a 6 VR headset comparison, weaker than the Pimax 5K of which many, based on his findings purchased.  https://youtu.be/2GMXS5WXb44

 

Even still, I found I could with my Il2 settings Id enemy fighters without zoom at a range of 500m and with the previous zoom at a range of up to 2kms.  I also in the last half year, not had any issues reading my cockpit instruments in normal non zoomed view.

 

Those who were having issues with the old setup either needed to check their VR SS settings in relation to their headsets native displayed resolution or see an optometrist.

I know VR techs will espouse how lens distortion profiles render displayed resolutions mute due to pixel warping in profiles but at the end of the day - running a display at a resolution that is not related to the native resolution the screen displays is a recipe for a crap image, regardless of the lens dumped in front of the screen.  The problem I found with tuning the Pimax 8K was that Pimax would not tell us how much of the 4K screen resolution was utilised and now much was not for IPD and vertical alignment purposes.  I have come to find at native it is 1988 vertical resolution to the screens actual 2160 vertical resolution or approx 92% screen utilisation.

 

There was however - noted, issues with online Multiplay whereby aircraft would not be visible to the player but this was more a server / client data issue not a view / zoom issue and at times, turning on track recorder would rectify the issue.

 

A nice go between for now would be for the inclusion of an option in the graphics settings for VR to have the new FOV or the original.

 

Ironic how yesterday I started a topic espousing the brilliance of Il2 in VR only to since then have an update that has messed that up. C'est la vie.

 

VR Comparison by SweViver.png

dxd11.png

SteamVR resolution.png

Pimax settings.png

Share this post


Link to post
Share on other sites
  1. No
  2. Valve Index
  3. No
  4. No need.

VR Zoom works SO well! Just perfect. Feels like monitor zoom. Thanks so much.

Share this post


Link to post
Share on other sites

1. Yes

2. Pimax 5K+

3. No

4. No

 

1. Yes, it is slightly distorted

2. Reverb, set to 68mm IPD in its software (natural IPD 69mm)

3. No

4. No

 

1. No

2. Cosmos Elite

3. No

4. No

  • Like 1

Share this post


Link to post
Share on other sites

1. Have you "fish-eye" trouble with normal zoom after 4.006d update?

Fisheye in no zoom when "normal" or "Large" Fov are selected in Pitool. No zoom and zoom OK when in "small" FoV.

Parallel projection must be on in  Pitool (that reduce fps and image quality 😞 )

 

2. Which VR device model you have? -

Pimax 5K+

 

3. Have you d3d11.dll file in <game_install_folder>\bin\game\d3d11.dll folder? -

No

 

4. Is PC restarting solving this issue? -

No

Share this post


Link to post
Share on other sites

1. Yes if trying to have the desktop resolution as it was pre-patch (feels a bit zoomed in and doesn't track head movements fluidly)
     No if resolution is set to monitor native.

2. Original VIVE
3. No
4. No

 

I was getting the Fish-Eye effect until I changed to native resolution, but I am now 2 or 3ft outside of my cockpit to the right of the plane! 
Resetting the VR view in game or through steam does nothing, simply floating there as if it's the default camera location.

 

It's not a tracking issue with my setup as everything is as it was pre-patch, all other VR games (and the IL-2 menus) are absolutely fine and tracking normally.

Share this post


Link to post
Share on other sites
13 minutes ago, i_r_olav said:

to the right of the plane

Which plane? Or any plane?

Share this post


Link to post
Share on other sites
Posted (edited)
15 minutes ago, Sneaksie said:

Which plane? Or any plane?

so it looks like just the I-16 at the moment (the one I've been playing mostly) I've checked 3 others and they all work fine so maybe it's an issue with that one plane!
I'll just go through the rest now and see if there are any others.

 

EDIT: it does appear to only be that one plane.

Edited by i_r_olav

Share this post


Link to post
Share on other sites

1.  No

2.  Valve Index

3.  No

4.  No need

 

 

von Tom

Share this post


Link to post
Share on other sites
Posted (edited)

1. Yes, Both Zoomed and Un-Zoomed.

 

2. Pimax 5k+, Pimax 8K

 

3. No

 

4. No

 

Sim is unplayable. Tried all the suggestions in this thread and it improves slightly but its still borked. I guess back to DCS for a while.

Edited by DAS_VillaiN
  • Upvote 1

Share this post


Link to post
Share on other sites

@c6_lefuneste Hey, do you have an idea of why this is happening? I am guessing they locked in a limiter to fov for even non-zoom rendering? I mean, this sort of problem is why we always had to use user-specified convergences when trying to zoom. Right? Each person had to dial in their own convergence based on their own ipds and the particular headset they were using. Thoughts?

Share this post


Link to post
Share on other sites
17 minutes ago, SCG_redcloud111 said:

@c6_lefuneste Hey, do you have an idea of why this is happening?

 

They decided to try and give VR users the same FOV default as 2D users have with then zoom on top or so my understanding is on the notes posted with the patch.

 

Workable solution would be original FOV with two zoom settings - original and then the new. My understanding would have been that at the normal view the game would use the FOV as given by the VR headset and that world scale would be 1 (real life size).  Then there would be zoom on top of that.

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

1. Have you "fish-eye" trouble with normal zoom after 4.006d update?

YES,I can't see normal fov,is like samll and not good;and if I use VR ZOOM,the Image separation becomes cross-eyed

2. Which VR device model you have?

PIMAX 5K+  SN:203 use 144HZ ,use normal  Tried with PP  off 

3. Have you d3d11.dll file in <game_install_folder>\bin\game\d3d11.dll folder?

yes it there

4. Is PC restarting solving this issue?

NO

 
Edited by =GW=a7610783

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...