Jump to content

Recommended Posts

1 minute ago, toratoratora said:

 

Would OC's INI SS setting override OTT SS setting? Or the other way around?

 

Not sure - I would only do one or the other though.  Only feature I used with Open Composite was to replace Steam VR for running my Oculus devices in.

Link to post
Share on other sites
  • 2 weeks later...

I have IL2 Steam version + OpenComposite app specific install. I run the game by launching the .exe file directly. Oddly, in the game I can't use any BoS aircraft (BoM, BoK, & BoBP) are fine. When I try to it says "The files are missing or corrupted". Any ideas?

Link to post
Share on other sites
  • 5 weeks later...
On 5/28/2020 at 10:48 PM, Pennix_LeGaulois said:

Did you add an "opencomposite.ini" file with a single line "enableAudio=False" in your [Il-2 BoX]\bin\game directory (same folder you installed the .dll) ?

 

I had to do that for IL-2 to work with open composite.

 

 

Thanks for that. Direct replacement of the openvr_api.dll with the 64bit version and then putting in that ini file tip got it working.

Link to post
Share on other sites
  • 2 months later...

I'm a convert to opencomposite.

 

To get mine to work, I downloaded the 64-bit dll, created an "opencomposite.ini" file with one line: "enableAudio=False", and put both in the [Il-2 BoX]\bin\game directory. (I renamed the original dll to preserve it just in case). I then ran the game in non-VR mode, selected Enable VR in the graphics menu, restarted the game, and it all worked except sound was now in my speakers not the headset. 

 

Changing the ini file to enableAudio=True didnt work at all (game didnt run) but selecting the Rift in the Windows Sound menu did.

 

Very impressed at the fps boost - I'm now playing 8v8 quick missions and fps stays at 80 almost all the time, whereas before it would dip down to 40. 

 

Question: is it possible to add other lines to the .ini to specify stuff like the supersampling (I'm not using OTT yet)?

 

EDIT: found my answer here

Edited by Gryphon962
Link to post
Share on other sites

Does anyone know how to make the audio switch from Windows default to headset on game start?

 

With 'enableAudio=False' it doesn't switch, and if you enter anything else (True, On, etc) then IL2 wont start at all.

Link to post
Share on other sites
23 hours ago, Gryphon962 said:

Does anyone know how to make the audio switch from Windows default to headset on game start?

 

With 'enableAudio=False' it doesn't switch, and if you enter anything else (True, On, etc) then IL2 wont start at all.

 

Solved it myself: the answer is to use the system-wide install, then it all works great, audio included, without any opencomposite.ini file at all. With it working by default, you can then add an opencomposite.ini file with an entry such as 'supersamplingRatio=1.1' if you wish. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...