Jump to content

Recommended Posts

Dear All,

 

Quick q - I have the OpenComposite system wide install, i.e. launch the exe, make sure the IL2 app is marked to be used with OpenComposite not Steam VR.

What is the best way of then launching IL2? I understand this should be through the Oculus store. I do that, but then, Steam launches. How should this be done?

 

Thanks for any tips!

Link to post
Share on other sites

Wondering this aswell. Is it only Steam launching or SteamVR aswell?

 

I have been fiddling with it and I managed to get it to work by cancelling Steam's startup after running from the IL2.exe but then I didn't have Steam content, only the content from the Il2sturmovik page, as if it was standalone. Launching this way gave me 10-15+fps boost but I don't have my Steam content. If I have Steam on SteamVR definitely appeared on my taskbar but then vanished so I am not sure if that's normal.

 

I'd love to know exactly how we're supposed to launch it with the Steam version.

Link to post
Share on other sites
2 hours ago, CF23Llama_Thumper said:

Dear All,

 

Quick q - I have the OpenComposite system wide install, i.e. launch the exe, make sure the IL2 app is marked to be used with OpenComposite not Steam VR.

What is the best way of then launching IL2? I understand this should be through the Oculus store. I do that, but then, Steam launches. How should this be done?

 

Thanks for any tips!

 

You can launch it through the Oculus store but certainly do not need to for anything.

When I start a flying session I prefer my Touch controllers remain in standby or off state, to save on batteries,  so I just have a shortcut to IL-2.exe on my desktop and launch it from there.

After Open Composite is selected, it will always launch with it in the Open Composite rendering.

 

Link to post
Share on other sites

I found that using the system wide install didn't work. (would still launch the game and steamvr)
So I made a backup of the original OpenVR_Api.dll in the Bin/Game folder. 
And replaced it with the x64 OpenVR_Api.dll downloaded from the Opencomposite page.

Then all you do is run the game as per normal from steam, and choose the "Run in steamvr" launch option, the game should launch, but steamvr will not.
If you ever want to go back to running the game through steamvr, just rename OpenVR_api.dll to something that you'll remember like OpenVR_api_Opencomp.dll. And bring your original dll file back.
 

Link to post
Share on other sites
On 5/26/2020 at 1:27 AM, PhunkaeG said:

I found that using the system wide install didn't work. (would still launch the game and steamvr)
So I made a backup of the original OpenVR_Api.dll in the Bin/Game folder. 
And replaced it with the x64 OpenVR_Api.dll downloaded from the Opencomposite page.

Then all you do is run the game as per normal from steam, and choose the "Run in steamvr" launch option, the game should launch, but steamvr will not.
If you ever want to go back to running the game through steamvr, just rename OpenVR_api.dll to something that you'll remember like OpenVR_api_Opencomp.dll. And bring your original dll file back.
 

 

Tried it, the game won't launch at all with the 64 or 32 bit .dll. It appears to start in steam and then just doesn't. Don't know what I'm doing wrong.

Edited by GearheadXII-A
Link to post
Share on other sites

My sequence with OComp is: steam on, launch Oculus tray tool, pick up rift S, touch sensor (the white light in eye area) to launch Oculus home, wait a second or two for home to load, launch IL-2 Vr from steam.   I can hear the voice from OTT loading the profile. Put rift on my head

 

works every time  for me    Give it a shot 

Edited by kuk111
Link to post
Share on other sites
26 minutes ago, dburne said:

Mine is two steps .

Launch Oculus Home then put headset on.

Launch IL-2.exe.

 


 mine is pretty much the same, I was just being thorough in my steps :)  I just click the launch from steam when I can still see haha 

 

home launching first was a key though. Earlier this week I noticed if Oculus home launched due to hitting Launch from Steam it would hang up. Endless 3 dot load thing. 

Edited by kuk111
Link to post
Share on other sites
22 hours ago, kuk111 said:

My sequence with OComp is: steam on, launch Oculus tray tool, pick up rift S, touch sensor (the white light in eye area) to launch Oculus home, wait a second or two for home to load, launch IL-2 Vr from steam.   I can hear the voice from OTT loading the profile. Put rift on my head

 

works every time  for me    Give it a shot 

 

21 hours ago, DD_Arthur said:

That’s what I do.

 

Okay, I'll give that a go. Maybe for me I need to start it via the Oculus Launcher. Launching via steam doesn't work with the DLL file for the game and it doesn't stop Steam VR from starting if I use the system-wide OpenComposite install. It's not the end of the world but an extra 10 frames would be nice!

Link to post
Share on other sites
11 minutes ago, GearheadXII-A said:

 

 

Okay, I'll give that a go. Maybe for me I need to start it via the Oculus Launcher. Launching via steam doesn't work with the DLL file for the game and it doesn't stop Steam VR from starting if I use the system-wide OpenComposite install. It's not the end of the world but an extra 10 frames would be nice!

 

Yeah especially as that is kind of the point of Open Composite to start with.

I assume you guys that are launching Steam are using the Steam version of the game.

Otherwise there is no reason at all to touch Steam.

Edited by dburne
Link to post
Share on other sites
On 5/27/2020 at 12:13 PM, GearheadXII-A said:

 

Tried it, the game won't launch at all with the 64 or 32 bit .dll. It appears to start in steam and then just doesn't. Don't know what I'm doing wrong.

Did you add an "opencomposite.ini" file with a single line "enableAudio=False" in your [Il-2 BoX]\bin\game directory (same folder you installed the .dll) ?

 

I had to do that for IL-2 to work with open composite.

Link to post
Share on other sites
3 hours ago, Pennix_LeGaulois said:

Did you add an "opencomposite.ini" file with a single line "enableAudio=False" in your [Il-2 BoX]\bin\game directory (same folder you installed the .dll) ?

 

I had to do that for IL-2 to work with open composite.

 

No I did not, I'll do that too! Thanks, I'll let you know if you've figured it out!

Link to post
Share on other sites
8 hours ago, dburne said:

Not sure why you guys are having to go through that, mine was just simply an install of the system wide application and worked beautifully from the start.

 

I also wish i knew, why. I'm not technically incompetent, but the system wide application simply didn't work. Regardless of what I try.
However, replacing the openvr_api.dll file works for me.

So, yeah, I dunno. PC's are weird.

 

Link to post
Share on other sites
On 5/28/2020 at 1:16 PM, dburne said:

Not sure why you guys are having to go through that, mine was just simply an install of the system wide application and worked beautifully from the start.

 

I dunno either. System Wide did nothing and replacing DLL didn't either. So now I'm trying the audio=false thing. Computers are weird and everyone has so much different hardware and software and settings it's no wonder bugs exist.

 

On 5/28/2020 at 8:48 AM, Pennix_LeGaulois said:

Did you add an "opencomposite.ini" file with a single line "enableAudio=False" in your [Il-2 BoX]\bin\game directory (same folder you installed the .dll) ?

 

I had to do that for IL-2 to work with open composite.

Well, tried that it did not work. Same deal no matter the order or where I start it from. It goes in steam to 'playing' and then back and never actually launches. I never see the red star on my task bar. Launching it any other way without the .dll in the folder just launches normally and so does SteamVR. I'm at a loss.

Link to post
Share on other sites

Sorry to hear you did not solve the issue.

 

I have a couple of additionnal (perhaps "stupid",please don't take offense) questions :

  • Did you get the 64bit of version of the .dll from Opencomposite ?
  • Did you replace the .dll installed by steam after each update (quite a lot the last few days) ? each time you performed a file integrity check ?
  • Is steam VR still installed on your computer ? from what I understand, opencomposite is bypassing some parts of steam VR but not all of them, and Steam VR still needs to be installed on your system.

 

As for launching the game, at least in my case I just start steam, clic play on IL-2 in my steam library and choose "Launch in VR". Steam VR doesn't start-up anymore, and the game launches in VR mode.

Link to post
Share on other sites
On 5/28/2020 at 3:48 PM, Pennix_LeGaulois said:

Did you add an "opencomposite.ini" file with a single line "enableAudio=False" in your [Il-2 BoX]\bin\game directory (same folder you installed the .dll) ?

 

 

Thanks, this did the trick for my Rift CV1. :)

 

Camo

Link to post
Share on other sites
6 hours ago, Pennix_LeGaulois said:

Sorry to hear you did not solve the issue.

 

I have a couple of additionnal (perhaps "stupid",please don't take offense) questions :

  • Did you get the 64bit of version of the .dll from Opencomposite ?
  • Did you replace the .dll installed by steam after each update (quite a lot the last few days) ? each time you performed a file integrity check ?
  • Is steam VR still installed on your computer ? from what I understand, opencomposite is bypassing some parts of steam VR but not all of them, and Steam VR still needs to be installed on your system.

 

As for launching the game, at least in my case I just start steam, clic play on IL-2 in my steam library and choose "Launch in VR". Steam VR doesn't start-up anymore, and the game launches in VR mode.

 

Hey, no shame in asking 'did you try turning it off and on again' or is it plugged in - crazy how often that's the answer. But yeah, I made sure all of the above was correct.

 

Without OC the game starts and I see the Steam VR icon and all that. I can change the settings. With OC SteamVR only appears for a second and then goes away. I can't change the settings or go into the task bar to find SteamVR. It is however in the task manager...

 

Is this how it is supposed to be? Cause all of a sudden I'm hitting 90+ fps (could be the newest update too).

 

5 hours ago, LLv34_Camouflage said:

 

Thanks, this did the trick for my Rift CV1. :)

 

Camo

 

Lucky duck!

Link to post
Share on other sites
On 5/30/2020 at 9:54 PM, GearheadXII-A said:

[...]

Without OC the game starts and I see the Steam VR icon and all that. I can change the settings. With OC SteamVR only appears for a second and then goes away. I can't change the settings or go into the task bar to find SteamVR. It is however in the task manager...

 

Is this how it is supposed to be? Cause all of a sudden I'm hitting 90+ fps (could be the newest update too).

[...]

 

When the game is running on opencomposite, I do not have the SteamVR windows. I never checked if it appears in task manager though.

 

When using Opencomposite, as far as I know, SteamVR setting are bypassed. If you want to adjust super-sampling or IPD, I suggets you do it in either oculus software or probably more efficient : Oculus Tray Tool, which allows you to set up specific profile per games.

 

Regarding your sudden performance boost :

  • If you had supersampling set up in SteamVR, it is no longer applied when using Opencomposite. Depending on the level of SS you had, it can appear as a huge boost ^^ (it recently happened to me : SS was not applied at game startup and I had +20% fps all of a sudden !)
  • Opencomposite is supposed to improved performances a bit compare to SteamVR (although I did not perform any comparison recently, but it was the case on my build in February)
  • 4.006 updates helped a lot for VR performances (I managed to bump my global setting from balanced to high while remaining at near identical fps compared to 4.005)

Hope this helps !

Link to post
Share on other sites
On 6/2/2020 at 12:42 PM, Pennix_LeGaulois said:

 

When the game is running on opencomposite, I do not have the SteamVR windows. I never checked if it appears in task manager though.

 

When using Opencomposite, as far as I know, SteamVR setting are bypassed. If you want to adjust super-sampling or IPD, I suggets you do it in either oculus software or probably more efficient : Oculus Tray Tool, which allows you to set up specific profile per games.

 

Regarding your sudden performance boost :

  • If you had supersampling set up in SteamVR, it is no longer applied when using Opencomposite. Depending on the level of SS you had, it can appear as a huge boost ^^ (it recently happened to me : SS was not applied at game startup and I had +20% fps all of a sudden !)
  • Opencomposite is supposed to improved performances a bit compare to SteamVR (although I did not perform any comparison recently, but it was the case on my build in February)
  • 4.006 updates helped a lot for VR performances (I managed to bump my global setting from balanced to high while remaining at near identical fps compared to 4.005)

Hope this helps !

It seems to be working well right now, not gonna mess about anymore! Thanks for the help!

Link to post
Share on other sites

I use open Composite system wide with my CV1and I have IL2 steam version. No need for Steam or Steam VR running. Create a shortcut from Il2.exe to desktop (when starting 1st time it connects with the steam account, after that no need for Steam)

My procedure:

 

1. Oculus home must be running

2. Start OTT and set settings like ASW or  SS (although it shows previous settings, they dont seem to apply 100% when just started)

3. Start il2.exe via shortcut

 

Works great with great performance

 

Link to post
Share on other sites
  • 2 weeks later...

thank you for this information my frame rate was about 60 off line and 39 - 45 max on line with middle of the road Graphix setting . Now I'm on 79-80 off line and 55-70 on line with full settings apart from grass! MSAA ON X4 SS set to 1.0 and ASW off all looks fantastic for rift s thank you all for the information. 

Link to post
Share on other sites
32 minutes ago, SR603-McMurdo_VR said:

thank you for this information my frame rate was about 60 off line and 39 - 45 max on line with middle of the road Graphix setting . Now I'm on 79-80 off line and 55-70 on line with full settings apart from grass! MSAA ON X4 SS set to 1.0 and ASW off all looks fantastic for rift s thank you all for the information. 

 

:good:

Link to post
Share on other sites

Just to add this as I had problems with using steam vr mine was 3 stage this works for me with oculus program running I have to start il2 on desk top it starts in 2d then I just pick use vr headset in game options grafix setting it restarts in vr works perfect after this if you see the hour glass in bottom right corner . Thanks again for all the help this is a game changer for me was on the brink of giving up and going 4K.

Link to post
Share on other sites
  • 1 month later...
23 minutes ago, TimJ147 said:

If i wanted to use open composite instead of steam vr, is the only way of changing SS and ASW settings though oculus tray tools ?

 

It can be done through the debug tool, but much easier to use Oculus Tray Tool with profile for the game.

 

Note also you can change the ASW setting whilst in the game by using the Oculus shortcut keys as follows:

 

Control-Numpad1: Disables ASW and returns to the standard rendering mode.

Control-Numpad2: Forces apps to 45Hz with ASW disabled. Depending on the application, you are likely to experience judder.

Control-Numpad3: Forces apps to 45Hz with ASW enabled. Enabling and disabling ASW will help you see the effects of ASW.

Control-Numpad4: Enables ASW. ASW will automatically turn on and off, depending on whether the app maintains a 90Hz frame rate. This will be the default rendering mode when ASW is officially enabled in the runtime.

 

For Rift S it would equate to 40/80 Hz rather than 45/90 Hz.

 

I myself use the Oculus Tray Tool with a profile for IL-2 for both my SS and ASW settings.

Edited by dburne
  • Upvote 1
Link to post
Share on other sites
31 minutes ago, TimJ147 said:

Thanks again dburne. Much less hassle using the open composite program . Just finishing with getting everything setup, are these settings still applicable with the latest patches                           

 

That looks pretty good Tim.  I'd only add a couple of things;  I'd have sharpen On when using VR and Exeter City bottled it in the play-offs as usual:(

  • Upvote 1
Link to post
Share on other sites

Open composite runs with ss at 100 percent as standard so I’d leave it like that initially and use the OTT to increase it as required. I’m using a 2070 and it runs at 1.2 no problem.

  • Upvote 1
Link to post
Share on other sites
1 hour ago, DD_Arthur said:

Open composite runs with ss at 100 percent as standard so I’d leave it like that initially and use the OTT to increase it as required. I’m using a 2070 and it runs at 1.2 no problem.

 

That is what I do.

Also agree to set "Sharpen" on.

I run SS at 1.2 in Oculus Tray Tool and get very good performance and nice image quality.

  • Upvote 1
Link to post
Share on other sites
8 minutes ago, TimJ147 said:

The only settings I have not changed now are Ui scale 100%, , anitialiasing fxaa,  antialiasing 4 and dynamic res factor full.

 

With your system try MSAA x2.

  • Upvote 1
Link to post
Share on other sites
2 hours ago, TimJ147 said:

Ive been looking through the forum to solve a minor issue I have found. Looking through the gyro gun sight i am getting some double vision. Is this to do with the prop ?

I think this is natural and an adjustment to get used to with VR with reflects real life: Focus on something near, the distance object behind it can blur/double. Focus on something far, the near onbject in-front if you will blur/double. There's threads about it on here with better explanations but the tips I got was to first adjust your default head position so the gun sight is more inline with your dominant eye rather than perfectly centred. Then, rather than closing one eye, or moving your head to see the sight, or trying to focus on both the sight and target, just focus your eyes on the target. If your head is in the right position then gunsight should just sort of "be there" due to how it's projected. 

Edited by rogueblade
  • Upvote 1
Link to post
Share on other sites
  • 3 months later...
On 5/28/2020 at 1:48 PM, Pennix_LeGaulois said:

Did you add an "opencomposite.ini" file with a single line "enableAudio=False" in your [Il-2 BoX]\bin\game directory (same folder you installed the .dll) ?

 

Just wanted to chime in with my own experience. I've used OpenComposite with IL-2 for a couple of years now, system-wide install, no issues. It's been a few months since I last played and I had to reinstall, and this time IL-2 just wouldn't start with OpenComposite at all. Steam would say it was starting, then it wouldn't, no error messages. Switched to the per-game install OC method, still nothing, until I did the above. Then it started just fine.

 

So yeah... never had to do it this way before, but I do now. Worth a try if anyone else is having problems.

Link to post
Share on other sites
  • 1 month later...

Digging up old post... I know... 😞

 

But my Quest 2 isn't working with per-game installation of Opencomposite 

 

I have done the following:

1. replace the openvr_api.dll in the GAME and VIEWER folders with 64-bit version of the Opencomposite DLL file

 

2. Start Oculus Link from my Quest 2, so it enters into PCVR 'Rift' mode

 

3. Start Oculus Home on Quest 2

 

4. Launch IL2 by either IL2.exe or the Launcher (ticking VR in Settings)... but then nothing happens!!

 

 

What am I doing wrong?

 

I also cannot do the system-wide installation as the OpenComposite Launcher file from the site below (supposedly it is the official one) contains a Trojan virus and it gets picked up by Windows virus protection:

https://gitlab.com/znixian/OpenOVR/blob/master/README.md#system-wide-installation

 

HELP please! 🙂 

28 minutes ago, toratoratora said:

Digging up old post... I know... 😞

 

But my Quest 2 isn't working with per-game installation of Opencomposite 

 

I have done the following:

1. replace the openvr_api.dll in the GAME and VIEWER folders with 64-bit version of the Opencomposite DLL file

 

2. Start Oculus Link from my Quest 2, so it enters into PCVR 'Rift' mode

 

3. Start Oculus Home on Quest 2

 

4. Launch IL2 by either IL2.exe or the Launcher (ticking VR in Settings)... but then nothing happens!!

 

 

What am I doing wrong?

 

I also cannot do the system-wide installation as the OpenComposite Launcher file from the site below (supposedly it is the official one) contains a Trojan virus and it gets picked up by Windows virus protection:

https://gitlab.com/znixian/OpenOVR/blob/master/README.md#system-wide-installation

 

HELP please! 🙂 

 

Got it working! Needed to add enableAudio=False to the INI file. But now it means that I can't hear audio from my Quest 2's headphones 😞

 

Still can't install system-wide setting though, because of the virus warning

Link to post
Share on other sites
37 minutes ago, toratoratora said:

Digging up old post... I know... 😞

 

But my Quest 2 isn't working with per-game installation of Opencomposite 

 

I have done the following:

1. replace the openvr_api.dll in the GAME and VIEWER folders with 64-bit version of the Opencomposite DLL file

 

2. Start Oculus Link from my Quest 2, so it enters into PCVR 'Rift' mode

 

3. Start Oculus Home on Quest 2

 

4. Launch IL2 by either IL2.exe or the Launcher (ticking VR in Settings)... but then nothing happens!!

 

 

What am I doing wrong?

 

I also cannot do the system-wide installation as the OpenComposite Launcher file from the site below (supposedly it is the official one) contains a Trojan virus and it gets picked up by Windows virus protection:

https://gitlab.com/znixian/OpenOVR/blob/master/README.md#system-wide-installation

 

HELP please! 🙂 

 

Got it working! Needed to add enableAudio=False to the INI file. But now it means that I can't hear audio from my Quest 2's headphones 😞

 

Still can't install system-wide setting though, because of the virus warning

 

 

Did you try it from here? Should not need to disable any audio.

https://gitlab.com/znixian/OpenOVR/blob/master/README.md#system-wide-installation

I used the system wide installer from here back when I was running my Rift S. Always worked great for me.

And yes I also used it with Oculus Link and my original Quest.

 

 

Link to post
Share on other sites
28 minutes ago, dburne said:

 

 

Did you try it from here? Should not need to disable any audio.

https://gitlab.com/znixian/OpenOVR/blob/master/README.md#system-wide-installation

I used the system wide installer from here back when I was running my Rift S. Always worked great for me.

And yes I also used it with Oculus Link and my original Quest.

 

 

 

Yes, that is the same link that I download the system-wide file from, and Windows Defender indicates that the .EXE file contains a virus.

 

I have tried again and again, without disabling audio on Quest 2, nothing happens after double clicking IL2.EXE, it is the only way to enter the game.

 

But yea, Opencomposite has given be a boost of around 15FPS, very impressed! 

Link to post
Share on other sites
3 minutes ago, toratoratora said:

 

Yes, that is the same link that I download the system-wide file from, and Windows Defender indicates that the .EXE file contains a virus.

 

I have tried again and again, without disabling audio on Quest 2, nothing happens after double clicking IL2.EXE, it is the only way to enter the game.

 

But yea, Opencomposite has given be a boost of around 15FPS, very impressed! 

 

Odd, I just downloaded it and scanned with Defender and it found no threats.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...