Jump to content
Han

Game version 4.006 discussion: Deferred Shading, Yak-9, SU-152, New Campaigns, 4K for 4 planes

Recommended Posts

Just wanting to express my thanks to the whole dev. team! Truly amazing work! Thank you so much guys!  :good:

Share this post


Link to post
Share on other sites

Intel 9900 5ghz gtx 2080 super, same situation like you Mastiff

Share this post


Link to post
Share on other sites

I noticed the VR restriction is very limiting in JU 88. You can not takehead down almost no forward movement and tight sideways. 

  • Like 1

Share this post


Link to post
Share on other sites
On 5/29/2020 at 4:45 PM, Redwo1f said:

Nope, not for me anyways...and not with the latest "e" patch. I know the attention has been on AMD and VR issues, so perhaps it gets a good looking at next week (fiingers crossed). Anyway, feel free anyone to add any info relevant in the the technical issues thread as I have reported this issue there:

 

 

 I still have this visual bug too

Share this post


Link to post
Share on other sites
10 minutes ago, UrrrrhhhhhWoutwocampe said:

 I still have this visual bug too

Apparently it is a known issue regarding the switch to Differed Shading -- and unfortunately given my responses to the thread in technical support from the first official person -- it isn't a big deal to them 😢

Share this post


Link to post
Share on other sites
1 minute ago, Redwo1f said:

Apparently it is a known issue regarding the switch to Differed Shading -- and unfortunately given my responses to the thread in technical support from the first official person -- it isn't a big deal to them 😢

 

Well I will give them the benefit of the doubt right now since they are working their asses off and its not the biggest issue really. To be honest I am more tired about the extremely redundant Bodenplatte german career than the blue halo actually!

Share this post


Link to post
Share on other sites
Just now, UrrrrhhhhhWoutwocampe said:

 

Well I will give them the benefit of the doubt right now since they are working their asses off and its not the biggest issue really. To be honest I am more tired about the extremely redundant Bodenplatte german career than the blue halo actually!

Well it has been eluded to that it was a trade off (and I guess means won't/can't be fixed (?)) - but depending on weather and lighting conditions, it ranges from "okay" at times to terrible at others (imho) - like radioactive space ships flying around in the distance -- that is my opinion and I am sorry if I offend anyone for having it.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello folks,

Since last update I have a lot of freeze, I'm playing only in VR : Pimax 5k+, intel 9900k and rtx 2080.

Before the last update I was playing ultra and everything was fine, not to say perfect.

Now I tried many things : new harddrive, new fresh win10, memtest86, ... and even in balanced it freeze.

It has become unplayable, I'm very sad of the situtation, I love IL2...

This is the only game which is crashing on my gaming rig, other demanding games like x-plane are running smoothly.

Is there any other than me that experience big freezes?

 

thanks.

 

Roman

Share this post


Link to post
Share on other sites
On 5/31/2020 at 5:43 PM, 159BAG_elegz said:

Hi everyone! After some update, perhaps 4.006e, I noticed a large drop in fps compared to the plain 4.006. Maybe it’s a coincidence with something else happened on my computer, so I am investigating. Could you please confirm whether you notice any change in performance?

Hello, Everyone.

I had unseen gains in fps with the update just prior to 4.006e and was very pleased. Now my fps dropped back to where it was before the major update with lots of stutters?

Share this post


Link to post
Share on other sites
11 minutes ago, RAECHERil2 said:

Hello, Everyone.

I had unseen gains in fps with the update just prior to 4.006e and was very pleased. Now my fps dropped back to where it was before the major update with lots of stutters?

First thing I think is to make sure your graphics settings are all the same as they were before, sometimes your settings get reverted during an update.

Share this post


Link to post
Share on other sites
5 hours ago, unreasonable said:

 

In my case it was already partially cured with a usb 2.0 powered hub, the newer one just seems all-round less  cranky. It is the powered part that I think did the trick.

I use Windows 7 and live somewhere where the electricity supply can can a little temperamental: it may not work  for you.

It's worth to try, that's why i posted the issue.....it may be on my part and ppl here can give me advice and solution and if it's on game part i give feedback to improve the product.

Healthy forum/customer/product relationship.

Anyway it's not something that happens regular or on daily basis so i can live with it!

Share this post


Link to post
Share on other sites
1 hour ago, Redwo1f said:

Well it has been eluded to that it was a trade off (and I guess means won't/can't be fixed (?)) - but depending on weather and lighting conditions, it ranges from "okay" at times to terrible at others (imho) - like radioactive space ships flying around in the distance -- that is my opinion and I am sorry if I offend anyone for having it.

 

Well sometimes it looks so blurry it feels like you were fighting underwater. 

Share this post


Link to post
Share on other sites

I'm having severe stuttering in MP. Tested on WOL and CB training servers and is really a lot of stutters, no matter if there are many planes near or not.

Share this post


Link to post
Share on other sites
11 hours ago, Redwo1f said:

Apparently it is a known issue regarding the switch to Differed Shading -- and unfortunately given my responses to the thread in technical support from the first official person -- it isn't a big deal to them 😢

 

I very much doubt that. The team are a bunch of perfectionists. The problem is solving something like that might involve a total graphics engine overhaul. It's not an easy thing to do... deferred shading has changed the effect a little but not completely. Other sims suffer from this problem in different ways as well (in DCS it's reflected water at certain angles and War Thunder has a similar fuzzy effect in clouds as two examples).

Share this post


Link to post
Share on other sites
Posted (edited)
8 minutes ago, ShamrockOneFive said:

 

I very much doubt that. The team are a bunch of perfectionists. The problem is solving something like that might involve a total graphics engine overhaul. It's not an easy thing to do... deferred shading has changed the effect a little but not completely. Other sims suffer from this problem in different ways as well (in DCS it's reflected water at certain angles and War Thunder has a similar fuzzy effect in clouds as two examples).

 

Only basing what I said based upon the responses I was given by the Q&A Manager in the Technical Support forum (go see what was said) - and that has been the only official word on the issue to date (and I am not saying the team doesn't do a terrific job and aren't perfectionists - only that it was pretty much stated that it was the trade off of going to DS (as the QA Manager responded)).

Edited by Redwo1f

Share this post


Link to post
Share on other sites

Hi

i have this problem only on the aircraft aerial wires! I don’t understand that it’s a trade off from deferred shading as mine only started after the hot fix C. Please don’t get me wrong, the developers do a fantastic job of supporting this excellent flight sim 👍🤝

Share this post


Link to post
Share on other sites

Thank you devs for a beautiful update

Share this post


Link to post
Share on other sites
20 hours ago, 71st_AH_Mastiff said:

 

MSAA x4 NVCPL, FXAA off GAMA off. 

 

I have noticed using this setting is good, but very blurry on a VR,

 

When I use FXAA very bad aliasing occurs. even when the FXAA and GAMA is off in NVCPL.

nvcpl44614.jpg

nvcpl44614pg2.jpg

nvcpl44614pg3.jpg

Thanks for the suggestion Mastiff, I remember you from the ATAG forum. You were the "Graphics Guru" there too. What happened to the ladies in your profile photo ?

 

Anyway, I tried your settings but it didn't improve the aliasing for my set up. 1080p on a 40' TV probably makes the jaggies stand out more than higher resolutions on smaller displays, especially the runway edges and airfield terrain.

 

I can live with that because I can spot and ID planes quite well. The anti aliaising works well with the contacts rendering in visual range. Distant spotting is quite difficult though. Was easier before 4.006. (I'm talking about normal "Expert" visibility, not the Alternative Visibility)

 

Any ideas for the contacts that balloon in the clouds ?

 

Thanks

 

Prey

Share this post


Link to post
Share on other sites
11 hours ago, ECV56_Lubermatz said:

I'm having severe stuttering in MP. Tested on WOL and CB training servers and is really a lot of stutters, no matter if there are many planes near or not.

Same here, a lot of stuttering since the latest hotfix, game ran smooth before that.

Share this post


Link to post
Share on other sites

well were still keeping at it so might have some more optimizations in the next update. 

 

I turned Gama back on and this helped with better color and 3D objects but yes AA will smooth it out but the contacts distance will decrease.

Share this post


Link to post
Share on other sites

A just flew a sortie and had zero stutters (other than when you first spawn in). Only difference was that it was night time - early morning.

Share this post


Link to post
Share on other sites
31 minutes ago, DrGreenthumbPhd said:

A just flew a sortie and had zero stutters (other than when you first spawn in). Only difference was that it was night time - early morning.

 

Sometimes the game stutters on first launch after a new update - maybe that was the case previously?

  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, fertito10 said:

Hello folks,

Since last update I have a lot of freeze, I'm playing only in VR : Pimax 5k+, intel 9900k and rtx 2080.

Before the last update I was playing ultra and everything was fine, not to say perfect.

Now I tried many things : new harddrive, new fresh win10, memtest86, ... and even in balanced it freeze.

It has become unplayable, I'm very sad of the situtation, I love IL2...

This is the only game which is crashing on my gaming rig, other demanding games like x-plane are running smoothly.

Is there any other than me that experience big freezes?

 

thanks.

 

Roman

Hello,

I think I've found what was causing the game to freeze, at last...

My pimax was runing at 72Hz, I turned it to 90Hz and everything is running smoothly now and with Ultra!!!!

Thank you very much for all the effort you took to help me.

Roman

Share this post


Link to post
Share on other sites

Mixed in here with everything else is the latest update to Windows 10 that came out last week, which includes a major feature upgrade for build 2004, and (optionally) changes to Windows Mixed Reality for VR.   Doesn't help troubleshooting and makes it easy to think the last game update did something it didn't do.   After the big update I definitely noticed changes in performance and had to dig in to the WMR update to set some things up again.

 

And of course an NVidia driver update last week as well just to add to the mix - although those are typically pretty painless. 

 

Share this post


Link to post
Share on other sites
1 hour ago, =[TIA]=Stoopy said:

Mixed in here with everything else is the latest update to Windows 10 that came out last week, which includes a major feature upgrade for build 2004, and (optionally) changes to Windows Mixed Reality for VR.   Doesn't help troubleshooting and makes it easy to think the last game update did something it didn't do.   After the big update I definitely noticed changes in performance and had to dig in to the WMR update to set some things up again.

 

And of course an NVidia driver update last week as well just to add to the mix - although those are typically pretty painless. 

 

I saw that driver update and elected not to install it just in case it futzed some things up. I'm kind of a 'ain't broke don't fix it' kind of guy when it comes to drivers. 

  • Upvote 2

Share this post


Link to post
Share on other sites
On 5/25/2020 at 10:37 AM, UrrrrhhhhhWoutwocampe said:

Whats up with the P-47? Its awful right now, so easy to shoot down.

 

I destroyed eleven yesterday in a single mission, eleven.

 

You shot down 11 AI P-47s on one ammo load?! I would like to see how that particular feat is done...got a track?

Share this post


Link to post
Share on other sites
8 minutes ago, MattS said:

 

You shot down 11 AI P-47s on one ammo load?! I would like to see how that particular feat is done...got a track?

Unfortunately no, but its true. I am not here to boast, I am here to help make a great game even better. Out of the 11 P47s I shot down, 10x had their double wasp catching on fire. The other was a lucky head shot from MGs. I shot down 3x P47s with only MG ammo left. 

 

Its not my best mission though, I shot down 10x russian birds in a single mission in a G4 without gunpods. Yaks and Lagg3s. I think its more impressive than shooting down 11x broken thunderbolts in a Dora.

Share this post


Link to post
Share on other sites
Posted (edited)
6 minutes ago, UrrrrhhhhhWoutwocampe said:

Unfortunately no, but its true. I am not here to boast, I am here to help make a great game even better. Out of the 11 P47s I shot down, 10x had their double wasp catching on fire. The other was a lucky head shot from MGs. I shot down 3x P47s with only MG ammo left. 

 

Its not my best mission though, I shot down 10x russian birds in a single mission in a G4 without gunpods. Yaks and Lagg3s. I think its more impressive than shooting down 11x broken thunderbolts in a Dora.

 

If you say it, I believe you but it is a hard pill to swallow on this end after struggling to take out damned Stukas in QMB. 

 

Also on a side note what happened with your username there, it's basically what I would imagine the text version of stroke would be 🤣

Edited by MattS

Share this post


Link to post
Share on other sites
Posted (edited)
8 minutes ago, MattS said:

 

If you say it, I believe you but it is a hard pill to swallow on this end after struggling to take out damned Stukas in QMB. 

 

Also on a side note what the hell happened with your username, it's basically what I would imagine the text version of stroke would be 🤣

 

Yeah....I am trying to edit it to replace the URRHHH by I./JG 52 but even though I save the modification it remains the same damnit. Can a mod help? 

 

Its also a hard pill to swallow when you hit a Gustav with 3x 37mm shells in your P-39, but still, even though its leaking coolant from both radiators and that you can see through the DB engine because of all the huge holes in it, it still outclimbs you and actually manages to run away and lands safely.

Edited by UrrrrhhhhhWoutwocampe

Share this post


Link to post
Share on other sites
Posted (edited)
2 minutes ago, UrrrrhhhhhWoutwocampe said:

 

Yeah....I am trying to edit it to replace the URRHHH by I./JG 52 but even though I save the modification it remains the same damnit. Can a mod help? 

 

 

 

Are you doing the name change in your actual account profile on il2sturmovik.com? I've had pretty good success with that. Good luck!

Edited by MattS
typo

Share this post


Link to post
Share on other sites
Posted (edited)
16 minutes ago, MattS said:

 

Are you doing the name change in your actual account profile on il2sturmovik.com? I've had pretty good success with that. Good luck!

 

 

I found that topic and clicked the link suggested by Hursty to edit the squad and replace it....doesnt seem to work

 

Edit : it worked finally

 

Edited by I./JG52_Woutwocampe
More info

Share this post


Link to post
Share on other sites
On 6/2/2020 at 10:30 AM, 216th_Jordan said:

 

Sometimes the game stutters on first launch after a new update - maybe that was the case previously?

So the problem was the server machine itself. The stutters stopped after it was restarted. Its an older machine running win7. 

  • Upvote 1

Share this post


Link to post
Share on other sites
On 5/29/2020 at 7:57 AM, 41Sqn_MADOV said:

The core issue  for you may have been solved. The sim platform has been rendered  unplayable for me. Different folks, different strokes.

 

I have basically the same problem...I CAN'T GET STEAM TO WORK!...it keeps going back to the PLAY position after about 5 seconds.

 

So no, I can't fly either.  This shouldn't be that difficult to fix...but it apparently is, isn't it?

Share this post


Link to post
Share on other sites
25 minutes ago, CTquicknthedead said:

 

I have basically the same problem...I CAN'T GET STEAM TO WORK!...it keeps going back to the PLAY position after about 5 seconds.

 

So no, I can't fly either.  This shouldn't be that difficult to fix...but it apparently is, isn't it?

Have you lodged a ticket with support?

Share this post


Link to post
Share on other sites
On 5/31/2020 at 6:43 AM, Raven109 said:

 

Perhaps a bit late, but to verify the integrity of the game files, right click on the game icon in steam, select Properties from the menu, select the LOCAL FILES tab, at the top, and then push the VERIFY INTEGRITY OF GAME FILES button. A window should pop-up and steam will start validating the files. If it finds anything wrong it will try to download the files again.

 

Not sure why steam doesn't do an integrity check automatically, even more so that lately it seems to be failing quite often at the first attempt.

Hey, Raven, thanks for the help on VERIFY INTEGRITY OF GAME FILES.  I ran it and discovered it WAS missing a file and the program said it would RE-AQUIRE the missing file. 

 

So, I ran it again, and the program then said  on VERIFY INTEGRITY OF GAME FILES that it now had all the files.

 

So, I hit the PLAY button...and after about 5 seconds with the program "trying" to start-up...it again bounced back to the PLAY buttion.

I then tried it a second time...and it failed again.

 

I wondering.  What if I uninstalled the program in Steam, and then downloaded it again?  Maybe then it would boot?

What to do you think, Raven?  (Also, I don't know where in Steam I can download this update.)  Thanks again, my friend...

1 hour ago, RedKestrel said:

Have you lodged a ticket with support?

No, I don't know where to lodge the ticket... 

Would you please let me know how I can get in touch with Support?  Thank you, Red!

Share this post


Link to post
Share on other sites
34 minutes ago, CTquicknthedead said:

Hey, Raven, thanks for the help on VERIFY INTEGRITY OF GAME FILES.  I ran it and discovered it WAS missing a file and the program said it would RE-AQUIRE the missing file. 

 

So, I ran it again, and the program then said  on VERIFY INTEGRITY OF GAME FILES that it now had all the files.

 

So, I hit the PLAY button...and after about 5 seconds with the program "trying" to start-up...it again bounced back to the PLAY buttion.

I then tried it a second time...and it failed again.

 

I wondering.  What if I uninstalled the program in Steam, and then downloaded it again?  Maybe then it would boot?

What to do you think, Raven?  (Also, I don't know where in Steam I can download this update.)  Thanks again, my friend...

No, I don't know where to lodge the ticket... 

Would you please let me know how I can get in touch with Support?  Thank you, Red!

Steam should automatically update your game. A full reinstall may help.

Here is where you contact support. You will need to log in to send them your problem.

https://il2sturmovik.com/support/

 

Share this post


Link to post
Share on other sites

Sometimes the steam version of the game requires a file verification procedure. I recommend   do this after each update. It often happens that one or two files from the old version are not updated.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 6/1/2020 at 4:17 PM, SAS_Storebror said:

 

"Ultra" is 100.00000 and you still have that butt-ugly grass "circle" around your plane when looking at it from outside, turning any screenshot into some kind of sit-in on an enlarged oriental grass carpet.

I'd love to have some kind of grass that would just be there, even it would just be static and not waving through plane parts like we have it at the moment.

As much as TC is concerned, to me the ability to turn off grass completely is almost like cheating.

Players with grass enabled can't see enemy targets which are plain visible for players with grass disabled and vice versa.

 

:drinks:

Mike

 

The Grass parameters in the settings like Normal Ultra, define a distance where grass is rendered. In the Ultra mode grass distance is 300 meters. This distance is too short still and gives this moving circle as you move in a grass field.

If you want this to disappear set in the setup.cfg file distance to 1000.0 meters. It is a little of an overkill. Doubling the circle radius makes the rendered surface quadruple. The sweet spot is probably around 600-700 meters. Anyway you do not see well the grass after a certain distance and LOD probably kicks also in. When you manually set a distance over 300 meters in the Game settings the Grass Quality parameter will become OFF.

 

This completely solves the visual problem. But the system needs to render and animate a much larger surface of grass and this will impact the FPS.

In my case it is not really an issue as I have basically the fastest CPU-GPU combination you can get with 64GB of very fast RAM. I play in full 4K and in extremely loaded scenarios I am still at a good 80-90 FPS. But for smaller less powerful machines it may be a frame killer and could impact playability.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, IckyATLAS said:

the system needs to render and animate a much larger surface of grass and this will impact the FPS

 

That's why I think we could use a much simpler grass model as soon as the view distance goes beyond let's say 50 meters.

From that distance, it doesn't make much of a difference whether grass is waving in the wind or not, and it doesn't make a difference whether each and every blade is a real 3d grass model or just a tube. Actually a randomly distributed array of static tubes on the ground would do for most of the time.

Within very close distance (TC anyone) the grass we have is fine, so at very close distance it could just remain as-is.

 

:drinks:

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...