Jump to content

Tool: using Dserver remote console from discord


super-truite
 Share

Recommended Posts

super-truite

Hello,

here is a little tool allowing to send commands to Dserver from discord. It can be used to manage players and send server inputs to trigger stuff in the missions.
It is a bit redundant with similar tools (ground commander, Sturmovik server control and maybe others I do not know), but I wanted something that could be used from discord and 
I wanted to play a bit with the remote console and discord bots. I do not know yet if it's useful, so feel free to suggest use cases I did not think of. I might improve it and make it more user friendly to install if I find a nice use case. It could be extended with more complex permission mechanisms with voting, with speech command etc.

 

The doc to install it is in the repository : https://github.com/Super-truite/il2_discord_bot

screenshots:

Capture.PNG.5a9bb5bee5c9aec757a456fd6584326d.PNG

 

Thanks again to those who help for the remote console commands: Coconut, Murleen, Sebj

 

Edited by super-truite
  • Thanks 1
  • Upvote 3
Link to comment
Share on other sites

  • 9 months later...

Hello. Thank you for your work.

I'm trying to make it run, but after several trials, and near the end (install, setup, bot OK, connected), every order I give allwasy the same answer (error):
 image.png.eef10b2ccfc8488cfb72cf12eef42471.png

This is a problem with unpackaging messages between console and bot. Quite weird since this package have not changed since your post.  

By the way there is a mistake in doc page here:

image.png.c388258faf04f69e139286c65e529528.png

It is not #, it is $

May be you can point me towards a solution.

Thx in advance

  • Thanks 1
Link to comment
Share on other sites

super-truite

Hello, I have tried to fix the problem yesterday but did not find anything wrong yet. I changed the doc and small things here and there but it will not solve the error.
We can try to solve it on discord if you want: https://discord.gg/FvzfA7Jp

  • Upvote 1
Link to comment
Share on other sites

super-truite

There was a bug (password and login were not loaded from the config file). It is fixed now. Thanks for pointing that out !
 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...