Jump to content
Sign in to follow this  
SCU_Server

Dedicated Server program crash version 4.005

Recommended Posts

Posted (edited)

I have just done a clean install of IL2 vers 4.005 plus the small dedicated server update today (35meg) on my dedicated IL2 server rig and Im getting a crashing server once the mission loads.

On the Dogfight server list I see less servers now so Is anyone else having an issue at all, i'm not getting an error on the server log as its a program crash, is no one else getting this ??, before the 4.005 update my dedicated server ran fine 24/7 with the odd crash every now and then.

Cheers

 

22:53:48    Remote Console service started on 192.168.1.100 port 8991

22:53:49    =====    DeathMatch mode    =====
22:53:49    =====    Dedicated server    =====
22:53:49    Brief info:
22:53:49        Max clients = 21
22:53:49        TCP: 28000, UDP: 28000, Downloader: 28100, U/D Limits = 1000/10000
22:53:49        Login with UserName 'kiwibirkin@gmail.com'
22:53:53    ... Login success
22:53:54        Server is being created
22:53:54    ... Server name 'DCSNZA-IL2-Server 2 Mission Testing'
22:53:54        Loading mission 'Multiplayer/Dogfight\RUS vs AI Kuban II Autum 1.00.mission' (Multiplayer/Dogfight\RUS vs AI Kuban II Autum 1.00)...
22:53:54        Server listener IP = '192.168.1.100'
22:54:54    ... Mission loaded successfully
22:54:55    Server succesfully registered on master server

I have now also tried the Dserver.exe on my gaming rig and this program just crashes as soon as the mission is loaded, its the same crash as on my dedicated server rig with no errors at all.

Edited by SCU_Server

Share this post


Link to post
Share on other sites

I have now narrowed this down to custom missions for Dogfight mode, the Dsever.exe runs the sample dogfight mission fine, any of my custom missions crash the Dserver.exe.

I have followed the std procedure I have in place for Il2 updates

In the ME I have re-saved all missions in the folder, then I have opened them in the ME and re-saved them to the Dogfight folder so all the correct files are generated along with the .list file, the newly generated 4.005 missions still crash the Dserver.exe with no crash log.

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/10/2020 at 1:01 PM, -DED-Rapidus said:

@SCU_Server, I need missions from you that cause a problem with the server.


Hi Rapidus thanks for getting back to me.

I have added the zips here minus the .mission file as that was to large, I have sent a PM too you also.

Both these missions crash the Dserver.exe once the mission loads successfully, I know these missions have errors in them when doing a integrity check in the mission editor but have always ran fine on my dedicated server for the last 2 years, I know they are heavy with AI and give warnings about the server being overloaded but as I have said, they have run fine and we have had a lot of playtime out of them.

I have several missions all based on the 2 included here, everyone kills the dedicated server, if you need anything else from me just let me know.

Cheers

Mission1.zip Mission2.zip

Edited by SCU_Server
  • Thanks 1

Share this post


Link to post
Share on other sites

Hi,

 

As PM'd, we also have a mission that crashes the server with the v4.005b patch.  Prior to that, it worked properly (afaik -- it was created by one of our former Admins a couple years ago)

 

Hope it helps you find the issue.

 

 

Regards,

 

wg-ressuply-routes-summer-02.zip

Share this post


Link to post
Share on other sites
1 hour ago, -NW-FourSpeed said:

Hi,

 

As PM'd, we also have a mission that crashes the server with the v4.005b patch.  Prior to that, it worked properly (afaik -- it was created by one of our former Admins a couple years ago)

 

Hope it helps you find the issue.

 

 

Regards,

 

wg-ressuply-routes-summer-02.zip 367.91 kB · 0 downloads

I tried your mission too Fourspeed, crashes my servers also.

Share this post


Link to post
Share on other sites

At first glance, it looks like the v4.005c hotfix now allows that mission to load properly again.

 

I'll keep an eye on it, but thanks, guys.

 

 

Regards,

4 ~S!~

Share this post


Link to post
Share on other sites

Hi the server update seems to have fixed the missions crashing, ill run all the missions that were crashing the sever over the next couple of days and report back...but so far it looks promising.

Thanks guys

Share this post


Link to post
Share on other sites

The latest hot-fix has fixed ever issue i had with the server crashing using the missions I host, thanks IL2 Team for getting on to this very quickly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...