Jump to content
Sign in to follow this  
Smeggles

GIMP Newbie: No option to add Alpha 1 channel layer mask on skin. What do?

Recommended Posts

Posted (edited)

Sorry I am new to Gimp / Photoshop, and don't know what I'm doing very well, but I could use your help.

 

I am attempting to edit the LA5FN Series 2 public skin from the public skins thread on the stickey. 

 

In many of the other skins the last steps I do after painting them are Flatten image, then Layer>add Transparency> select "mask" then "add layer mask", which brings up a dialog "initialize layer mask on", then I choose "Other" and am supposed to select "alpha channel" from the dropdown.  this is supposed to give me a nice glossy coat on my new skin.  And it has so far on all the ones i've edited.  I am able to do everything except the last part, because "Alpha 1 channel" is not selectable in the dropdown (nor is anything else) like on the other skins I have tried so far.  (if you have time and gimp you can try it on the skin yourself, maybe you can see what I mean)

 

This skin which is giving me problems does have an alpha channel, but I take it this is not the same thing as adding an alpha channel to the ship's mask  Is there an easy way to fix this?

 

I've managed to figure out a lot of things on my own so far but how to get it to allow me to make an alpha channel layer mask, is stumping me.

Edited by Smeggles

Share this post


Link to post
Share on other sites

Answering my own question in case anybody else runs into the problem:

 

Select channels tab, right click new, name it anything really (let's go with Alpha 1 since that's what everyone else does).  Then you'll need to right click on your new Alpha 1 channel then "edit channel attributes" set the opacity (I went with 55 because that's what the other skins I use use), then set the color (i went with typing in the HTML notation ff0000 since that's what the others use).

 

Then unless you already know what you're doing you'll want to find a suitable image for the mask.  it will look like the plane in the skin file, and will have been specially made for it.  You can use a blank grey square the same dimension as the skin if you want, but everything will be equally glossy if you do, even the chips, dirt, etc, so it'll look weird unless it's on a skin that's supposed to be a pristine plane with no dirt or chips or anything.  Open whatever you decided to use for you mask with gimp, select all, copy, go back to your other image and select your Alpha 1 channel, then paste, then go to Layer > anchor layer

 

that will put it in place.

 

If it's too glossy you can re-open the mask file you copied and lighten or darken parts of it then paste it back in the image.  There may be a way to edit the mask directly from the skin file once you've pasted it in, but I haven't found a way.

Share this post


Link to post
Share on other sites

Glad you got it sorted. Personally I use Photoshop so I couldn't really be of much help anyway but there are quite a few people who use GIMP, I believe.

Rap

  • Haha 1

Share this post


Link to post
Share on other sites
1 hour ago, Raptorattacker said:

Glad you got it sorted. Personally I use Photoshop so I couldn't really be of much help anyway but there are quite a few people who use GIMP, I believe.

Rap

I also use Photoshop, when I tried GIMP ... I got a headache ...
Rap, however I must say that our dear Smeggles, has a great rear!😜😊
Sorry Smeggles, I can't help you either.

 

  • Haha 2

Share this post


Link to post
Share on other sites
Posted (edited)

There is option, but before you need to save at gimp format, flatten image, and only after "the add layer > transparency > add aplpha channel" will light up. After export as .dds.

 

First: open .psd and save it as .xcf.

 

image.thumb.png.3d89302d9d15787b7c3b2dea58d1cdfc.png

 

Second: go image > flatten image

 

 

 

Third: go layer  > transparency > add alpha channel

 

Fourth: export as .dds

Edited by =BLW=Tales
  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Have you seen Smeggles! In this forum there is always someone who helps you!
Thanks = BLW = Tales!👍

  • Like 3

Share this post


Link to post
Share on other sites
7 hours ago, =BLW=Tales said:

There is option, but before you need to save at gimp format, flatten image, and only after "the add layer > transparency > add aplpha channel" will light up. After export as .dds.

 

First: open .psd and save it as .xcf.

 

image.thumb.png.3d89302d9d15787b7c3b2dea58d1cdfc.png

 

Second: go image > flatten image

 

 

 

Third: go layer  > transparency > add alpha channel

 

Fourth: export as .dds

 

Oh this is good advice, I will keep this on hand in case I ever run into this problem again

 

 

6 hours ago, geraki9 said:

Have you seen Smeggles! In this forum there is always someone who helps you!
Thanks = BLW = Tales!👍

 

My first foray into the forums has been very helpful, I think I will like it here!

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...