Jump to content
Alfaunostebas11

Problem with restarting the engine

Recommended Posts

I was developing a mission in which the player lands in an intermediate field, turns off the engine. Then after a while he turns it back on and takes off again for further goals.
For a while I was busy in other things, then taking up again the work on this mission, I realized that once the engine landed and turned off, it does not turn on again, while before it was all OK (and it seems to me not to have introduced substantial modifications…).
I also tried to stop the plane near a Service Area, but it doesn't start again.
For information the plane in question is the Bf.109 F-4.
Intrigued by this fact, I tried other situations in Quick Mission mode. The results are as follow:
1) With the airplane in Parking (engine off), after turning on the engine, I turn it off and on again without problems.
2) Always with the plane in Parking (engine off), I taxi, take off, make a circuit and return. I switch off and on again: everything OK.
3) With Runway airplane (engine on). I turn off and the engine does not start again.
4) With airplane in Runway (engine on). Take off, make a circuit and land. I turn off the engine and it doesn't start again.
5) With airplane in flight (engine on). I land, I turn off the engine and it doesn't start again.
I noticed that the ignition sequence of the engine stops at the first two stages: "first engine start" and "power on", then nothing more (the third stage for Bf-109 F4 should be "generator on") and therefore the engine does not start.
What catches my eyes is that the problem exists only when the engine is running at the beginning of the mission and not when we start with the engine off (about this I inform that in the realism preferences I have the flag on warmed engine).
I have also tried other planes and I can say that, for example, the LaGG-3 and the FW-190 do not present this problem, while other German planes such as the Bf-109 G2, Bf-109 G4 and Ju-87 have it.
This means that some planes cannot perform the Rearm / Refuel / Repair, or, better to say, they are able to do it, but then they cannot restart … (with the exception of the Ju-87, wich is able to restart…).
I would like to know, first of all, if it is some mistake on my part or if it is a bug (in this case to be corrected immediately by the developers ...).
Secondly if any of you had already discovered this problem and how you dealt with it.
Thanks, Stebas.

Share this post


Link to post
Share on other sites

I've had the exact same issue in my JG.52 career flying the Bf-109 where once you stop the engine it cannot be started again.  Going, as you said, for the Bf-109 F4, G2, and G4.
This seems to be relatively recent issue, as I distinctly remember around 9 months ago in the same career being able to stop the engine upon parking and then restarting it at a later time should one wish to.  I haven't found any solution.

Thankfully this issue doesn't apply should you cut the engine in flight for whatever reason lol.

Edited by Ram399
  • Like 1

Share this post


Link to post
Share on other sites

Thank Ram.

Among other things, I have confirmation that some time ago it worked and now no longer. Possibly the problem may have arisen collaterally to the update with the Rearm Refuel and Repair which has not been set up in a completely correct way ...

Share this post


Link to post
Share on other sites

I just did a test in quick mission  on the Moscow map with the F4. I started with the engine running on the runway. I then turned off the engine and was able to re start. I don't know what your problem might be, Do you have warmed up engine turned off in the difficulty settings?

BTW I'm happy to see you are making missions for IL2 BOX. I really liked the ones you did for the old IL2. 

Share this post


Link to post
Share on other sites

Thank Stolle. No, as I said i have the warmed engine in the realism settings. I cannot test the engine on/off in the BoM because I don t have it. But also Ram399 has had my problems.

Edited by Alfaunostebas11

Share this post


Link to post
Share on other sites

Doesn't the 109 series require an external battery pack? It doesn't have an onboard battery that allows you to start it by yourself. The 190 and others do have their own batteries. Maybe the developers tried to model this?

Share this post


Link to post
Share on other sites

I read in a previous message (i didn't take time to test, i must do it) that it doesn't work if you are using simple difficulty. It would works fine in expert difficulties. I fly in expert difficulty, and i always can restart my engine.

 

What is the difficulty you use ?

 

 

Share this post


Link to post
Share on other sites

Hi,

 

it's indeed related to the realism setings (Thruttle auto limit, Engine auto control, Radiator assisist and Cruise control)

you can read about this bug in the topic here, I found out a workaround that makes it possible to restart the engine again 

(as long as Cruise control is not enabled in realism settings):

 

Disable the automatics just before restarting the engine. 

Disable them by using (default:) Left shift+R, Lshift+N and Lshift+M.

After the engine started they can be enabled again with the same keys.

 

It affects all 109 Fs and Gs.

 

Edited by CorvusX

Share this post


Link to post
Share on other sites
Posted (edited)

Very well, it works... Thank you !

The key to set before restarting engine are: LShift+N, LCtrl+R and Lctrl+M.

Edited by Alfaunostebas11

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...