Jump to content
Sign in to follow this  
exlax

Can't map trim to hat switch

Recommended Posts

I have a Thrustmaster  TWCS throttle and want to use trim on the top hat switch but it doesn't work,, is there a restriction on using hat switches for trim? The hat switch works and I have functions mapped to the other hats on the the throttle.

Share this post


Link to post
Share on other sites

Afaik, there is no restriction for using a hat to trim.  I use a vkb modern combat grip for a stick and it has a combination hat (analogue/digital) I use for the same purpose.  But that hat (strangely for a hat) has two modes.  One analogue and one digital.  You have to press on the hat to switch modes.  I mention this because my trim only works in the correct mode.  Is it possible your throttle is similar in this regard?  I'm just guessing here.

Otherwise I'm at a loss.  I hope you find a solution and hopefully someone with the same throttle can offer better feedback.  Good luck.

Share this post


Link to post
Share on other sites
20 minutes ago, exlax said:

I have a Thrustmaster  TWCS throttle and want to use trim on the top hat switch but it doesn't work,, is there a restriction on using hat switches for trim? The hat switch works and I have functions mapped to the other hats on the the throttle.

 

What trim are you trying to set there and with what plane did you test it? Does the trim work on other buttons than the hat switch?

All the trims should be able to be mapped to hat switch, just be sure that you are assigning correct controls (for example stab trim axis for Bf-109 and not the elevator etc) and that the plane has that trim.

Share this post


Link to post
Share on other sites

I have pitch trim and roll trim assigned to the hat in game , it doesn't work in the P38 or P51. The trim does work using the keyboard. I don't have any more buttons available and wanted it on that particular hat so I had access without moving my hand.

Just noticed I put this in wrong forum, sorry.

Edited by exlax
misstyoped

Share this post


Link to post
Share on other sites

If I recall correctly, then there are different controls for "trim axis" and "trim" and my guess is that you have mapped "trim" and not "trim axis" controls.

You can still map the axis to buttons, but it is a different row in controls.

Edited by II./JG77_Kemp
  • Upvote 1

Share this post


Link to post
Share on other sites
1 hour ago, II./JG77_Kemp said:

If I recall correctly, then there are different controls for "trim axis" and "trim" and my guess is that you have mapped "trim" and not "trim axis" controls.

You can still map the axis to buttons, but it is a different row in controls.

This was it, I needed to map it as an axis not as buttons, Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...