Jump to content
Beebop

My Train Won't Start

Recommended Posts

Here's the setup:

A Complex Trigger is activated by the entry of a plane into it and sends an "OnObjectSpawned" Event Link to START Trigger Timer 2 Sec (ID 1438).
START Trigger  Timer 2 Sec is Target Linked to Train START and Train STOP Trigger Timers.
Train START Trigger Timer is set for 3 seconds and is Target Linked to Formation START which has Vehicle Forward chosen in Advanced Properties.
Train STOP Trigger Timer is set for 4 seconds and is Target Linked to Formation STOP which has Vehicle Stop chosen in Advanced Properties.
Formation START and Formation STOP are both Object Linked to the train.

START Trigger 2 Sec is also Target Linked to Train WP STOP, the only waypoint for the train.
Train WP STOP is Object Linked to the train.

 

It Looks like this:

1276528505_TrainStart_Sortie.jpg.142d27a558b70342941a92b86ab9d571.jpg

 

The Complex Trigger has the correct country set for the entering plane and that plane is in the Objects Scripts.

 

1471922323_ComplexTrigger.jpg.c46efa5d82aba3d6fb14a987675561a0.jpg

 

What have I done wrong/forgotten to do?

 

ADDENDUM:  Forgot to mention this is a Dogfight Mission if that makes a difference.

 

 

Edited by Beebop

Share this post


Link to post
Share on other sites

You do not need the formation commands to make the train move to the next waypoint. The "START Trigger Timer" triggers the waypoint and starts the train. See "Make a Train Follow a Route" on pg. 70 of the editor manual for the correct setup.

 

Re. the complex trigger:

  • The "Events Filter" entry at the top of the advanced properties has to match the "On Events Table" output at the bottom. Change your "On Events Table" entry to "OnObjectEntered".
  • Are you sure about all the scripts you specified versus the country you specified? Are all those different planes British? If not, remove the scripts from non-British planes from the list. 
Edited by JimTM

Share this post


Link to post
Share on other sites

OK.  Thanks for the input.
I read carefully your "Make a Train Follow a Route" on pg. 70 of the editor manual" but since I didn't need the intermediate stops I passed them over and just looked at starting and stopping the train.

So I removed the formation command and Target Linked the START Timer to the waypoint.  I left the formation Stop command in place as you made no comment about that.
In the complex trigger changed the event to "OnObject Entered" and event linked it to the START timer as before
I removed all planes and put in just the Tempest and set the country to Great Britain.
I flew the Tempest into the complex trigger radius and the train still didn't start moving.

 

A little background on the mission.
I am trying to make a mission where you can use various planes to practice attacking ground and air targets.  (air targets are another issue I won't get into here.)
Initially I had the various planes and their associated countries all in the complex trigger.  Maybe it doesn't work that way so I tried your suggestion and pared it down to one plane and the appropriate country.
As for the train, that very setup in the screenshot works in another mission.  Rather than risk a corruption by copying it from there into this mission I took careful notes on the working setup and duplicated them in this mission from scratch.

 

At this point my frustration level is at an all time high.  I just spent a week getting Stuka's to dive bomb an target and get Ju-52's to drop on a target.  Several people tried to help and it finally took Tip taking my mission and rewriting the logic to make them work.  I heartily thanked him for his efforts.  
Gut here's the deal, several others tried to explain what to do, including you Tim, but I was still unable to construct a working flight.  No one was able to explain the needed logic that Tip put in so I didn't get the hands on practice I needed to help me remember how to do it another time.
I guess I am too stupid to figure the ME out.  I get instructions, follow them to the letter and it still doesn't work.  I tried using the instructions in Prangster's manual, to the letter, didn't work.
You and Prangster have made in depth manuals that explain a lot but in your example for instance, you show how to make a trains that makes stops.  Lots of waypoints, tiriggers, subtitles...all I want is how to make a train move from point A to point B.  Then I would be interested in making stops along the way.  Prangsters manual too explains setups that are prioritized for his mission, not necessarily general instructions.  I can guess the response to that, something like "there isn't the time to go into that much work to explain both types of setups" or something like that.  I get it but not everyone needs to set things up in those manners.  Sometimes what is needed is a "here's how to get 'X' to go from A to B".

 

Here comes the part everyone will probably hate but I'm getting too effin' frustrated....
This mission editor is overly complex!  I understand it has to be to give the flexibility it allows but...there needs to be simple, easy to understand, reliable methods to get stuff wokring.  I have asked for documentation from the Devs, Tim you suggested by your link in response to that that more people need to but the game so the Dev team has the money to hire someone who can dedicate their time to that.  Fine, but in the meantime.
You have stated that you are not going to be updating your manual any time soon do to real life issues.  that's fine, I'm good with that.  Real life always comes first.  But no one has stepped up to the plate to take the reigns of updating ME documentation to the latest version.  Many of the instructions are somewhat out of date in where crertain items can be found in dialogs, some items had not been implemented at the time of writing etc. etc.
It's been seven years since the game came out and yet still there are a lot of folks asking how do I do this and get a variety of answers, some work, some don/t.  What further frustrating is some of those answers work for the writer but no the recipient.  46 was at the time a complex editor to learn but even as a neophyte I had the basics down enough after three weeks to consistently make missions that worked.  I have been at this mission editor for two months, read everything several times over, tried different ways based on others suggestions and still....I can't seem to build a train that moves consistently. 

People have said that using the ME comes with time but in three months I feel I have made little, if any, headway.  I can't blame the editor you say so it must be me.   That only show what a complete thick headed idiot I guess I am .

 

I am sorry if I have offended you or anyone else by this rant, that really wasn't my intention.  It's just I am so g*ddamn frustrated.....

I love this game and I want to learn but I just don't have the brains to make a mission.

Share this post


Link to post
Share on other sites

Whenever you debug anything involving a complex trigger,  you always confirm that it is firing by linking it to a subtitle MCU.

Share this post


Link to post
Share on other sites

Thanks Cynical_Al.  (great name btw).  I guess they are not firing.  I linked the train complex trigger to one and nothing showed on screen.

 

Subtitle Advanced Properties: 

Coalitions: Allies True.  All others False.

Duration: 20 seconds

Font Size: 20

Vertical and Horizontal Alignments: Center

Tex Color: 0, 255, 0  (which should give me a green message)

Text:  All Aboard!

Train Complex Trigger Target Linked to Subtitle MCU

 

So my trigger isn't firing. 

I linked the trains complex trigger (set to Object Entered/Event Type: OnObjectEntered as suggested by Tim) to the "START Trigger Timer 2 sec" for the train.

 

Is that it?  I can't trigger events in a dogfight?

 

"The ME is a tool meant for developers. We released it to the public because users asked for it. "  So it looks like Tim's suggestion of buying more product will not change anything about the ME.  It's their tool "graciously" released to the proletariat.  Nice!  (so sorry if i ruffled some feathers)

 

 

 

 

Edited by Beebop

Share this post


Link to post
Share on other sites

Here is a simple train group photo. The train is set to enable, when the mission begins there is a timer that links to the waypoint, the waypoint then links to the train to get it moving. When it reaches the waypoint, it triggers the second waypoint. If your train is not set to enabled (train advanced properties), it would have to be trigger activated before the waypoint gets triggered. If you replace the mission begin mcu with your complex trigger it should work.

simpletrain.thumb.jpg.bcea28670fbe2b9e48906cdeb98ca859.jpg

Edited by No_85_Gramps
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks Gramps.

 

OK,  so I make sure Train is "Enabled".

I need two waypoints. One close to the train and one at journey's end.
Waypoint logic:
Mission Begin >TL > Timer id 135
Timer id 135 > TL > Waypoint id 132

Waypoint id 132 > TL > Waypoint id 131
Waypoint id 132 > OL > Train
Waypoint id 132 > TL > Trigger Timer id 130
Trigger Timer id 130 > TL > Waypoint id 131
Waypoint id 131 > OL > Train

 

Timers set for at least 2(?) seconds?

Is that right? 

I'll give it a try.

 

Share this post


Link to post
Share on other sites

You don't always need two waypoints. One at the stop point is generally enough, but I needed two here due to the severe curvature of the tracks (with only the last waypoint used the train would de-rail shortly after moving. One of those weird ME things...).

Think of enabled/disabled like this:  Enabled - train all steamed up and ready to move, enabled un-checked - train on the track but not steamed-up.

 

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Your logic works just fine.  I ditched the complex trigger and using your suggestion the train runs fine. 

I'm having the same problem with enemy planes, they don't spawn using the complex trigger.  I tried using Prangster's method and it didn't work.  I tried using pre-made groups, can't get them to work.  The main manual tells you how to take off and land put doesn't cover air spawns.  This is like wanting to learn how to change a flat tire.  You take it to the mechanic and ask "How do I change this flat?"  He says "Let me look at it", takes it into the garage, closes the door and a few minutes later brings out your car with the spare on it.  Great but I still don't know how to change the tire.

I guess I'll dispense with complex triggers in this mission and just give the AI a crapload of waypoints.

 

It's a pity that we have the ability to trigger events but it's sometimes hard to make it happen reliably.  Reading the manuals tells you a lot but they are old and outdated in many respects and sometimes don't give you the basic how to get X from A to B.  and since the Dev's seem uninterested in giving the Community a more streamlined and user friendly interface I guess we'll just plod along making mistakes, (hopefully) learning from them and missions will take longer than they should to come to fruition.  I find it interesting that even seasoned ME users sometimes have trouble making things work.  In my opinion that shouldn't happen.

And I just can't keep coming to the Community whining "my mission won't work" and expect someone to do it for me.  That's lazy on my part and if I keep coming to the well it will soon be dry.  I just want to learn how!  That's all.

Maybe I'll get enough brains to learn someday.

 

Anyway, thanks for your help Gramps.  ~S!~

Share this post


Link to post
Share on other sites

If you want to try the complex trigger look at this. I find it easier to just list the countries for detection. Now click on add event, select on object entered, and for the target select the timer that triggers the waypoint. US or GB plane flies within 1000m's, complex trigger fires, sets off the trigger timer  that triggers the waypoint that starts the train moving. Just replace the mission begin MCU with the complex trigger.

complextrig.jpg.c534972f970d01369160ff2a0d8a3edb.jpg

 

I, and many others, have struggled with the ME. It's complicated for sure, but with the help of others here, I started to slowly figure things out. And you can always ask questions! I asked quite a few myself when I first started.

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

BY JOVE I think that worked!

I've given up on starting the train with a complex trigger.  It's the Lapino map and at 40kph it takes a good long time to traverse the entire system.

However, I did as you suggested with my AI enemy planes at it works!  At least once.

I removed the Mission Begin and Event Linked the complex trigger to the timer that is Target Linked to the first enemy plane waypoint.  I entered the radius and VIOLA!  Enemy fighters.  The attacked the s**t out of me but hey, they spawned and they attacked.  Just what I wanted.

I'll need to test further to see if it's consistent.

 

THANKYOUTHANKYOUTHANKYOU!!!!! 

You have restored my faith that I can get enough brains to figure this out.

If I had my way and won the lottery, I'd offer you a handsome sum to update and clarify the ME manual. 😉

I'll let you know if I run into any issues.

Until then....

🏆🎖️👌👍

~S!~

Share this post


Link to post
Share on other sites

Glad it worked out for you. I wouldn't be were I am without the help of JimTM, Prangster, TIP, Gambit, and some others whose names I don't immediately recall. I still have a lot to learn, and it can be a struggle at times, that's for sure.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...