Jump to content
Spacebomber

Really strange graphical issue [RESOLVED: just needed to update GPU driver]

Recommended Posts

Hi, everyone!

 

I just got the game and on my first mission I saw a really strange graphical issue (see the attached images), I tried the first three graphical settings, I tried setting the options "manually", it didn't disappear with Vsync on and off neither. Tried deleting and reinstalling, tried restarting the computer. Tried playing the carrier and quick missions too. Could somebody help me fix it because I can't play, but if nothing works, then I can still get a refund. 

 

If you need more info, then I'll be eager to give!

 

Thanks in advance,

Spacebomber

20191226190803_1.jpg

20191226190807_1.jpg

20191226191110_1.jpg

20191226191115_1.jpg

20191226191116_1.jpg

20191226191117_1.jpg

20191226191119_1.jpg

20191226191133_1.jpg

20191226191142_1.jpg

20191226191151_1.jpg

20191226191154_1.jpg

20191226191203_1.jpg

20191226191204_1.jpg

20191226191205_1.jpg

20191226191207_1.jpg

20191226191208_1.jpg

20191226191215_1.jpg

20191226191221_1.jpg

Share this post


Link to post
Share on other sites

Hi again!

 

A little update:

I reinstalled the game for the 3rd time and before reinstalling, I deleted the things from Steam/steamapps/common/IL-2 Sturmovik Battle of Stalingrad. Now the flickering is a bit more rare (but it happens every 2 seconds) and it's now not really a flickering, it is that all the objects in the game disappear for some frames. But the print of the previous frame (that black phenomenon) is still there sometimes. (1. Attached image)

 

Please somebody help me, how to fix them!

 

Thanks in advance,

Spacebomber

20191227115231_1.jpg

20191227115213_1.jpg

Some more screenshots of the bug:

20191227120627_1.jpg

20191227120633_1.jpg

To anyone who is familiar here: Are the devs active?

Share this post


Link to post
Share on other sites

What type of GPU you have? It looks like it either can't handle the game or it's about to die.

Share this post


Link to post
Share on other sites

DxDiag_2019_12_27.txt

I have an idea: if I get a refund on steam and buy the game on the il2sturmovik.com, do you think it'll be better?

And brano, the game runs on about 30 fps on normal graphics, and other games run really good too.

Edited by Spacebomber

Share this post


Link to post
Share on other sites

No - this has nothing to do with Steam, and probably not with your installation. As Brano says, it is almost certainly your PC that is the problem, not the game, although I am not tech aware enough to say what exactly.

 

Can you play any other game with high graphics?

Share this post


Link to post
Share on other sites
7 minutes ago, Spacebomber said:

DxDiag_2019_12_27.txt 24.92 kB · 1 download

I have an idea: if I get a refund on steam and buy the game on the il2sturmovik.com, do you think it'll be better?

 

Well, according to your DxDiag your GPU (graphic processor unit) is a NVidia GT 1030 / 2GB Vram, which brings it a little bit to the point.

Your graphic card is very weak for this game. Have you installed the most recent drivers for your GPU? Get it there:

 

https://www.nvidia.de/Download/index.aspx?

 

image.png.77a41ea01ca90bd73183494bc7819d2e.png

 

Select your GPU as shown above. Then download and install it.

 

After you installed the driver correctly, you right-click on your desktop and select NVidia control pane.

 

NVidiaCP1.PNG.3030359f80da6e1ce8ce29e25ccdcb38.PNG

 

Here you I would suggest you to select the first option "Let the 3D application decide" to start with.

 

IN GAME: Select low graphics preset (on the left big button) and on the right set all to low to begin with.

 

Then restart the game and make some test in the Quick missions - if all is OK, you can slowly improve your graphical settings.

 

Cheerio

  • Like 1

Share this post


Link to post
Share on other sites

Before I saw -=-THERION 's comment, I set everithing to minimum, including the resloution (I kept the aspect ratio), it was still flickering. Then I uptadet the driver, ran the game, everything was really fine. Then I tried to set the resolution to my monitor's. I restarted the game and now it doesn't run, the loading bar at the beginning of the game just frozes near the start and doesn't do anything. Should I reinstall the game to get it working?

 

And really funny, icecream.

 

54 minutes ago, unreasonable said:

Can you play any other game with high graphics?

Yes, I can, and they run pretty well.

Edited by Spacebomber

Share this post


Link to post
Share on other sites
38 minutes ago, Spacebomber said:

Before I saw -=-THERION 's comment, I set everithing to minimum, including the resloution (I kept the aspect ratio), it was still flickering. Then I uptadet the driver, ran the game, everything was really fine. Then I tried to set the resolution to my monitor's. I restarted the game and now it doesn't run, the loading bar at the beginning of the game just frozes near the start and doesn't do anything. Should I reinstall the game to get it working?

 

And really funny, icecream.

 

Yes, I can, and they run pretty well.

 

No, this is for nothing, it won't help you to resolve the problem. Now, back to your first step:

 

- You installed the newest drivers, which apparently already helped. I suspect you did have any specific NVidia driver installed yet.

- You run the game successfully with the lowest settings, right?

 

OK, now what is your native monitor resolution right now (Windows screen resolution)?

 

Try to select the next lower resolution of your monitor's resolution and run the game in full screen because of different resolutions.

And don't push the graphics detail to much because, remember, you only got 2GB of Vram and another 2GB of shared memory.

 

I would start with the preset "balanced" and the set other options to low, f.ex. landscape distance at 40km. Most important don't

use HDR and SSAO - these options are a killer for low systems. Also, set shadows to simple and mirrors too.

 

P.S.: Reinstalling Windows operation system is BS. Not helpful nor will it help you.

 

 

NCP_2019_2.JPG.de2a3f6a78ff7ed77d569c9703db1189.JPG

 

In the NVidia control panel you may create a profile for IL2 and there change the Power management mode to "Prefer maximum performance".

Also, set vertical sync to "Use the 3D application setting".

 

N.B.: In your game graphical settings try to cap the FPS to 50 and don't switch "Vsync On".

Edited by -=-THERION
  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Spacebomber said:

You don't understand, I can't set the setting because in the beginning it doesn't load.

 

So you're saying your game doesn't even start now?

 

Well, please, can you look up for your configuration file "startup.cfg", which you should find in your game directory/data folder and attach it.

I will see, what the problem is.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Before I read your comment, I renamed the startup.cfg, so it doesn't work (I read on the internet, that it contains settings) and the game started normally. Then I set the settings, restarted it, it worked, tweaked the settings again and the game didn't run this time. I had to delete the startup.cfg again and it's now running normally.

 

It seems like if you set the settings and the game is in the mood then it won't start.

 

And I can't attach the .cfg files, and how could you open it?

Edited by Spacebomber

Share this post


Link to post
Share on other sites
17 minutes ago, Spacebomber said:

Before I read your comment, I renamed the startup.cfg, so it doesn't work (I read on the internet, that it contains settings) and the game started normally. Then I set the settings, restarted it, it worked, tweaked the settings again and the game didn't run this time. I had to delete the startup.cfg again and it's now running normally.

 

It seems like if you set the settings and the game is in the mood then it won't start.

 

And I can't attach the .cfg files, and how could you open it?

 

It has the file extension *.cfg, but you can actually rename it to startup.txt to attach it. Btw. you can open that file type using your notepad to read and modify it (careful!).

Just make sure not to change the name nor the extension type (cfg).

  • Like 1

Share this post


Link to post
Share on other sites

I just checked your first configuration file and modified it, because the resolution was set wrongly.

 

Maybe you can try with this file. Remember to rename it to "startup.cfg" and have a look.

 

startup.txt

  • Like 1

Share this post


Link to post
Share on other sites

Both I think - you need to be careful when you change the resolution of the game. It is also related to the "Full screen" mode.

 

Did you try now with my modifications?

  • Like 1

Share this post


Link to post
Share on other sites

Yes, everything works fine with it, but I have two questions:

1. Is full screen mode buggy or whats up with it?

2. Why did you set the fps cap to 50 and not 60, does that makes something better or just because?

Share this post


Link to post
Share on other sites
9 minutes ago, Spacebomber said:

Yes, everything works fine with it, but I have two questions:

1. Is full screen mode buggy or whats up with it?

2. Why did you set the fps cap to 50 and not 60, does that makes something better or just because?

 

1. Not buggy, but if you choose a different resolution from your native monitor resolution and switch back this may happen, when full screen is on.

2. I did it to avoid screen tearing, because with vsync on it would also avoid screen tearing, but with a lot of performance impact. With your graphic

    card it is better that way. And you may have some room for other tweaking of your graphic settings.

  • Like 1

Share this post


Link to post
Share on other sites

Ok, everything is working fine now, one last question: Do I need to set the controls manually? I can't find any button to auto-set the controls for my controller.

Share this post


Link to post
Share on other sites
4 hours ago, Spacebomber said:

Ok, everything is working fine now, one last question: Do I need to set the controls manually? I can't find any button to auto-set the controls for my controller.

 

Yes, you will have to configure you controller in the key mapping section.

Share this post


Link to post
Share on other sites
1 hour ago, Spacebomber said:

Every singe thing manually?

 

 

Are you taking about the button you want to use with your controller, right? Yes, you need to assign those functions to your buttons accordingly.

 

It is not the same as - f.ex. the majority of shooter games where you usually only use a keyboard and a mouse. In these games default settings

suit most of the players and there isn't that vast selection of different controller - just keyboard and mouse. Period.

 

But, if you look at flight sim gears, there are quite a bunch of different controllers - simple ones and very complex ones. What controller do you

have?

Share this post


Link to post
Share on other sites

I set the controls manually. Btw I use keyboard and mouse at the moment, in the near future I wil get a normal controller.

 

But the topic of this topic is resolved and there are 0 flickering and other bugs, thank you really much. It looks like I just had to update my driver.

Share this post


Link to post
Share on other sites
18 minutes ago, Spacebomber said:

I set the controls manually. Btw I use keyboard and mouse at the moment, in the near future I wil get a normal controller.

 

But the topic of this topic is resolved and there are 0 flickering and other bugs, thank you really much. It looks like I just had to update my driver.

 

Cheerio

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...