Jump to content
jollyjack

BAIT rules for waypoints and Ai planes ...

Recommended Posts

So i set 3 three sets of Ai planes in a mission.

 

1) A ju87 'platoon' flies OK starting 'in air' and drops it.s eggs alright, and got a city fire staring triggered by the bomb job thanks tips from JimTM and IckyATLAS about the Extended City Fire group protocol, and AttackArea command used with target links aimed on Linked Entry City Blocks.

 

2) Now another set of Ju88 planes, in air' start, with the same waypoint rules used: range, heights, distances, targeting and objecting all checked. They spawn alright, but keep cyrcling around the first waypoint.

 

3) Also a set of three Spitfires, player plane but manually set to Autopilot, take off OK from a runway. But they keep cycling around the first way point.

 

So the Q is, why sometimes it works without cycling, and why not in other situations. Plane related? Some extra parameters  need to be set? I am going crazy by now.

Edited by jollyjack
correction

Share this post


Link to post
Share on other sites

It is not clear to me what you are trying to do wit each aircraft type. Dive bomb, level bomb or guns attack on the ground

Are you linking more than one way point.

Are you using an attack command. 

Can you attach the mission of a image of the setup in the mission builder

  • Thanks 1

Share this post


Link to post
Share on other sites

The Ju87s dive bomb OK, height set to 800m. Command AreaAtack, target linked to Linked Entry blocks (buildings set to ground).

The Ju88s are set the same way, height set around 1000m.

 

Actually the Q was about Cycling, and i just found out i did not set 'OnPlaneTookOff' pointing to the first waypoints on route of the second, and third plane sets. Now the 2nd set of J88 still Cycle, but the Spitfires follow the route, but in a funny way, see pictures below.

 

I am still puzzling with this mission right now, so it might be useles to post any thing now .... thanks for the offer.

 

To liven up the show, never saw this before my Ai-ed Leader takes off into the air with  "NO HANDS MA" :

 

DareDevil pilot 01.jpg

 

 

DareDevil pilot 02.jpg

Edited by jollyjack
added

Share this post


Link to post
Share on other sites

Spitfire pilots occasionally fly with their feet sticking out of the bottom of the fuselage instead :)  Next time you open the mission they will usually be OK.

 

Cannot help on the circling problem : I have had planes do this even when I have copy/pasted a functioning plane and set of waypoints for multiple planes: most are OK but a few circle. Yet to see an explanation. You could try increasing the time on the trigger timer for the first waypoint in the group that is misbehaving. 

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Are they spawning over flat ground / do they have to fly over any mountains ?

I'm having bother with them over mountains - they seem to take their alt reading to the actual ground rather than sea level which causes them problems trying to match the waypoint alt, and possibly makes them think they can't get over the hill making them circle to gain alt first.

 

Share this post


Link to post
Share on other sites

Hey guys, i had this flock of Ju88s cycling at the first waypoint .....

 

Now i found this: i set this first waypoint to High (priority) with a range of 1000m TOUCHING the leader plane in air offset point, onplanetookoff set to this first waypoint.

 

Then set the Triggers Mission Begin AND timer addressing the first waypoint to the same 1500m height (MCU properties, Y axe) as the plane are set.

The next waypoint is about 60km further ...

 

Maybe it's important that the speed matches the normal flying speed of your chosen plane model. In this case i set all waypoints en route to 300km/h.

 

Behold, THEY OBEY; no more cycling now !

 

ADDED: i tried this with a new mission, and AAARGGHHHH, cycling again with spawned He111 Ai bombers ....

Edited by jollyjack
added

Share this post


Link to post
Share on other sites
22 hours ago, Zooropa_Fly said:

Are they spawning over flat ground / do they have to fly over any mountains ?

I'm having bother with them over mountains - they seem to take their alt reading to the actual ground rather than sea level which causes them problems trying to match the waypoint alt, and possibly makes them think they can't get over the hill making them circle to gain alt first.

 

For waypoints altitude it is always in mt absolute value from sea level. So if you fly with a waypoint at 1000 mt and you have a mountain at 1100 mt you crash. The altitude of the plane and waypoint are on the same altitude definition.

If you had the waypoints as an above ground value and same for the plane, you would never fly straight (except on flat land) because the trajectory would follow the ground profile. This type of flying is perfect for cruise missiles 🙂 

You can set your waypoint priority to high medium or low. Maybe at low it may avoid the mountain. I have never tested it that way, worth trying.

Share this post


Link to post
Share on other sites

Thanks Icky, I've given them enough altitude to make sure they all clear the mountain tops now.

The biggest problem is that when they hit their (only) waypoint - unless they get into a fight, they head for the stratosphere, in a climbing turn relative to the waypoint.

I'm struggling to differentiate between 'waypoints altitude' and 'waypoints..above ground value'. I guess this could be the key..

Share this post


Link to post
Share on other sites

When you place a new waypoint from the MCU menu (ie not copy an old one) the WP is set on the ground. You can see the altitude in the properties window: Y coordinate under Position: so this is the ASL value.  You can type in what you want to set the altitude, but if you have done that and want to check the ground altitude you can use the "place on ground" icon, just like a plane.  

 

It would be useful if the window also had a AGL measurement, or even if there was an option to set the WPs AGL rather than ASL. Not essential though: if you want to have a series of WPs say 1,000m above ground, you set the WPs on the ground and then add 1,000 to the value in the properties box.

 

Apologies if this is teaching granny to suck eggs: but I found it confusing when I started. 

  • Thanks 1

Share this post


Link to post
Share on other sites

Somewhere HABU said in response to a question involving cycling and a group of planes, but i don't think that's the solution as i have been experimenting with it and various distances and ranges for the waypoints .....:

 

Quote

: Your waypoint was too close, so when your waypoint is activated, your plane is already after your waypoint, so they have to go back, and the leader have to fly in the area of the waypoint to activate the next one, which is the command attack area. And as you have many planes, it's difficult to him to reach the area of the waypoint.

Edited by jollyjack
correction

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...