Jump to content

IL2 refuses to see my other controllers.


Recommended Posts

The game sees my Sidewinder FF joystick, but refuses to see my rudder pedals and throttle quadrant. This happened after the recent patches though i`m uncertain which. It was never an issue before. I have tried several ways to fix this, nothing works. Non Steam version.

 

I can`t play the game nor buy any new add-ons while this  broken aspect remains. I would appreciate the Devs posting a solution, please.

 

Clean PC. Windows 10,

32 gig ram 3200mhz.

Ryzen2700x

1080 card.

 

 

 

 

 

  • Upvote 1
Link to post
Share on other sites

Ok update. Found the issue.

 

Solution in case anyone else is interested:

1. I went back into my controller settings on Windows to see if Windows was still recognising all my controllers. It wasn`t. It only recognised the FF Sidewinder. It placed my other controllers under `Unspecified`.

2. I tried several ways to get Windows to `specify` them. Nothing worked.

3. So, finally, I grabbed CH Control manager, installed and added my controllers in the Utility, configuring them there.

4. It worked in IL2.

 

Seems obvious, right? But no, because I was previously able to use all my controllers without ever needing CH Control manager at all and before Windows was able to see everything no problem. Something has clearly changed in Windows. This means from now on, with every new install of IL2 I`m going to have to use CH Control Manager. That is new.

 

Good news is, it isn`t IL2 Dev`s fault, it`s Windows. My apologies to the Devs.

Edited by seafireliv
  • Upvote 1
Link to post
Share on other sites

Edit: Further update... Not so good news.

 

Well, now the game recognises all my controls, but when in the aircraft`s ready to fly it won`t respond to my lever controls (the ones with the axes if I`ve explained that right). Even when I go back into settings, on the field and it acknowledges my controller axes, it still doesn`t work when I go back to the running aircraft!

 

I don`t understand why it`s all so unstable.

 

I think I`ve had enough of messing with this for now. I`ll try to spend what`s left of my weekend doing something that`s fun.

  • Upvote 1
Link to post
Share on other sites

I'm having this exact same issue. The game has worked perfectly for years with all of my controllers. All of a sudden it doesn't see my rudder pedals. It "sees" my stick and throttle, but once in the actual aircraft, it doesn't respond to any control inputs.

 

I have deleted all of the content of the data/inputs folder to force it to generate new files. This didn't fix it.

I have uninstalled the game, downloaded a new copy, reinstalled, and this didn't fix it either. At 20gb's, reinstalling is no fun.

 

It seems like there's something persistent that is not being deleted/regenerated during the uninstall/reinstall process. I've searched for any remnant that may be causing IL-2 to "remember" my control inputs and settings but I can't find anything. Very frustrating. It worked perfectly for years, now, all of a sudden, broken. All of my controllers work fine in DCS and Rise of Flight.

 

I need to clean out the man cave today and do some much needed cable management. My plan is, uninstall IL2 (again) and this time, manually look through the PC for anything left behind. Reinstall IL2 with all of my controllers unplugged. Go through several game boot sequences and system restarts with no controllers plugged in, then finally add my controllers back and see what happens. It's a tedious solution but I'll be cleaning and organizing while it's going on so this is the least painful time to do something like this. Will let you know how things turn out.

 

Hopefully, there are no settings being "saved to the cloud" that will load back in and undo all the work. I'll see if I can stay offline after reinstall.

Edited by OG_Porkchopper
  • Upvote 1
Link to post
Share on other sites
4 hours ago, OG_Porkchopper said:

 

I need to clean out the man cave today and do some much needed cable management. My plan is, uninstall IL2 (again) and this time, manually look through the PC for anything left behind. Reinstall IL2 with all of my controllers unplugged. Go through several game boot sequences and system restarts with no controllers plugged in, then finally add my controllers back and see what happens. It's a tedious solution but I'll be cleaning and organizing while it's going on so this is the least painful time to do something like this. Will let you know how things turn out.

 

Hopefully, there are no settings being "saved to the cloud" that will load back in and undo all the work. I'll see if I can stay offline after reinstall.

Well good luck,.let me know if you succeed, but I`ve had enough. It seems to be a combination of possible Window changes and whatever these patches might`ve done. As the game ran fine with all my controllers before this . Elite runs perfect! The lack of any confirmation from the Devs might mean they`re puzzled as well. I`ll try again next weekend... maybe.

Edited by seafireliv
Link to post
Share on other sites

I am fighting with my windows recognition of my controllers every time. I have three systems running (different places), but the problem shows up only on one of this systems.

Luckily I can get windows to recognize them by pulling them out and in until they are seen under controllers. If one is not recognized before I run IL2, none of them will work as the registration number changes within IL2. Microsoft obviously doesn´t care about this USB registration problem. 

 

 

Edited by Quax
  • Upvote 1
Link to post
Share on other sites
  • 2 weeks later...
On 12/11/2019 at 5:27 PM, Quax said:

I am fighting with my windows recognition of my controllers every time. I have three systems running (different places), but the problem shows up only on one of this systems.

Luckily I can get windows to recognize them by pulling them out and in until they are seen under controllers. If one is not recognized before I run IL2, none of them will work as the registration number changes within IL2. Microsoft obviously doesn´t care about this USB registration problem. 

 

 

All my controllers are recognised. They even indicate they see my controllers in game - Then they stop working (except for the main joystick) when on the tarmac. It still isn`t working.

 

Well i`m not wasting my Xmas with trying to fix this. I`ll do something else.

Link to post
Share on other sites

Sometimes I lost the stick during flight, but I did hear the windows sound for disconnection and reconnection of the controller.

But still there is the fact, that although I use FFB2,  CH throttle, TIR5 and rudder on all 3 of my systems, I get all problems only on one of them. That tells me, that it can´t be an IL2.exe problem. It seems to be hardware related. At the moment I am testing a powered USB HUB, instead of connecting the controllers to the mainboard.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...