Jump to content
TWC_NINja

Need help with low framerate on Rift S with 1080ti

Recommended Posts

Sooo... I decided to get the RiftS at the current reduced price, having high hopes that IL-2 would run and look as had been touted by so many reviewers. I even downloaded OpenComposite in preparation for the experience.

Unfortunately, I am not getting the results I hoped for. My framerates barely make it above 40, mostly between 20-30 (single player so far). In game settings on Balanced with most bells and whistles turned down or off.

And the clarity is more like looking at a CRT monitor up close. I have read so much that the Rift S looks like a 1080p and spotting, ID and terrain looks nice and clear. Not the case for me. Not too much different from my old CV1 that was returned for that reason.

I have a 1080Ti, 12Gb RAM, but an old i7 2600k running at 3.92Ghz. Wireless 5G connection. (I can run IL2 on pancake at 90-110 fps with high settings on that rig.)

What am I doing wrong? I have updated Windows, NVidia and Oculus drivers.

I need help. I'm willing to try any suggestions. Looking for better framerates and clearer visuals. I it some setting, or some voodoo I'm missing?

Share this post


Link to post
Share on other sites

The CPU is likely the bottleneck. Use Oculus Tray Tool with the visible HUD set to “application render timing”. Check your CPU and GPU frame times. You need < 12.5ms for 80fps and < 25ms for 40fps.

 

I suspect you’re going to see CPU frame times are the problem. Try going down to Low preset and dropping other settings. You might be able to get 40fps by turning up only settings that are GPU impacting such as AA and supersample.

Share this post


Link to post
Share on other sites

Ninja, look in the VR pinned posts on our Discord channel for a number of posts that may alleviate your issues.  7-8 of TWC VR users are  using those tips in BOS and ED

Share this post


Link to post
Share on other sites

Also check your usb - hdmi ports and try different ones. FpsVR is a good program for check a possible CPU / GPU bottleneck during gameplay.. 

Share this post


Link to post
Share on other sites

might bea shot in the dark here but try turning up your settings as apposed to lowering them. i run Rift s on a MSI 1070 carded laptop on ultra with most other options turn to high. the lower my sttings the worse the performance. i keep a constant 35-40 on PWCG and it look smooth as silk to me

Share this post


Link to post
Share on other sites
6 hours ago, TWC_NINja said:

old i7 2600k running at 3.92Ghz

 

I think your 2600K is as good as my 4790K and many other current CPUs on the market.

It is just the freq at which you can overclock it. In our past tests a user was reporting about 92fps on 4K with the 2600K at 5.0GHz.

Untitled.thumb.png.c2ae292de92a38b8f164fff4f7b700eb.png

 

What is the freq and latency of your RAM?

 

You can get that info in these thread:

 

Share this post


Link to post
Share on other sites

Thanks a bunch for all your input, guys.

After checking and trying different "fixes" and settings, I'm not getting any improvements.

My mobo will not OC and it's only good for DDR3 RAM up to 1600Ghz.

I think it's time for a better system. I'm waiting to see if Cyber Monday brings any good deals.

 

Looking at an i7 9700k paired with RTX 1080S. Hopefully that will future-proof me a few more years.

 

 

 

Share this post


Link to post
Share on other sites

I've got a stock ryzen 5 2600 and a 5700 XT. Corsair Vengeance 3000mhz 16 gb. After doing Fenris settings I had a bump in FPS and somewhat better. On the ground I sit at 38 FPS. Take off and get higher up it improves to 40-50 FPS. Get around busy targets, FPS will tank. I definitely prefer snow maps for FPS.

 

Along with OpenComposite, use the Oculus Tool Tray.

Oculus tool try settings Default Super Sampling to 1.1.

ASW Mode - Off.

Oculus Homeless Enabled.

Mirror Oculus Home.

 

Power Options -

Set Power Plane on Start - High Performance ( not sure if this does CPU priority)

 

TIP***Also use the Visual Hud and set to ASW Status and start game. It will show ASW available even though "Default ASW Mode" is set to Off for some reason. I think the control to turn it off is Ctrl/Shift Numpad 1. The visual Hud will show if disabled or not activated. Then you have to go back to OTT and change the visual HUD back to "none".

 

Fenris' settings: Copy paste his settings in startup.cfg file. Dont use SteamVR. Maybe use the Spectre thing. Im trying it.

 

And Im trying this also Lefuneste's amazing mod can be found here, mainly for disabling the prop option.

 

 

Edited by Fern

Share this post


Link to post
Share on other sites
On 12/1/2019 at 5:27 AM, chiliwili69 said:

 

I think your 2600K is as good as my 4790K and many other current CPUs on the market.

It is just the freq at which you can overclock it.

 

Clock speed is only half of the equation. There is IPC (instructions per cycle) for example which severely increased by increasing the amount of transistors and changing architecture on the chip. 

 

The CPU is definitely the bottleneck (and maybe also the DDR3). One problem that might be the case for Il-2 in VR is that the 2600k only supports pci-e 2.0 and I think this might really be a cause. (Also the mobo might even use the lower x8 standard instead of x16). 

Share this post


Link to post
Share on other sites
1 hour ago, 216th_Jordan said:

There is IPC (instructions per cycle) for example which severely increased by increasing the amount of transistors and changing architecture on the chip.

 

Yes, of course,  the IPC counts as well, but for pure single-threaded app (like it is almost IL-2 in VR) the IPC has not been increased significantly (7% in total) from the 2600K (9 years old chip).

Take a look of the 3DParticle Movement single thread test:

https://www.anandtech.com/show/9483/intel-skylake-review-6700k-6600k-ddr4-ddr3-ipc-6th-generation/9

 

The PCI-2 2.0 and RAM speed support might be the major influencer for IL-2 VR.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...