Jump to content
SCG_motoadve

HP Reverb @ 60Hz refresh rate, distorted graphics

Recommended Posts

Did the big windows update and now  when I choose refresh rate 60Hz I get distorted fish eyed graphics.

Is anyone with the HP Reverb able to use 60Hz?

Any known fixes?

 

I was able before the update and it ran smooth.

Share this post


Link to post
Share on other sites

When I had the Reverd I tried also the 60Hz mode just to see if it is playable. I remember that 60Hz was the also the freq of the original Oculus DK1 and it was OK but noticeable, the DK2 at 75 Hz was better.

In my case it didn´t work when I tried, read that:

https://forum.il2sturmovik.com/topic/53603-valve-index-vs-hp-reverb-through-the-lens-pictures/?do=findComment&comment=815845

 

I didn´t dig more on the problem since with 90Hz was working OK at that time, specially with "Motion Reprojection"

  • Thanks 1

Share this post


Link to post
Share on other sites

Did some more testing in 60Hz.

Its super smooth , and very clear.

The problem I have is that depth looks a bit strange, no anomalies, or artifacts whatsoever

 

This is how I can explain it.

If I close one eye , looks perfect, depth, colors , clear, everything, with both eyes open , depth perception looks strange fish eye.

Dont know if this is possible to fix or not,

3D Migoto had one eye mod?

 

Share this post


Link to post
Share on other sites

Having the same problem myself, Reverb in 90Hz looks alright but in 60Hz I get the same fish-eye effect - in that it is difficult to focus on anything.

 

Would be cool to try out 60Hz without that effect as it does seem to run a bit smoother

Share this post


Link to post
Share on other sites

I did a system restore to the previous 1903 windows version now, and works fine, lots smoother at 60Hz

Share this post


Link to post
Share on other sites

From 1903 to the previous that was 1809*

 

😉

 

But that won't last forever. Already things like Gremlin/vJoy don't work anymore on pre-1903 systems. Also, from the data security POV, it's not advisable😶

Share this post


Link to post
Share on other sites

I noticed the same. IL-2 has stable 60 FPS and the picture is better, with 90 Hz I have with reprojection on 45 FPS but this stable 60 FPS looks better. Pity :(.

Any idea how to solve it? It looks like very strange IPD but I did few test with this digital IPD and was the same effect.

Edited by YoYo

Share this post


Link to post
Share on other sites

There is a file located somewhere along the lines of

 

\steamapps\common\Windows Mixed Reality for SteamVR\resources\settings\  

 

there is a vrsettings file in there, called something like that. It has a line in it, motionreprojection = "auto" iirc. Comment it out using // in front of it. Then reprojection will be disabled after next restart. Make sure to have no VR software running while you do this.

Share this post


Link to post
Share on other sites

Motionreprojection = "auto" is different subject, always "ON" for me. Here we talk about strange picture view with 60 Hz. With 90 Hz the picture is ok.

As I know its a WMR and Microsoft problem. Hope they will solve it.

Edited by YoYo

Share this post


Link to post
Share on other sites

What is good with 60 Hz and stable 60 FPS (Reverb takes it) no any ghosting effect and the picture is very clear and better.

I need IT !!! :unsure:

Share this post


Link to post
Share on other sites
40 minutes ago, c6_lefuneste said:

Is it a fish eye or a convergence problem ? Do you notice image distortion if you close one eye ?

 

No the picture is ok, something like wrong IPD I think, like squint I suppose.

Share this post


Link to post
Share on other sites
2 hours ago, c6_lefuneste said:

Is it a fish eye or a convergence problem ? Do you notice image distortion if you close one eye ?

I think it is convergence.

If you close one eye, everything looks fine.

You think you can fix it Lefuneste?

 

60Hz runs pretty smooth.

I had to go back to an older windows version to be able to run it in 60Hz.

Staying with it as long as needed.

  • Upvote 1

Share this post


Link to post
Share on other sites

Of course it could be possible to do something with the mod, but I think you should try at first the new IL2 built in IPD modifier : LSHIFT+numPad Add to increase or LSHIFT+numpad Enter to decrease.

I found it introduce more eyestrain than my "IPD like" modifier because it shift the whole image, but in your case that should be the needed feature.

Edited by c6_lefuneste

Share this post


Link to post
Share on other sites
1 hour ago, c6_lefuneste said:

Of course it could be possible to do something with the mod, but I think you should try at first the new IL2 built in IPD modifier : LSHIFT+numPad Add to increase or LSHIFT+numpad Enter to decrease.

I found it introduce more eyestrain than my "IPD like" modifier because it shift the whole image, but in your case that should be the needed feature.

 

Uuuu I didn't know it. Will try it with 60 Hz / 60 FPS and back here, thx.

 

Just a question is it key for default settings (to back to default IPD) if I will touch something?

Edited by YoYo

Share this post


Link to post
Share on other sites
2 hours ago, c6_lefuneste said:

Of course it could be possible to do something with the mod, but I think you should try at first the new IL2 built in IPD modifier : LSHIFT+numPad Add to increase or LSHIFT+numpad Enter to decrease.

I found it introduce more eyestrain than my "IPD like" modifier because it shift the whole image, but in your case that should be the needed feature.

lefuneste , I did try the IL2 in built modifier, it does changes the scale, but did not do anything to fix the convergence.

Il2 using 60Hz in the latest Windows 10 built ran even smoother than the old windows build I am using, but only way to see things normal was closing one eye.

I reverted it to old an older Windows 10 version where 60Hz works without convergence issues, I am using Windows version 17763 now.

 

But I would be nice if convergence could be fixed and we can use the HP Reverb at 60Hz with the newest Windows 10 built.

Share this post


Link to post
Share on other sites
1 hour ago, SCG_motoadve said:

lefuneste , I did try the IL2 in built modifier, it does changes the scale, but did not do anything to fix the convergence.

Il2 using 60Hz in the latest Windows 10 built ran even smoother than the old windows build I am using, but only way to see things normal was closing one eye.

I reverted it to old an older Windows 10 version where 60Hz works without convergence issues, I am using Windows version 17763 now.

 

But I would be nice if convergence could be fixed and we can use the HP Reverb at 60Hz with the newest Windows 10 built.

 

Did you try the "IPD like" feature of my mod ? You can use the last "beta" version that provides an easiest way (I hope) for settings : https://forum.il2sturmovik.com/topic/39748-3dmigoto-mod-icon-masked-by-cockpit-zoom-for-vr-color-change-sight-strengthened13-features/?do=findComment&comment=861226

 

 

 

Share this post


Link to post
Share on other sites
11 hours ago, c6_lefuneste said:

 

Did you try the "IPD like" feature of my mod ? You can use the last "beta" version that provides an easiest way (I hope) for settings : https://forum.il2sturmovik.com/topic/39748-3dmigoto-mod-icon-masked-by-cockpit-zoom-for-vr-color-change-sight-strengthened13-features/?do=findComment&comment=861226

 

 

 

When I had the Odyssey+ I used your IPD mod a lot, flet the scale was a bit small , and it worked great.

So it also works for convergence?

I will give it a try.

15 hours ago, YoYo said:

 

Uuuu I didn't know it. Will try it with 60 Hz / 60 FPS and back here, thx.

 

Just a question is it key for default settings (to back to default IPD) if I will touch something?

Looks like lefuneste convergence might work, I tested it and changes the convergence.

Want to give it a try at 60Hz and use lefuneste latest mod?

 

I am running old windows version so 60Hz already works in my PC

Since you are running a more recent version, can you give it a try and please let us know if it works.

Share this post


Link to post
Share on other sites
1 hour ago, SunCup said:

The IPD adjustment in IL2 doesn't help ?

No that is for scale.

Which I think in the HP reverb is a pretty accurate 1:1

Share this post


Link to post
Share on other sites

If it enters 60hz accidently everything is fine (sometimes after shutdown). But if I select 60hz in WMR I also get the fisheye view.

  • Upvote 2

Share this post


Link to post
Share on other sites
1 hour ago, Gomoto said:

If it enters 60hz accidently everything is fine (sometimes after shutdown). But if I select 60hz in WMR I also get the fisheye view.

Can you try this mod and report if it works for you?

https://forum.il2sturmovik.com/topic/39748-3dmigoto-mod-icon-masked-by-cockpit-zoom-for-vr-color-change-sight-strengthened13-features/?do=findComment&comment=861226

Share this post


Link to post
Share on other sites
On 12/1/2019 at 7:45 AM, c6_lefuneste said:

 

Did you try the "IPD like" feature of my mod ? You can use the last "beta" version that provides an easiest way (I hope) for settings : https://forum.il2sturmovik.com/topic/39748-3dmigoto-mod-icon-masked-by-cockpit-zoom-for-vr-color-change-sight-strengthened13-features/?do=findComment&comment=861226

 

 

 

lefuneste, I updated to the latest Windows 10 version, 60Hz still looks out of convergence.

Tried your mod, and did not solved the problem.

Reverted back to older Windows version

  • Upvote 1

Share this post


Link to post
Share on other sites

Are you certain? Did you cold-start the Computer afterwards, and replugged HP Reverb? 

 

I have read it should work now. This is really odd. 

 

Does the 60Hz mode on WMR work for anyone here? If yes, do you have a Reverb?

Share this post


Link to post
Share on other sites

I made 60Hz work accidentally. I have no idea what I did? Refresh rate was selected to auto. Before that I was testing Chiliwili's benchmark and when I replaced Startup file back to original file, which is for VR  , frame rate was 60fps without fisheye effect. 

Really hope Reverb could support 72Hz in future. 60Hz was just a little bit too slow for my taste.

Share this post


Link to post
Share on other sites

Actually it works quite well at 90hz even if the frame rate is floating between 55 and 85,  if one turns off the FPS counter and just concentrates on flying :-).

Share this post


Link to post
Share on other sites
1 minute ago, Gomoto said:

Actually it works quite well at 90hz even if the frame rate is floating between 55 and 85,  if one turns off the FPS counter and just concentrates on flying :-).

 

Amen to that - more VR flyers should give that a try - sometimes we got so fixated on FPS department, which is not so indicative in VR as it is on a monitor.

If it is smooth and looks good  you are good to go.

  • Upvote 1

Share this post


Link to post
Share on other sites
On 12/11/2019 at 4:40 PM, SCG_Fenris_Wolf said:

Does the 60Hz mode on WMR work for anyone here? If yes, do you have a Reverb?


As I know „no” even with Odyssey + so with WMR also.

W10 update :/.

Share this post


Link to post
Share on other sites
On 11/30/2019 at 6:30 PM, SCG_motoadve said:

I think it is convergence.

If you close one eye, everything looks fine.

You think you can fix it Lefuneste?

 

60Hz runs pretty smooth.

I had to go back to an older windows version to be able to run it in 60Hz.

Staying with it as long as needed.

Which version of Windows are you running VR with Reverb at 60Hz?  I have Windows 7 and considering purchasing Reverb for VR.

Edited by Trek64Trek64
new info

Share this post


Link to post
Share on other sites
1 hour ago, Trek64Trek64 said:

Which version of Windows are you running VR with Reverb at 60Hz?  I have Windows 7 and considering purchasing Reverb for VR.

 I am using Windows 10 version 17763 now.

 

Share this post


Link to post
Share on other sites
1 hour ago, YoYo said:

New Steam WMR VR update: 1.9.13 

https://steamcommunity.com/games/250820/announcements/detail/3150762393120220262

But with 60Hz still the left screen is tighter than the right, bugy 60 Hz :(.

What do you have in Settings under visual quality?

If it is High Beta try to change it to high, and can you report please?

That might make it work at 60Hz.

Share this post


Link to post
Share on other sites

Thx, checked but the same problem.

See this also, more people has this issue:

 

  • Thanks 1

Share this post


Link to post
Share on other sites

 

On 12/1/2019 at 4:45 PM, c6_lefuneste said:

 

Did you try the "IPD like" feature of my mod ? You can use the last "beta" version that provides an easiest way (I hope) for settings : https://forum.il2sturmovik.com/topic/39748-3dmigoto-mod-icon-masked-by-cockpit-zoom-for-vr-color-change-sight-strengthened13-features/?do=findComment&comment=861226

 

 

 

 

With 60Hz the picture on screens in WMR looks something like this (W10, 1903):

 

uoukPmml.jpg

 

So setting of IPD option +/- doesnt solve this problem. The left screen shows tighter image so both looks like is distorted picture.

Edited by YoYo

Share this post


Link to post
Share on other sites

So I'm seeing a lot of really positive youtube vids regarding clarity of the Reverb and IL-2.

 

I love my Rift S..but I'm tempted to grab a reverb for mainly IL-2 and DCS.  I've got an 8700k/1080ti setup.  Is it worth grabbing a reverb?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...