Jump to content
Jason_Williams

Stuttering in Single-player Research

Recommended Posts

Guys,

 

The stuttering issue is very complex because we have issues in SP as well as MP.  We need to be more scientific in this work.

First, we need to make sure you are not stuttering in SP under reasonable loads.

I need to design a standard test for everyone and check results. You may experience what I call Microstutters and Macrostutters.

 

- Microstutters are usually caused by a graphics settings or other graphics pipeline issues. This is usually a constant, jittery and fast stutter. 

- Macrostutters are usually caused by loading objects or textures or other bottlenecks not related to graphics processing. This is usually a very noticeable pause at seemingly random intervals.

Add Example of Microstutrer Video
Add Example of Macrostutter Video

You need to understand what you are experiencing on your own system before we can pinpoint a cause.

 

More soon...

Jason

  • Like 3
  • Upvote 1

Share this post


Link to post
Share on other sites

G’day Jason

 

I found that I was getting microS after the patch with my pre-patch settings, that is with clouds set to high and it was much more noticeable when nearing a large population centre on the BoBp map, so I assumed it was basically a graphic load issue, seemed to mostly dissapear when I went down one level on the cloud setting, sorry for the anecdotal evidence, however I’m away from my PC at the moment and so can’t give you my full settings or spec’s or make a track at present, needles to say with weather set for clear sky’s there is minimal if any microS.

 

As for macroS, it was indeed random and still seems apparent after the cloud setting was reduced, as they are quite erratic and small in number I’ve more or less just put up with it, but my guess is that it happens when a new object is created, I like hunting trains and I think it happens when the train is first loaded, but as I said this is only a guess.

Edited by spudkopf

Share this post


Link to post
Share on other sites

Let's post it again to ensure that it will be taken into account...

problem : HUD activation is causing spikes in VR and stutters. Reporterd by other users.

Reported whatever graphic option are.

I do not know how to make video in VR, but here is a copy of steamVR "advanced frame timing".

SteamvR resol is 2260x2256, graphics settings are "LOW" in IL2, fps caped to 64 fps by Pitool, no mods installed. Quick mission in Kuban, Ju88 at 1500m.

Recording has started without HUD, "H" key pressed to moved to HUD OFF to HUD ON

Capture.thumb.JPG.0ff2984b34fc553b4c2543ef674a5569.JPG

 

"LOW" option is lgiving a huge power margin on my PC (see my signature for more information), so it is unlikely that problem is caused by saturation.

Edited by lefuneste
  • Like 1
  • Upvote 3

Share this post


Link to post
Share on other sites

Bonjour dev team and community,

 

i love this flight sim but as many people, I have some stuttering even if my overall fps are never below 60 on big maps like kuban. i tried all tips from community but nothing really work. the only settings which really reduce stuttering for me is to reduce horizon draw distance to 40km. problem with this setting is the ground looks very "hazy" in comparison with setting over 130km which is indeed really better without this strange fog.

does somebody know how to have the same ground aspect in 40km setting as it is on 150km?

may be something to change in "startup.cfg" or in options? 

The only thing I found was a mod named "no fog mod".

Indeed, it allow to set draw distance to 40km for low performance systems like mine and have no haze and same quality as you can see if you set draw distance to 150km (see below picture at 40 km setting)

image.png.0965d810e50a462c153dd2c96e015f7c.png

With this 40km setting, I have no stutter anymore  and every options on ULTRA with average 100 fps and no hickups. This mod solve all my stuttering issues which occurred since 3.001 patch.

My rig is :

(Intel i7950 3,2 ghz, 12 GB ram 1600, motherboard x58, 500 GB evo 850 ssd, screen is an Asus rogue 279q Gsync 144hz, I already test vsync, gsync, fixed frequency but stuttering is always there)

Moreover I have a g940 ffb joystick which does not help with stuttering issues. 

 

I also noticed that stuttering is far less on small maps like "lapino" qmb mission (16 aircraft, ground units, clouds, )where I can set every options on maximum including horizon  draw distance on 150km. may be it need less RAM and less ssd page file access.

 

 

 

Update: With last Nvidia drivers 440.97, I have been able to remove micro stuttering with setting below. I follow setting advises from https://www.blurbusters.com/gsync/gsync101-input-lag-tests-and-settings/14/.

 

However, during flight for unknown reason, stuttering appear even with 50 FPS limit but I can eradicate it by going in FPS limiter option, put it on "no FPS limit" then go back inflight. If stutter appear again, I set again 50 fps limit and it is ok until the end of the flight.... Really strange ??? I can not explain the root cause of that but it works for me.

 

Another thing I noticed in forum topics is even people with a very powerfull rig (I9900K, GPU 2080TI, 32mo RAM...etc) have this stutter issue.

 

HUD (H key) activation also have a bad impact and involve stuttering.

 

image.png.90e8a0602d8f71b52bd9c83ed9403d36.png

 

Nvidia panel

image.thumb.png.a1e3bdbe5e24f4b0856da5d35e8c4d5c.png

 

 

Game option panel

image.thumb.png.42040bf287efff1e84cdd1f07fea3ec2.png

 

image.thumb.png.de891a6738e5408b0e448b55bc8c7893.png

 

 

Hope my feedback can help community and dev team to squash this stuttering problem. I really trust in your team, Jason. you have already soved so many bugs and enhanced so many aspects of this fabulous warbird sim!!!!

 

Best regards

 

Edited by AFsparrow1968
  • Upvote 3

Share this post


Link to post
Share on other sites

I'd had basically game breaking micro and macro stutters since the Windows update which dropped shortly after the patch dropped. After following the advice of RedKestrel and others in previous threads, the only thing I have found which worked was dropping down a clouds detail level. 

 

This has pretty much solved the issue in sp. However, in mp I'm still getting macro stutters when there's stuff going on. I'm guessing my i5 gtx 950 is just getting a little long in the tooth. 

 

On the flip side, in some ways my game looks better than ever and I've discovered all kinds of functionality in the invidia control panel I was never aware of previously! 

  • Like 1

Share this post


Link to post
Share on other sites

Hi, 

My game was running smoothly (ultra settings, i7 6700k, 1070ti) until last weekend.  I had been away two weeks and when I came back windows was updated.  

After that there were stutters and changing game settings didn't help.

 

Then, I made changes suggested here and game runs smoothly on SP modes at 1080p@60fps https://www.google.com/amp/s/windowsreport.com/fix-pc-stuttering-windows-10/%3famp

Edited by vvuorela

Share this post


Link to post
Share on other sites

I turned off the Game Bar and Diagnostic policy serve as recommended and tried it out on WoL.

I also turned down my view distance to 40km 

No stutters. But I need more time for testing. Looks promising.

I did not disable Dynamic Tick, and the other 2 edits because I don't know how they will effect my system.

I know this is the SP thread, but here is where I found the info, and it might work for MP. The jury is still out.

Edited by newbravado
clarity

Share this post


Link to post
Share on other sites

Quick update if anybody cares. Still having stutters on MP. Worse on Kuban maps than older maps.

Noticeable on older maps and aggravating on newer maps. Data bottlenecks in my old rig? maybe. 

Again posted here cause this is were I found the edits advice.

 

Share this post


Link to post
Share on other sites
On 10/25/2019 at 6:29 PM, Jason_Williams said:

Guys,

 

The stuttering issue is very complex because we have issues in SP as well as MP.  We need to be more scientific in this work.

First, we need to make sure you are not stuttering in SP under reasonable loads.

I need to design a standard test for everyone and check results. You may experience what I call Microstutters and Macrostutters.

 

- Microstutters are usually caused by a graphics settings or other graphics pipeline issues. This is usually a constant, jittery and fast stutter. 

- Macrostutters are usually caused by loading objects or textures or other bottlenecks not related to graphics processing. This is usually a very noticeable pause at seemingly random intervals.

Add Example of Microstutrer Video
Add Example of Macrostutter Video

You need to understand what you are experiencing on your own system before we can pinpoint a cause.

 

More soon...

Jason

 

guys, correct me, if I am wrong, but do I understand the big boss well, and we can expect "the standardized performance test" ?
soon?

 

 

Edited by wju

Share this post


Link to post
Share on other sites
On 11/17/2019 at 3:59 PM, wju said:

 

guys, correct me, if I am wrong, but do I understand the big boss well, and we can expect "the standardized performance test" ?
soon?

 

 

Think that would be great, as we need to be sure we are using real game inputs in the benchmark and not the Video output. 

Share this post


Link to post
Share on other sites

It's seems that check the "Enable mods" box cause stutter. even I don't use any mods, it was still stutter.
uncheck the "Enable mods" box, and stutter will gone.
If someone test this, please tell me the result😉

Edited by Oyster_KAI

Share this post


Link to post
Share on other sites

I removed macro stutters (for example in the Remagen benchmark track under the bridge) by moving the install from my second slot NVMe Corsair Force 510 to my first slot Samsung NVMe 970 EVO  Plus 1 TB.

 

CPU Ryzen 3600X, Motherboard Asrock B450 Pro4, 16 GB RAM 

Edited by Gomoto

Share this post


Link to post
Share on other sites

Hello,

As I still found a lot of stutter in VR, I made more testings.

I setup my rig for best measurement : no overclocking, no mod.

My rig is a core I7 8700K, 16BG, Gtx1080 ti. I use a Pimax 5K+, Pitool last version, nvidia driver 441.66, nvidia options by default, IL2Bos settings below. Pitool at 2.0 steamVR SS et 20%, res. per eye in steamVR = 2359x2355.

Pitool target fps = 64, no smart smoothing.

In all testing I maintain the target fps, so there should be no stutter. I fact I can have 90 fps in this scenario.

I am (unfortunately!) able to see stutter in a simple way : at ramp start on runway I move my head from left to right and look at a part of airframe (eg the lewis on the SE5a) and see if there is stutter.

stuttering occured whatever the graphics settings are in IL2 GB, even with low...

I was not able to see the same stutter when playing a track than when in real game.

But I noticed that I always had CPU "late start" when I see stutters. Moreover, it looks like the stutters are linked also to planes:

 

Map = moscow, plane = SE5A, stutters

moscow_SE5.thumb.JPG.6c93ae8842f78654c0e2a7ae9034ab43.JPG

 

Map = moscow, plane = lagg3, not stutters

moscow_lagg.thumb.JPG.d5ef6e47bf15fad216609e651bf8099b.JPG

 

Map = moscow, plane = BF190D9, stutters

moscow_FW190D9.thumb.JPG.6203cdd6ae30a32e1528cb1231831556.JPG

 

Map = moscow, plane = albatros, stutters,

moscow_albatross.thumb.JPG.c167310206a113f5a0ec7df524742eae.JPG

 

Map = moscow, plane= BF109F4, no stutters

moscow_BF109F4.thumb.JPG.3a4d59425852265e3eb33bf783a3dd2c.JPG

 

Map = Arras, plane = BF109F4,  no stutters

arras_BF109F4.thumb.JPG.1b5fe7c947cb6134772f0c24994e9056.JPG

 

I think I have a PC with  enough power to make IL2 GB works in VR at 64 fps. Moreover, the problem seems not to be linked to GPU but to CPU !

 

My settings:

[KEY = graphics]
	3dhud = 0
	adapter = 0
	bloom_enable = 0
	desktop_center = 1
	detail_rt_res = 1024
	draw_distance = 0.54500
	far_blocks = 1
	fps_counter = 1
	fps_limit = 60
	full_height = 1080
	full_width = 1920
	fullscreen = 0
	gamma = 1.20000
	grass_distance = 100.00000
	hdr_enable = 0
	land_anisotropy = 0
	land_tex_lods = 0
	max_cache_res = 1
	max_clouds_quality = 1
	mgpu_compatible = 0
	mirrors = 1
	multisampling = 0
	or_ca = 0.34907
	or_enable = 1
	or_height = 2352
	or_hud_rad = 1.50000
	or_hud_size = 0.75000
	or_ipd = 0.06818
	or_sipdc = 0.00000
	or_width = 2356
	post_sharpen = 1
	preset = 2
	prop_blur_max_rpm_for_vr = 315
	rescale_target = 1.00000
	shadows_quality = 2
	ssao_enable = 0
	stereo_dof = 5.00000
	vsync = 0
	win_height = 1080
	win_width = 1920
[END]

 

Can some of you reproduce my problem ?

 

Edited by c6_lefuneste

Share this post


Link to post
Share on other sites

Some recurring Macrostutters are induced by PiTool later than .144 and it's settings for GPU utilization. Next PiTool version will feature a GPU utilization slider, which I have been told by a Pimax dev.

 

See my signature for a workaround in keeping PiTool disabled and all RGB software to minimize the problem.

 

If you're with a Pimax, it'll be hard to separate your specific issue from a global one affecting IL-2. With that in mind any collection of data should be taken with a grain of salt lefuneste, it's impossible for you or me to isolate and help IL-2 in the current situation.

 

Best regards 😁

Share this post


Link to post
Share on other sites

I confirmed that my stuttering was linked to pitool usage. Thanks for the tip, I was not aware of that. And I noticed the stuttering even with the .144, I did a rollback (including the Helmet firmware) some days ago to  check.

Maybe a dedicated post in VR section may help, because this very important information for Pimax users is a bit hired in your post.

I was confused because the different behaviour with planes.

Share this post


Link to post
Share on other sites

The problem I'm getting is when I look around in cockpit (I use the mouse for this) in quick mission mode it's absolutely buttery smooth. As soon as I'm in a scripted campaign or career mode it's almost laggy even at the same fps. 

 

I've got and i5 7600 ( CPU usage is very low even on max setting) GTX 1080ti...16gb ram. 3440x1440 gsync monitor. 

 

I guess you could call it a micro stutter. I'm not sure, but it's very apparent. 

 

No matter what settings I alter it's always there. It's really spoiling the game for me.

 

Is there a fix? ?

Share this post


Link to post
Share on other sites

Try recording it and post the video. With CPU/GPU/RAM usage if possible. 

Have you tried quick mission with max possible units (four flights of 4, vehicles, aa, etc)? 

Share this post


Link to post
Share on other sites
5 hours ago, marshall said:

The problem I'm getting is when I look around in cockpit (I use the mouse for this) in quick mission mode it's absolutely buttery smooth. As soon as I'm in a scripted campaign or career mode it's almost laggy even at the same fps. 

 

I've got and i5 7600 ( CPU usage is very low even on max setting) GTX 1080ti...16gb ram. 3440x1440 gsync monitor. 

 

I guess you could call it a micro stutter. I'm not sure, but it's very apparent. 

 

No matter what settings I alter it's always there. It's really spoiling the game for me.

 

Is there a fix? ?

You may also try more smoothing in your looking around in game. Some people found this helped a bit with the jerkiness.

Share this post


Link to post
Share on other sites
On 1/30/2020 at 2:45 AM, marshall said:

The problem I'm getting is when I look around in cockpit (I use the mouse for this) in quick mission mode it's absolutely buttery smooth. As soon as I'm in a scripted campaign or career mode it's almost laggy even at the same fps. 

 

I've got and i5 7600 ( CPU usage is very low even on max setting) GTX 1080ti...16gb ram. 3440x1440 gsync monitor. 

 

I guess you could call it a micro stutter. I'm not sure, but it's very apparent. 

 

No matter what settings I alter it's always there. It's really spoiling the game for me.

 

Is there a fix? ?

 I have a comparable processor but a lower end graphics card (1060 GTX) and get 60 FPS on a 1080p monitor. SP Career is pretty smooth, not as smooth as running a QMB with little activity but good.

Another thing to try - make sure your power regime for your graphics card and your PC as a whole are set to Performance power mode rather than Balanced. With a balanced or power-saving setting the computer often throttles the performance of your cards and processors to keep power usage low.

What I did to get smooth gameplay in single player is this:  I set up a 'stress test' mission in the QMB. 8 allied fighters (tempests) vs. 8 axis bombers (He-111), over a city on the Bodenplatte map, with active ground targets and AA. I chose bombers since bomber formations are more likely to stress the game engine because of the gunners. This effectively simulates a career mode mission IMO. 

Turn all your settings to as low as you can tolerate, then fly the test missions. Keep increasing your settings until it stops giving you acceptable performance, then turn it back down to the settings where it was still acceptable.

When I did this, with my setup, I could run the game in SP mode on High presets, with medium shadows, high clouds, complex mirrors, sharpen on, 4K Textures off, vsync on and set to 60 fps. Right now I'm actually running these settings except I switched to Balanced preset as that gets me better performance online.

Share this post


Link to post
Share on other sites

Thanks for the feedback guys. I do have power settings to prefer maximum performance.

 

I set the draw distance from 150km to 40km and saw a dramatic improvement last night. I think on previous tests I'd only knocked it down one notch as it were. I also took clouds down from ultra to high. 

 

I'll keep tweaking but it's helped loads. It's just weird as my pc is not under any stress at max settings. Between 85 and 100 fps at all times. 

 

100fps with draw distance lowered is now near what i get on QMB and 100fps draw distance maxed is noticeably choppy!!

Share this post


Link to post
Share on other sites

Its been a good while since playing single player mode in BOS, but now suffering what I think is being described as stuttering in this thread.

 

What I am seeing is fluctuations in FPS below whatever limit I set so vsync can't sync and hence looking around with headtracking becomes stuttery.

 

My system resources seem nowhere near stretched, but whatever I set FPS limit to whether 100 or 50, it dips below by upto 10FPS at times.

 

The same is true for min and max graphics settings, different maps and different number of AI. The same fluctuations appear without headtracking active and I see no disk activity at the time either.

 

Graphics driver and Windows are upto date, and power set to max performance, so not sure what to do next.

 

I'm happy to share data as required, because as awesome as this sim is, it  does not seems to be since the big 'visibility' update, but thats just my perception.

 

Update: Closing Edtracker GUI completely once calibrated made a huge positive difference for me! I have Vsync on and FPS capped at 60 both ingame and Nvidia.

 

I can now run on Max/ extreme settings without stutter in SP! 🙂

 

 

 

Edited by Nake350
Possible solution for me added

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...