Jump to content
Sign in to follow this  
blitze

Bluriness in VR - possible solution

Recommended Posts

Been doing some extensive testing and have found a possible culprit for the blurriness in VR with Il2.  Co-incidence that this occurred around the same time as the most recent hotfix.

 

SteamVR not long ago introduced a new filter which can be turned off in your steamvr file located in C:\Users\Username\AppData\Local\openvrusers/

 

"allowSupersampleFiltering" : false,

 

This filter softens the VR image to erase Aliasing but at great expense to detail / sharpness.  It might be ok to have on for small room VR interactions but for those of us in sim land be it car or plane, it is horrible.  I have tested it both on and off at various Render Target Settings and on various Il2 Maps and the results are the same, with it on, there is definite blurring which makes spotting and general world detail crap.

 

Hope this helps others out there and returns Il2 back to what is a great and fun experience.

 

Next up - Ryzen Master settings and stable Il2 Foreated settings. 👍😁

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

If you're using opencomposite, you shouldn't have to do to this right?

 

But I'll try it anyways. I'll report back.

Share this post


Link to post
Share on other sites
9 minutes ago, Fern said:

If you're using opencomposite, you shouldn't have to do to this right?

 

But I'll try it anyways. I'll report back.

 

No, with Open Composite for Rift you are not using Steam VR at all.

Share this post


Link to post
Share on other sites

There is a checkbox for Advanced Super Sampling Filter in steamvr setup under ...advanced or developer tab?  Is there some differences between those two?

Edited by Hartigan

Share this post


Link to post
Share on other sites
3 minutes ago, Hartigan said:

There is a checkbox for Advanced Super Sampling Filter in steamvr setup under ...advanced or developer tab?  Is there some differences between those two?

I couldnt find file path either.

 I unchecked " enable advanced supersampling filter" , BUT I've been using opencomposite. Maybe not running steamvr with this setting is causing my blurriness. 

Share this post


Link to post
Share on other sites

Yeah - sorry, no help for Oculus folks - this is a SteamVR thing but it has returned with realistic spotting (not the alternate spotting in Realism Options selected) for me seeing targets at around 10km out.  Not easy but better than the sub 2km I was experiencing recently.

Share this post


Link to post
Share on other sites
1 hour ago, blitze said:

Yeah - sorry, no help for Oculus folks - this is a SteamVR thing...

 

BoX uses SteamVR anyway as it has no native Oculus mode. Unless I'm missing something.

Share this post


Link to post
Share on other sites
10 hours ago, Goffik said:

BoX uses SteamVR anyway as it has no native Oculus mode. Unless I'm missing something.

 

Some people might be using the Open Composite alternative to SteamVR if they are using Oculus headsets.

13 hours ago, II/JG11ATLAN said:

Really cannot find this path

Is there another way? 

The path

C:\Users\"Username"\AppData\Local\openvr\

 

Whereby "Username" is your Windows Login name.  The config file is steamvr

 

and the line to add under steamvr section is

 

"allowSupersampleFiltering" : false,

 

Sorry for the mistype earlier, between work and testing VR my brain went to mush.💥

Edited by blitze
clarification

Share this post


Link to post
Share on other sites
10 hours ago, Goffik said:

 

BoX uses SteamVR anyway as it has no native Oculus mode. Unless I'm missing something.

 

 I find Open Composite to be better than Steam VR for the Rift/Rift s.

But yeah native support for Oculus would be ideal.

Share this post


Link to post
Share on other sites
9 hours ago, dburne said:

 I find Open Composite to be better than Steam VR for the Rift/Rift s.

 

Not an option for me unfortunately because I'm on "old-school" Win7. :p I'll definitely switch to it though, if I ever bother "upgrading" to Win10.

 

Quote

The path

C:\Users\"Username"\AppData\Local\openvr\

Whereby "Username" is your Windows Login name.  The config file is steamvr

 

So if I'm on a Rift, this file won't exist? The only file I have in that folder is openvrpaths.vrpath which contains no SVR settings.

Edited by Goffik

Share this post


Link to post
Share on other sites
9 hours ago, blitze said:

 

Some people might be using the Open Composite alternative to SteamVR if they are using Oculus headsets.

The path

C:\Users\"Username"\AppData\Local\openvr\

 

Whereby "Username" is your Windows Login name.  The config file is steamvr

 

and the line to add under steamvr section is

 

"allowSupersampleFiltering" : false,

 

Sorry for the mistype earlier, between work and testing VR my brain went to mush.💥

 

No 'AppData' for me under my 'Username'.  Perhaps this is something you get with Steam VR beta; I use release version.

I use Pimax 5k+.

 

Talisman

Edited by 56RAF_Talisman

Share this post


Link to post
Share on other sites
6 minutes ago, 56RAF_Talisman said:

No 'AppData' for me under my 'Username'.

 

It's a hidden system folder. You can either make system folders visible in your folder options, or you can just type C:\Users\<Username>\AppData into the address bar.

  • Upvote 1

Share this post


Link to post
Share on other sites
8 minutes ago, Goffik said:

 

It's a hidden system folder. You can either make system folders visible in your folder options, or you can just type C:\Users\<Username>\AppData into the address bar.

 

Still no result.  Perhaps this is just for folks with open vr.

 

Talisman

Share this post


Link to post
Share on other sites

"C:\Program Files (x86)\Steam\steamapps\common\SteamVR\resources\settings\default.vrsettings"

 

Here he is modifying the 8192 file.

Share this post


Link to post
Share on other sites
1 hour ago, 56RAF_Talisman said:

Still no result.  Perhaps this is just for folks with open vr.

 

Well, that folder is an integral part of Windows, at least up to Win7, so it should exist for everyone. No idea why you cant find it, but it's there somewhere. Unless you're on Win10 and it no longer exists there?

Edited by Goffik

Share this post


Link to post
Share on other sites
8 minutes ago, Goffik said:

 

Well, that folder is an integral part of Windows, at least up to Win7, so it should exist for everyone. No idea why you cant find it, but it's there somewhere. Unless you're on Win10 and it no longer exists there?

 

It is still there in Win 10.

 

C:/Users/<your user name>/appdata/

 

As mentioned "show hidden files and folders" must be checked to see the appdata folder and it's contents.

Edited by dburne

Share this post


Link to post
Share on other sites

The old appdata folder - it's there and it has lots of yummy stuff in it including openvr stuff.

 

Windows 10 and prior versions. 

45 minutes ago, IV./JG5_a7610783 said:

"C:\Program Files (x86)\Steam\steamapps\common\SteamVR\resources\settings\default.vrsettings"

 

Here he is modifying the 8192 file.

 

You can also modify that file but if you get a SteamVR update, it might reset your altered settings.  I just decided to pay attention to what Valve was saying at the beginning of the file and use the User version instead.

Share this post


Link to post
Share on other sites
6 minutes ago, dburne said:

As mentioned "show hidden files and folders" must be checked to see the appdata folder and it's contents.

 

If you navigate there directly using the address bar, you don't need to have that option enabled to get there or see the contents. (Win7)

 

Also, the steamvr.vrsettings file definitely doesn't exist for me in that location. Instead, I found it in <SteamInstallLocation>\Steam\config.

Edited by Goffik

Share this post


Link to post
Share on other sites

If you have trouble finding user files for SteamVR use the default Steam tool. Follow this guideline:

 

Output from C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64\vrpathreg.exe. (=program to run)
Run vrpathreg.exe in command window and redirect output to txt file. (vrpathreg.exe > path.txt, this txt file will be in the directory where you started the program)

 

This was the content in my txt file:

Runtime path = C:\Program Files (x86)\Steam\steamapps\common\SteamVR
Config path = E:\Program Files (x86)\Steam\config
Log path = E:\Program Files (x86)\Steam\logs

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
14 hours ago, blitze said:

 

Some people might be using the Open Composite alternative to SteamVR if they are using Oculus headsets.

The path

C:\Users\"Username"\AppData\Local\openvr\

 

Whereby "Username" is your Windows Login name.  The config file is steamvr

 

and the line to add under steamvr section is

 

"allowSupersampleFiltering" : false,

 

Sorry for the mistype earlier, between work and testing VR my brain went to mush.💥

 

Thanks.  Found the folder eventually, but I found that the line you have given is already written in the file, probably because I have already turned off the advanced supersample filter by using the option to do so via the Steam VR 'Developer' drop down box. 

 

Happy landings,

 

Talisman

On 10/10/2019 at 10:39 AM, Hartigan said:

There is a checkbox for Advanced Super Sampling Filter in steamvr setup under ...advanced or developer tab?  Is there some differences between those two?

 

It would appear not.

 

Talisman

Share this post


Link to post
Share on other sites

Checked my config file,

Already had  "allowSupersampleFiltering" : false,  set.

still have performance and spotting issues.

 

:cray:

Share this post


Link to post
Share on other sites

Please find my solution to this issue here:

 

https://forum.il2sturmovik.com/topic/54528-did-yesterday’s-hotfix-mess-up-your-vr-sharpness-settings/page/2/#comments

 

Happy landings,

 

Talisman

Share this post


Link to post
Share on other sites

To further discussion,  these are my altered settings in the personal streamvr settings file located in newly discovered folder for you guys:

 

"steamvr" : {
      "allowSupersampleFiltering" : false,
      "background" : "#FF000000",
      "enableDistortion" : false,
      "enableHomeApp" : false,
      "installID" : "2329656033398071845",
      "lastVersionNotice" : "1.7.15",
      "lastVersionNoticeDate" : "1568937933",
      "maxRecommendedResolution" : 8192,
      "preferredRefreshRate" : 72,
      "supersampleScale" : 0.5

 

I have spotting back at range not under 2km like it was and I have clear ground targets, ground detail etc.

 

For Pimax users I am using PiTool Render 1.25, Large FOV and SteamVR Vid 50%.  No AA and High in Il2 Graphics Settings.

Share this post


Link to post
Share on other sites
10 hours ago, blitze said:

To further discussion,  these are my altered settings in the personal streamvr settings file located in newly discovered folder for you guys:

 

"steamvr" : {
      "allowSupersampleFiltering" : false,
      "background" : "#FF000000",
      "enableDistortion" : false,
      "enableHomeApp" : false,
      "installID" : "2329656033398071845",
      "lastVersionNotice" : "1.7.15",
      "lastVersionNoticeDate" : "1568937933",
      "maxRecommendedResolution" : 8192,
      "preferredRefreshRate" : 72,
      "supersampleScale" : 0.5

 

I have spotting back at range not under 2km like it was and I have clear ground targets, ground detail etc.

 

For Pimax users I am using PiTool Render 1.25, Large FOV and SteamVR Vid 50%.  No AA and High in Il2 Graphics Settings.

 

blitze, I fear I must get you to stop this now. You are handing out advice by the sheer volume of posts you are giving left and right, which often contradicts itself. I am certain that your intentions are good, but you need to really start asking yourself if you are posting cohesively and structured as well. This is confusing people with false information, and the constant posting of different settings isn't helping anyone.

 

This thread however is too much, and here is why:

 

Guys, do not follow this advice. It can break SteamVR settings, the refreshrate isn't even adapted to your individual HMD, the code is also incomplete, you might be using another version of SteamVR, best case is SteamVR settings will just reset themselves, etc. Also, this is not blitze's idea, but had been posted by some guy on the Pimax forums. Beside not mentioning that, you also didn't mention these settings are specific for (some types of) Pimax' hmds.

 

Also: allowSuperSampleFiltering is a very old setting, has always been there, and it's not responsible for the change. It is nothing new, it has been around for two years. The information that it was new is false. It's referring to Advanced Supersample Filtering in SteamVR's settings.

 

I had tackled that more than a year ago and recommend to switch it off in the sticky thread.

 

 

P.S. blitze, please don't take this personal, I know of your good intentions. But it's really not helping people, quite the opposite. They'll either have, if lucky, automatically defaulting SteamVR settings after this, or will get constant stuttering and ghosting of 72fps trying to feed their 90Hz panels.

 

:coffee:

Edited by SCG_Fenris_Wolf

Share this post


Link to post
Share on other sites

Wow, it is an example of a Pimax Setting - if people can't adapt settings to their own headset oh well.

 

Fenris - you are right - there is no helping to be had from this point on.

 

I know what works and others don't time to enjoy this great sim.  Cya.

 

Mods - Please thread lock this.

  • Like 1

Share this post


Link to post
Share on other sites

@blitze You can delete a topic you originate by checking the options box in the title box up above.

I appreciate anyone's attempts to bring a better vr image to this sim. We'll have to keep at it.

Share this post


Link to post
Share on other sites
11 minutes ago, blitze said:

 

Mods - Please thread lock this.

 

I do hope they will keep it open.

 

BTW could someone please publish the source from this info, as it appears it is taken from another forum. 

Share this post


Link to post
Share on other sites

I dunno, last night I decided to give SteamVR Beta another try and was impressed.

 

Problem is we have a moving target with 4 to 5 piecess of software to work with (5 if you are a Pimax owner), PiTool, Windows 10, SteamVR, Nvidia and then there is Il2 itself.

 

The load screen flickering is still there with SteamVR Beta but with PiTool 1.25, Large FOV, SteamVR Vid 50%, App 100% - Kuban Map looked really nice as did the FW 190D I was flying over it in various outside views.

 

VR is a constantly moving target as it is still infant days as a tech.   I will be upgrading to the Pimax 8K-X when available as I believe native res 4K per eye will be very nice to use in Il2 but that is me.

 

I hope everyone having issues pertaining to their headsets be able to work them out.  The previous information was a suggestion from Pimax forums from Gared.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...