Jump to content
Jodet

CH Pro Throttle - anyway to get the 'Mode' button working?

Recommended Posts

If you push the 'mini-mouse' on the CH Products Pro Throttle it changes your 'status' LED from red, to green, to amber.   In Control Manager this lets you program key presses for each of those states. 

 

I'm used to having a 'nav' mode, an 'AA' mode and an 'AG' mode and it's very handy.

 

I can't seem to get this to work in IL2 when using the IL2 mapping functions.   Once you've said, 'this button is G' then that's it.... that button is always G regardless of what color your LED is. 

 

Anyone know any way around this?   

Share this post


Link to post
Share on other sites

This button is just a DX button like any other, so when mapped in games controls GUI can use for only one function.

 

In CH Manager the button is set for change "layers" (profiles), and in each the other buttons send different keypress for game.

 

Since Manager became a "hit or miss" in Windows 10 you can achieve similar functionality using 3rd part keymappers, thanks to the button be a DX button (Saitek X-5x mode button is not a DX button, so has no use without Saitek software).

 

Press the button change for "profile 2", press again for "profile 3", press again back to "profile 1" (default), rinse and repeat. In each button other buttons is mapped for send different key press.

 

For IL-2:GB the ideal keymapper is Joystick Gremlin because can deal with "delay" issue of this game.

 

BTW - Since the mode button is DX button, if want besides change profiles you can use then for some game command.

 

I use VKB Gladiator Mode button (a DX button) in this way.

 

Mode 2 - LED is green = ground profile, so set this mode before spawn on runway, in this mode some of other buttons is mapped for functions related to ground operation, and trigger and other weapons buttons is not tied to weapons (are in "safety). Trigger can be used for example for "wheel brakes".

 

Mode 2 - LED is red = air profile, so when press mode button for change for mode 2, DX button toggle landing gear*. In mode 2 trigger and weapons buttons are "hot".

 

* LED red = gear up

LED green = gear down

;)

 

 

 

 

Edited by Sokol1

Share this post


Link to post
Share on other sites

Hello,

 

- have you mapped different button for the different mode (i.e. mode 1 :a , mode 2 : g mode 3 : k) ?

- have you in program setting tab of your profile in Control Manager  set the mode control to "pro throttle" ?

 

I just tried on my setup and mode changing is ok (I tries sending keys to text editor).

As sokol said there are malfunctions in Windows 10.

 

Hope it helps

Share this post


Link to post
Share on other sites

I just came across some possible fixes for the WI does 10 issues a few minutes ago on Reddit. I will be trying this when I hop on this evening:

 

Post 1:

When the buttons grey out, sign out of windows and then sign back in. The devices will reinitialize and Control Manager will be in the mode you had tried to switch to. 

 

Post 2:

Turn off and Disable the Windows Service called SysMain. That fixes all the issues. It gets reenabled by updates though. 

*Edited for better wording.*

The service has something to do with precaching for the windows metro apps. If the buttons grey out again, just open the Windows Store app. Disabling SysMain completely fixes it.

 

Post 3:

Killing the Microsoft Store process in the task manager literally fixed every single problem I've had with Control Manager in Windows 10.

 

Edited by Eclipse4349

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...